Community discussions

MikroTik App
 
JLC
just joined
Topic Author
Posts: 1
Joined: Tue Feb 09, 2021 9:26 pm

Foreach problem.

Tue Feb 09, 2021 9:30 pm

I have a script that removes MAC from the hotspot / binding if it is not in the hotspot / cookies. It worked perfectly. After an update, it stopped working.
Can someone help me?
:foreach b in=[/ip hotspot ip-binding find where server=HOTSPOT] d={
:global mac [/ip hotspot ip-binding get $b mac-address];
:foreach c in=[/ip hotspot cookie find where mac-address=$mac] do={
exit;
}
/ip hotspot ip-binding remove $b
}

Who is online

Users browsing this forum: Bing [Bot], solar77 and 14 guests