Community discussions

MUM Europe 2020
 
springwifi
just joined
Topic Author
Posts: 9
Joined: Sun Jun 17, 2007 1:41 am

Compare the wireless ack timeout?

Wed Nov 07, 2007 3:56 am

I am attempting to write a script to compare the ack timeout. If the ack is greater than 100 then reset the wlan device. Is this possible? Or maybe check the Overall tx CCQ to see if it's less than 50%.

Any help would be greatly appreciated. Thanks.
 
User avatar
karo84
Member Candidate
Member Candidate
Posts: 194
Joined: Fri Aug 17, 2007 9:06 am

Re: Compare the wireless ack timeout?

Wed Nov 07, 2007 6:18 pm

:
foreach i in=[/interface wireless find ] do={/interface wireless monitor $i once do {:if ($current-ack-timeout > 100) do {:local tmpfreq [interface wireless get [/interface wireless find interface=$i] frequency] ; 
:log info $tmpfreq ;  
:set tmpfreq ($tmpfreq + 5) ; 
:log warning $tmpfreq ; 
:if ($tmpfreq < 2472) do={/interface wireless set $i frequency=$tmpfreq} else={/interface wireless set $i frequency=2412 ;}}}}
This One I have Written for changing channels But You can Use it For your goal;
I think this will help You
with Regards
Karapet Aznavuryan
 
fe4r
newbie
Posts: 34
Joined: Mon Feb 25, 2008 7:02 pm

Re: Compare the wireless ack timeout?

Mon Feb 25, 2008 7:33 pm

hi,

i'm new here, but i work with mikrotik since last year..

i need a script with the ack-timeout, but i can't do it..i'm studyng the script lenguage 2 weeks, but the scripts dosnt work...

i need the script see the ack-timeout of every connected clients on registration-table, if its higher than 50, it looks for the mac (or the comment) in the access-list, disable this one, and enable after 5 seconds..

because, every one thats the ack is high, i just 'drop' him and he reconnect with the ack good..

sorry the bad english..i'm form brazil

thanks all
 
matmor
just joined
Posts: 19
Joined: Wed Jan 07, 2009 5:09 pm
Location: Quebec, Canada

Re: Compare the wireless ack timeout?

Thu Jul 30, 2009 9:33 pm

Hi have similar problem on some client ... I put this script on my AP to Log ack-timeout over 100 !

My AP log remote to a syslog server, so it's easy to grep in the message log on the server to see problem on all AP
/system script
add name=ack_log policy=ftp,reboot,read,write,policy,test,winbox,password,sniff source=":foreach i in=[ /int wir reg find ap=no] do={\r\
    \n:if ([int wir reg get \$i ack-timeout] > 100) do={\r\
    \n:log info (\"=== ACK-TIMEOUT HIGH === Mikrotik \" . [/system identity get name] . \" AP: \" . [int wir reg get \$i interface] . \"  MAC: \" . [int wir reg get \$i mac-address \
    ] . \" ACT-Timeout: \" . [int wir reg get \$i ack-timeout] )\r\
    \n:}}"
/system scheduler
add comment="" disabled=no interval=1h name=ack_timeout_log on-event=ack_log policy=read,write,test start-time=startup

Who is online

Users browsing this forum: Google [Bot], gpglang and 20 guests