Community discussions

 
Gerard
Trainer
Trainer
Topic Author
Posts: 336
Joined: Wed Apr 26, 2006 4:21 am
Location: Kentucky, USA
Contact:

RB411 Alignment LED Script

Fri Apr 18, 2008 6:22 pm

Here is an alignment script using the 5 LED's on the RB411/RB411A.

Tested with 3.7.. You can adjust the signal levels to suite your needs..
:for i from=1 to=100 do={
 /interface wireless monitor wlan1 interval=1 do={
  :if ($"signal-strength" <= -90) do={
   :led led1=no led2=no led3=no led4=no led5=no;
   }
  :if ($"signal-strength" <= -85 && $"signal-strength" > -90) do={
   :led led1=yes led2=no led3=no led4=no led5=no;
   }  
  :if ($"signal-strength" <= -80 && $"signal-strength" > -85) do={
   :led led1=yes led2=yes led3=no led4=no led5=no;
   }  
  :if ($"signal-strength" <= -75 && $"signal-strength" > -80) do={
   :led led1=yes led2=yes led3=yes led4=no led5=no;
   }
  :if ($"signal-strength" <= -65 && $"signal-strength" > -75) do={
   :led led1=yes led2=yes led3=yes led4=yes led5=no;
   }  
  :if ($"signal-strength" <= -20 && $"signal-strength" > -65) do={
   :led led1=yes led2=yes led3=yes led4=yes led5=yes;
   }  
 }
}
Mikrotik PLEASE PLEASE PLEASE add better scripting functionality for the wireless scan function..

This is just a proof of concept.. Don't blame me if it doesn't work for you..

Thanks,
Gerard
Certified Mikrotik Trainer
 
User avatar
Giepie
Member
Member
Posts: 430
Joined: Mon Sep 13, 2004 12:33 pm
Location: Western Cape, South Africa
Contact:

Re: RB411 Alignment LED Script

Sun Jul 06, 2008 4:59 pm

Brilliant script!!!

Congrats man!

I'll be sure to use it soon.

G
The only thing Mikrotik lack, is to send power to your High Sites wirelessly.....
 
fireline
just joined
Posts: 1
Joined: Sat Sep 27, 2008 5:55 am

Re: RB411 Alignment LED Script

Sat Sep 27, 2008 5:58 am

Anyone try to get this working on ROS 3.11? I can't seem to figure out the problem.
 
marks-mkt
just joined
Posts: 2
Joined: Wed Jul 11, 2007 8:30 pm

Re: RB411 Alignment LED Script

Tue Feb 10, 2009 10:53 pm

For what it's worth, I just posted another wireless alignment script that uses the LEDs and beeps. Here's the link to the new post I made: http://forum.mikrotik.com/viewtopic.php?f=9&t=29638
 
brianc
just joined
Posts: 5
Joined: Sat Aug 22, 2009 12:54 am

Re: RB411 Alignment LED Script

Mon Aug 24, 2009 4:30 pm

Trying to get this led script to work all the time. I dont want to have to manually start script. I need it to be always on.
How can I do this???
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5716
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: RB411 Alignment LED Script

Mon Aug 24, 2009 4:31 pm

add scheduler to run script at certain intervals.
 
brianc
just joined
Posts: 5
Joined: Sat Aug 22, 2009 12:54 am

Re: RB411 Alignment LED Script

Mon Aug 24, 2009 6:30 pm

When I reboot router it says that it ran the script 1 time and sytem scheduler says it ran 1 time but leds dont light up. If I click on run script then they come on.

I want them to automatically come on
 
changeip
Forum Guru
Forum Guru
Posts: 3803
Joined: Fri May 28, 2004 5:22 pm

Re: RB411 Alignment LED Script

Mon Aug 24, 2009 6:32 pm

your script is probbaly running too quickly - before the system is fully ready for whatever your script does. Put a delay of 10s on startup and try again.
Colo and Wholesale Bandwidth Available! Sales at SanDiegoBroadband dot com
 
brianc
just joined
Posts: 5
Joined: Sat Aug 22, 2009 12:54 am

Re: RB411 Alignment LED Script

Mon Aug 24, 2009 6:50 pm

Thank you!!!!!!!!! That worked.
 
David1234
Forum Guru
Forum Guru
Posts: 1209
Joined: Sun Sep 18, 2011 7:00 pm

Re: RB411 Alignment LED Script

Wed Jan 18, 2012 3:04 pm

I tried to use this script in 411 v5.7 and 5.0rc2

and it doesn't work?
why is it?

I want to make a simple script - that only blink when the registration is under -90 else led 1-4 is on

plsssss help me .
I think that me mistake is in the syntax
thank you !

this is my script:
:if ([/interface wireless registration-table get value-name=signal-strength number=0] =-123)
do={/interface wireless registration-table remove numbers=0}
else={beep frequency=1000 length=2}

this one works, and if I change the "=" to "<= " it give me that the interval is not good.

why is it?????
I ask this question 3 times here and still get no answer - it cant be that hard.
please help me.

thank you ,

Who is online

Users browsing this forum: No registered users and 7 guests