Community discussions

 
pokeman
Member Candidate
Member Candidate
Topic Author
Posts: 136
Joined: Fri Jun 05, 2009 10:52 pm

Netwatch with some modification required

Fri Dec 19, 2008 1:26 pm

Hi There
i need script to change interface ip if the destination ping timeout we have 4 public ip e.g 10.0.0.2, 10.0.0.3, 10.0.0.4 and single gateway 10.0.0.1 According to check every ip one by one

:local i 0; {:do {:set i ($i + 1)} while (($i < 5) && ([/ping 72.14.207.104 interval=3 count=1]=1)};
:if ($i=5 && [ /ip address set 2 address=10.0.0.2]= ([/ping 72.14.207.104 interval=3 count=1]=1)false) ($i + 1)} while (($i < 5) && ([/ping 72.14.207.104 interval=3 count=1]=1)};
:if ($i=5 && [ /ip address set 2 address=10.0.0.3]([/ping 72.14.207.104 interval=3 count=1]=1)=false) ($i + 1)} while (($i < 5) && ([/ping 72.14.207.104 interval=3 count=1]=1)};
:if ($i=5 && [ /ip address set 2 address=10.0.0.4]([/ping 72.14.207.104 interval=3 count=1]=1)=false) }
 
pokeman
Member Candidate
Member Candidate
Topic Author
Posts: 136
Joined: Fri Jun 05, 2009 10:52 pm

Re: Netwatch with some modification required

Sun Dec 21, 2008 1:04 pm

hi there

waiting for solution
Chupaka ! normis ! scripting master !!
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: Netwatch with some modification required

Sun Dec 21, 2008 1:24 pm

Hi pokemon,
I am not ignoring you. I am just not sure what you need. There is only one gateway (10.0.0.1), correct? If it is down, I am not sure what good it would do to change your interface IP address.
 
pokeman
Member Candidate
Member Candidate
Topic Author
Posts: 136
Joined: Fri Jun 05, 2009 10:52 pm

Re: Netwatch with some modification required

Mon Dec 22, 2008 8:48 am

thanks for your response actually some of our client using DDC Mirc chat due to some issue the admin block the ip addresses. e.g host addresses irc.eunet.net now i need if the ping not answer with the following host my ip public ip change then trying to ping again. 2nd time again ping to host again not answer change with another ip. we don't need to change or disable gateway
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: Netwatch with some modification required

Mon Dec 22, 2008 9:15 am

...due to some issue the admin block the ip addresses. e.g host addresses irc.eunet.net now i need if the ping not answer with the following host my ip public ip change then trying to ping again...
So you need a script to get around an IP blocker (like I use) used by some network admin (like I am) so you can continue what he/she wants you to stop? Is that it?
 
pokeman
Member Candidate
Member Candidate
Topic Author
Posts: 136
Joined: Fri Jun 05, 2009 10:52 pm

Re: Netwatch with some modification required

Mon Dec 22, 2008 10:45 am

you are right !
 
pokeman
Member Candidate
Member Candidate
Topic Author
Posts: 136
Joined: Fri Jun 05, 2009 10:52 pm

Re: Netwatch with some modification required

Tue Dec 23, 2008 8:00 pm

SurferTim waiting for script !
 
burek
just joined
Posts: 22
Joined: Sun Dec 09, 2007 8:42 pm

Re: Netwatch with some modification required

Mon Mar 09, 2009 1:33 am

lol SurferTim :)
 
User avatar
omega-00
Forum Guru
Forum Guru
Posts: 1167
Joined: Sat Jun 06, 2009 4:54 am
Location: Australia
Contact:

Re: Netwatch with some modification required

Mon Mar 16, 2009 4:27 pm

...due to some issue the admin block the ip addresses. e.g host addresses irc.eunet.net now i need if the ping not answer with the following host my ip public ip change then trying to ping again...
So you need a script to get around an IP blocker (like I use) used by some network admin (like I am) so you can continue what he/she wants you to stop? Is that it?
To be honest, if the admin doesn't just block the sites then all power be to whoever bypasses his system and teaches him a valuable lesson. However if the reason the admin's blocking isn't working is due to a system issue perhaps you could recommend him a suitable mikrotik router in return for him removing his block rules :-)
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: Netwatch with some modification required

Mon Mar 16, 2009 8:34 pm

Hi omega-00

I will help anyone protect themselves from a hacker, but I will NOT assist anyone in their quest to become one, as impervious as my system is to that type attack.

Who is online

Users browsing this forum: No registered users and 8 guests