Community discussions

MUM Europe 2020
 
User avatar
rahrouh
Trainer
Trainer
Topic Author
Posts: 29
Joined: Wed Apr 15, 2009 4:14 pm
Location: 550 Alden Road, Unit 210A
Contact:

Antenna Alignment with RB/4xx LED & Beep Script

Wed Apr 15, 2009 4:48 pm

http://www.netware.ir
This is a good solution for MikroPoint Antenna
BEEP SCRIPT
:local beep "10ms";
:local no "2400ms";
:local s90 "1290ms";
:local s85 "790ms";
:local s80 "590ms";
:local s77 "390ms";
:local s74 "290ms";
:local s71 "240ms";
:local s68 "190ms";
:local s65 "140ms";
:local s62 "90ms";
:local s59 "60ms";
:local s56 "40ms";
:local s53 "20ms";
:local s50 "10ms";
:for i from=1 to=100 do={
/interface wireless monitor wlan1 interval=1 do={
:if ($"signal-strength" <= -90) do={
:delay $no;
}
:if ($"signal-strength" <= -85 && $"signal-strength" > -90) do={
:for i from=1 to=2 do={ :beep length=$beep; :delay $s90; }
}
:if ($"signal-strength" <= -80 && $"signal-strength" > -85) do={
:for i from=1 to=3 do={ :beep length=$beep; :delay $s85; }
}
:if ($"signal-strength" <= -77 && $"signal-strength" > -80) do={
:for i from=1 to=4 do={ :beep length=$beep; :delay $s80; }
}
:if ($"signal-strength" <= -74 && $"signal-strength" > -77) do={
:for i from=1 to=6 do={ :beep length=$beep; :delay $s77; }
}
:if ($"signal-strength" <= -71 && $"signal-strength" > -74) do={
:for i from=1 to=8 do={ :beep length=$beep; :delay $s74; }
}
:if ($"signal-strength" <= -68 && $"signal-strength" > -71) do={
:for i from=1 to=10 do={ :beep length=$beep; :delay $s71; }
}
:if ($"signal-strength" <= -65 && $"signal-strength" > -68) do={
:for i from=1 to=12 do={ :beep length=$beep; :delay $s68; }
}
:if ($"signal-strength" <= -62 && $"signal-strength" > -65) do={
:for i from=1 to=16 do={ :beep length=$beep; :delay $s65; }
}
:if ($"signal-strength" <= -59 && $"signal-strength" > -62) do={
:for i from=1 to=24 do={ :beep length=$beep; :delay $s62; }
}
:if ($"signal-strength" <= -56 && $"signal-strength" > -59) do={
:for i from=1 to=34 do={ :beep length=$beep; :delay $s59; }
}
:if ($"signal-strength" <= -53 && $"signal-strength" > -56) do={
:for i from=1 to=48 do={ :beep length=$beep; :delay $s56; }
}
:if ($"signal-strength" <= -50 && $"signal-strength" > -53) do={
:for i from=1 to=80 do={ :beep length=$beep; :delay $s53; }
}
:if ($"signal-strength" <= -20 && $"signal-strength" > -50) do={
:for i from=1 to=120 do={ :beep length=$beep; :delay $s50; }
}
}
}


LED SCRIPT FOR ACCESS POINT

:for i from=1 to=100 do={
/interface wireless monitor wlan1 interval=1 do={
:if ($"registered-clients"=1 ) do={
:for i from=1 to=24 do={:led led5=yes; :led led4=yes; :led led3=yes; :led led2=yes; :led led1=yes; }
}
:if ($"registered-clients"=0 ) do={
:for i from=1 to=24 do={:led led5=no; :led led4=no; :led led3=no; :led led2=no; :led led1=no; }
}
:if ($"signal-strength" <= -63 && $"signal-strength" > -75) do={
:for i from=1 to=48 do={ :led led5=no; :led led4=no; :led led3=yes; :led led2=yes; :led led1=yes; }
}
:if ($"signal-strength" <= -45 && $"signal-strength" > -62) do={
:for i from=1 to=120 do={ :led led5=no; :led led4=yes; :led led3=yes; :led led2=yes; :led led1=yes; }
}
:if ($"signal-strength" <= -10 && $"signal-strength" > -44) do={
:for i from=1 to=120 do={ :led led5=yes; :led led4=yes; :led led3=yes; :led led2=yes; :led led1=yes; }
}
}
}

LED SCRIPT FOR STATION
:for i from=1 to=100 do={
/interface wireless monitor wlan1 interval=1 do={
:if ($"signal-strength" <= -86 && $"signal-strength" > -90) do={
:for i from=1 to=24 do={:led led5=no; :led led4=no; :led led3=no; :led led2=no; :led led1=yes; }
}
:if ($"signal-strength" <= -76 && $"signal-strength" > -85) do={
:for i from=1 to=34 do={:led led5=no; :led led4=no; :led led3=no; :led led2=yes; :led led1=yes; }
}
:if ($"signal-strength" <= -63 && $"signal-strength" > -75) do={
:for i from=1 to=48 do={ :led led5=no; :led led4=no; :led led3=yes; :led led2=yes; :led led1=yes; }
}
:if ($"signal-strength" <= -45 && $"signal-strength" > -62) do={
:for i from=1 to=120 do={ :led led5=no; :led led4=yes; :led led3=yes; :led led2=yes; :led led1=yes; }
}
:if ($"signal-strength" <= -10 && $"signal-strength" > -44) do={
:for i from=1 to=120 do={ :led led5=yes; :led led4=yes; :led led3=yes; :led led2=yes; :led led1=yes; }
}
}
}
hr@wirelessnetware.ca
647-204-0455
wirelessnetware.ca
MikroTik Certified Trainer
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8324
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: Antenna Alignment with RB/4xx LED & Beep Script

Wed Apr 15, 2009 8:00 pm

nice =) this should be added to Wiki :)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
kameelperdza
Member
Member
Posts: 469
Joined: Thu Nov 27, 2008 11:45 am
Location: Oudtshoorn, South Africa

Re: Antenna Alignment with RB/4xx LED & Beep Script

Mon Apr 20, 2009 4:56 pm

can you maybe tell how it works? and how to test it. thanx
Give me some karma
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8324
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: Antenna Alignment with RB/4xx LED & Beep Script

Mon Apr 20, 2009 5:46 pm

run the script and move the antenna - RB will beep with frequency and length depending on wireless signal strength
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
kameelperdza
Member
Member
Posts: 469
Joined: Thu Nov 27, 2008 11:45 am
Location: Oudtshoorn, South Africa

Re: Antenna Alignment with RB/4xx LED & Beep Script

Mon Apr 20, 2009 6:02 pm

thanx
Give me some karma
 
User avatar
kameelperdza
Member
Member
Posts: 469
Joined: Thu Nov 27, 2008 11:45 am
Location: Oudtshoorn, South Africa

Re: Antenna Alignment with RB/4xx LED & Beep Script

Tue Apr 21, 2009 12:51 pm

Very cool script indeed. But im getting confused with the beeps. And the lights. Now it is 4 lights on and then 3. Can you maybe give a explanation of what the lights mean etc 1led, 2leds ,3leds 3leds and the beeps.
Give me some karma
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8324
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: Antenna Alignment with RB/4xx LED & Beep Script

Tue Apr 21, 2009 12:56 pm

more leds - stronger signal
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
wojtek
just joined
Posts: 2
Joined: Tue Jun 30, 2009 8:04 am

Re: Antenna Alignment with RB/4xx LED & Beep Script

Tue Jun 30, 2009 8:11 am

Hi
Sorry form my english ;)

This script work only for bridge mode?
When i set station-WDS and run script MT not beeping ;) (OS 3.10)
 
User avatar
kameelperdza
Member
Member
Posts: 469
Joined: Thu Nov 27, 2008 11:45 am
Location: Oudtshoorn, South Africa

Re: Antenna Alignment with RB/4xx LED & Beep Script

Tue Jun 30, 2009 9:09 am

Try upgrading to the latest routeros.
Give me some karma
 
wojtek
just joined
Posts: 2
Joined: Tue Jun 30, 2009 8:04 am

Re: Antenna Alignment with RB/4xx LED & Beep Script

Tue Jun 30, 2009 9:42 am

I test today with RB411 (brigde) & RB433 (station WDS). This script on 411 works fine, but on 433 - silence (RB411&Rb433 - OS 3.25)
 
ckgth
Frequent Visitor
Frequent Visitor
Posts: 64
Joined: Wed Jun 06, 2007 5:03 pm

Re: Antenna Alignment with RB/4xx LED & Beep Script

Mon Nov 30, 2009 7:23 pm

Hello!

The Script works NOT on 411 with ROS 4.3, but on 3.30
I have tested!
"led led5=yes" -> Led5 not lighting ?! Why on 4.3 not, but on 3.30?

regards
Christian
 
pikpik
Frequent Visitor
Frequent Visitor
Posts: 71
Joined: Wed Jan 20, 2010 11:25 am

Re: Antenna Alignment with RB/4xx LED & Beep Script

Thu Mar 18, 2010 11:18 am

syntax errors on v4.5
 
Jamesy
Member Candidate
Member Candidate
Posts: 206
Joined: Fri Dec 18, 2009 7:04 pm

Re: Antenna Alignment with RB/4xx LED & Beep Script

Thu Jun 17, 2010 6:10 pm

I'm running 4.6 and looking to make this work.

Any insight on what syntax errors I might run into?
 
User avatar
emperatoor
just joined
Posts: 1
Joined: Tue Apr 29, 2008 9:39 am

Re: Antenna Alignment with RB/4xx LED & Beep Script

Mon Jul 05, 2010 2:10 pm

very thanx
 
xtremevision
just joined
Posts: 1
Joined: Mon Aug 08, 2011 10:35 am

Re: Antenna Alignment with RB/4xx LED & Beep Script

Mon Aug 08, 2011 10:46 am

Does this script can be used when physically installing the wireless devices as well?
Meaning.
First install the main-node, next installe the end-node.
To line up the end-node with the main-node, can this scipt be used to check wether the alignemt between main -and end node is good?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24360
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Antenna Alignment with RB/4xx LED & Beep Script

Wed Aug 10, 2011 12:40 pm

Does this script can be used when physically installing the wireless devices as well?
Meaning.
First install the main-node, next installe the end-node.
To line up the end-node with the main-node, can this scipt be used to check wether the alignemt between main -and end node is good?
this is exactly the purpose of this script actually
No answer to your question? How to write posts

Who is online

Users browsing this forum: No registered users and 16 guests