Community discussions

 
zevoxi
just joined
Topic Author
Posts: 6
Joined: Tue May 05, 2009 11:26 am

how to check the router os version

Wed Jun 24, 2009 1:29 am

How can I check what version of the os is running ,using only the API commands?
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8308
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: how to check the router os version

Wed Jun 24, 2009 12:05 pm

"/system/resource/print" and then check 'version' value
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
MATU
just joined
Posts: 12
Joined: Thu Apr 03, 2014 11:01 am

Re: how to check the router os version

Thu Apr 03, 2014 12:08 pm

I am having a peculiar problem that specifically affects apple products. Apple products regardless of their IOS are exhibiting very slow loading time from websites and most times will not open at all. I have found a work around of "binding" the specific client IP address and "bypassing" it. This always solves the problem but I want it to work normally without having to by pass the IP addresses since bypassing the client makes it impossible to monitor or control his/her bandwidth.
The problem has occurred several times before but it always goes away with time but this time around it has persisted.
Note that my authentication is the hotspot http chap therefore the issues discussed above regarding AES are not related with this.

Find my router configuration below. Your help will be very much appreciated.

Regards,

Matu



jan/04/2007 start-time=07:30:00
add comment="" disabled=yes interval=1w name="Weekend BW Upgrade Sat" \
on-event="04 - Upgrade_BW" policy=read,write,test start-date=jul/28/2007 \
start-time=07:05:00
add comment="" disabled=no interval=1w name="Weekend BW Upgrade Sun" \
on-event="04 - Upgrade_BW" policy=read,write,test start-date=jul/29/2007 \
start-time=07:05:00
add comment="" disabled=no interval=30s name="07 - Remove busy status" \
on-event="07 - Remove busy status" policy=read,write,test start-date=\
nov/11/2011 start-time=16:45:00
add comment="" disabled=no interval=1m name="08 - Busy status remove" \
on-event="08 - Busy status remove" policy=read,write,test start-date=\
nov/11/2011 start-time=16:52:00
/system script
add name=Email_backup_file policy=ftp,reboot,read,write,policy,test source="/s\
ystem backup save name=email-system\r\
\n/tool e-mail send to=\"*****\" from=\"*****.\
co.ke\" server=\"smtp.accesskenya.com\" subject=(\"Backup of: \" . [/syste\
m identity get name] . \"-\" . [/system clock get time] . \"-\" . [/syste\
m clock get date]) body=\" This is the weekly backup of the hotgossip rout\
er. Please find attached the backup config for router *******. \
Keep this in a safe place.\" file=email-system.backup\r\
\n:log info \"Backup email sent OK\""
add name="04 - Upgrade_BW" policy=ftp,reboot,read,write,policy,test,winbox \
source=":log info \"Begin bandwidth daily upgrade...\"\r\
\n###\r\
\n# Change 24/48 Day - 32/128 Night back to 32/128 for Night\r\
\n/ip hotspot user profile set \"24/48 Day - 32/128 Night\" rate-limit=\"3\
2k/128k 100000000k/100000000k 18k/36k 40 8\"\r\
\n\r\
\n###\r\
\n# Change 24/48 to 32/64 for night\r\
\n/ip hotspot user profile set \"24/48 Customers\" rate-limit=\"32k/64k 10\
0000000k/100000000k 24k/48k 40 8\"\r\
\n\r\
\n###\r\
\n# Change 24k/48k Night to 1k/1k for day\r\
\n/ip hotspot user profile set \"24k/48k Night\" rate-limit=\"24k/48k 1000\
00000k/100000000k 18k/36k 40 8\"\r\
\n\r\
\n###\r\
\n# Change 24/48 Day - 32/96 Night to 32/96 for night\r\
\n/ip hotspot user profile set \"24/48 Day - 32/96 Night\" rate-limit=\"32\
k/96k 100000000k/100000000k 24k/68k 40 8\"\r\
\n\r\
\n###\r\
\n# Change 32/64 to 48/96 for night\r\
\n/ip hotspot user profile set \"32/64 Customers\" rate-limit=\"48k/96k 10\
0000000k/100000000k 33k/68k 40 8\"\r\
\n\r\
\n###\r\
\n# Change 48/64 to 48/96 for night\r\
\n/ip hotspot user profile set \"48/64 Customers\" rate-limit=\"48k/96k 10\
0000000k/100000000k 33k/68k 40 8\"\r\
\n\r\
\n###\r\
\n# Change 48/96 to 64/128 for night\r\
\n/ip hotspot user profile set \"48/96 Customers\" rate-limit=\"64k/128k 1\
00000000k/100000000k 72k/115k 40 8\"\r\
\n\r\
\n\r\
\n###\r\
\n# Change 64/128 to 128/256 for night\r\
\n/ip hotspot user profile set \"64/128 Customers\" rate-limit=\"128k/256k\
\_100000000k/100000000k 115k/230k 40 8\"\r\
\n\r\
\n\r\
\n###\r\
\n# Change Camp Kenya Office Day Only to 24k/48k for night\r\
\n/ip hotspot user profile set \"Camp Kenya Office Day Only\" rate-limit=\
\"24k/48k 100000000k/100000000k 18k/36k 40 8\"\r\
\n\r\
\n###\r\
\n# Change Camp Kenya Directors for night\r\
\n/ip hotspot user profile set \"Camp Kenya Directors\" rate-limit=\"64k/1\
28k 100000000k/100000000k 48k/96k 40 8\"\r\
\n\r\
\n###\r\
\n# Change 24/48 Day - 32/256 Night to 32/256 for night\r\
\n/ip hotspot user profile set \"24/48 Day - 32/256 Night\" rate-limit=\"3\
2k/256k 100000000k/100000000k 24k/230k 40 8\"\r\
\n\r\
\n##\r\
\n# Change 32/64 Day - 0/0 Night to 0/0 for night\r\
\n/ip hotspot user profile set \"32/64 Day - 0/0 Night\" rate-limit=\"1k/1\
k\"\r\
\n\r\
\n###\r\
\n# Change 32/256 Night Only to ON for night\r\
\n/ip hotspot user profile set \"32/256 Night Only\" rate-limit=\"32k/256k\
\_100000000k/100000000k 24k/230k 40 8\"\r\
\n\r\
\n\r\
\n\r\
\n#End.\r\
\n:log info \"End: daily bandwidth upgrade complete!\"\r\
\n:delay 10\r\
\n"
add name="03 - Downgrade_BW" policy=ftp,reboot,read,write,policy,test,winbox \
source=":log info \"Begin bandwidth daily downgrade...\"\r\
\n###\r\
\n# Change 24/48 Day - 32/128 Night back to 24/48 for day\r\
\n/ip hotspot user profile set \"24/48 Day - 32/128 Night\" rate-limit=\"2\
4k/48k 100000000k/100000000k 18k/36k 40 8\"\r\
\n\r\
\n###\r\
\n# Change 24/48 back to 24/48 for day\r\
\n/ip hotspot user profile set \"24/48 Customers\" rate-limit=\"24k/48k 10\
0000000k/100000000k 18k/36k 40 8\"\r\
\n\r\
\n###\r\
\n# Change 24k/48k Night to 1k/1k for day\r\
\n/ip hotspot user profile set \"24k/48k Night\" rate-limit=\"1k/1k\"\r\
\n\r\
\n###\r\
\n# Change 24/48 Day - 32/96 Night back to 24/48 for day\r\
\n/ip hotspot user profile set \"24/48 Day - 32/96 Night\" rate-limit=\"24\
k/48k 100000000k/100000000k 18k/36k 40 8\"\r\
\n\r\
\n###\r\
\n# Change 32/64 back to 32/64 for day\r\
\n/ip hotspot user profile set \"32/64 Customers\" rate-limit=\"32k/64k 10\
0000000k/100000000k 24k/48k 40 8\"\r\
\n\r\
\n###\r\
\n# Change 48/64 back to 48/64 for day\r\
\n/ip hotspot user profile set \"48/64 Customers\" rate-limit=\"48k/64k 10\
0000000k/100000000k 24k/48k 40 8\"\r\
\n\r\
\n###\r\
\n# Change 48/96 back to 48/96 for day\r\
\n/ip hotspot user profile set \"48/96 Customers\" rate-limit=\"48k/96k 10\
0000000k/100000000k 24k/72k 40 8\"\r\
\n\r\
\n###\r\
\n# Change 64/128 back to 64/128 for day\r\
\n/ip hotspot user profile set \"64/128 Customers\" rate-limit=\"64k/128k \
100000000k/100000000k 48k/96k 40 8\"\r\
\n\r\
\n###\r\
\n# Change Camp Kenya Office Day Only to 128/256 for day\r\
\n/ip hotspot user profile set \"Camp Kenya Office Day Only\" rate-limit=\
\"128k/256k 100000000k/100000000k 115k/230k 40 8\"\r\
\n\r\
\n###\r\
\n# Change Camp Kenya Directors to 1k/1k for day\r\
\n/ip hotspot user profile set \"Camp Kenya Directors\" rate-limit=\"1k/1k\
\"\r\
\n\r\
\n###\r\
\n# Change 24/48 Day - 32/256 Night back to 24/48 for day\r\
\n/ip hotspot user profile set \"24/48 Day - 32/256 Night\" rate-limit=\"2\
4k/48k 100000000k/100000000k 24k/48k 40 8\"\r\
\n\r\
\n###\r\
\n# Change 32/64 Day - 32/256 Night back to 32/64 for day\r\
\n/ip hotspot user profile set \"32/64 Day - 0/0 Night\" rate-limit=\"32/6\
4k 100000000k/100000000k 24k/48k 40 8\"\r\
\n\r\
\n###\r\
\n# Change 32/256 Night Only to ON for night\r\
\n/ip hotspot user profile set \"32/256 Night Only\" rate-limit=\"6k/6k\"\
\r\
\n\r\
\n#End.\r\
\n:log info \"End: daily bandwidth downgrade complete!\"\r\
\n:delay 10\r\
\n\r\
\n"
add name="06 - enable_night_users" policy=\
ftp,reboot,read,write,policy,test,winbox,password source="###\r\
\n# Enable Night Only Customers\r\
\n/ip hotspot user profile set \"16k/32k Night\" shared-users=1"
add name="05 - disable_night_users" policy=\
ftp,reboot,read,write,policy,test,winbox,password source="###\r\
\n# Disable Night Only Customers\r\
\n/ip hotspot user profile set \"24k/48k Night\" shared-users=0"
add name="00 - mv-static" policy=\
ftp,reboot,read,write,policy,test,winbox,password,sniff source=":foreach n\
\_in=[/queue simple find priority=7] do={ /queue simple move \$n [:pick [/\
queue simple find] 0] }\r\
\n:foreach n in=[/queue simple find priority=5] do={ /queue simple move \$\
n [:pick [/queue simple find] 0] }\r\
\n:foreach n in=[/queue simple find priority=4] do={ /queue simple move \$\
n [:pick [/queue simple find] 0] }"
add name="02 - Throttle p2p during the day" policy=\
ftp,reboot,read,write,policy,test,winbox,password,sniff source="/ip firewa\
ll filter enable [/ip firewall filter find comment=\"Drop P2p Marked Packe\
ts\"]\r\
\n/ip firewall filter enable [/ip firewall filter find comment=\"Drop P2p \
Protocol\"]"
add name="01 - Allow p2p during the Night" policy=\
ftp,reboot,read,write,policy,test,winbox,password,sniff source="/ip firewa\
ll filter disable [/ip firewall filter find comment=\"Drop P2p Marked Pack\
ets\"]\r\
\n/ip firewall filter disable [/ip firewall filter find comment=\"Drop P2p\
\_Protocol\"]"
add name="07 - Remove busy status" policy=\
ftp,reboot,read,write,policy,test,winbox,password,sniff source=":foreach i\
\_in=[/ip dhcp-server lease find status=\"busy\"]\\\r\
\n do={\r\
\n :log error (\"Busy status detected: \" . [/ip dhcp-server lease get \$i\
\_address]);\r\
\n /ip dhcp-server lease remove \$i;\r\
\n }\r\
\n"
add name="08 - Busy status remove" policy=\
ftp,reboot,read,write,policy,test,winbox,password,sniff source=":foreach i\
\_in=[/ip dhcp-server lease find mac-address=00:00:00:00:00:00]\\\r\
\ndo={\r\
\n:log error (\"Mac address zero detected: \" . [/ip dhcp-server lease get\
\_\$i address]);\r\
\n/ip dhcp-server lease remove \$i;\r\
\n}"
/system upgrade mirror
set check-interval=1d enabled=no primary-server=0.0.0.0 secondary-server=\
0.0.0.0 user=""
/system watchdog
set auto-send-supout=no automatic-supout=no no-ping-delay=5m watch-address=\
none watchdog-timer=no
/tool bandwidth-server
set allocate-udp-ports-from=2000 authenticate=yes enabled=yes max-sessions=10
/tool e-mail
set from=<winbox> password="" server=**.**.**.**/** username=""
/tool graphing
set store-every=5min
/tool graphing interface
add allow-address=192.168.101.0/24 disabled=no interface=all store-on-disk=\
yes
add allow-address=**.**.**.**/** disabled=no interface=all store-on-disk=yes
add allow-address=10.1.10.253/32 disabled=no interface=all store-on-disk=yes
add allow-address=10.1.10.251/32 disabled=no interface=all store-on-disk=yes
add allow-address=10.1.10.250/32 disabled=no interface=all store-on-disk=yes
add allow-address=10.1.10.0/24 disabled=no interface=all store-on-disk=yes
add allow-address=172.16.2.0/24 disabled=no interface=all store-on-disk=yes
add allow-address=**.**.**.**/** disabled=no interface=all store-on-disk=\
yes
/tool graphing queue
add allow-address=192.168.1.0/24 allow-target=yes disabled=no simple-queue=\
"Simon Home" store-on-disk=yes
add allow-address=192.168.101.0/24 allow-target=yes disabled=no simple-queue=\
all store-on-disk=yes
add allow-address=**.**.**.**/** allow-target=yes disabled=no simple-queue=\
all store-on-disk=yes
add allow-address=10.1.10.253/32 allow-target=yes disabled=no simple-queue=\
all store-on-disk=yes
add allow-address=10.1.10.251/32 allow-target=yes disabled=no simple-queue=\
all store-on-disk=yes
add allow-address=10.1.10.250/32 allow-target=yes disabled=no simple-queue=\
all store-on-disk=yes
add allow-address=10.1.10.0/24 allow-target=yes disabled=no simple-queue=all \
store-on-disk=yes
add allow-address=172.16.2.0/24 allow-target=yes disabled=no simple-queue=all \
store-on-disk=yes
add allow-address=**.**.**.**/** allow-target=yes disabled=no simple-queue=\
all store-on-disk=yes
/tool graphing resource
add allow-address=192.168.101.0/24 disabled=no store-on-disk=yes
add allow-address=**.**.**.**/** disabled=no store-on-disk=yes
add allow-address=10.1.10.253/32 disabled=no store-on-disk=yes
add allow-address=10.1.10.251/32 disabled=no store-on-disk=yes
add allow-address=10.1.10.250/32 disabled=no store-on-disk=yes
add allow-address=10.1.10.0/24 disabled=no store-on-disk=yes
add allow-address=172.16.2.0/24 disabled=no store-on-disk=yes
/tool mac-server
add disabled=no interface=all
/tool mac-server ping
set enabled=yes
/tool netwatch
add comment="Check if Idirect modem is pingable and log it" disabled=no \
down-script="/tool e-mail send to=\"**.**.**.**/**\" from=\"sup\
port@hotgossip.co.ke\" server=\"192.168.101.11\" subject=(\"Idirect Modem \
Down: \" . \"-\" . [/system clock get time] . \"-\" . [/system clock get \
date]) body=\" The Simbanet Idirect Modem has gone down.\"\r\
\n:log info \"Idirect VSAT Modem gone DOWN! Boo!\"" host=**.**.**.**/** \
interval=5m timeout=800ms up-script="/tool e-mail send to=\"**.**.**.**/**\" from=\"**.**.**.**/**\" server=\"192.168.101.11\" s\
ubject=(\"Idirect Modem Up: \" . \"-\" . [/system clock get time] . \"-\"\
\_. [/system clock get date]) body=\" The Simbanet Idirect Modem has gone \
back up!.\"\r\
\n:log info \"Idirect VSAT Modem gone UP! Yay!!\""
add comment="Check if KDN Link is pingable and log it" disabled=no \
down-script="/tool e-mail send to=\"**.**.**.**/**\" from=\"sup\
**.**.**.**/**\" server=\"192.168.101.11\" subject=(\"KDN Link Down:\
\_\" . \"-\" . [/system clock get time] . \"-\" . [/system clock get date\
]) body=\" The KDN Link has gone down.\"\r\
\n:log info \"KDN Link gone DOWN! Boo!\"" host=**.**.**.**/** interval=1m \
timeout=400ms up-script="/tool e-mail send to=\"**.**.**.**/**\
\" from=\"**.**.**.**/**\" server=\"192.168.101.11\" subject=(\"K\
DN Link Up: \" . \"-\" . [/system clock get time] . \"-\" . [/system cloc\
k get date]) body=\" The KDN Link has gone back up!.\"\r\
\n:log info \"KDN Link gone UP! Yay!!\""
/tool sniffer
set file-limit=10 file-name="" filter-address1=0.0.0.0/0:0-65535 \
filter-address2=0.0.0.0/0:0-65535 filter-protocol=ip-only filter-stream=\
yes interface=all memory-limit=10 only-headers=no streaming-enabled=no \
streaming-server=0.0.0.0
/user aaa
set accounting=yes default-group=read interim-update=0s use-radius=no
 
jkroon
just joined
Posts: 20
Joined: Thu Apr 03, 2008 2:18 am
Contact:

Re: how to check the router os version

Wed Sep 12, 2018 6:48 pm

Code: Select all

curl -s ${targetip} | sed -nre 's/.*RouterOS v([0-9.]*)<.*/\1/p'
Useful if like us you need to scan a network range for MikroTik versions to notify customers that they've got outdated installs.

Who is online

Users browsing this forum: No registered users and 14 guests