Page 1 of 1

Help me pls - script stop work with ROS-4.0b4

Posted: Sat Sep 19, 2009 12:41 am
by Nedialko
This script work fine with ROS 3.11 and stop work with ROS 4.0b4

/ queue simple
:for i from=192 to=223 do={
set [find target-addresses="78.130.184.$i/32"] \
burst-limit=1024000/1536000 burst-threshold=500000/1000000 burst-time=40s/40s \
limit-at=128000/192000 max-limit=512000/1024000 \
priority=8 queue="End Users/End Users"
}

If someone know where is the problem please help me.
Thanks !

/sorry for my bad english/

Re: Help me pls - script stop work with ROS-4.0b4

Posted: Sat Sep 19, 2009 1:36 am
by Chupaka
what error does it show when you paste it to CLI?

Re: Help me pls - script stop work with ROS-4.0b4

Posted: Sat Sep 19, 2009 2:14 am
by Nedialko
Hi, Chupaka

No errors. I didn't see ANYTHING in CLI.

when i change target-addresses="78.130.184.$i/32" with name="ALL" (ALL is exist queue name) "find" command work .

I make experimet with :

find max-limit="XX/XX"
find burst-threshold="XX/XX"
....................................
....................................

Only with parameter name="XX" , find command work.

Re: Help me pls - script stop work with ROS-4.0b4

Posted: Sat Sep 19, 2009 2:36 am
by Nedialko
This is my analisis
I Understand why "find" command not work with "target-address= "

[admin@MTik Proxy] > :put [/queue simple get [find name="queue974"]];
dst-address=0.0.0.0/0;direction=both;comment=;burst-time=40s/40s;total-bytes=0;burst-threshold=500k/1M;packet-rate=0/0;total-dropped=
0;burst-limit=1024k/1536k;total-lends=0;borrows=0/0;bytes=0/355973;rate=0/0;queue=End Users/End Users;total-borrows=0;name=queue974;d
st-netmask=0.0.0.0;packets=0/6982;queued-bytes=0/0;.nextid=*33C2;total-packets=0;priority=8;queued-packets=0/0;interface=vlan2012-kun
chevo;dropped=0/0;total-pcq-queues=0;limit-at=128k/192k;pcq-queues=4/4;.id=*33C1;lends=0/6982;total-queued-bytes=0;parent=EndUsers_Tr
affic;total-queued-packets=0;max-limit=512k/1024k;total-packet-rate=0;target-addresses=62.73.109.68/32;total-queue=default;total-rate
=0

[admin@MTik Proxy] > :put [/queue simple get [find target-addresses=62.73.109.68/32]];
no such item

[admin@MTik Proxy] > :put [/queue simple get [find target-addresses="62.73.109.68/32"]];
no such item

[admin@MTik Proxy] > :put [/queue simple get [find target-addresses=62.73.109.68]];
no such item

[admin@MTik Proxy] > :put [/queue simple get [find target-addresses="62.73.109.68"]];
no such item

Re: Help me pls - script stop work with ROS-4.0b4

Posted: Wed Sep 23, 2009 11:08 am
by janisk
wait for next beta release there it should be ok.

Re: Help me pls - script stop work with ROS-4.0b4

Posted: Wed Jul 30, 2014 11:16 pm
by noyo
Hello, I have versions 6.17 and so far the problem has not been corrected, so that the absence of something interrupts loops? How can I mute it so precious loop on?

Re: Help me pls - script stop work with ROS-4.0b4

Posted: Wed Jul 30, 2014 11:54 pm
by rextended
First of all, do not bring back 2009 topic,
Open new topic and inside paste your script and ask for help describing the exat error which occours.

Re: Help me pls - script stop work with ROS-4.0b4

Posted: Thu Jul 31, 2014 12:00 am
by noyo
But it has never been resolved. So why post new since it's the same problem. I've never met to get at it was not.

Re: Help me pls - script stop work with ROS-4.0b4

Posted: Thu Jul 31, 2014 12:14 am
by rextended
I've never met to get at it was not.
I do not understand this...

Re: Help me pls - script stop work with ROS-4.0b4

Posted: Thu Jul 31, 2014 12:37 am
by rextended
How you can say the function is not working?

Have tested it yourself?

Must be fixed all the syntax errors, for make it compatible with RouterOS 6.17, that not are MikroTik problems, but script creator problems.
:for i from=192 to=223 step=1 do={
 /queue simple set [find where target=("78.130.184.".$i."/32")] \
                   burst-limit=1024000/1536000 \
                   burst-threshold=500000/1000000 \
                   burst-time=40s/40s \
                   limit-at=128000/192000 \
                   max-limit=512000/1024000 \
                   priority=8/8 \
                   queue="End Users/End Users";
};