Community discussions

 
dorijan
Member Candidate
Member Candidate
Topic Author
Posts: 244
Joined: Fri Jun 04, 2004 12:42 am
Location: Croatia

WOL over net

Mon Nov 16, 2009 1:13 pm

Hi to all..
I saw there is a way to send a magic packet to some mac address with shell...
I am wondering is there a way that I could send some packet to some port and trigger WOL?

thx to everyone...
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5942
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: WOL over net

Mon Nov 16, 2009 1:17 pm

 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24272
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: WOL over net

Mon Nov 16, 2009 1:18 pm

Mrz meant to say "you can't" . you can only send to a MAC in the same network
No answer to your question? How to write posts
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8319
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: WOL over net

Mon Nov 16, 2009 1:40 pm

dorijan, you mean, 'port knocking' for powering on a machine with known MAC address?..
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
dorijan
Member Candidate
Member Candidate
Topic Author
Posts: 244
Joined: Fri Jun 04, 2004 12:42 am
Location: Croatia

Re: WOL over net

Mon Nov 16, 2009 1:55 pm

I know you can send magic packet only broadcast space, not over routed network. So I want to be able to somehow initialize magic packet (maybe firewall rule) over routed network so I dont have to logon to mikrotik and initialize /tool wol mac=xxxxxxx
Maybe port triggering would do it...
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24272
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: WOL over net

Mon Nov 16, 2009 2:01 pm

how can you connect to a port, if the machine is powered down :) ?
No answer to your question? How to write posts
 
dorijan
Member Candidate
Member Candidate
Topic Author
Posts: 244
Joined: Fri Jun 04, 2004 12:42 am
Location: Croatia

Re: WOL over net

Mon Nov 16, 2009 2:11 pm

I meant to connect to some port on mikrotik, and then mikrotik sends magic pocket :)
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8319
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: WOL over net

Mon Nov 16, 2009 2:39 pm

well, you may add some rule to firewall to match necessary packet, and then in Scheduler check whether rule's packet count is > 0. then send WOL and reset the counter
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
dorijan
Member Candidate
Member Candidate
Topic Author
Posts: 244
Joined: Fri Jun 04, 2004 12:42 am
Location: Croatia

Re: WOL over net

Mon Nov 16, 2009 2:48 pm

Chupaka, that is the answer...Ill do it that way :)
thank you
 
dssmiktik
Forum Veteran
Forum Veteran
Posts: 732
Joined: Fri Aug 17, 2007 8:42 am

Re: WOL over net

Tue Nov 17, 2009 1:03 am

It's way easier:

example LAN segment is: 192.168.1.0/24

create static arp entry to resolve IP -> broadcast
/ip arp add address=192.168.1.254 comment="" disabled=no interface=LAN mac-address=FF:FF:FF:FF:FF:FF
create a NAT rule to forward packet on specific to this IP (effectively sending it to broadcast MAC)
/ip firewall nat add chain=dstnat action=dst-nat to-addresses=192.168.1.254 to-ports=7 protocol=udp dst-port=7000
tell your WoL client to send a packet to <your IP> port 7000. packet comes in, get's forwarded to broadcast MAC out LAN interface to port 7.

Works great.
Doug
 
ecarlevaro
just joined
Posts: 4
Joined: Wed Jan 02, 2013 12:22 am

Re: WOL over net

Tue Feb 04, 2014 6:02 pm

Thanks dssmiktik!

That was exactly what I was looking for!
Your solution is simply and powerful!

I have spend more than 6 hours figuring out how to solve this problem!.
I have hosts that are in network 192.168.1.0/24 connected to a Mikrotik in network 192.168.100.0/24 through a router, and I need to turn on a server that is connected to a Mikrotik at network 192.168.100.0/24 from the 192.168.1.0/24 clients.

Thanks!
 
BobcatGuy
Member Candidate
Member Candidate
Posts: 224
Joined: Thu Apr 19, 2007 7:41 am

Re: WOL over net

Fri Jul 01, 2016 12:28 pm

all we need now is to be able to WOL to wake up the Mikrotik devices that I accidently did system shutdown. :(

I know, power cycle it..... but its 44km drive to get to it.
perhaps wait for a power failure  (off/on) on the next thunderstorm tomorrow afternoon, that might fix my problem.  Unless anyone else has an easier solution?
 
pe1chl
Forum Guru
Forum Guru
Posts: 5927
Joined: Mon Jun 08, 2015 12:09 pm

Re: WOL over net

Fri Jul 01, 2016 1:01 pm

I don't think MikroTik devices support wakeup by WOL.
This discussion is about using MikroTik devices to send WOL packets to other devices (e.g. PC) to wake them.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24272
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: WOL over net

Fri Jul 01, 2016 3:40 pm

all we need now is to be able to WOL to wake up the Mikrotik devices that I accidently did system shutdown. :(

I know, power cycle it..... but its 44km drive to get to it.
perhaps wait for a power failure  (off/on) on the next thunderstorm tomorrow afternoon, that might fix my problem.  Unless anyone else has an easier solution?
Most RouterBOARD devices will turn back on after a minute or so. 
No answer to your question? How to write posts
 
User avatar
nickshore
Member
Member
Posts: 473
Joined: Thu Mar 03, 2005 4:14 pm
Location: Suffolk, UK.
Contact:

Re: WOL over net

Fri Jul 01, 2016 5:14 pm

Most RouterBOARD devices will turn back on after a minute or so. 

I've just shutdown a 951ui to test this, and it hasn't restarted after 10 mins

Which models do this ?

Nick
Nick Shore MTCNA MTCWE MTCRE MTCINE MTCTCE
LinITX.com - MultiThread Consultants
Get your MikroTik RBs and Training: http://linitx.com/brand/mikrotik
Official UK MikroTik Distributor
IRC chan: #routerboard on irc.z.je (IPv4 and IPv6)
 
savage
Forum Guru
Forum Guru
Posts: 1213
Joined: Mon Oct 18, 2004 12:07 am
Location: Cape Town, South Africa
Contact:

Re: WOL over net

Fri Jul 01, 2016 11:19 pm

all we need now is to be able to WOL to wake up the Mikrotik devices that I accidently did system shutdown. :(

I know, power cycle it..... but its 44km drive to get to it.
perhaps wait for a power failure  (off/on) on the next thunderstorm tomorrow afternoon, that might fix my problem.  Unless anyone else has an easier solution?
Most RouterBOARD devices will turn back on after a minute or so. 
Never seen that in my life with MT.  Not on one single device.
Regards,
Chris

Who is online

Users browsing this forum: No registered users and 17 guests