Community discussions

 
Sunsetcomputers
just joined
Topic Author
Posts: 1
Joined: Mon Apr 05, 2010 11:39 pm

Multiple Files in one e-mail.

Tue Apr 06, 2010 12:04 am

I have been searching the forums on a way to send multiple files in one e-mail script. to be more specific I want to send the Log.txt, a userman backup and full config backup. just not sure what the script is to add more then one file into a single e-mail... thanks for any help.
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: Multiple Files in one e-mail.

Tue Apr 06, 2010 2:25 pm

it is only possible to attach one file to e-mail message in routeros.
 
tafisa
just joined
Posts: 2
Joined: Wed Nov 26, 2014 3:20 pm

Re: Multiple Files in one e-mail.

Wed Nov 26, 2014 3:21 pm

That was on 2010, but now?

Thanks :-)
 
23q
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Thu Sep 02, 2010 2:54 pm
Location: Ukraine

Re: Multiple Files in one e-mail.

Wed May 06, 2015 12:23 pm

?????2015 :lol: :lol:
 
jarda
Forum Guru
Forum Guru
Posts: 7602
Joined: Mon Oct 22, 2012 4:46 pm

Thu May 07, 2015 7:21 am

Now it is still the same. I would like to have the possibility to attach more files too.
 
korniza
newbie
Posts: 26
Joined: Fri Jan 06, 2012 4:05 pm

Re: Multiple Files in one e-mail.

Fri Mar 11, 2016 7:04 am

any news for multiple files attachment??!?!? Really guys, it is not rocket sciense! :D
 
jarda
Forum Guru
Forum Guru
Posts: 7602
Joined: Mon Oct 22, 2012 4:46 pm

Fri Mar 11, 2016 7:35 am

... And so the time goes year by year ...
 
User avatar
ploquets
Member Candidate
Member Candidate
Posts: 128
Joined: Tue Nov 17, 2015 12:49 pm
Location: Uruguaiana, RS, Brazil
Contact:

Re: Multiple Files in one e-mail.

Fri Mar 03, 2017 5:00 pm

nothing ? +1 for multiple files in email
 
User avatar
BlackVS
Member Candidate
Member Candidate
Posts: 171
Joined: Mon Feb 04, 2013 7:00 pm
Contact:

Re: Multiple Files in one e-mail.

Wed Dec 06, 2017 2:25 pm

:local files {$backupconf;$backuplog}
/tool e-mail send to="vvs@somewhere.com" subject="$[/system identity get name]-$[/system clock get time] Backup Configuration & Log - SBB-Optic" file=$files
sends two files!!!
Why - I don't know.
Because wiki clearly says (https://wiki.mikrotik.com/wiki/Manual:Tools/email):
file (File[,File]; Default: ) - List of the file names that will be attached to the mail separated by comma."
I just put myself on place of developer and imagine how I would passed few files...
 
pin
just joined
Posts: 21
Joined: Mon Jul 23, 2018 3:18 pm

Re: Multiple Files in one e-mail.

Fri Dec 07, 2018 11:54 am

:local files {$backupconf;$backuplog}
/tool e-mail send to="vvs@somewhere.com" subject="$[/system identity get name]-$[/system clock get time] Backup Configuration & Log - SBB-Optic" file=$files
sends two files!!!
Why - I don't know.
Because wiki clearly says (https://wiki.mikrotik.com/wiki/Manual:Tools/email):
file (File[,File]; Default: ) - List of the file names that will be attached to the mail separated by comma."
I just put myself on place of developer and imagine how I would passed few files...
Great idea. Still works.
 
User avatar
floaty
newbie
Posts: 39
Joined: Sat Oct 20, 2018 1:24 am
Location: 52°08'32.34"N 14°39'05.0"E

Re: Multiple Files in one e-mail.

Fri Oct 18, 2019 1:28 pm

... or just send all files in a specific folder (disk2/sw/*) ...
.
/tool e-mail send  to="rcvr@rcvr.net" from="$sysName@sndr.net" body="disk2/sw-content" subject="disk2/sw-content" file=[:file find where name~"disk2/sw/"]
~~
We know what happens to people who stay in the middle of the road. They get run over.

Who is online

Users browsing this forum: No registered users and 6 guests