Community discussions

MUM Europe 2020
 
kazanova
Member
Member
Topic Author
Posts: 407
Joined: Tue Sep 06, 2005 11:52 am

script

Mon May 10, 2010 7:41 pm

my ip rang 192.168.10.0/24
and i simple queue
but this script
can someone help me
i don't know from where i should start
thx for try

:local traf;
/queue simple
:for i from=1 to= 254 do = {
:if ([/queue simple find target-addresses=("192.168.10." . $i)] != "") do={
:set traf [get [find target-addresses=("192.168.10." . $i)] total-bytes]
:if ($traf > 1048500) do = {
set [find target-addresses=("192.168.10." . $i)] max-limit=

}
}
}
انا انزلنا التوراه فيها هدى ونور يحكم بها النبيون الذين اسلموا للذين هادوا والربانيون والاحبار بما استحفظوا من كتاب الله وكانوا عليه شهداء فلا تخشوا الناس واخشون ولا تشتروا باياتي ثمنا قليلا ومن لم يحكم بما انزل الله فاولئك هم الكافرون
 
kazanova
Member
Member
Topic Author
Posts: 407
Joined: Tue Sep 06, 2005 11:52 am

Re: script

Mon May 10, 2010 9:40 pm

i use RO 3.30
but no script run fine why??
:for i from=2 to=254 do={/queue simple add name="172.16.64.$i"
target-address="172.16.64.$i/32" max-limit="256000/800000"
burst-limit="0/1500000" burst-threshold="0/400000" burst-time="0s/1m"}
انا انزلنا التوراه فيها هدى ونور يحكم بها النبيون الذين اسلموا للذين هادوا والربانيون والاحبار بما استحفظوا من كتاب الله وكانوا عليه شهداء فلا تخشوا الناس واخشون ولا تشتروا باياتي ثمنا قليلا ومن لم يحكم بما انزل الله فاولئك هم الكافرون
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: script

Tue May 11, 2010 1:26 pm

use PCQ and set 1 simple queue that will limit all the users in network. For examples please take a look on wiki and search in forum.
 
kazanova
Member
Member
Topic Author
Posts: 407
Joined: Tue Sep 06, 2005 11:52 am

Re: script

Tue May 11, 2010 7:37 pm

janisk thx
i had take many look :D
simple i wan to know why script don't work with me
i like to know more about script
i know about PCQ
انا انزلنا التوراه فيها هدى ونور يحكم بها النبيون الذين اسلموا للذين هادوا والربانيون والاحبار بما استحفظوا من كتاب الله وكانوا عليه شهداء فلا تخشوا الناس واخشون ولا تشتروا باياتي ثمنا قليلا ومن لم يحكم بما انزل الله فاولئك هم الكافرون
 
dssmiktik
Forum Veteran
Forum Veteran
Posts: 732
Joined: Fri Aug 17, 2007 8:42 am

Re: script

Wed May 12, 2010 4:20 am

A few things I noticed:
1) I usually don't put spaces between 'do={'
2) specify a max-limit when setting the queue.

Try this code: (replace FIXME with a max-limit value)
:local traf;
/queue simple
:for i from=1 to=254 do={
   :if ([/queue simple find target-addresses=("192.168.10." . $i)] != "") do={
      :set traf [get [find target-addresses=("192.168.10." . $i)] total-bytes]
      :if ($traf > 1048500) do = {
         set [find target-addresses=("192.168.10." . $i)] max-limit=FIXME
      }
   }
}
Doug
 
kazanova
Member
Member
Topic Author
Posts: 407
Joined: Tue Sep 06, 2005 11:52 am

Re: script

Wed May 12, 2010 6:12 pm

it come like that but no hope
any idea what could be the problem

:local traf;
/queue simple
:for i from=10 to=15 do={
:if ([/queue simple find target-addresses=("192.168.10." . $i)] != "") do={
:set traf [get [find target-addresses=("192.168.10." . $i)] total-bytes]
:if ($traf < 1048500) do = {
set [find target-addresses=("192.168.10." . $i)] max-limit=16000/16000
}
}
}
انا انزلنا التوراه فيها هدى ونور يحكم بها النبيون الذين اسلموا للذين هادوا والربانيون والاحبار بما استحفظوا من كتاب الله وكانوا عليه شهداء فلا تخشوا الناس واخشون ولا تشتروا باياتي ثمنا قليلا ومن لم يحكم بما انزل الله فاولئك هم الكافرون
 
dssmiktik
Forum Veteran
Forum Veteran
Posts: 732
Joined: Fri Aug 17, 2007 8:42 am

Re: script

Wed May 12, 2010 11:38 pm

Here is the corrected version (my last post wasn't quite the correct version):

Again, (replace FIXME with a max-limit value):
:local traf;
/queue simple
:for i from=1 to=254 do={
   :if ([/queue simple find target-addresses=("192.168.10." . $i)] != "") do={
      :set traf [get [find target-addresses=("192.168.10." . $i)] total-bytes]
      :if ($traf > 1048500) do={
         set [find target-addresses=("192.168.10." . $i)] max-limit=FIXME
      }
   }
}
Doug
 
kazanova
Member
Member
Topic Author
Posts: 407
Joined: Tue Sep 06, 2005 11:52 am

Re: script

Fri May 14, 2010 6:04 pm

had you test it ??
انا انزلنا التوراه فيها هدى ونور يحكم بها النبيون الذين اسلموا للذين هادوا والربانيون والاحبار بما استحفظوا من كتاب الله وكانوا عليه شهداء فلا تخشوا الناس واخشون ولا تشتروا باياتي ثمنا قليلا ومن لم يحكم بما انزل الله فاولئك هم الكافرون
 
dssmiktik
Forum Veteran
Forum Veteran
Posts: 732
Joined: Fri Aug 17, 2007 8:42 am

Re: script

Fri May 14, 2010 7:57 pm

Does the latest post work for you?
Doug
 
kazanova
Member
Member
Topic Author
Posts: 407
Joined: Tue Sep 06, 2005 11:52 am

Re: script

Fri May 14, 2010 7:58 pm

no one work with me :S
انا انزلنا التوراه فيها هدى ونور يحكم بها النبيون الذين اسلموا للذين هادوا والربانيون والاحبار بما استحفظوا من كتاب الله وكانوا عليه شهداء فلا تخشوا الناس واخشون ولا تشتروا باياتي ثمنا قليلا ومن لم يحكم بما انزل الله فاولئك هم الكافرون
 
dssmiktik
Forum Veteran
Forum Veteran
Posts: 732
Joined: Fri Aug 17, 2007 8:42 am

Re: script

Sat May 15, 2010 5:44 am

Here is the exact script I tested, and it worked on v4.8 x86:
:local traf;
/queue simple
:for i from=1 to=254 do={
   :if ([/queue simple find target-addresses=("192.168.10." . $i)] != "") do={
      :set traf [get [find target-addresses=("192.168.10." . $i)] total-bytes]
      :if ($traf > 1048500) do={
         set [find target-addresses=("192.168.10." . $i)] max-limit=16000/16000
      }
   }
}
Doug
 
kazanova
Member
Member
Topic Author
Posts: 407
Joined: Tue Sep 06, 2005 11:52 am

Re: script

Tue Jul 06, 2010 7:33 pm

it dont work with me
i have v3.30 do u think that will cuz tobrok this scrpit
انا انزلنا التوراه فيها هدى ونور يحكم بها النبيون الذين اسلموا للذين هادوا والربانيون والاحبار بما استحفظوا من كتاب الله وكانوا عليه شهداء فلا تخشوا الناس واخشون ولا تشتروا باياتي ثمنا قليلا ومن لم يحكم بما انزل الله فاولئك هم الكافرون
 
User avatar
NAB
Trainer
Trainer
Posts: 503
Joined: Tue Feb 10, 2009 4:08 pm
Location: UK
Contact:

Re: script

Tue Jul 06, 2010 7:39 pm

it dont work with me
How are you running the script and what error message do you get?
Nicholas Barnes BSc(hons)
Certified Mikrotik Consultant
Certified Mikrotik Trainer

Vitell - Asterisk, Linux and network consultants
Unofficial IRC channel: #routerboard on irc.z.je
 
psamsig
Member Candidate
Member Candidate
Posts: 161
Joined: Sun Dec 06, 2009 1:36 pm
Location: Denmark

Re: script

Wed Jul 07, 2010 11:16 am

I think the problem was in the matching of the target address, it lacked the '/32' suffix
/queue simple {
   :for i from=1 to=254 do={
      :local o [find target-addresses=("192.168.10." . $i . "/32")]
      :if ($o != "") do={
         :if ([get $o total-bytes] > 1048500) do={
            set $o max-limit=16000/16000
         }
      }
   }
}
 
kazanova
Member
Member
Topic Author
Posts: 407
Joined: Tue Sep 06, 2005 11:52 am

Re: script

Fri Jul 09, 2010 3:39 pm

13 post
274 viwe
thx for every one
but psamsig u get karam + thx
انا انزلنا التوراه فيها هدى ونور يحكم بها النبيون الذين اسلموا للذين هادوا والربانيون والاحبار بما استحفظوا من كتاب الله وكانوا عليه شهداء فلا تخشوا الناس واخشون ولا تشتروا باياتي ثمنا قليلا ومن لم يحكم بما انزل الله فاولئك هم الكافرون

Who is online

Users browsing this forum: No registered users and 18 guests