Community discussions

MikroTik App
 
frogale
just joined
Topic Author
Posts: 21
Joined: Thu Jun 22, 2006 11:57 pm

OSPF failure resetator

Tue Aug 17, 2010 10:51 am

We have problem with our routerboards. Sometimes OSPF stops working and "route print" command get stuck (endless running with no results). I've trying solve this problem with Mikrotik support but they are not able to help us. This problem occurs randomly and repeatedly only on some routerboards even with new softwares and firmwares.

Is possible to make script which can reboot routerboard in case of this ospf failure? Maybe somehow detect "route print" running time and reboot in case of stuck.

Many thanks for help!
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8367
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: OSPF failure resetator

Tue Aug 17, 2010 12:26 pm

maybe something like
/system scheduler
add name=schedule1 start-date=jan/01/1970 start-time=00:00:00 interval=5m on-event=":global fine; :set fine false;"
add name=schedule2 start-date=jan/01/1970 start-time=00:00:05 interval=5m on-event=":global fine; /ip route print; :set fine true;"
add name=schedule3 start-date=jan/01/1970 start-time=00:00:20 interval=5m on-event=":global fine; :if (!$fine) do={ /system reboot };"
add necessary policies to the schedules - I don't have a time to test...
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
frogale
just joined
Topic Author
Posts: 21
Joined: Thu Jun 22, 2006 11:57 pm

Re: OSPF failure resetator

Tue Aug 17, 2010 1:00 pm

Great idea. Thanks!
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8367
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: OSPF failure resetator

Tue Aug 17, 2010 1:08 pm

karrrma? =)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
frogale
just joined
Topic Author
Posts: 21
Joined: Thu Jun 22, 2006 11:57 pm

Re: OSPF failure resetator

Tue Aug 17, 2010 2:04 pm

Of course :)
 
blake
Member
Member
Posts: 426
Joined: Mon May 31, 2010 10:46 pm
Location: Arizona

Re: OSPF failure resetator

Wed Aug 18, 2010 2:34 am

karrrma? =)
Just continue posting on every single topic…post count matters more than anything.
IT consultant. Network manager. Packet junkie.
1-928-328-1509
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8367
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: OSPF failure resetator

Wed Aug 18, 2010 4:46 pm

post count matters more than anything.
http://forum.mikrotik.com/viewtopic.php ... 67#p204567

look at the screenshot :D
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24493
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: OSPF failure resetator

Thu Aug 19, 2010 3:02 pm

Chupaka already has the biggest post count, so he has the next target - best karma :)

http://forum.mikrotik.com/memberlist.ph ... &sk=d&sd=d
No answer to your question? How to write posts
 
frogale
just joined
Topic Author
Posts: 21
Joined: Thu Jun 22, 2006 11:57 pm

Re: OSPF failure resetator

Mon Aug 23, 2010 7:32 pm

Mind the time interval after restart (OSPF needs same time to start and scheduler restarting over and over) 8)
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8367
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: OSPF failure resetator

Tue Aug 24, 2010 7:41 pm

well, good remark, but in that case, "/ip route print" should work even if OSPF is not started yet =)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
frogale
just joined
Topic Author
Posts: 21
Joined: Thu Jun 22, 2006 11:57 pm

Re: OSPF failure resetator

Tue Aug 24, 2010 7:58 pm

I don't really know yet.. But after last OSPF failure routerboard ended in restart loops.. I had only 3 seconds for quick mac-telnet login and disable commands..

Who is online

Users browsing this forum: ctlo and 17 guests