Community discussions

 
bronco1980
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 63
Joined: Wed Jul 22, 2009 5:02 pm

How to Block utorrent!!

Thu Jun 07, 2012 9:12 pm

Hi guys,
pls can u help me block utorrent, because it's consuming a lot of bandwith in our network..

Regards,
 
n21roadie
Forum Guru
Forum Guru
Posts: 1889
Joined: Fri Aug 07, 2009 10:36 pm
Location: Limerick,Ireland

Re: How to Block utorrent!!

Thu Jun 07, 2012 9:52 pm

Hi guys,
pls can u help me block utorrent, because it's consuming a lot of bandwith in our network..

Regards,
With torrents becoming more difficult to block with scripts, I have found the most effective solution is to contact the bill payer about excessive downloading, a lot of times they are unaware of this as one of their family is usually downloading torrents, failing that slow them down during peak usage hours, they have two options change their download times or find another internet service provider, another more bandwidth demanding is "Netflix" which a lot of customers do not realise streaming movies consumes bandwidth, once again communication with customers about bandwidth usage is helpful.
N21roadie,
Network 100% MT for Now?
 
bronco1980
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 63
Joined: Wed Jul 22, 2009 5:02 pm

Re: How to Block utorrent!!

Fri Jun 08, 2012 1:46 pm

thanks for replying man, i appreciate it..
we'll try like u said .. i guess they will not like it at all :)
 
angboontiong
Forum Guru
Forum Guru
Posts: 1115
Joined: Fri Jan 16, 2009 9:59 am

Re: How to Block utorrent!!

Fri Jun 08, 2012 4:08 pm

i believe you should able to limit they bandwidth by the queue scheduler...
or some radius manager server which can do such option as well...
 
User avatar
jahidhk
just joined
Posts: 9
Joined: Sat Feb 26, 2011 9:15 pm

Re: How to Block utorrent!!

Sun Oct 07, 2012 9:59 pm

ros code

/ip firewall layer7-protocol
add name=BITTORRENT_ANNOUNCE regexp=^get.+announce.
add name=BITTORENT regexp="^(\\x13bittorrent protocol|azver\\x01\$|get /scrape\
    \\\?info_hash=get /announce\\\?info_hash=|get /client/bitcomet/|GET /data\
    \\\?fid=)|d1:ad2:id20:|\\x08'7P\\)[RP]\\r\\n"
/ip firewall filter
add action=add-src-to-address-list address-list="Torrent Announce" \
    address-list-timeout=1h30m chain=forward comment=______Announce____ \
    disabled=no dst-address-list=!torrent_permit layer7-protocol=\
    BITTORRENT_ANNOUNCE src-address-list=!torrent_permit time=\
    0h-23h59m,sun,mon,tue,wed,thu,fri,sat
add action=reject chain=forward disabled=no dst-address-list=!torrent_permit \
    layer7-protocol=BITTORRENT_ANNOUNCE reject-with=icmp-network-unreachable \
    src-address-list=!torrent_permit time=\
    0h-23h59m,sun,mon,tue,wed,thu,fri,sat
 
ajay
just joined
Posts: 12
Joined: Thu May 17, 2012 12:48 pm

Re: How to Block utorrent!!

Sun Dec 16, 2012 3:46 pm

So above ROS code will block utorrent traffic is that correct?
 
snowpro
just joined
Posts: 20
Joined: Thu Apr 10, 2008 3:56 am
Location: Ottawa Canada

Re: How to Block utorrent!!

Tue Dec 18, 2012 2:00 am

it appears it would and I guess you can adjust the times in the script?

there has not been much talk about appliances like Netequalizer in a long time

I mentioned in another post that I use a script available by a Mikrotik trainer

I prefer to control the torrents and the upload rather than block it
(I will get more phone calls and complaints if I block them)
 
ajay
just joined
Posts: 12
Joined: Thu May 17, 2012 12:48 pm

Re: How to Block utorrent!!

Tue Dec 25, 2012 12:16 pm

Can you please refer me to the link available by mikrotik trainer?

Yes I would also rather control the torrent than block it. Have you done that before. If yes can you please send us the code to do so.

Ajay
 
User avatar
TheWiFiGuy
Member
Member
Posts: 351
Joined: Thu Nov 24, 2011 7:26 pm
Location: UK

Re: How to Block utorrent!!

Fri Jan 04, 2013 2:11 pm

Ditto!

If anyone can point me in the right direction to the fabled script it would be great. I would rather not spend time developing and testing a solution if one can be purchased for a reasonable fee.
----------------------
Mikrotik Consultant.
MTCNA, MTWCE, MTCTCE, MTCRE, MTCINE

Who is online

Users browsing this forum: No registered users and 18 guests