Community discussions

MikroTik App
 
ah3000
newbie
Topic Author
Posts: 42
Joined: Fri Mar 07, 2014 12:02 am

any Idea to get Cache out with lan speed 100m

Sat Apr 26, 2014 11:59 pm

i need the cache out to the user Without speed Limitation

this mt server info

Image
 
ronix
Member Candidate
Member Candidate
Posts: 152
Joined: Thu Nov 17, 2011 6:51 pm

Re: any Idea to get Cache out with lan speed 100m

Sat May 03, 2014 11:56 am

mark cached contents by mangle Rule.
(change dscp to yours cache dscp)

ros code

/ip firewall mangle
add action=mark-packet chain=output comment="cache hit" disabled=no dscp=12 \
new-packet-mark=cache-hits passthrough=no
create an queue tree which will send cache-hits packets to users at full LAN speed

ros code

/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
max-limit=0 name="unlimited speed for cache hit" packet-mark=cache-hits \
parent=global priority=8 queue=default
 
obadaabdullah
Frequent Visitor
Frequent Visitor
Posts: 71
Joined: Wed Jan 08, 2014 7:41 pm

Re: any Idea to get Cache out with lan speed 100m

Wed May 07, 2014 10:31 pm

mark cached contents by mangle Rule.
(change dscp to yours cache dscp)

ros code

/ip firewall mangle
add action=mark-packet chain=output comment="cache hit" disabled=no dscp=12 \
new-packet-mark=cache-hits passthrough=no
create an queue tree which will send cache-hits packets to users at full LAN speed

ros code

/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
max-limit=0 name="unlimited speed for cache hit" packet-mark=cache-hits \
parent=global priority=8 queue=default

hi
i do exactly as u said , but
there is no traffic in this mangle rules
does this work with hotspot users?
i'v already asked for some thing like that
http://forum.mikrotik.com/viewtopic.php?f=2&t=84638

would you pleas help me
 
catallguy
just joined
Posts: 17
Joined: Wed Jul 15, 2009 1:17 am

Re: any Idea to get Cache out with lan speed 100m

Sun Jul 27, 2014 6:09 am

Any updated on this? I am having the same problem. There are a number of posts with this type of problem but the ones I've found don't have a resolution.

I can't get mangle to see the dscp of the mikrotik cache.

I have tried a lot of different things but no luck. If I remove the DSCP value from the mangle I do see traffic on it. And YES I am getting proxy hits!
 

/ip firewall mangle print
 0   ;;; proxy HIT
     chain=output action=mark-packet new-packet-mark=proxy-hit passthrough=no 
     out-interface=bridge2 dscp=4 

/ip proxy print
                 enabled: yes
             src-address: ::
                    port: 8321
               anonymous: no
            parent-proxy: 0.0.0.0
       parent-proxy-port: 0
     cache-administrator: sys admin
          max-cache-size: unlimited
   max-cache-object-size: 2048KiB
           cache-on-disk: yes
  max-client-connections: 2000
  max-server-connections: 2000
          max-fresh-time: 4w2d
   serialize-connections: no
       always-from-cache: no
          cache-hit-dscp: 4
             cache-drive: usb1
Here are some stats shortly after a router reboot to see if that helped. It didn't.

Uptime 00:05:26
Requests 123
Hits 3
Cache Used 2 021 580 KiB
Total RAM Used 1 509 KiB
Received From Servers 2 738 KiB
Sent To Clients 3 020 KiB
Hits Sent To Clients 254 KiB
 
sc0tt
just joined
Posts: 15
Joined: Thu Sep 25, 2014 5:34 am

Re: any Idea to get Cache out with lan speed 100m

Sat Oct 04, 2014 3:15 pm

here in pakistan cache is very importan . sad to say no support in rb :?
 
User avatar
bax
Member Candidate
Member Candidate
Posts: 270
Joined: Mon Dec 20, 2004 8:45 pm
Location: Croatia

Re: any Idea to get Cache out with lan speed 100m

Sun Oct 05, 2014 4:31 pm

Im using this configuration :
/ip firewall mangle
add action=mark-packet chain=output comment="CACHE HIT -dscp4" dscp=4 new-packet-mark=\
    cache-hits out-interface=hotspot passthrough=no
add action=mark-packet chain=output comment="CACHE HIT - L7 hits" layer7-protocol=\
    httpcachehit new-packet-mark=cache-hits out-interface=hotspot passthrough=no
add action=mark-packet chain=output comment="CACHE HIT -X-Cache: HIT" content=\
    "X-Cache: HIT" new-packet-mark=cache-hits out-interface=hotspot passthrough=no
and layer7
/ip firewall layer7-protocol
add name=httpcachehit regexp=\
    "http/(0\\.9|1\\.0|1\\.1)[\\x09-\\x0d ][1-5][0-9][0-9][\\x09-\\x0d -~]*(x-cache: hit)"
And queue tree
/queue tree
add comment="Cache Hit Queue" name="Max Speed for CACHED files" packet-mark=cache-hits parent=global \
    queue=default
and there is some bandwith growning ... most from layer7

Who is online

Users browsing this forum: No registered users and 24 guests