Community discussions

 
mazinsaeed
newbie
Topic Author
Posts: 28
Joined: Wed Oct 16, 2013 4:55 pm

http-video mark-packet prerouting

Wed May 21, 2014 8:42 pm

Hi All , please this script it was worked before , but after reset my RB its not working ... i used to make the videos very slow with simple queues
this is the layer protocols 7
/ip firewall layer7-protocol
add name=http-video regexp="http/(0\\.9|1\\.0|1\\.1)[\\x09-\\x0d ][1-5][0-9][0-9\
    ][\\x09-\\x0d -~]*(content-type: video)"
and this is the mangle
/ip firewall mangle
add action=mark-packet chain=prerouting comment="http-video mark-packet" \
    layer7-protocol=http-video new-packet-mark=http-video passthrough=no
this is the simple queues
/queue simple
add limit-at=64k/64k max-limit=64k/64k name=http-video packet-marks=http-video \
    target=10.9.2.0/24
please help
 
mazinsaeed
newbie
Topic Author
Posts: 28
Joined: Wed Oct 16, 2013 4:55 pm

Re: http-video mark-packet prerouting

Sat May 24, 2014 11:58 am

UP UP UP UP
 
User avatar
shahbazian
Trainer
Trainer
Posts: 166
Joined: Fri Sep 09, 2011 6:22 pm
Location: Iran
Contact:

Re: http-video mark-packet prerouting

Sat May 24, 2014 12:14 pm

Hi mazinsaeed,
L7 matcher collects the first 10 packets of a connection or the first 2KB of a connection.
It is better to mark connections with connection-mark, Then make packet mark for that.
/ip firewall mangle
add action=mark-connection chain=prerouting comment="http-video mark-connection" \
    layer7-protocol=http-video new-connection-mark=http-video passthrough=yes
add action=mark-packet chain=prerouting comment="http-video mark-packet" \
    connection-mark=http-video new-packet-mark=http-video passthrough=yes
Learn MikroTik to improve your network.
( MTCNA, MTCRE, MTCWE, MTCTCE, MTCUME, MTCIPv6E, MTCINE )
MikroTik Certified Trainer & Consultant
RIPE NCC Trainer
 
User avatar
shahbazian
Trainer
Trainer
Posts: 166
Joined: Fri Sep 09, 2011 6:22 pm
Location: Iran
Contact:

Re: http-video mark-packet prerouting

Sat May 24, 2014 12:25 pm

This pattern match only by first packet of http-video connection; When reboot your router, the new packets have not this pattern and do not match with L7 pattern.
So this is a natural.
Learn MikroTik to improve your network.
( MTCNA, MTCRE, MTCWE, MTCTCE, MTCUME, MTCIPv6E, MTCINE )
MikroTik Certified Trainer & Consultant
RIPE NCC Trainer
 
mazinsaeed
newbie
Topic Author
Posts: 28
Joined: Wed Oct 16, 2013 4:55 pm

Re: http-video mark-packet prerouting

Wed May 28, 2014 12:25 pm

Thanks a lot , every thing now is good :)

Who is online

Users browsing this forum: No registered users and 17 guests