Community discussions

MikroTik App
 
Denuro
just joined
Topic Author
Posts: 4
Joined: Tue Dec 10, 2013 2:32 pm

Getting wireless interface rx signal-strength

Thu Jul 17, 2014 10:28 pm

Hi all,

is there any possible way to get the rx signal-strength in a script?
I've tested the attributes in the [ /interface wireless registration-table get ], but couldn't find it.

Thanks
 
User avatar
Kickoleg
Member Candidate
Member Candidate
Posts: 129
Joined: Tue Mar 11, 2014 3:13 pm
Location: Yverdon-les-Bains, Suisse

Re: Getting wireless interface rx signal-strength

Fri Jul 18, 2014 9:50 am

/interface wirelles registration-table get <number> <value-name>
number - number of item
value-name - in your case rx-signal
MTCNA, MTCUME, MTCRE, MTCWE, MTCTCE certified
 
ovdeathiam
just joined
Posts: 20
Joined: Wed Jul 16, 2014 11:15 am

Re: Getting wireless interface rx signal-strength

Fri Jul 18, 2014 9:51 am

You mean like /interface wireless registration-table get value-name=signal-strength?
 
User avatar
Kickoleg
Member Candidate
Member Candidate
Posts: 129
Joined: Tue Mar 11, 2014 3:13 pm
Location: Yverdon-les-Bains, Suisse

Re: Getting wireless interface rx signal-strength

Fri Jul 18, 2014 11:22 am

You mean like /interface wireless registration-table get value-name=signal-strength?
Yes you right - my mistake ... sorry
MTCNA, MTCUME, MTCRE, MTCWE, MTCTCE certified
 
Denuro
just joined
Topic Author
Posts: 4
Joined: Tue Dec 10, 2013 2:32 pm

Re: Getting wireless interface rx signal-strength

Fri Jul 18, 2014 3:07 pm

You mean like /interface wireless registration-table get value-name=signal-strength?
Yes you right - my mistake ... sorry
You are right, the signal-strength is exactly what I need!

I thought it was the same as the tx-signal-strength, but looks like I was wrong :lol:

Thanks
 
plisken
Forum Guru
Forum Guru
Posts: 2504
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: Getting wireless interface rx signal-strength

Mon Sep 15, 2014 12:36 pm

Where can you read the result?
 
User avatar
c0d3rSh3ll
Long time Member
Long time Member
Posts: 558
Joined: Mon Jul 25, 2011 9:42 pm
Location: [admin@Chile] >

Re: Getting wireless interface rx signal-strength

Tue Sep 16, 2014 6:50 am

Where can you read the result?
paste this in the terminal

ros code

put [/interface wireless registration-table get value-name=signal-strength 0 ]
this read the signal strength for the station 0
nothing
 
plisken
Forum Guru
Forum Guru
Posts: 2504
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: Getting wireless interface rx signal-strength

Tue Sep 16, 2014 8:44 am

Thanks c0d3rSh3ll
 
hulitolku
just joined
Posts: 3
Joined: Wed Nov 21, 2018 1:57 am

Re: Getting wireless interface rx signal-strength

Sun May 24, 2020 1:40 am

Why this work ok in Terminal:
:global dbm [/interface wireless registration-table get value-name=signal-strength 0]
But dont work in script?
Global dont get value.
 
User avatar
nichky
Long time Member
Long time Member
Posts: 665
Joined: Tue Jun 23, 2015 2:35 pm

Re: Getting wireless interface rx signal-strength

Sun May 24, 2020 1:50 am

Where can you read the result?
paste this in the terminal

ros code

put [/interface wireless registration-table get value-name=signal-strength 0 ]
this read the signal strength for the station 0

Can you please give me more details about this rule
in my case i got

0 wlan1m.vl101 DC:D9:16:9A:FD:F4 no -39dBm@1Mbps 57.7... 9h37m4s
1 wlan1m.vl101 D4:F5:47:27:FC:33 no -43dBm@1Mbps 72.2... 4h35m11s
2 wlan2v.vl100 AC:D1:B8:84:F5:13 no -59dBm@HT20-7 72.2... 1h2m7s
3 wlan2v.vl100 38:CA:DA:D2:E0:EF no -50dBm@1Mbps 72.2... 3m14s

with your rule im getting resault..... -41dBm@1Mbps
So does it calculate?
RouterOS does not have a random function. Many has tried to make script to make random text, but all seems to be flawed.
viewtopic.php?f=9&t=160183

!) Safe Mode is your friend;
 
User avatar
Jotne
Forum Guru
Forum Guru
Posts: 1874
Joined: Sat Dec 24, 2016 11:17 am
Location: jo.overland at gmail.com

Re: Getting wireless interface rx signal-strength

Sun May 24, 2020 10:17 am

To get better detail about the field, use as-value. Try cut/past this script.
Its part of my Splunk script to monitor all wifi clients. (see signature)
{
	:if ([:len [/interface wireless find ]]>0) do={
		:foreach logline in=[/interface wireless registration-table find] do={
			:local output "$[/interface wireless registration-table print  as-value from=$logline]"
			:set ( "$output"->"script" ) "wifi"
			:put "$output"
		}
	}
}
Output
.id=*8;ap=false;comment=;interface=wlan-2g;mac-address=04:79:70:xx:xx:B3;signal-strength=-52dBm@5.5Mbps;tx-rate=1Mbps;uptime=00:00:08;script=wifi
 
Why do not use Splunk to monitor your MikroTik Router(s)? Look at this page in how to set it up.

MikroTik->Splunk
 
 
User avatar
nichky
Long time Member
Long time Member
Posts: 665
Joined: Tue Jun 23, 2015 2:35 pm

Re: Getting wireless interface rx signal-strength

Mon May 25, 2020 7:34 am

To get better detail about the field, use as-value. Try cut/past this script.
Its part of my Splunk script to monitor all wifi clients. (see signature)
{
	:if ([:len [/interface wireless find ]]>0) do={
		:foreach logline in=[/interface wireless registration-table find] do={
			:local output "$[/interface wireless registration-table print  as-value from=$logline]"
			:set ( "$output"->"script" ) "wifi"
			:put "$output"
		}
	}
}


it would be great if you can make it work from system script. which it does not at the moment

Output
.id=*8;ap=false;comment=;interface=wlan-2g;mac-address=04:79:70:xx:xx:B3;signal-strength=-52dBm@5.5Mbps;tx-rate=1Mbps;uptime=00:00:08;script=wifi
RouterOS does not have a random function. Many has tried to make script to make random text, but all seems to be flawed.
viewtopic.php?f=9&t=160183

!) Safe Mode is your friend;
 
User avatar
Jotne
Forum Guru
Forum Guru
Posts: 1874
Joined: Sat Dec 24, 2016 11:17 am
Location: jo.overland at gmail.com

Re: Getting wireless interface rx signal-strength

Mon May 25, 2020 8:05 am

@nichky

Use the "Post Reply" button to reply someone. If quote is needed, only quote some part, not the whole post.
Here you quoted the post without writing anything :)
 
Why do not use Splunk to monitor your MikroTik Router(s)? Look at this page in how to set it up.

MikroTik->Splunk
 
 
plisken
Forum Guru
Forum Guru
Posts: 2504
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: Getting wireless interface rx signal-strength

Fri Dec 25, 2020 2:51 pm

I know this is an old topic but no less important for that.
I would like to email the signal from my point to point link daily. Can you make a script for this?
regards
 
User avatar
Jotne
Forum Guru
Forum Guru
Posts: 1874
Joined: Sat Dec 24, 2016 11:17 am
Location: jo.overland at gmail.com

Re: Getting wireless interface rx signal-strength

Fri Dec 25, 2020 7:33 pm

Every thing you get an output from can be sent as an email. I have not worked with email sending, so cant help you with that part. Have seen various post here on the forum on how to setup email, so should be possible.

I do use Splunk to monitor this. There I can look at any give time period. If you have paid version it can also send email for any triggered alert you setup. Here is an graph of strengt from two wifi devices.
Wifi_strength.jpg
You do not have the required permissions to view the files attached to this post.
 
Why do not use Splunk to monitor your MikroTik Router(s)? Look at this page in how to set it up.

MikroTik->Splunk
 

Who is online

Users browsing this forum: No registered users and 26 guests