Community discussions

MikroTik App
 
Insanityflea
just joined
Topic Author
Posts: 13
Joined: Thu Jul 31, 2014 9:30 am

Two ISP's

Thu Aug 07, 2014 3:25 pm

Hi all,

I'm trying to setup scheduled times to connect and disconnect pppoe connections. (two ISP's)

1. Weekdays from 6:00:00 till 17:59:50, interface pppoe-out1 (ISP1) must be used.
2. Weekdays from 18:00:00 till 5:59:50, interface pppoe-out2 (ISP2) must be used.
3. Weekends from Friday 17:59:50 until Monday 5:59:50, interface pppoe-out2 (ISP2) must be used

It's easy enough to do this daily, but how would I get this to recognize weekends?

Thanks.
(note - still a noob, be gentle.)
 
Insanityflea
just joined
Topic Author
Posts: 13
Joined: Thu Jul 31, 2014 9:30 am

Re: Two ISP's

Fri Aug 08, 2014 9:04 am

I have this so far:
/system scheduler
add interval=1d name=peak on-event=start_peak policy=reboot,read,write,policy,test,password,sniff,sensitive start-date=aug/07/2014 start-time=06:00:00
add interval=1d name=offpeak on-event=start_offpeak policy=reboot,read,write,policy,test,password,sniff,sensitive start-date=aug/07/2014 start-time=18:00:00
add interval=1w name=week on-event=enable_switch policy=reboot,read,write,policy,test,password,sniff,sensitive start-date=aug/11/2014 start-time=00:00:00
add interval=1w name=weekend on-event=disable_switch policy= reboot,read,write,policy,test,password,sniff,sensitive start-date=aug/09/2014 start-time=00:00:00
/system script
add name=start_peak policy=reboot,read,write,policy,test,password,sniff,sensitive source=\
    "/interface pppoe-client disable pppoe-out2
     /interface pppoe-client enable pppoe-out1"
add name=start_offpeak policy=reboot,read,write,policy,test,password,sniff,sensitive source=\
    "/interface pppoe-client disable pppoe-out1
    /interface pppoe-client enable pppoe-out2"
add name=enable_switch policy=reboot,read,write,policy,test,password,sniff,sensitive source="/system scheduler enable [/system scheduler find name=peak] /system scheduler enable [/system scheduler find name=offpeak]"
add name=disable_switch policy=reboot,read,write,policy,test,password,sniff,sensitive source="/system scheduler disable [/system scheduler find name=peak] /system scheduler disable [/system scheduler find name=offpeak]"
For some reason the peak & off-peak are not triggering, the weekend ones did.
 
CrazyLittleBunny
just joined
Posts: 1
Joined: Tue Feb 03, 2015 4:37 pm

Re: Two ISP's

Tue Feb 03, 2015 4:39 pm

I have the exact same question. Have you been able to figure it out?

Who is online

Users browsing this forum: No registered users and 32 guests