Community discussions

MikroTik App
Topic Author
Posts: 34
Joined: Fri Dec 03, 2010 7:20 pm

Flashfig problem for external wlan-card

Fri Mar 27, 2015 12:56 pm


I'm going to configure 200 RouterBOARD RB912UAG-2HPnD with a R11e-5HacD card in the expantion slot.

I've set up a template router and exported the config to a rsc-file.
Importing this rsc-file to the same machine with blank config works as intended.
But running the same script through flashfig it does not, everything seems to get set except the settings for wlan2 (wich is the R11e-5HacD).

My guess is that this card is not yet initialized when the import set by flashfig runs (documentation doesn't specify, but my best guess is that this happens during the first boot after flashfig).

Tried two workarounds
1. added a delay of 10 seconds with
:delay 10
as the first line in the script, no change.
2. Re-wrote the rsc-file to just add the hole config as a script, and scheduled it to run it during the next boot and then delete the script and the scheduled task. Also this with a 10 second delay after boot. Didn't seem to work at all.
worked on my test without flashfig, but no script or schedule seemed to be added through flashfig
This would also be a bit dirty workaround , but was worth a try

I don't know if my theory is correct, and/or how to solve it. When configuring this amount of boards, the difference of just flashfiging and boot - reset - paste config gets pretty time consuming (and boring :? )

Any ideas?

This is the config
# mar/26/2015 16:35:02 by RouterOS 6.22
# software id = 05J1-5RVQ
/interface wireless security-profiles
add authentication-types=wpa-psk,wpa2-psk,wpa-eap,wpa2-eap eap-methods="" \
    group-ciphers=tkip,aes-ccm management-protection=allowed mode=\
    dynamic-keys name=CO-key supplicant-identity="" unicast-ciphers=\
    tkip,aes-ccm wpa-pre-shared-key=V3ryS3cret wpa2-pre-shared-key=V3ryS3cret
add authentication-types=wpa-psk,wpa2-psk eap-methods="" \
    management-protection=allowed mode=dynamic-keys name="Some WiFi" \
    supplicant-identity="" wpa-pre-shared-key=B0gusP@ass \
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n country=sweden disabled=no \
    distance=indoors frequency=2417 frequency-mode=regulatory-domain \
    hw-protection-mode=cts-to-self l2mtu=1600 mode=ap-bridge rx-chains=0,1 \
    security-profile="Some WiFi" ssid="Some WiFi" tx-chains=0,1 \
set [ find default-name=wlan2 ] country=sweden disabled=no distance=indoors \
    frequency=5320 frequency-mode=regulatory-domain l2mtu=1600 rx-chains=0,1 \
    security-profile=CO-key ssid=1918-Visitor tx-chains=0,1 \
/ip pool
add name=dhcp_pool1 ranges=
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=wlan1 lease-time=8h name=\
/system logging action
set 2 remember=yes
/ip address
add address= interface=wlan1 network=
/ip dhcp-client
add default-route-distance=0 dhcp-options=hostname,clientid disabled=no \
    interface=wlan2 use-peer-ntp=no
/ip dhcp-server network
add address= dns-server=, gateway=
/ip firewall nat
add action=masquerade chain=srcnat out-interface=wlan2
/ip upnp
set allow-disable-external-interface=no enabled=yes
/ip upnp interfaces
add interface=wlan2 type=external
add interface=wlan1 type=internal
set trap-community=public
/system identity
set name=TheRouterName
/system leds
set 0 interface=wlan2
/system ntp client
set enabled=yes primary-ntp= secondary-ntp=
/system routerboard settings
set cpu-frequency=600MHz
/user set admin password=N0tTh3RealP@ass
Edit: Corrected spelling mistake
Topic Author
Posts: 34
Joined: Fri Dec 03, 2010 7:20 pm

Re: Flashfig problem for external wlan-card

Mon Mar 30, 2015 9:04 am

Sorry for bumping, but starting my configuration in about 2 hours. Just a bit desperate to see if someone have any ideas

edit: Never found a solution to this, went the "paste config to console"-route instead lacking other options. Was faster than I expected, even though flashfig would be smoother

Who is online

Users browsing this forum: Google [Bot], runbound and 53 guests