Community discussions

MikroTik App
 
EdPa
MikroTik Support
MikroTik Support
Topic Author
Posts: 305
Joined: Fri Sep 15, 2017 10:05 am
Location: Riga
Contact:

v7.9.1 [stable] is released!

Mon May 22, 2023 11:57 am

RouterOS version 7.9.1 has been released in the "v7 stable" channel!

Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

What's new in 7.9.1 (2023-May-19 15:11):

!) ipv6 - fixed DNS server processing by IPv6/ND services (CVE-2023-32154);

To upgrade, click "Check for updates" at /system package in your RouterOS configuration interface, or head to our download page: http://www.mikrotik.com/download

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while a router is not working as suspected or after some problem has appeared on the device

Please keep this forum topic strictly related to this particular RouterOS release.
 
User avatar
Znevna
Forum Guru
Forum Guru
Posts: 1348
Joined: Mon Sep 23, 2019 1:04 pm

Re: v7.9.1 [stable] is released!

Mon May 22, 2023 12:06 pm

....
Would've been nice to have the "fixes" from 7.10beta5 in this release.
 
usx
newbie
Posts: 26
Joined: Sun Oct 27, 2013 7:30 pm

Re: v7.9.1 [stable] is released!

Mon May 22, 2023 12:14 pm

Bug in webfig still persists: Toggle WiFi Interface off, then on. It stays greyed out even if it got enabled. This applies to all toggable rows in any config area.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 7093
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: v7.9.1 [stable] is released!

Mon May 22, 2023 12:15 pm

read the changelog
 
User avatar
own3r1138
Long time Member
Long time Member
Posts: 694
Joined: Sun Feb 14, 2021 12:33 am
Location: Pleiades
Contact:

Re: v7.9.1 [stable] is released!

Mon May 22, 2023 12:23 pm

2023-05-22_12-52-26.jpg
You do not have the required permissions to view the files attached to this post.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 26464
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia
Contact:

Re: v7.9.1 [stable] is released!

Mon May 22, 2023 12:38 pm

THIS RELEASE CONTAINS ONLY ONE THING
IT IS IN THE CHANGELOG
 
User avatar
pothi
newbie
Posts: 47
Joined: Fri Sep 14, 2018 7:48 pm
Location: Srivilliputhur, Tamil Nadu, India
Contact:

Re: v7.9.1 [stable] is released!

Mon May 22, 2023 1:46 pm

Why don't you just close this topic so that no one else could reply?

We already have another topic if someone wants to discuss the specific security issue.
 
EdPa
MikroTik Support
MikroTik Support
Topic Author
Posts: 305
Joined: Fri Sep 15, 2017 10:05 am
Location: Riga
Contact:

Re: v7.9.1 [stable] is released!

Mon May 22, 2023 3:33 pm

Please feel free to continue discussing topics that are also related to the previous stable version 7.9, as the latest version 7.9.1 primarily focuses on addressing a single security fix (see viewtopic.php?t=196384)
 
felixka
Frequent Visitor
Frequent Visitor
Posts: 58
Joined: Mon Oct 19, 2020 4:12 am
Location: Canada

Re: v7.9.1 [stable] is released!

Mon May 22, 2023 4:04 pm

As mentioned in viewtopic.php?p=1001827#p1001827 I am also seeing a DAC cable between a CCR2004-16G-2S+ and an Aruba 1930 switch no longer being able to connect. That CCR2004 was running 7.6 before and the cable worked just fine for all releases before 7.9 (tested with 7.9, 7.9.1 and 7.10beta5).
Screenshot from 2023-05-22 09-03-44.png
You do not have the required permissions to view the files attached to this post.
 
User avatar
sirbryan
Member
Member
Posts: 341
Joined: Fri May 29, 2020 6:40 pm
Location: Utah
Contact:

Re: v7.9.1 [stable] is released!

Mon May 22, 2023 4:34 pm

Bug in webfig still persists: Toggle WiFi Interface off, then on. It stays greyed out even if it got enabled. This applies to all toggable rows in any config area.
This is also present in 7.10b. Just noticed this the other day after upgrading a couple routers to 7.9.
 
Guscht
Member Candidate
Member Candidate
Posts: 241
Joined: Thu Jul 01, 2010 5:32 pm

Re: v7.9.1 [stable] is released!

Mon May 22, 2023 7:49 pm

workx

Screenshot 2023-05-22 184826.jpg
You do not have the required permissions to view the files attached to this post.
 
xh116
just joined
Posts: 18
Joined: Wed Oct 17, 2018 3:44 pm

Re: v7.9.1 [stable] is released!

Mon May 22, 2023 9:47 pm

It seems my backup script not work well
:local MODEL [/system resource get board-name]

:do {
:if ([:len [/file find type="backup" ]] > 0) do={
:foreach FILE in=[/file find name~"$MODEL.*" && type="backup" ]  do={
:local oldBackupFilename [/file get $FILE name];
/ file remove "$oldBackupFilename"
:log info message="Deleted Old Backup File--$oldBackupFilename";
 } 
 } 
 }
The $oldBackupFilename looks like RB5009UPr+S+-7.9.1 (stable)-20230523.backup
Now it doesn't work.

The scripts used to work since 6.x and I tested on another device running 7.8 which works also.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 12096
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: v7.9.1 [stable] is released!

Tue May 23, 2023 2:35 am

workx
But did you install it on all those machines without waiting even if it was stable or if a problem came up?
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 12096
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: v7.9.1 [stable] is released!

Tue May 23, 2023 2:49 am

It seems my backup script not work well
[...]
And the rest?
What's the use of the ":do {" at the beginning of the script?

Put "RB5009UPr+S+" inside a "~" create a new RegEx: "RB5009UPr+S+.*"...
so the file name searched is like
RB5009UP{one or more r}{one or more S}{any characters here}
and the + disappear from string.
For do the correct search the regexp must be writed:
RB5009UPr\+S\+.*

This works and is less complicated, but suffer the same "+" problem:
:foreach item in=[/file find where name~"^$[/system resource get board-name]" and type="backup"]  do={
    :log info message="Deleted Old Backup File: $[/file get $item name]"
    /file remove $item
}

Hint: Use RouterBOARD name instead of the RouterBOARD model.
:foreach item in=[/file find where name~"^$[/system identity get name]" and type="backup"]  do={
    :log info message="Deleted Old Backup File: $[/file get $item name]"
    /file remove $item
}

You can control how you call the device, bout you can't control the RouterBOARD name...
 
buset1974
Frequent Visitor
Frequent Visitor
Posts: 86
Joined: Wed Sep 13, 2006 12:12 pm
Location: Jakarta

Re: v7.9.1 [stable] is released!

Tue May 23, 2023 6:03 am

!) ipv6 - fixed DNS server processing by IPv6/ND services (CVE-2023-32154);

What this issue affects: The issue affects devices running MikroTik RouterOS versions v6.xx and v7.xx with enabled IPv6 advertisement receiver functionality. You are only affected if one of the below settings is applied:

the issue affects v6.xx and v7.xx, i did not see any update for v6?
I think alot of people still using v6.x.x

thx
 
cdemers
Member Candidate
Member Candidate
Posts: 224
Joined: Sun Feb 26, 2006 3:32 pm
Location: Canada
Contact:

Re: v7.9.1 [stable] is released!

Tue May 23, 2023 6:24 am

@buset1974 They have already mentioned that they will be releasing it for v6 also, they are still checking the releases it takes time, probably the next day or so. Check the blog:
https://blog.mikrotik.com/security/cve-2023-32154.html
 
xh116
just joined
Posts: 18
Joined: Wed Oct 17, 2018 3:44 pm

Re: v7.9.1 [stable] is released!

Tue May 23, 2023 6:34 am

It seems my backup script not work well
[...]
And the rest?
What's the use of the ":do {" at the beginning of the script?

Put "RB5009UPr+S+" inside a "~" create a new RegEx: "RB5009UPr+S+.*"...
so the file name searched is like
RB5009UP{one or more r}{one or more S}{any characters here}
and the + disappear from string.
For do the correct search the regexp must be writed:
RB5009UPr\+S\+.*

This works and is less complicated, but suffer the same "+" problem:
:foreach item in=[/file find where name~"^$[/system resource get board-name]" and type="backup"]  do={
    :log info message="Deleted Old Backup File: $[/file get $item name]"
    /file remove $item
}

Hint: Use RouterBOARD name instead of the RouterBOARD model.
:foreach item in=[/file find where name~"^$[/system identity get name]" and type="backup"]  do={
    :log info message="Deleted Old Backup File: $[/file get $item name]"
    /file remove $item
}

You can control how you call the device, bout you can't control the RouterBOARD name...
Thank you for that.
Using the identity name should be a better choice !

I just test again.
if I add "-", the backup file name with MODEL will be recognized.
"$MODEL.*"  ==> "$MODEL . "-" . *"
edit: It will delete all backup file...
have to switch to use identity name.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 12096
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: v7.9.1 [stable] is released!

Tue May 23, 2023 10:27 am

( "$MODEL-.*" or ("$MODEL" . "-" . ".*") is the same, "$MODEL . "-" . *" is wrong )
 
User avatar
osc86
Member Candidate
Member Candidate
Posts: 197
Joined: Wed Aug 09, 2017 1:15 pm

Re: v7.9.1 [stable] is released!

Tue May 23, 2023 10:59 am

fasttrack counters are not working on hap ax3
 
HighTech
just joined
Posts: 4
Joined: Fri Feb 22, 2019 2:26 pm

Re: v7.9.1 [stable] is released!

Tue May 23, 2023 5:40 pm

There is a bug in v7.9.1, When upgrading CCR2004-1G-12S+2XS from v7.8 to v7.9.1 the SFP+ mudules stops sending light on random SFP+ ports, downgrading to v7.8 fix the problem again
 
gabeselig1
just joined
Posts: 2
Joined: Mon Jan 16, 2023 11:39 pm
Location: Indiana, USA

Re: v7.9.1 [stable] is released!

Tue May 23, 2023 7:38 pm

Is anyone else having an issue with any automation scripts that rely on using SSH to connect to a mikrotik? It seems like when in a pseudo-terminal, line wrap is occurring at around 80 characters.

I went from v7.8 to v7.9 (and v7.9.1). Before, when in a pseudo-terminal, we could send a column width of something above 80 characters. Now, when sending a SSH_MSG_CHANNEL_REQUEST to jump into a pseudo-terminal and sending the pty-req with a larger terminal width, the responses are limited to 80 characters per line.

We also tried changing terminal types to xterm and VT102 from vt100. I've also tried sending a terminal width in pixels. Per rfc4254, we've also tried sending a window-change after in the pseudo-terminal with a larger terminal width.

We are only using a psuedo-terminal after authenticating because the default banner causes issues with automation.

PHP code we are using is:
#Using version 3.0.19 from https://github.com/phpseclib/phpseclib/releases
$ssh = new \phpseclib3\Net\SSH2('SomeIP');
if ($ssh->login('SomeUsername', 'SomePassword')) {
$ssh->setWindowSize(120, 240); //default 80x24
$ssh->enablePTY();
$ssh->exec('/ip arp print without-paging');
$streamResponse = $ssh->read('[6n');
$ssh->disablePTY();
$streamResponse = preg_replace('#\\x1b[[][^A-Za-z]*[A-Za-z]#', '', $streamResponse);
$streamResponse = substr($streamResponse, 0, -5);
}

It seems related to @jlgonzalez post about v7.9 - viewtopic.php?p=1003126&hilit=v7.9+is+released#p1002242

Put a support ticket in (SUP-117157)
Last edited by gabeselig1 on Tue May 23, 2023 8:24 pm, edited 2 times in total.
 
holvoetn
Forum Guru
Forum Guru
Posts: 5690
Joined: Tue Apr 13, 2021 2:14 am
Location: Belgium

Re: v7.9.1 [stable] is released!

Tue May 23, 2023 7:46 pm

Has been reported before ( I think 7.9 thread)
Have you sent report to support about this ?
 
User avatar
blackhandnz
just joined
Posts: 14
Joined: Mon Nov 29, 2021 11:41 pm
Location: New Zealand

Re: v7.9.1 [stable] is released!

Tue May 23, 2023 10:49 pm

After this update is anyone getting these warnings : received Router Advertisement packet with non-linklocal source address ?
 
MasteRTriX
just joined
Posts: 10
Joined: Tue Nov 12, 2013 3:02 am

Re: v7.9.1 [stable] is released!

Wed May 24, 2023 6:32 am

Cannot upgrade from dude "needed packages are not available"
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 26464
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia
Contact:

Re: v7.9.1 [stable] is released!

Wed May 24, 2023 7:22 am

Check what packages you have installed. What is the current version in that router?
 
deanMK
newbie
Posts: 32
Joined: Sat Apr 12, 2014 2:46 pm
Location: Macedonia

Re: v7.9.1 [stable] is released!

Wed May 24, 2023 9:26 am

....
Would've been nice to have the "fixes" from 7.10beta5 in this release.
I dont think so. That will be included in 7.10 stable release !

Mainwhile i got "MAC@wifi1 disconnected, key handshake timeout, signal strength -74" errors into console on my AX3 and devices not connecting to it. Someone with fix for this problem?
 
holvoetn
Forum Guru
Forum Guru
Posts: 5690
Joined: Tue Apr 13, 2021 2:14 am
Location: Belgium

Re: v7.9.1 [stable] is released!

Wed May 24, 2023 9:35 am

The error message you show, I've seen as well. Other wifi issues I've encountered are related to PMKSA or clients simply not being able to connect anymore (password prompt even for a known network and nothing further).

Some issues are solved with 7.10b5 (now b8).
There are alpha versions around for some users to address yet other wifi issues (but which issues exactly they address, is not clear).
So we need to wait for another beta, I guess, which will then move later on to stable.

Moving down to 7.8 is also an option.
 
rplant
Member
Member
Posts: 370
Joined: Fri Sep 29, 2017 11:42 am

Re: v7.9.1 [stable] is released!

Wed May 24, 2023 11:00 am

I don't suppose applying this cve fix (only) to some (one??) of the versions people are currently having to roll back too is an option?
 
User avatar
Znevna
Forum Guru
Forum Guru
Posts: 1348
Joined: Mon Sep 23, 2019 1:04 pm

Re: v7.9.1 [stable] is released!

Wed May 24, 2023 1:56 pm

....
Would've been nice to have the "fixes" from 7.10beta5 in this release.
I dont think so. That will be included in 7.10 stable release !

Mainwhile i got "MAC@wifi1 disconnected, key handshake timeout, signal strength -74" errors into console on my AX3 and devices not connecting to it. Someone with fix for this problem?
I don't think so.
 
User avatar
mkx
Forum Guru
Forum Guru
Posts: 11871
Joined: Thu Mar 03, 2016 10:23 pm

Re: v7.9.1 [stable] is released!

Wed May 24, 2023 6:41 pm

I don't suppose applying this cve fix (only) to some (one??) of the versions people are currently having to roll back too is an option?
It was applied to all releases that MT considers stable or long term: 6.48, 6.49 and 7.9 ... if there are reasons for any particular user not to use one of these releases, then it really isn't up to MT to patch the rest (if it was up to MT, then everybody would either use one of stable releases or latest beta which is AFAIK patched as well). After all, the vulnerability is a problem in specific cases and not all devices are used in those cases. Default config is not vulnerable for example and I guess many users use their devices with default config (as far as this vulnerability goes).
 
tihovsky
newbie
Posts: 48
Joined: Mon Aug 13, 2012 11:11 pm

Re: v7.9.1 [stable] is released!

Wed May 24, 2023 6:54 pm

I have relatively complex and redundant network and noticed already since 7.8 up until 7.9.1 I have some issues with RSTP bringing ports down.

Happens twice or three times a week and logging only contains local interface > Bridge RX looped packet MAC of the local admin brdge MAC and then main router VRRP address info.
Even though the bridging and stp debug logs are active these messages are only thing I get, and sometimes particular switches get completely isolated from the network.
Switches are 3xx and use hardware bridging so probably why not more details in the log about bridge ports and why/when they go down.

When it happens, locally connecting to the switch I notice there is no root port selected in the bridge ports and all copper edge ports 1-48 are switching between disabled and designated state, so seems like a bug although I cannot be certain but issue doesn't correct itself until switch is rebooted.

Could be some sfpplus or QSFP interface in the network occasionally flapping causing this to happen. I can send more info as suppout if someone interested to check.
I noticed in 7.9 changelog there was some work done on the bridging, so applied fw update but this issue persisted.

Not sure how to harden RSTP by relaxing or tightening the parameters?
To sort out immediate issue I could make a netwatch script that would additionally check if no root port on the bridge selected for sfpplus and qsfpplus and then reboot the switch.
But I have a number of smaller switches connected using POE so don't want to also reboot them all.
Any better ideas are welcome.
 
User avatar
mkx
Forum Guru
Forum Guru
Posts: 11871
Joined: Thu Mar 03, 2016 10:23 pm

Re: v7.9.1 [stable] is released!

Wed May 24, 2023 7:22 pm

A good step forward would be to create supout.rif file on a switch which has the problem ongoing. Then send the file to MT support so that they can analyze it and hopefully discover the bug causing it.
 
Rox169
Member
Member
Posts: 445
Joined: Sat Sep 04, 2021 1:47 am

Re: v7.9.1 [stable] is released!

Thu May 25, 2023 9:12 am

Hi,
I had another error login with WiFi on this "STABLE" 9.1. Ït has been reported as SUP-116195. Mobile can not join WiFi mobile say the password is not correct and after reboot all is OK and mobile can join the WiFi without any chage. Im using only WPA/WPA2.
 
holvoetn
Forum Guru
Forum Guru
Posts: 5690
Joined: Tue Apr 13, 2021 2:14 am
Location: Belgium

Re: v7.9.1 [stable] is released!

Thu May 25, 2023 9:53 am

Known issue. Should be solved with 7.10b8.
 
erlinden
Forum Guru
Forum Guru
Posts: 2100
Joined: Wed Jun 12, 2013 1:59 pm
Location: Netherlands

Re: v7.9.1 [stable] is released!

Thu May 25, 2023 10:02 am

Im using only WPA/WPA2.
Is this on purpose...? WPA is like near-no security.
 
Rox169
Member
Member
Posts: 445
Joined: Sat Sep 04, 2021 1:47 am

Re: v7.9.1 [stable] is released!

Thu May 25, 2023 1:20 pm

Yes, I just installed AX2 to parent and they can not join. So I tried to lover security. House is on village so there is minimum risk of attack.
 
deanMK
newbie
Posts: 32
Joined: Sat Apr 12, 2014 2:46 pm
Location: Macedonia

Re: v7.9.1 [stable] is released!

Thu May 25, 2023 1:46 pm

The error message you show, I've seen as well. Other wifi issues I've encountered are related to PMKSA or clients simply not being able to connect anymore (password prompt even for a known network and nothing further).

Some issues are solved with 7.10b5 (now b8).
There are alpha versions around for some users to address yet other wifi issues (but which issues exactly they address, is not clear).
So we need to wait for another beta, I guess, which will then move later on to stable.

Moving down to 7.8 is also an option.
Tryed also 7.10b8 but same problem. Wifi devices refused to connect to AX3. Back to 7.8 stable. Waitning for new update!
 
wormik
just joined
Posts: 6
Joined: Sun Oct 10, 2021 1:48 am

Re: v7.9.1 [stable] is released!

Thu May 25, 2023 3:07 pm

I'm unable to upgrade to the latest release on my hAP ac3 - the router downloads the image, reboots itself, but loads the older version 7.9.
I can perform the upgrade on hAP ac2 on the same network.

Is anyone experiencing the same issue?
 
User avatar
mkx
Forum Guru
Forum Guru
Posts: 11871
Joined: Thu Mar 03, 2016 10:23 pm

Re: v7.9.1 [stable] is released!

Thu May 25, 2023 3:18 pm

I'm unable to upgrade to the latest release on my hAP ac3 - the router downloads the image, reboots itself, but loads the older version 7.9.

After router reboots after failed upgrade, is there anything in log about it?
 
p3rad0x
Long time Member
Long time Member
Posts: 638
Joined: Fri Sep 18, 2015 5:42 pm
Location: South Africa
Contact:

Re: v7.9.1 [stable] is released!

Thu May 25, 2023 4:37 pm

BFD support would be nice
 
noradtux
newbie
Posts: 39
Joined: Mon May 24, 2021 6:33 pm

Re: v7.9.1 [stable] is released!

Thu May 25, 2023 5:02 pm

BFD support would be nice
It's in 7.10beta. So the wait is almost over :)
 
wormik
just joined
Posts: 6
Joined: Sun Oct 10, 2021 1:48 am

Re: v7.9.1 [stable] is released!

Fri May 26, 2023 12:39 am

I'm unable to upgrade to the latest release on my hAP ac3 - the router downloads the image, reboots itself, but loads the older version 7.9.

After router reboots after failed upgrade, is there anything in log about it?
Unfortunately no…
The first log is a statement “router rebooted”, afterwards there’s L2TP VPN messages, then ethernet interfaces up, DHCP leases, etc., but nothing with regards to the system upgrade.

Free HDD space is 88.7 MBs
 
Wyz4k
Member Candidate
Member Candidate
Posts: 240
Joined: Fri Jul 10, 2009 10:23 am

Re: v7.9.1 [stable] is released!

Fri May 26, 2023 3:54 am

I upgraded 3 hap ac2s from 7.9 to 7.9.1 and all three bricked. If you have any hap ac2s be very careful with this upgrade.

I had done netinstalls recently on all of these to get them to ROS7 and stable, I'll have to do it again now but this caused disruption and downtime unfortunately.
 
User avatar
vecernik87
Forum Veteran
Forum Veteran
Posts: 884
Joined: Fri Nov 10, 2017 8:19 am

Re: v7.9.1 [stable] is released!

Fri May 26, 2023 5:12 am

@Wyz4k: Thanks for heads up! I tested that first on a spare device and then on one production - both survived alright. What is the use case for your devices? My spare device works as a VLAN aware switch with one SSTP mgmt VPN. Other one is my home router so nothing strange either - sstp server, some basic forwarding into multiple VLANs. I have to say though, that both have
/ipv6 settings set disable-ipv6=yes
which might play role? Perhaps some other configuration with DNS affects this? (looking at you DOH, you dirty feature)
Also, both are from the unique 256MB RAM batch. Lack of memory might play a role as well?
 
Wyz4k
Member Candidate
Member Candidate
Posts: 240
Joined: Fri Jul 10, 2009 10:23 am

Re: v7.9.1 [stable] is released!

Fri May 26, 2023 5:20 am

They function as distributed desk Gigabit switches and WiFi APs (CAPS). Other than that their configs are very basic.
 
User avatar
mkx
Forum Guru
Forum Guru
Posts: 11871
Joined: Thu Mar 03, 2016 10:23 pm

Re: v7.9.1 [stable] is released!

Fri May 26, 2023 6:57 am

After router reboots after failed upgrade, is there anything in log about it?
Unfortunately no…

It seems that router doesn't attempt to upgrade then. Could be that upgrade package fails at consistency check or something ... and I've no idea why it happens.
 
User avatar
armandfumal
Member Candidate
Member Candidate
Posts: 161
Joined: Wed Apr 25, 2012 5:50 pm
Location: Weiswampach,LUX
Contact:

Re: v7.9.1 [stable] is released!

Fri May 26, 2023 5:19 pm

THIS RELEASE CONTAINS ONLY ONE THING
IT IS IN THE CHANGELOG
it seems clear. easy to understand...but...
 
grol
just joined
Posts: 1
Joined: Sun Jun 13, 2021 9:25 pm

Re: v7.9.1 [stable] is released!

Fri May 26, 2023 7:56 pm

After upgrade 7.9.1 total mess in CAPSMAN - CAPs connecting/disconnecting, no WiFi. After downgrade to to 7.9 - OK
 
pamribeirox
just joined
Posts: 18
Joined: Fri Dec 22, 2017 6:20 pm

Router-id selection not following the selected criteria (v7.8, v7.9, v7.9.1)

Sat May 27, 2023 10:37 pm

I've had an OSPF instability due to duplicate router-id's in the network when migrating services from one old router to a new (v7.x) one.
The problem was originated because I've included the loopback address from the old router in the new one. I've intentionally placed the address in the disable state to avoid conflicts until the migration was completed and the old equipment shutdown but ... the router-id selection has selected the disabled address and the conflict happened anyway.

To reproduce the problem:
# Create a loopback interface (bridge without ports)
/interface bridge add arp=disabled name=loopback protocol-mode=none
# Add one /32 address to the loopback
/ip address add address=10.10.10.10 interface=loopback network=10.10.10.10
# Add another lower /32 address to the loopback, in the disabled state
/ip address add address=10.10.10.9 disabled=yes interface=loopback network=10.10.10.9
# Create a new router-id with criteria to only select the lowest ACTIVE static address from the loopback interfaces
/routing id add disabled=no name=id-1 select-dynamic-id=only-static,only-loopback,only-vrf,only-active,lowest
# See the selected address ... ooops!!!
/routing id print where name=id-1
Columns: NAME, DYNAMIC-ID, SELECT-DYNAMIC-ID
# NAME  DYNAMIC-ID  SELECT-DYNAMIC-ID
1 id-1 10.10.10.9  only-static
                    only-loopback
                    only-vrf
                    only-active
                    lowest
It's not a critical bug and should be easy solved in one of the next minor releases.

Thanks for the "super feature" of placing the comments in line with the corresponding lines (WebFig). Still needs some "tunning" but is much better this way. The old behavior was a mess!!!
Keep the good work.
 
User avatar
Plnt
just joined
Posts: 10
Joined: Thu Jul 16, 2015 2:27 pm
Contact:

Re: v7.9.1 [stable] is released!

Sun May 28, 2023 12:09 pm

Hi,
I had another error login with WiFi on this "STABLE" 9.1. Ït has been reported as SUP-116195. Mobile can not join WiFi mobile say the password is not correct and after reboot all is OK and mobile can join the WiFi without any chage. Im using only WPA/WPA2.
I just experienced the same problem. I upgraded hAP ax2 from 7.9 to 7.9.1 on May 22. Today all WiFi clients all of a sudden were disconnected and can't reconnect. Nothing in the logs except for disconnect info. After reboot everything works fine.
 
Pirlet
just joined
Posts: 16
Joined: Mon Nov 25, 2013 4:13 pm

Re: v7.9.1 [stable] is released!

Sun May 28, 2023 12:22 pm

Hey guys, my RB4011 ARM is failing to upgrade, it downloads the package reboots, but then it's on 7.9 again.

Any idea how to fix it?
 
User avatar
Ullinator
just joined
Posts: 9
Joined: Tue Jun 08, 2021 12:53 pm
Location: North-West Germany

Re: v7.9.1 [stable] is released!

Sun May 28, 2023 12:48 pm

Hey guys, my RB4011 ARM is failing to upgrade, it downloads the package reboots, but then it's on 7.9 again.

Any idea how to fix it?
Export the config, netinstall, re-import. It's the savest and easiest way. :-)
 
Pirlet
just joined
Posts: 16
Joined: Mon Nov 25, 2013 4:13 pm

Re: v7.9.1 [stable] is released!

Sun May 28, 2023 1:06 pm

Hey guys, my RB4011 ARM is failing to upgrade, it downloads the package reboots, but then it's on 7.9 again.

Any idea how to fix it?
Export the config, netinstall, re-import. It's the savest and easiest way. :-)
That seems quite the hassle, I think I'll wait for the stable of 7.10 and see if an upgrade works.
 
F1le
newbie
Posts: 29
Joined: Tue Nov 21, 2017 1:35 am

Re: v7.9.1 [stable] is released!

Sun May 28, 2023 2:27 pm

My mangle rules stopped working after 7.9.1 update... on RB5009
It just can't mark certain CONTENT packets anylonger...

Anybody has same issue? I made another entry in Mangle rule :

chain=prerouting action=add-dst-to-address-list protocol=tcp
address-list=TEST address-list-timeout=5d dst-port=443 log=no
log-prefix="" tls-host=*youtube*

I tagged first packets and later not even 1

This rule :

chain=prerouting action=add-dst-to-address-list
address-list=IPs-to-2ndWAN address-list-timeout=none-dynamic
content=my.abc.com log=no log-prefix=""

Was working so fine and suddenly after 7.9.1 stopped working.

Anybody?
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 12096
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: v7.9.1 [stable] is released!

Sun May 28, 2023 6:46 pm

Sorry, but now (from 8 May...) Youtube use TLS 1.3..... and not only TCP....
All modern browsers and app use TLS 1.3, so you are unable to mark the traffic.
You just noticed it now, and of course you have to blame RouterOS...

Just if you still use some old browser that doesn't support TLS 1.3, but at most 1.2, it can make you match that rule.
The other domain doesn't know what it is, so I haven't checked it, if it still uses http you can still catch it,
but when that too switches to https, your rules won't be of any use.
 
Rox169
Member
Member
Posts: 445
Joined: Sat Sep 04, 2021 1:47 am

Re: v7.9.1 [stable] is released!

Sun May 28, 2023 8:11 pm

Hi,
I had another error login with WiFi on this "STABLE" 9.1. Ït has been reported as SUP-116195. Mobile can not join WiFi mobile say the password is not correct and after reboot all is OK and mobile can join the WiFi without any chage. Im using only WPA/WPA2.
I just experienced the same problem. I upgraded hAP ax2 from 7.9 to 7.9.1 on May 22. Today all WiFi clients all of a sudden were disconnected and can't reconnect. Nothing in the logs except for disconnect info. After reboot everything works fine.
Did you send supout.rif?
 
pamribeirox
just joined
Posts: 18
Joined: Fri Dec 22, 2017 6:20 pm

Re: v7.9.1 [stable] is released!

Tue May 30, 2023 5:06 pm

CRS312 NO SFP (SX/LX) LINK with Nokia/Alcatel after upgrade from 6.49.7 to 7.9.1

In one of our CRS312-4C+8XG we have a backup link using SFP S-85DLC05D connected to an Nokia(Alcatel MPLS router 7210-SAS-M
When we upgraded to ROS 7.9.1 the link doesn't establish anymore.
  • Behavior (before and after upgrade) reproduced in another two CRS312-4C+8XG at different site.
  • Optical signals reported OK by DDM ok both sides
  • Tested using SFP's S-31DLC20D and corresponding Nokia LX SFP, NO LINK
  • Tested between two ports on the same CRS312-4C+8XG with SFP S-85DLC05D , LINK OK!
  • Combo port was forced to SFP media (from auto) without any behavior change
  • Disabling auto-negociation on the port and forcing to 1Gbps raises the link on CRS312 but at the Nokia side remains DOWN
  • Forcing the rate select to "low" doesn't solve the problem

regards!
 
Simonej
Frequent Visitor
Frequent Visitor
Posts: 59
Joined: Sun Aug 22, 2021 3:34 am

Re: v7.9.1 [stable] is released!

Tue May 30, 2023 9:35 pm

Hello, is anyone having issues connecting iOS 16.5 devices to AC Wifiwave2 AP? Android phones are working.
I'm aware of troubles with MT AX WiFi but never had problems in the last few weeks using 7.8 and 7.9 (only AC APs).
Reboot is not helping.
Sending supout to support right now.
 
aat
just joined
Posts: 2
Joined: Tue Dec 27, 2016 1:02 am

Re: v7.9.1 [stable] is released!

Wed May 31, 2023 12:05 pm

Hello,
I have the same issue with Chateau lte12 - now installed ROS version 7.8, after trying to update to 7.9.1 and rebooting still version 7.8. Does anyone have any experience with the solution?
 
EdPa
MikroTik Support
MikroTik Support
Topic Author
Posts: 305
Joined: Fri Sep 15, 2017 10:05 am
Location: Riga
Contact:

Re: v7.9.1 [stable] is released!

Wed May 31, 2023 1:14 pm

RouterOS v7.9.2 has been released
viewtopic.php?t=196619

Who is online

Users browsing this forum: No registered users and 9 guests