Community discussions

MikroTik App
 
dnnix
just joined
Topic Author
Posts: 11
Joined: Fri Aug 18, 2023 3:12 pm
Location: Washington, DC
Contact:

Client AP Bridge

Tue Jan 09, 2024 3:16 am

I'm trying to make a "wAP ac" into a client access point that bridges wired clients behind it onto the network. Essentially, I'm giving a device which only supports wired networks access to a wireless network.

I have the wAP ac joining to my wireless network just fine, but I cannot get it to relay DHCP requests to the DHCP server (main router). Any ideas? I've looked everywhere, but don't see a clear solution documented. Maybe I'm using the wrong station mode?
 2024-01-08 20:12:37 by RouterOS 7.14beta4
# software id = REYE-I8XU
#
# model = RBwAPG-5HacD2HnD
# serial number = HDE08DJPY85
/interface bridge
add name=bridge1 port-cost-mode=short
/interface wireless
set [ find default-name=wlan1 ] ssid=MikroTik
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=20/40/80mhz-eeeC \
    disabled=no frequency=5805 skip-dfs-channels=all ssid=Hector \
    wireless-protocol=802.11
/interface ethernet switch port
set 0 default-vlan-id=auto vlan-mode=disabled
set 1 default-vlan-id=auto vlan-mode=disabled
set 2 default-vlan-id=auto vlan-mode=disabled
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk disable-pmkid=yes mode=\
    dynamic-keys supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=hotspot
/interface bridge port
add bridge=bridge1 interface=ether1 internal-path-cost=10 path-cost=10
add bridge=bridge1 interface=ether2 internal-path-cost=10 path-cost=10
/ip firewall connection tracking
set udp-timeout=10s
/interface list member
add interface=wlan2 list=WAN
add interface=ether1 list=LAN
add interface=ether2 list=LAN
add interface=wlan1 list=LAN
add interface=bridge1 list=LAN
/ip dhcp-client
add interface=wlan2
/ip dhcp-relay
add dhcp-server=10.62.14.1 disabled=no interface=wlan2 local-address=10.62.14.5 \
    name=relay1
/ip firewall nat
add action=masquerade chain=srcnat out-interface=wlan2
/system clock
set time-zone-name=America/New_York
/system identity
set name=clientap-livingroom
/system note
set show-at-login=no
/system package update
set channel=testing
 
dnnix
just joined
Topic Author
Posts: 11
Joined: Fri Aug 18, 2023 3:12 pm
Location: Washington, DC
Contact:

Re: Client AP Bridge

Tue Jan 09, 2024 11:11 am

I think I figured this out. I started using the mode station-pseudobridge and added wlan2 to bridge1.
# 2024-01-09 04:16:07 by RouterOS 7.14beta4
# software id = REYE-I8XU
#
# model = RBwAPG-5HacD2HnD
# serial number = HDE08DJPY85
/interface bridge
add name=bridge1 port-cost-mode=short
/interface wireless
set [ find default-name=wlan1 ] ssid=MikroTik
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=20/40/80mhz-eeeC disabled=no frequency=5805 mode=station-pseudobridge skip-dfs-channels=all ssid=Hector wireless-protocol=802.11
/interface ethernet switch port
set 0 default-vlan-id=auto vlan-mode=disabled
set 1 default-vlan-id=auto vlan-mode=disabled
set 2 default-vlan-id=auto vlan-mode=disabled
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk disable-pmkid=yes mode=dynamic-keys supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=hotspot
/interface bridge port
add bridge=bridge1 interface=ether1 internal-path-cost=10 path-cost=10
add bridge=bridge1 interface=ether2 internal-path-cost=10 path-cost=10
add bridge=bridge1 interface=wlan2
/ip firewall connection tracking
set udp-timeout=10s
/interface list member
add interface=wlan2 list=WAN
add interface=ether1 list=LAN
add interface=ether2 list=LAN
add interface=wlan1 list=LAN
add interface=bridge1 list=LAN
/ip address
add address=10.62.14.5/24 interface=wlan2 network=10.62.14.0
/ip dhcp-relay
add dhcp-server=10.62.14.1 disabled=no interface=wlan2 local-address=10.62.14.5 name=relay1
/system clock
set time-zone-name=America/New_York
/system identity
set name=clientap-livingroom
/system note
set show-at-login=no
/system ntp client
set enabled=yes
/system ntp client servers
add address=10.62.54.1
/system package update
set channel=testing

Who is online

Users browsing this forum: igorr29, vodokotlic and 5 guests