Community discussions

MikroTik App
 
SekasJr
just joined
Topic Author
Posts: 2
Joined: Sun Feb 11, 2024 9:02 am

Empty BGP session on ROS 7.13.4

Sun Feb 11, 2024 9:42 am

Hi Mikrotik folks,
I have purchased a new router CCR2116-12G-4s+ (arm64) ROS version 7.13.4. I was unsuccessful in applying e-BGP settings in ROS v7 where the e-BGP session did not display anything. Here's the information from my ISP:
GLOBAL >> LAN 3 >> BW 140Mbps
DOMESTIC >> LAN 4 >> BW100Mbps
BW Total : 240 Mbps

# IP GLOBAL # 
IP ADD : 179.20.18.60
SM : 255.255.255.252
GW : 179.20.18.59/30
===========

# IP DOMESTIC # 
IP ADD : 175.30.18.82
SM : 255.255.255.252
GW : 175.30.18.81/30

IP GATEWAY PUBLIK 1 : 104.99.182.128/29
IP GATEWAY PUBLIK 2 : 180.250.18.92/29

as number : 89898
remote as : 7713

The following are the settings that I have applied to ROS 7 :
/interface ethernet
set [ find default-name=ether1 ] name=ether1-global
set [ find default-name=ether2 ] name=ether2-domestic
set [ find default-name=ether3 ] name=ether3-public-104
set [ find default-name=ether4 ] name=ether4-public-180
set [ find default-name=ether10 ] name=ether10-local

/ip pool
add name=dhcp_pool0 ranges=192.168.10.2-192.168.10.254

/ip address
add address=179.20.18.60/30 interface=ether1-global network=179.20.18.58
add address=175.30.18.82/30 interface=ether2-domestic network=175.30.18.80
add address=104.99.182.129/29 interface=ether3-public-104 network=\
    104.99.182.128
add address=180.250.18.92/29 interface=ether4-public-180 network=180.250.18.91
add address=192.168.10.1/24 interface=ether10-local network=192.168.10.0

/ip dhcp-server
add address-pool=dhcp_pool0 interface=ether10-local name=dhcp1

/ip dhcp-server network
add address=192.168.10.0/24 dns-server=192.168.10.1 gateway=192.168.10.1

/ip dns
set allow-remote-requests=yes servers=208.67.222.222,208.67.220.220

/ip firewall address-list
add address=104.99.182.128/29 list=my-network
add address=180.250.18.91/29 list=my-network

/ip firewall nat
add action=src-nat chain=srcnat comment="global to 104" src-address=\
    179.20.18.60 to-addresses=104.99.182.129
add action=src-nat chain=srcnat comment="domestic to 104" src-address=\
    175.30.18.82 to-addresses=104.99.182.129
add action=src-nat chain=srcnat comment="global to 180" src-address=\
    179.20.18.60 to-addresses=180.250.18.92
add action=src-nat chain=srcnat comment="domestic to 180" src-address=\
    175.30.18.82 to-addresses=180.250.18.92
add action=src-nat chain=srcnat comment="ether 10 to 104" src-address=\
    192.168.10.0/24 to-addresses=104.99.182.129

/routing bgp template
set default as=89898 disabled=no output.network=my-network routing-table=main
add as=89898 disabled=no name=My_BGP routing-table=main

/routing bgp connection
add as=89898 disabled=no local.role=ebgp name=domestic \
    output.network=my-network remote.address=175.30.18.81/30 routing-table=main \
    templates=My_BGP
add as=89898 disabled=no local.role=ebgp name=global \
    output.network=my-network remote.address=179.20.18.59/30 routing-table=main \
    templates=My_BGP
From the settings above, nothing appears in the session.
Please help. Is there a setting I'm missing?
What script should I add to the BGP Filter?
 
savage
Forum Guru
Forum Guru
Posts: 1261
Joined: Mon Oct 18, 2004 12:07 am
Location: Cape Town, South Africa
Contact:

Re: Empty BGP session on ROS 7.13.4

Mon Feb 12, 2024 12:25 pm

BGP in ROSv7 defaults to 'deny all' for route filters, where as ROSv6 was 'accept all'.

You need an inbound and outbound filter on the BGP sessions.
 
SekasJr
just joined
Topic Author
Posts: 2
Joined: Sun Feb 11, 2024 9:02 am

Re: Empty BGP session on ROS 7.13.4

Mon Feb 12, 2024 6:57 pm

BGP in ROSv7 defaults to 'deny all' for route filters, where as ROSv6 was 'accept all'.

You need an inbound and outbound filter on the BGP sessions.
I have not been able to apply filters to the inbound and outbound filters on the BGP sessions. Can you help me with how to implement it?

Who is online

Users browsing this forum: No registered users and 5 guests