Community discussions

MikroTik App
 
Biohazard3k
just joined
Topic Author
Posts: 3
Joined: Fri Feb 02, 2024 6:50 pm

V7 "routing mask"

Fri Feb 02, 2024 7:00 pm

Hey guys,

I have a RB4011 which was running V6.

I have packet bonding with my ISP that allows me to bond both my FTTC connections for upload and download (same ISP and with there supported RADIUS) but on my own for the router.

This has been working fine until i upgraded to V7 whereby it seems "routing-mark" is no longer supported in /ip route and all my routes have been removed.

Here was my config in V6 (IPs removed)

/ip address
add address=x.x.x.x/30 interface=HANDOVER network=x.x.x.x

/ip firewall mangle
add action=mark-packet chain=prerouting new-packet-mark=ONE nth=2,1 \ passthrough=yes src-address=x.x.x.x/30
add action=mark-packet chain=prerouting new-packet-mark=TWO nth=2,2 \ passthrough=yes src-address=x.x.x.x/30
add action=mark-routing chain=prerouting new-routing-mark=ONE packet-mark=ONE \ passthrough=no
add action=mark-routing chain=prerouting new-routing-mark=TWO packet-mark=TWO \ passthrough=no

/ip route
add check-gateway=ping distance=1 gateway="FTTC Line 1" routing-mark=ONE
add check-gateway=ping distance=1 gateway="FTTC Line 2" routing-mark=TWO
add check-gateway=ping distance=2 gateway="FTTC Line 1,FTTC Line 2"

I assume this has been removed or changed into the Firewall and other modules.

Does anyone know if its possible to convert it to work with V7? (I know i could go back to V6)

Any advise or pointers would be greatly appreciated.

Kind Regards,

Adam
 
DeadStik
just joined
Posts: 18
Joined: Thu Jan 04, 2024 4:35 pm

Re: V7 "routing mask"

Fri Feb 02, 2024 8:31 pm

It is an easy fix! In v7, routing-mark was replaced by routing tables.
/routing table
add disabled=no fib name="ONE"
add disabled=no fib name="TWO"
And change routing-mark to routing-table in routes.
/ip route
add check-gateway=ping distance=1 gateway="FTTC Line 1" routing-table=ONE
add check-gateway=ping distance=1 gateway="FTTC Line 2" routing-table=TWO
add check-gateway=ping distance=2 gateway="FTTC Line 1,FTTC Line 2"
 
jaclaz
Long time Member
Long time Member
Posts: 667
Joined: Tue Oct 03, 2023 4:21 pm

Re: V7 "routing mask"

Fri Feb 02, 2024 8:33 pm

In version 7 you need to add the routing tables (fib):

viewtopic.php?t=182044
viewtopic.php?t=191319
 
pe1chl
Forum Guru
Forum Guru
Posts: 10248
Joined: Mon Jun 08, 2015 12:09 pm

Re: V7 "routing mask"

Fri Feb 02, 2024 9:28 pm

When you have an existing configuration in a router running v6, and then you upload v7 and upgrade, the configuration will be automatically converted. So you should not have such problems unless you have netinstalled v7 and then try to import (or paste) the old v6 configuration into v7.

In case of the RB4011 you can usually just go back to v6 and migrate to v7, but unfortunately when you had bought a new router (e.g. a CCR2004 or RB5009) this would not be an option because you cannot install v6 on those.

When you are experienced, you can install v6 CHR, load the v6 config, upgrade the CHR to v7 and see what has changed.
It would be nice when MikroTik offered a v6-to-v7 converter on their website...
(paste v6 config into a text area or upload .rsc file, click a button, and see it converted to v7 available for download)
 
Biohazard3k
just joined
Topic Author
Posts: 3
Joined: Fri Feb 02, 2024 6:50 pm

Re: V7 "routing mask"

Sat Feb 03, 2024 10:21 pm

It is an easy fix! In v7, routing-mark was replaced by routing tables.
/routing table
add disabled=no fib name="ONE"
add disabled=no fib name="TWO"
And change routing-mark to routing-table in routes.
/ip route
add check-gateway=ping distance=1 gateway="FTTC Line 1" routing-table=ONE
add check-gateway=ping distance=1 gateway="FTTC Line 2" routing-table=TWO
add check-gateway=ping distance=2 gateway="FTTC Line 1,FTTC Line 2"
Thank you DeadStik, i shall drop that config in. Very kind of you x
 
Biohazard3k
just joined
Topic Author
Posts: 3
Joined: Fri Feb 02, 2024 6:50 pm

Re: V7 "routing mask"

Sat Feb 03, 2024 10:22 pm

When you have an existing configuration in a router running v6, and then you upload v7 and upgrade, the configuration will be automatically converted. So you should not have such problems unless you have netinstalled v7 and then try to import (or paste) the old v6 configuration into v7.

In case of the RB4011 you can usually just go back to v6 and migrate to v7, but unfortunately when you had bought a new router (e.g. a CCR2004 or RB5009) this would not be an option because you cannot install v6 on those.

When you are experienced, you can install v6 CHR, load the v6 config, upgrade the CHR to v7 and see what has changed.
It would be nice when MikroTik offered a v6-to-v7 converter on their website...
(paste v6 config into a text area or upload .rsc file, click a button, and see it converted to v7 available for download)
Hey pe1chl,

Yeah, it did not migrate or convert the existing configuration. It just removed it all. I have a RB3011 as well and it did the same thing. :(
 
memo009525
just joined
Posts: 13
Joined: Sun May 01, 2022 9:30 pm

Re: V7 "routing mask"

Tue Feb 13, 2024 6:19 am

Hey Adam,Can you please tell me if you've fixed the problem? I have the same issue and can't find a solution. If you've solved it, could you please tell me what to do? I would be very grateful. Thank you in advance.
 
pe1chl
Forum Guru
Forum Guru
Posts: 10248
Joined: Mon Jun 08, 2015 12:09 pm

Re: V7 "routing mask"

Tue Feb 13, 2024 10:44 am

The appropriate replies were already given above...
 
memo009525
just joined
Posts: 13
Joined: Sun May 01, 2022 9:30 pm

Re: V7 "routing mask"

Tue Feb 13, 2024 1:35 pm

The appropriate replies were already given above...
Hello pe1ch, I attempted the solution you suggested, but unfortunately, it didn't resolve my issue. Additionally, I have two WAN connections that I was balancing using the Nth method. However, after an update, this approach ceased to function, even though I'm using the same rules as mentioned above, albeit with different names. Could you please provide guidance on how to fix this?Thank you in advance for your help... Thank you for reply.
 
pe1chl
Forum Guru
Forum Guru
Posts: 10248
Joined: Mon Jun 08, 2015 12:09 pm

Re: V7 "routing mask"

Tue Feb 13, 2024 2:55 pm

No. Use the manual or the links above. I am not an unpaid consultant.
 
jaclaz
Long time Member
Long time Member
Posts: 667
Joined: Tue Oct 03, 2023 4:21 pm

Re: V7 "routing mask"

Tue Feb 13, 2024 5:22 pm

@memo009525

You are having an issue that you believe (but not necessarily is) the same of the OP.

Since you cannot apply (or you can apply but it doesn't resolve the issue) the solution that worked for the OP, you are asking for assistance, and you are asking that to specific members.

It usually doesn't work this way.

The proper way to (hopefully) obtain assistance in the forum is:
1) start a NEW topic, where:
2) you detail the issue you are having
3) post your complete configuration, see: viewtopic.php?t=203686#p1051720
4) provide a description of your physical LAN/WAN setup (if very simple) or - better, particularly when multiple switch/routers/access points are involved a network diagram

There (again hopefully) someone, not necessarily the members you addressed, may be able to give you advice or hints towards the resolution.
 
memo009525
just joined
Posts: 13
Joined: Sun May 01, 2022 9:30 pm

Re: V7 "routing mask"

Tue Feb 13, 2024 6:27 pm

Alright thanks alot
 
Mesquite
Member
Member
Posts: 420
Joined: Tue Jan 23, 2024 9:16 pm

Re: V7 "routing mask"

Wed Feb 14, 2024 4:39 pm

Proof positive for the infinite time, new posters need guidance/education prior to posting......
 
jaclaz
Long time Member
Long time Member
Posts: 667
Joined: Tue Oct 03, 2023 4:21 pm

Re: V7 "routing mask"

Wed Feb 14, 2024 5:36 pm

Proof positive for the infinite time, new posters need guidance/education prior to posting......
... and old posters need to remark it, every time.

Life as usual ...
 
Mesquite
Member
Member
Posts: 420
Joined: Tue Jan 23, 2024 9:16 pm

Re: V7 "routing mask"

Wed Feb 14, 2024 9:14 pm

Some people except failure as usual. I dont.

Who is online

Users browsing this forum: ringrring and 17 guests