Community discussions

MikroTik App
 
User avatar
Meltto
just joined
Topic Author
Posts: 6
Joined: Tue Apr 09, 2024 6:53 am

Passive Interfaces MPLS - VPLS RouterOS v7

Wed Apr 10, 2024 4:49 pm

Hello, Im doing an MPLS VPLS Lab and I made all the configurations but the VPLS tunnel doesnt work.
The only strange thing I see is that the connection with the neighbors is DOp. What does it mean for the interface to be passive?
1.png
SW-CORE

/port
set 0 name=serial0
/interface bridge port
add bridge=*6 interface=ether2
add bridge=*6 interface=ether3
/ip address
add address=192.168.15.239/24 interface=ether1 network=192.168.15.0
add address=1.1.1.1 interface=lo network=1.1.1.1
add address=20.0.0.1/30 interface=ether2 network=20.0.0.0
add address=20.0.0.5/30 interface=ether3 network=20.0.0.4
/ip dhcp-client
add interface=ether1
/ip route
add disabled=no dst-address=2.2.2.2/32 gateway=20.0.0.2 routing-table=main \
suppress-hw-offload=no
add disabled=no dst-address=3.3.3.3/32 gateway=20.0.0.6 routing-table=main \
suppress-hw-offload=no
/mpls interface
add disabled=no input=yes interface=ether2
add disabled=no input=yes interface=lo
/mpls ldp
add disabled=no lsr-id=1.1.1.1 transport-addresses=1.1.1.1
/mpls ldp interface
add accept-dynamic-neighbors=yes disabled=no interface=ether2 \
transport-addresses=1.1.1.1
add disabled=no interface=ether3 transport-addresses=1.1.1.1
/system identity
set name=SW-CORE
/system note
set show-at-login=no
/tool romon
set enabled=yes

SW-NODO-1

/interface bridge
add name=VPLS-TUNEL
/interface vpls
add arp=enabled disabled=no mac-address=02:DE:AB:FB:E7:22 mtu=1500 name=VPLS1 \
peer=3.3.3.3 vpls-id=1:1
/port
set 0 name=serial0
/interface bridge port
add bridge=VPLS-TUNEL interface=VPLS1
add bridge=VPLS-TUNEL interface=ether2
/ip address
add address=2.2.2.2 interface=lo network=2.2.2.2
add address=20.0.0.2/30 interface=ether1 network=20.0.0.0
add address=192.168.1.1/30 interface=VPLS1 network=192.168.1.0
/ip dhcp-client
add interface=ether1
/ip route
add disabled=no dst-address=0.0.0.0/0 gateway=20.0.0.1 routing-table=main \
suppress-hw-offload=no
add disabled=no distance=1 dst-address=1.1.1.1/32 gateway=20.0.0.1 pref-src="" \
routing-table=main scope=30 suppress-hw-offload=no target-scope=10
/mpls interface
add disabled=no input=yes interface=ether2
add disabled=no input=yes interface=lo
/mpls ldp
add disabled=no lsr-id=2.2.2.2 transport-addresses=2.2.2.2
/mpls ldp interface
add accept-dynamic-neighbors=yes disabled=no interface=ether1 \
transport-addresses=2.2.2.2
/system identity
set name=SW-NODO-1
/system note
set show-at-login=no
/tool romon
set enabled=yes


SW-NODO-2

/interface bridge
add name=VPLS-TUNEL
/interface vpls
add arp=enabled disabled=no mac-address=02:5A:60:BF:D3:E9 mtu=1500 name=VPLS1 \
peer=2.2.2.2 vpls-id=1:1
/port
set 0 name=serial0
/interface bridge port
add bridge=VPLS-TUNEL interface=VPLS1
add bridge=VPLS-TUNEL interface=ether2
/ip address
add address=20.0.0.6/30 interface=ether1 network=20.0.0.4
add address=3.3.3.3 interface=lo network=3.3.3.3
add address=192.168.1.2/30 interface=VPLS1 network=192.168.1.0
/ip dhcp-client
add interface=ether1
/ip route
add disabled=no dst-address=0.0.0.0/0 gateway=20.0.0.5 routing-table=main \
suppress-hw-offload=no
add disabled=no dst-address=1.1.1.1/32 gateway=20.0.0.5 routing-table=main \
suppress-hw-offload=no
/mpls ldp
add disabled=no lsr-id=3.3.3.3 transport-addresses=3.3.3.3
/mpls ldp interface
add accept-dynamic-neighbors=yes disabled=no interface=ether1 \
transport-addresses=3.3.3.3
/system identity
set name=SW-NODO-2
/system note
set show-at-login=no
/tool romon
set enabled=yes

2.png
You do not have the required permissions to view the files attached to this post.
 
User avatar
Meltto
just joined
Topic Author
Posts: 6
Joined: Tue Apr 09, 2024 6:53 am

Re: Passive Interfaces MPLS - VPLS RouterOS v7

Wed Apr 10, 2024 5:36 pm

For those who are interested, find the following information:

In MPLS (Multiprotocol Label Switching), a passive interface on a Mikrotik router refers to an interface that does not actively participate in the exchange of MPLS labels. In other words, the passive interface on a Mikrotik router does not perform MPLS packet tagging or untagging.

In a typical MPLS scenario, routers that are part of the MPLS network exchange MPLS labels to route packets efficiently through the network. However, in the case of a passive interface, the Mikrotik router simply forwards the MPLS packets without modifying the MPLS labels associated with them.

In summary, a passive interface in MPLS with a Mikrotik router is an interface that does not perform active tagging or untagging operations on MPLS packets, but simply forwards the packets as it receives them.

BUT MY VPLS TUNNEL ISNT WORKING YET.
 
User avatar
loloski
Member
Member
Posts: 361
Joined: Mon Mar 15, 2021 9:10 pm

Re: Passive Interfaces MPLS - VPLS RouterOS v7

Wed Apr 10, 2024 6:33 pm

I have a similar post to you, as per some folks here they said v7 has still some bug in VPLS even though everything seems right the VPLS tunnel is up IGP is up and BGP sessildons is all up it still won't work... If you really want to make VPLS work make the P router as Route Reflector with v6.49.X it should work
 
User avatar
loloski
Member
Member
Posts: 361
Joined: Mon Mar 15, 2021 9:10 pm

Re: Passive Interfaces MPLS - VPLS RouterOS v7

Wed Apr 10, 2024 6:44 pm

This works for me, it worked but not really great because you still have ros v6 at play
1.png
You do not have the required permissions to view the files attached to this post.
 
User avatar
Meltto
just joined
Topic Author
Posts: 6
Joined: Tue Apr 09, 2024 6:53 am

Re: Passive Interfaces MPLS - VPLS RouterOS v7

Wed Apr 10, 2024 7:22 pm

This works for me, it worked but not really great because you still have ros v6 at play

1.png
Ok ok, let me try.
 
User avatar
Meltto
just joined
Topic Author
Posts: 6
Joined: Tue Apr 09, 2024 6:53 am

Re: Passive Interfaces MPLS - VPLS RouterOS v7

Wed Apr 10, 2024 7:46 pm

This works for me, it worked but not really great because you still have ros v6 at play

1.png
You need the Route Reflector. Without it, doesnt work, right?
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 7070
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: Passive Interfaces MPLS - VPLS RouterOS v7

Fri Apr 12, 2024 11:27 pm

For those who are interested, find the following information:

In MPLS (Multiprotocol Label Switching), a passive interface on a Mikrotik router refers to an interface that does not actively participate in the exchange of MPLS labels. In other words, the passive interface on a Mikrotik router does not perform MPLS packet tagging or untagging.

In a typical MPLS scenario, routers that are part of the MPLS network exchange MPLS labels to route packets efficiently through the network. However, in the case of a passive interface, the Mikrotik router simply forwards the MPLS packets without modifying the MPLS labels associated with them.

In summary, a passive interface in MPLS with a Mikrotik router is an interface that does not perform active tagging or untagging operations on MPLS packets, but simply forwards the packets as it receives them.
Where did you find this?

Who is online

Users browsing this forum: Bing [Bot] and 1 guest