Community discussions

MikroTik App
 
User avatar
kehrlein
newbie
Topic Author
Posts: 48
Joined: Tue Jul 09, 2019 1:35 am

Issue with Auto Upgrade / packages from another MikroTik device

Wed Mar 25, 2020 11:06 pm

Hi guys,

I'm trying to update a MikroTik device (named as "client" in the following case) with packages provided from another MikroTik device ("server").

server (running on a x86 system; v6.46.4) provides this package:
> file print where type=package
 # NAME                                                  TYPE                                                SIZE CREATION-TIME       
 0 routeros-mmips-6.46.4.npk                             package                                             9.8MiB mar/25/2020 18:18:23

client is on mmips plattform running v6.46.3:
/system upgrade upgrade-package-source print 
 # ADDRESS       USER                                                                                                                      
 0 10.0.1.1      update

During "/system upgrade refresh" I can see that the client connects via winbox port to the server for several seconds.
But "Available Packages" on the client stays empty and download-all shows:
/system upgrade print 
 # SOURCE          NAME             VERSION      STATUS        COMPLETED

/system upgrade download-all 
failure: there is no newer full release version available

Any ideas why the client isn't using the newer npk from the server?

Thanks!
 
User avatar
robtor
newbie
Posts: 45
Joined: Sat Dec 09, 2023 3:27 pm
Location: Germany, Hessen
Contact:

Re: Issue with Auto Upgrade / packages from another MikroTik device

Fri Apr 12, 2024 2:15 pm

This answer might be a little bit late, but I'm intrerested in this topic as well. I cannot get it working and always get an error message that the router could not determine which is the system package.

Hopefully someone from MT staff reads this and can give a quick answer. I cannot find anything in the documentation.
 
pimmie
newbie
Posts: 43
Joined: Fri Mar 27, 2015 4:51 pm

Re: Issue with Auto Upgrade / packages from another MikroTik device

Fri Apr 12, 2024 2:52 pm

Shouldnt you be using `/system/package/update/check-for-updates` and `/system/package/update/download` ? Or is that v7 only?
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 12045
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: Issue with Auto Upgrade / packages from another MikroTik device

Fri Apr 12, 2024 6:13 pm

Shouldnt you be using `/system/package/update/check-for-updates` and `/system/package/update/download` ? Or is that v7 only?
Before answering, make sure you are talking about the same topic, obviously NOT.
 
pimmie
newbie
Posts: 43
Joined: Fri Mar 27, 2015 4:51 pm

Re: Issue with Auto Upgrade / packages from another MikroTik device

Fri Apr 12, 2024 8:42 pm

Sure, but sometimes that's not how learning new things work. And aren't we all here to learn things we didn't knew yet?
 
User avatar
robtor
newbie
Posts: 45
Joined: Sat Dec 09, 2023 3:27 pm
Location: Germany, Hessen
Contact:

Re: Issue with Auto Upgrade / packages from another MikroTik device

Sat Apr 13, 2024 6:59 pm

Shouldnt you be using `/system/package/update/check-for-updates` and `/system/package/update/download` ? Or is that v7 only?
Like the others wrote that's a completely different feature. The Auto-Upgrade menu the thread-creator and me we want to use is for using other ROS-Devices as upgrade source. For my setup I need it because the devices itself all reside within a management vlan that has NO access to the internet and thus the
/system/package/update/check-for-updates
won't work because it will contact mikrotik's servers.

Therefor I want to create a small mirror on my Edge-Router that has internet access by downloading packages manually or with a self-written script and then I need all other devices to pull the updates from this device.

I also followed the article some user mentioned in my thread about this topic:
viewtopic.php?t=203236
But unfortunately I only get the login messages on the edge router but nothing happes.

Who is online

Users browsing this forum: abbio90, anav, Bing [Bot], Google [Bot], hmatmtf, neopike, Schaka, SystemZ and 44 guests