Community discussions

MikroTik App
 
Ismael23
just joined
Topic Author
Posts: 3
Joined: Tue Apr 16, 2024 9:14 pm

Blank ARP failure (not displaying information) RouterOS 7 version

Wed Apr 17, 2024 2:38 am

Hello, I'm having difficulty displaying the ARP table information, which is showing blank. This issue started after updating the routers from version 6 to version 7. Each version 7 update has presented this type of failure in different production equipment. For example, currently I have two routers with this issue: one is the CCR1009 model, running version 7.8, and the other is the CCR1036, running version 7.11.2. I am a small ISP, and these routers provide access to clients. The configuration used for layer 2 encapsulation for each client connection is the 802.1q protocol (VLAN), and currently, I have an average of 300 to 500 VLANs configured on the equipment.

When the equipment experiences this failure, if restarted, it returns to displaying ARP table information normally, but after some time of use, the failure occurs again. If anyone knows of a solution and can help me, I would be very grateful.
 
pe1chl
Forum Guru
Forum Guru
Posts: 10304
Joined: Mon Jun 08, 2015 12:09 pm

Re: Blank ARP failure (not displaying information) RouterOS 7 version

Wed Apr 17, 2024 11:45 am

It means your L2 link is dead. A blank MAC address in an ARP entry means the entry is "incomplete", i.e. there was no reply to the ARP request.

That being said, a difference between v6 and v7 is that v7 never clears the ARP table. So even after an entry is unused for a long time, it still remains in the table. v6 would remove it after some time.
So it may be that you now see more entries and that a lot of them are "blank", but that does not necessarily mean there is a failure.
It could be there is a client that was online before, and is now offline.

Before declaring it a failure, you need to check if there actually are issues with communication, rather than only a lot of blank ARP entries in the table.
When you want to clean the table without rebooting, you can schedule a script like this:
/ip arp remove [ find where !complete and !published ]
and run it e.g. once a day or once an hour.
 
Ismael23
just joined
Topic Author
Posts: 3
Joined: Tue Apr 16, 2024 9:14 pm

Re: Blank ARP failure (not displaying information) RouterOS 7 version

Thu Apr 18, 2024 2:51 am

So, it happens that L2 communication is working correctly, but the information in the ARP table is completely blank, without any data whatsoever. Even when I use the Terminal with the 'ip arp print' command, it also displays all the information as blank. In the screenshot below, it shows how the ARP information looks even when it was confirmed by the log that the linking of IP addresses with MAC addresses occurred.


https://drive.google.com/file/d/19QFuqR ... sp=sharing
 
User avatar
vingjfg
Member
Member
Posts: 358
Joined: Fri Oct 20, 2023 1:45 pm

Re: Blank ARP failure (not displaying information) RouterOS 7 version

Thu Apr 18, 2024 7:48 am

Hi there.

Can you provide an expunged/sanitized config?

When you have the blank arp table, is all l3 connectivity lost? Or does everything works as usual?
 
Ismael23
just joined
Topic Author
Posts: 3
Joined: Tue Apr 16, 2024 9:14 pm

Re: Blank ARP failure (not displaying information) RouterOS 7 version

Mon Apr 22, 2024 6:34 pm

Hi there.

Can you provide an expunged/sanitized config?

When you have the blank arp table, is all l3 connectivity lost? Or does everything works as usual?

Hello vingjfg,

Here is a basic configuration for setting up a service VLAN
#Creation of VLANs.
/interface vlan
add interface=ether1 name=vlan1-3540 vlan-id=3540
add interface=vlan1-3540 name=vlan-954789 vlan-id=346

#Adding the pool
/ip pool
add name=dhcp-pool-954789 ranges=100.65.61.26

#Adding the DHCP Server
/ip dhcp-server
add add-arp=yes address-pool=dhcp-pool-958347 conflict-detection=no disabled=\
no interface=vlan-958347 lease-time=1d name=dhcp-958347


#Adding IP addresses to physical interfaces and VLANs
/ip address
add address=172.16.227.194/27 disabled=yes interface=ether1 network=\
172.16.227.192
add address=100.65.61.25/30 interface=vlan-954789 network=100.65.61.24

#Adding network information to the DHCP Server
/ip dhcp-server network
add address=100.65.61.24/30 dns-server=8.8.8.8,8.8.4.4 gateway=\
100.65.61.25

When a failure occurs, L3 connectivity works correctly, there are no network communication failures, only ARP does not display any information.

Another issue we have observed is that some of these routers have also been experiencing errors when new configurations are saved to the NAND memory. When new configurations are made, they remain in volatile memory. However, if no backup of the new information is saved, and the router is restarted, it reverts to an older backup. Most of the routers that have shown this error either needed to be reset and a newer backup uploaded, or sent to technical support for investigation. What we haven't yet identified is whether all routers experiencing this ARP display failure may also be experiencing issues with saving information to the NAND memory.
 
pe1chl
Forum Guru
Forum Guru
Posts: 10304
Joined: Mon Jun 08, 2015 12:09 pm

Re: Blank ARP failure (not displaying information) RouterOS 7 version

Mon Apr 22, 2024 7:14 pm

The latter is usually caused by the flash memory being completely full.
Check System->Resources and look at the HDD space. When it is zero or near zero (e.g. 8K), you are in trouble.
 
srijit92
Frequent Visitor
Frequent Visitor
Posts: 81
Joined: Sun Jul 01, 2012 11:56 am
Location: India
Contact:

Re: Blank ARP failure (not displaying information) RouterOS 7 version

Sat May 25, 2024 8:56 pm

Facing similar issue with CCR 2116. Changed hardware but same problem.

But with 1009 and 1036 running V6 no issues. Simple plug and play connectivities with proper ARP and ping.

But with v7 and 2116 blank Arp and no ping. Wireshark pcap shows arp request from mikrotik but no arp response received.

Gateway is a Cisco Router with two switch in between. Similar Config runs fine or V6 1009 and 1036.

Any idea?

Who is online

Users browsing this forum: No registered users and 6 guests