Community discussions

MikroTik App
 
akkurad
just joined
Topic Author
Posts: 5
Joined: Sun Mar 17, 2024 8:15 pm

Problems with connecting Samsung Orsay Smart TV to my WIFI network

Fri Apr 19, 2024 12:03 pm

Dear community,

I'm relatively new to networking and recently bought a Mikrotik hap ax³ to replace my ISP router.

I have since set it up and so far everything has been working for all my devices. Until yesterday, when I tried to connect my older Samsung Orsay Smart TV to my network.

What's happening:
  • The network shows up in the network settings of the TV, I can enter the password and it will say it's connected.
  • It gets an IP and the necessary infos about default gateway and dns servers from my DHCP server.
  • It then proceeds to say that it is not able to connect to the local network, nor the internet and stops being reachable from the local network (ping).
  • I monitored under Firewall -> Connections that it was connecting to remote servers.
What I've tried in order to fix the issue:
  • "Have you tried turning it off and on again?" (Yes)
  • Resetting the TV (didn't work)
    - Weirdly enough, during the reset process it will say it's downloading an EULA or privacy policy, which...works without issues?
  • Connecting the TV using a powerline ethernet adapter
    - Result: Everything works perfectly fine, the TV is able to reach the internet and is also reachable from the local network.
    - Problem: Unfortunately not a permanent solution (adapter is needed elsewhere).
  • Disabling the 5ghz band on the router
    - Result: Still unable to connect
I'm kind of at a loss with this, it used to work fine on the ISP router's WIFI network. I suspected that it had something to with the older wireless standard it might be using (I don't know which standards the TV supports), since the old network was WIFI4 and this one is WIFI6. It's just kind of weird to me that it would connect at first and seemingly be able to access the internet, then suddenly stop working. I have verified the DHCP info the TV gets and everything is correct.

Does anybody with more experience have an idea on how to solve this, or even just what the issue is?
It would be much appreciated, thank you in advance.

Config of WIFI interfaces on the router (I am trying to connect to the DEFAULT network):
# Wireless Channels configuration
/interface wifiwave2 channel
	add name=ch-2ghz band=2ghz-ax width=20mhz skip-dfs-channels=10min-cac
	add name=ch-5ghz band=5ghz-ax width=20/40/80mhz skip-dfs-channels=10min-cac

# Security Profiles
/interface wifiwave2 security
	add name=DEFAULT-auth authentication-types=wpa2-psk,wpa3-psk passphrase="*****" wps=disable ft=yes
	add name=GUEST-auth authentication-types=wpa2-psk,wpa3-psk passphrase="*****" wps=disable ft=yes
	add name=IOT-auth authentication-types=wpa2-psk,wpa3-psk passphrase="*****" wps=disable ft=yes

# Configurations
/interface wifiwave2 configuration
	add name=DEFAULT-conf ssid=YPPK9DQM country=* security=DEFAULT-auth mode=ap
	add name=GUEST-conf ssid=YPPK9DQM-GUEST country=* security=GUEST-auth mode=ap
	add name=IOT-conf ssid=YPPK9DQM-IOT country=* security=IOT-auth mode=ap hide-ssid=yes

# Interfaces
/interface wifiwave2
# 5ghz
	set [ find default-name=wifi1 ] channel=ch-5ghz name=DEFAULT-5ghz configuration=DEFAULT-conf disabled=no
	add name=GUEST-5ghz configuration=GUEST-conf master-interface=DEFAULT-5ghz disabled=no

#2ghz
	set [ find default-name=wifi2 ] channel=ch-2ghz name=DEFAULT-2ghz configuration=DEFAULT-conf disabled=no
	add name=GUEST-2ghz configuration=GUEST-conf master-interface=DEFAULT-2ghz disabled=no
	add name=IOT-2ghz configuration=IOT-conf master-interface=DEFAULT-2ghz disabled=yes
Last edited by akkurad on Fri May 17, 2024 9:44 pm, edited 1 time in total.
 
User avatar
Kanzler
Frequent Visitor
Frequent Visitor
Posts: 64
Joined: Wed Oct 05, 2022 6:55 pm
Location: Ukraine

Re: Problems with connecting Samsung Tizen Smart TV to my WIFI network  [SOLVED]

Fri Apr 19, 2024 12:21 pm

What channel are you using? Try channel 36 and AC mode instead of AX
 
User avatar
mkx
Forum Guru
Forum Guru
Posts: 11778
Joined: Thu Mar 03, 2016 10:23 pm

Re: Problems with connecting Samsung Tizen Smart TV to my WIFI network

Fri Apr 19, 2024 2:05 pm

Also many (older) IoT devices don't like seeing anything modern being broadcast in their SSID ... such as WPA3 or FT or similar.
 
akkurad
just joined
Topic Author
Posts: 5
Joined: Sun Mar 17, 2024 8:15 pm

Re: Problems with connecting Samsung Tizen Smart TV to my WIFI network

Sat Apr 20, 2024 1:51 am

What channel are you using? Try channel 36 and AC mode instead of AX
Thank you very much for your reply, it appears that AC mode for the 5ghz channel and G mode for the 2ghz channel has indeed solved the connection issues.

I believe the way to go to not lose the advantages of newer standards would be creating a new channel and wifi interface for legacy devices, correct me if I'm wrong please.
 
akkurad
just joined
Topic Author
Posts: 5
Joined: Sun Mar 17, 2024 8:15 pm

Re: Problems with connecting Samsung Tizen Smart TV to my WIFI network

Sat Apr 20, 2024 1:52 am

Also many (older) IoT devices don't like seeing anything modern being broadcast in their SSID ... such as WPA3 or FT or similar.
Thank you for your input, it seems to be working for now but I'll keep this in mind in case it acts up again.
 
sailren
just joined
Posts: 1
Joined: Tue Apr 23, 2024 6:28 am

Re: Problems with connecting Samsung Tizen Smart TV to my WIFI network

Tue Apr 23, 2024 6:38 am

Hello, I had the same problem, I reconfigured the wi-fi and now everything works, the tablet connects to Wi-Fi 6, the Samsung TV connects to Wi-Fi 5. Here are my settings.
[sailren@Mikrotik AX3] > interface/wifi/print          
Flags: M - MASTER; B - BOUND; R - RUNNING
Columns: NAME, CONFIGURATION.MODE, CONFIGURATION.SSID, CHANNEL.FREQUENCY, CHANNEL.WIDTH
#     NAME       CONFIGURATION.MODE  CONFIGURATION.SSID  CHANNEL.FREQUENCY  CHANNEL.WIDTH
0 MB  cap-wifi2  ap                  SkyNet              2402-2482          20/40mhz     
1 MB  cap-wifi5  ap                  SkyNet              5180-5300          20/40/80mhz  
2 MB  wifi 5     ap                  SkyNet              5180-5300          20/40/80mhz  
3 MBR wifi2.4    ap                  SkyNet              2402-2482          20/40mhz

[sailren@Mikrotik AX3] > interface/wifi/configuration/print 
Flags: X - disabled 
 0   name="wifi-conf-2.4" mode=ap ssid="SkyNet" country=United States multicast-enhance=enabled security=ax6 
     security.authentication-types=wpa2-psk,wpa3-psk .passphrase="******" .ft=yes .ft-over-ds=yes 
     datapath=data-main 
     datapath.bridge=bridge1 
     channel=channel2 
     channel.frequency=2402-2482 .width=20/40mhz .skip-dfs-channels=10min-cac 

 1   name="wifi-conf-5" mode=ap ssid="SkyNet" country=United States multicast-enhance=enabled security=ax6 
     security.authentication-types=wpa2-psk,wpa3-psk .passphrase="******" .ft=yes .ft-over-ds=yes 
     datapath=data-main 
     datapath.bridge=bridge1 
     channel=channel5 
     channel.frequency=5180-5300 .width=20/40/80mhz .skip-dfs-channels=all

Who is online

Users browsing this forum: No registered users and 4 guests