Community discussions

MikroTik App
 
User avatar
nithinkumar2000
Member Candidate
Member Candidate
Topic Author
Posts: 164
Joined: Wed Sep 11, 2019 7:42 am
Location: Coimbatore
Contact:

IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Mon Jul 06, 2020 11:35 am

Hi Everyone,

I am a ISP in India and we have a customer base of 3k+

We are trying to implement IPv6 in our network but we are currently stuck due to no IPv6 radius accounting in Mikrotik Routers.

As an ISP we need to know which IPv6 Address is delegated to which customer, But since there is no IPv6 Radius Accounting mikrotik routers we are unable to get the data to our session logs in radius.

It would be really helpful if anyone can help us on this and also is there any alternate solution to this issue???
Last edited by nithinkumar2000 on Tue Jul 14, 2020 8:43 am, edited 1 time in total.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 26466
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia
Contact:

Re: IPv6 Radius Accounting Not Working

Mon Jul 06, 2020 4:19 pm

Not correct. This feature exists already.

Release 6.45.1 2019-07-01
What's new in 6.45.1 (2019-Jun-27 10:23):
*) dhcpv6-server - added RADIUS accounting support with queue based statistics;
 
User avatar
nithinkumar2000
Member Candidate
Member Candidate
Topic Author
Posts: 164
Joined: Wed Sep 11, 2019 7:42 am
Location: Coimbatore
Contact:

Re: IPv6 Radius Accounting Not Working

Mon Jul 06, 2020 4:36 pm

Not correct. This feature exists already.

Release 6.45.1 2019-07-01
What's new in 6.45.1 (2019-Jun-27 10:23):
*) dhcpv6-server - added RADIUS accounting support with queue based statistics;
Hi Normis,

Thank you for your valuable response but still we are unable to get the Delegated IPV6 Prefix (DHCPv6 PD) in our Radius Session.

We are only able to get the Remote IPv6 Prefix.

But as per our ISP Regulations in INDIA it is mandatory for us to maintain both Delegated IPV6 Prefix (DHCPv6 PD) & Remote IPv6 Prefix so that we can identify which user got the delegation at which time (IPDR Purpose).

Hope The Images Attached herewith this post may clear your doubts.
PPP Profile.JPG
IPv6 ND.JPG
DHCPv6_Server.JPG
IN Radius Session.JPG

Expecting Your Reply at the earliest.
You do not have the required permissions to view the files attached to this post.
 
mducharme
Trainer
Trainer
Posts: 1777
Joined: Tue Jul 19, 2016 6:45 pm
Location: Vancouver, BC, Canada

Re: IPv6 Radius Accounting Not Working

Thu Jul 09, 2020 2:35 am

The feature only exists when using DHCPv6 server outside of PPP/PPPoE situations. It is not yet implemented for PPPoE. We really want to see it implemented for PPPoE situations as well.
 
User avatar
nithinkumar2000
Member Candidate
Member Candidate
Topic Author
Posts: 164
Joined: Wed Sep 11, 2019 7:42 am
Location: Coimbatore
Contact:

Re: IPv6 Radius Accounting Not Working

Thu Jul 09, 2020 6:35 am

The feature only exists when using DHCPv6 server outside of PPP/PPPoE situations. It is not yet implemented for PPPoE. We really want to see it implemented for PPPoE situations as well.
Yes because most of the ISP and WISP is using PPPOE for connecting to Clients, Using DHCPv6 or DHCP Server in ISP Grade network in very difficult.

Hope Mikrotik Team may take this issue on priority and do the needful at the earliest.
 
User avatar
nithinkumar2000
Member Candidate
Member Candidate
Topic Author
Posts: 164
Joined: Wed Sep 11, 2019 7:42 am
Location: Coimbatore
Contact:

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Tue Jul 14, 2020 8:46 am

Hmmm, I Think people are mostly not interested in IPv6 Implementation or am i the only one who is so furious in implementing IPv6....

Well i cant understand!!!
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8712
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Wed Jul 15, 2020 10:27 pm

Do you have a ticket number?
 
mducharme
Trainer
Trainer
Posts: 1777
Joined: Tue Jul 19, 2016 6:45 pm
Location: Vancouver, BC, Canada

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Thu Jul 16, 2020 7:44 am

Do you have a ticket number?
I had ticket 2018070222004763 for this, but it was in the older OTRS system they used before they moved to JIRA.
 
User avatar
nithinkumar2000
Member Candidate
Member Candidate
Topic Author
Posts: 164
Joined: Wed Sep 11, 2019 7:42 am
Location: Coimbatore
Contact:

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Thu Jul 16, 2020 7:52 am

Do you have a ticket number?
Mikrotik Support Reference No.: SUP-20538
 
vgdorneles
just joined
Posts: 19
Joined: Mon Mar 12, 2018 4:27 pm

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Thu Jul 16, 2020 5:00 pm

Hmmm, I Think people are mostly not interested in IPv6 Implementation or am i the only one who is so furious in implementing IPv6....

Well i cant understand!!!
In Brazil we also have the legislation to keep the Logs of Delegated IPV6 Prefix & Remote IPv6 Prefix, and it is really frustrating the development delay of Mikrotik in relation to IPv6.

Is it really that difficult to add the RADIUS Delegated-IPv6-Prefix Attribute to v6? Or should we wait for v7?
 
User avatar
nithinkumar2000
Member Candidate
Member Candidate
Topic Author
Posts: 164
Joined: Wed Sep 11, 2019 7:42 am
Location: Coimbatore
Contact:

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Thu Jul 16, 2020 8:56 pm

Hmmm, I Think people are mostly not interested in IPv6 Implementation or am i the only one who is so furious in implementing IPv6....

Well i cant understand!!!
Is it really that difficult to add the RADIUS Delegated-IPv6-Prefix Attribute to v6? Or should we wait for v7?
Same Doubt i also have. Mikrotik is used by many ISP around the globe and we are requesting this feature from long time.

I believe that Mikrotik Team will do something to solve this issue. Already Mikrotik is late as all other Major Brands like Cisco, Huwai, Juniper etc are fully functional & compatable with IPv6.
 
User avatar
nithinkumar2000
Member Candidate
Member Candidate
Topic Author
Posts: 164
Joined: Wed Sep 11, 2019 7:42 am
Location: Coimbatore
Contact:

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Sat Jul 18, 2020 8:29 am

Finally received a response from Mikrotik Support Team,
Hello

Thank you for contacting us. Yes, it is in our plans to add such functionality when PPP service is authenticated by the RADIUS server. However, unfortunately, I can not provide any ETA for such functionality.

Best regards
I Know they have not given any ETA, but atleast it gives all of us a hope. :) :D :) :D
 
mducharme
Trainer
Trainer
Posts: 1777
Joined: Tue Jul 19, 2016 6:45 pm
Location: Vancouver, BC, Canada

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Sun Jul 19, 2020 3:23 am

I Know they have not given any ETA, but atleast it gives all of us a hope. :) :D :) :D
They gave me this same response a year ago.
 
User avatar
nithinkumar2000
Member Candidate
Member Candidate
Topic Author
Posts: 164
Joined: Wed Sep 11, 2019 7:42 am
Location: Coimbatore
Contact:

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Sun Jul 19, 2020 3:35 pm

I Know they have not given any ETA, but atleast it gives all of us a hope. :) :D :) :D
They gave me this same response a year ago.
Then I think some Mikrotik Support Member will surely answer to this post!
 
User avatar
nithinkumar2000
Member Candidate
Member Candidate
Topic Author
Posts: 164
Joined: Wed Sep 11, 2019 7:42 am
Location: Coimbatore
Contact:

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Sun Aug 23, 2020 8:13 pm

RADIUS ACCOUNTING FOR PPP DELEGATED PREFIX...... Any Update.

Please do the needful to add the same. waiting from so many years and still no updates from mikrotik team...?
 
User avatar
IPAsupport
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Fri Sep 20, 2019 4:02 pm

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Wed Aug 26, 2020 8:16 pm

We have clients that also need PPPoE + PD + Radius, please consider implementing this feature
 
User avatar
omidkosari
Trainer
Trainer
Posts: 640
Joined: Fri Sep 01, 2006 4:18 pm
Location: Canada, Toronto

Re: IPv6 Radius Accounting Not Working

Fri Aug 28, 2020 3:24 pm

Not correct. This feature exists already.

Release 6.45.1 2019-07-01
What's new in 6.45.1 (2019-Jun-27 10:23):
*) dhcpv6-server - added RADIUS accounting support with queue based statistics;
@Normis
Please take a look at this viewtopic.php?f=2&t=89443 to remember the problem
 
freddyk
just joined
Posts: 22
Joined: Wed Oct 28, 2015 8:39 pm

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Tue Oct 20, 2020 8:41 pm

What's new in 6.48beta48 (2020-Oct-14 10:26):

...

Other changes since v6.47.4:
*) ppp - added support for "Framed-IPv6-Route" RADIUS attribute;

Do this works for PPPoE ?
 
MarcosPytel
just joined
Posts: 7
Joined: Tue Mar 10, 2020 2:19 pm

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Thu Oct 22, 2020 3:54 pm

Hi!
What's new in 6.48beta48 (2020-Oct-14 10:26):

...

Other changes since v6.47.4:
*) ppp - added support for "Framed-IPv6-Route" RADIUS attribute;

Do this works for PPPoE ?

I tried to use Delegated-Ipv6-Prefix with PPPoE and Radius in v6.48 and I get this error:
Could not add dhcpv6 with pool "poolname": same interface for multiple servers cannot be used!

Thanks,
Marcos.
 
User avatar
omidkosari
Trainer
Trainer
Posts: 640
Joined: Fri Sep 01, 2006 4:18 pm
Location: Canada, Toronto

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Tue Oct 27, 2020 4:26 pm

Delegated-IPv6-Prefix + PPPoE is the last part of the IPv6 puzzle. Hey Mikrotik we are looking for this change in changelog .
 
depe
just joined
Posts: 16
Joined: Thu May 03, 2012 8:06 pm

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Fri Nov 06, 2020 4:20 am

I was able to do a dirty fix using a Script in the Mikrotik, a php server on freeradius, and some changes in queries.conf of freeradius 3 to save the PD assigned to the pppoe user.

The idea is to save the PD in the attribute of the radreply table named Delegated-IPv6-Prefix , (I know should be used in the other way).
And later, when the Mikrotik do the accounting, update the Delegated-IPv6-Prefix in the radacct table.

https://github.com/dpecile/Delegated-IPv6-Prefix
 
User avatar
nithinkumar2000
Member Candidate
Member Candidate
Topic Author
Posts: 164
Joined: Wed Sep 11, 2019 7:42 am
Location: Coimbatore
Contact:

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Fri Nov 06, 2020 7:46 am

I still dont understand why no one from Mikrotik is addressing this issue.

Govt. is pressuring all ISP to implement IPv6 but Mikrotik Team is showing no interest in addressing IPv6 Issues.
 
User avatar
nithinkumar2000
Member Candidate
Member Candidate
Topic Author
Posts: 164
Joined: Wed Sep 11, 2019 7:42 am
Location: Coimbatore
Contact:

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Mon Nov 16, 2020 11:10 am

Come on Mikrotik Team, One Fix to solve IPv6 Implementation.

Pls Add IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)
 
User avatar
danunjaya123
Member Candidate
Member Candidate
Posts: 102
Joined: Thu Oct 03, 2019 7:36 am
Location: India

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Mon Nov 16, 2020 12:00 pm

Use Cisco for IPv6 accounting and Delegated prefix.
 
User avatar
nithinkumar2000
Member Candidate
Member Candidate
Topic Author
Posts: 164
Joined: Wed Sep 11, 2019 7:42 am
Location: Coimbatore
Contact:

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Wed Nov 18, 2020 3:45 pm

Use Cisco for IPv6 accounting and Delegated prefix.
You Mean Mikrotik is never gona Develop IPv6?
 
User avatar
nithinkumar2000
Member Candidate
Member Candidate
Topic Author
Posts: 164
Joined: Wed Sep 11, 2019 7:42 am
Location: Coimbatore
Contact:

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Mon Dec 07, 2020 3:48 pm

Waiting for Reply from Mikrotik.

Please atleast let us know the reason of delay???
 
User avatar
nithinkumar2000
Member Candidate
Member Candidate
Topic Author
Posts: 164
Joined: Wed Sep 11, 2019 7:42 am
Location: Coimbatore
Contact:

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Wed Jan 06, 2021 7:49 pm

Hello!!! Any Update on this issue???
 
User avatar
seriousblack
newbie
Posts: 36
Joined: Tue Apr 03, 2018 4:02 am
Contact:

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Wed Jan 06, 2021 9:14 pm

Hello..

I think limiting the clients with the PPPOE usernames limits the clients to the Cap specified on the dynamic Queues by radius both for v4 & v6.

This has worked for me since I rolled out v6. 3 weeks ago. Doing 6.48
 
mducharme
Trainer
Trainer
Posts: 1777
Joined: Tue Jul 19, 2016 6:45 pm
Location: Vancouver, BC, Canada

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Thu Jan 07, 2021 6:32 am

I think limiting the clients with the PPPOE usernames limits the clients to the Cap specified on the dynamic Queues by radius both for v4 & v6.
Yes, limits have always been working, that is not the problem. The issue is tracking the prefix that the customer receives, which is often a legal requirement so that if you get a court order that has an IPv6 address on it and a date and time, you can identify who had that prefix at the time. MikroTik has now partially implemented this but has not finished.
 
User avatar
nithinkumar2000
Member Candidate
Member Candidate
Topic Author
Posts: 164
Joined: Wed Sep 11, 2019 7:42 am
Location: Coimbatore
Contact:

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Thu Jan 07, 2021 2:36 pm

This we all are requesting from very long time..... Hope Mikrotik Team will take little bit more serious.
 
User avatar
seriousblack
newbie
Posts: 36
Joined: Tue Apr 03, 2018 4:02 am
Contact:

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Thu Jan 07, 2021 2:43 pm

I think limiting the clients with the PPPOE usernames limits the clients to the Cap specified on the dynamic Queues by radius both for v4 & v6.
Yes, limits have always been working, that is not the problem. The issue is tracking the prefix that the customer receives, which is often a legal requirement so that if you get a court order that has an IPv6 address on it and a date and time, you can identify who had that prefix at the time. MikroTik has now partially implemented this but has not finished.
Oooh okay.


Hope this' implemented on the next release. With the ipv6 only update error too :)
 
User avatar
nithinkumar2000
Member Candidate
Member Candidate
Topic Author
Posts: 164
Joined: Wed Sep 11, 2019 7:42 am
Location: Coimbatore
Contact:

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Thu Mar 04, 2021 1:53 pm

Still We are waiting for some Positive Reply from Mikrotik Team...................
 
User avatar
nithinkumar2000
Member Candidate
Member Candidate
Topic Author
Posts: 164
Joined: Wed Sep 11, 2019 7:42 am
Location: Coimbatore
Contact:

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Fri Apr 09, 2021 11:04 am

Hello Mikrotik Team,

Any Update regarding IPv6 Prefix Delegation Accounting for PPP Users???

All are requesting this from years and still we have not received any proper Response or feedback from Mikrotik Team.
 
User avatar
nithinkumar2000
Member Candidate
Member Candidate
Topic Author
Posts: 164
Joined: Wed Sep 11, 2019 7:42 am
Location: Coimbatore
Contact:

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Sun Nov 21, 2021 9:25 am

Delegated IPv6 Prefix Parameter is still not included in Radius Accounting Packet for PPP Service.
 
regissouza
just joined
Posts: 1
Joined: Tue Dec 21, 2021 3:19 pm

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Tue Dec 21, 2021 3:29 pm

Hi, I work in a software company that develops a web-based program for managing ISPs.
The PD information in PPPoE accounting is very important to our clients, and they are always asking when will Mikrotik resolve this issue.
Please consider putting some effort in bringing this feature in future updates.
There are laws here too that makes this information mandatory in the PPPoE accouting.
Almost, give the community some information, e.g. if this feature is very difficult to implement and what are the steps that are required to make it work.
 
User avatar
nithinkumar2000
Member Candidate
Member Candidate
Topic Author
Posts: 164
Joined: Wed Sep 11, 2019 7:42 am
Location: Coimbatore
Contact:

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Mon Apr 04, 2022 8:43 pm

Come on Mikrotik Team,,, You are Developing New Things but what about Basic Please add IPv6 Delegation Accounting in PPP Radius Accounting also.....

Pls Pls Pls....................................
 
DarkNate
Forum Guru
Forum Guru
Posts: 1065
Joined: Fri Jun 26, 2020 4:37 pm

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Fri Apr 15, 2022 11:19 am

Is it possible to assign persistently instead of dynamic when using PPPoE?

Dynamic creates problems anyways:
 
mducharme
Trainer
Trainer
Posts: 1777
Joined: Tue Jul 19, 2016 6:45 pm
Location: Vancouver, BC, Canada

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Fri Apr 15, 2022 10:55 pm

Is it possible to assign persistently instead of dynamic when using PPPoE?
In our case we have a script that goes through every dynamic v6 binding every 5 minutes and does a "make static" so it never changes. It is much easier than having to manually assign a prefix to each new customer.
 
DarkNate
Forum Guru
Forum Guru
Posts: 1065
Joined: Fri Jun 26, 2020 4:37 pm

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Fri Apr 15, 2022 11:43 pm

Is it possible to assign persistently instead of dynamic when using PPPoE?
In our case we have a script that goes through every dynamic v6 binding every 5 minutes and does a "make static" so it never changes. It is much easier than having to manually assign a prefix to each new customer.
Can you share the script, please? Does it also work for RouterOS v7?
 
mducharme
Trainer
Trainer
Posts: 1777
Joined: Tue Jul 19, 2016 6:45 pm
Location: Vancouver, BC, Canada

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Sat Apr 16, 2022 2:23 am

Can you share the script, please? Does it also work for RouterOS v7?
Sure. I'm not sure if it works on RouterOS v7 but I don't see why not. Here it is - it is pretty simple:
/ipv6 dhcp-server binding;
:foreach i in=[find server~"pppoe"] do={
  make-static $i;
  set $i comment=[get $i server];
  set $i server=all;
}
The server for the static binding has to be set to "all" as the server is dynamically created when the user connects and destroyed when the user disconnects, so if that is not done, the binding will be using a server that no longer exists and doesn't work. The comment is set to the server so that you know what user it is for - the server name is something like <pppoe-customerusername> and so this gets copied to the comment so you have a permanent record of which customer the lease is for.
 
srijit92
Frequent Visitor
Frequent Visitor
Posts: 84
Joined: Sun Jul 01, 2012 11:56 am
Location: India
Contact:

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Thu May 05, 2022 4:22 pm

Hi,
When does Mikrotik plans to fix the IPv6 accounting problem? Due to this, IPv6 integration stays pending. Any workaround?
 
User avatar
nithinkumar2000
Member Candidate
Member Candidate
Topic Author
Posts: 164
Joined: Wed Sep 11, 2019 7:42 am
Location: Coimbatore
Contact:

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Thu May 19, 2022 8:06 am

We are Requesting this to mikrotik Team from many years and they care least.

They are focused in everything else but ipv6 they dont care
 
User avatar
CoMMyz
Frequent Visitor
Frequent Visitor
Posts: 61
Joined: Fri Dec 04, 2015 10:56 pm

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Fri May 20, 2022 12:56 pm

Can you share the script, please? Does it also work for RouterOS v7?
Sure. I'm not sure if it works on RouterOS v7 but I don't see why not. Here it is - it is pretty simple:
/ipv6 dhcp-server binding;
:foreach i in=[find server~"pppoe"] do={
  make-static $i;
  set $i comment=[get $i server];
  set $i server=all;
}
The server for the static binding has to be set to "all" as the server is dynamically created when the user connects and destroyed when the user disconnects, so if that is not done, the binding will be using a server that no longer exists and doesn't work. The comment is set to the server so that you know what user it is for - the server name is something like <pppoe-customerusername> and so this gets copied to the comment so you have a permanent record of which customer the lease is for.
This is a good solution - however if you have many routers acting as a pppoe server - if the client moves you will loose the lease again. Radius solution is required from mikrotik.
 
User avatar
nithinkumar2000
Member Candidate
Member Candidate
Topic Author
Posts: 164
Joined: Wed Sep 11, 2019 7:42 am
Location: Coimbatore
Contact:

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Tue May 24, 2022 5:13 pm

There should be somthing which we can do about it. Is there any chance of logging the same using the Traffic Flow IPFIX???
 
LunaticRv
newbie
Posts: 42
Joined: Mon Dec 31, 2018 8:50 am

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Fri Jun 23, 2023 11:21 pm

There should be somthing which we can do about it. Is there any chance of logging the same using the Traffic Flow IPFIX???
Hey, did you find any solution to that? Is this feature still not implemented?
 
renanzeraa
just joined
Posts: 1
Joined: Tue Sep 12, 2023 1:15 am

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Tue Sep 12, 2023 1:30 am

Hi, I work in a software company that develops a web-based program for managing ISPs.
The PD information in PPPoE accounting is very important to our clients, and they are always asking when will Mikrotik resolve this issue.
Please consider putting some effort in bringing this feature in future updates.
There are laws here too that makes this information mandatory in the PPPoE accouting.
Almost, give the community some information, e.g. if this feature is very difficult to implement and what are the steps that are required to make it work.
_
I work with the same type of company as you in Brazil and Mikrotik needs to respect us. This feature is mandatory if almost all ISPs use RADIUS and PPPoE protocols (in reference to IPv6-PD accounting back to the RADIUS server). This is a shame. They need to complete the implementation of this feature in IPv6 or provide further clarification transparently to their customers.
 
washcroft
just joined
Posts: 6
Joined: Tue Apr 09, 2024 1:50 pm

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Tue Apr 09, 2024 2:06 pm

Can you share the script, please? Does it also work for RouterOS v7?
Sure. I'm not sure if it works on RouterOS v7 but I don't see why not. Here it is - it is pretty simple:
/ipv6 dhcp-server binding;
:foreach i in=[find server~"pppoe"] do={
  make-static $i;
  set $i comment=[get $i server];
  set $i server=all;
}
The server for the static binding has to be set to "all" as the server is dynamically created when the user connects and destroyed when the user disconnects, so if that is not done, the binding will be using a server that no longer exists and doesn't work. The comment is set to the server so that you know what user it is for - the server name is something like <pppoe-customerusername> and so this gets copied to the comment so you have a permanent record of which customer the lease is for.
This is a great solution but sadly doesn't appear to be working in ROSv7 - the make-static command fails with error "can't use dynamic server".
 
User avatar
nithinkumar2000
Member Candidate
Member Candidate
Topic Author
Posts: 164
Joined: Wed Sep 11, 2019 7:42 am
Location: Coimbatore
Contact:

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Tue May 14, 2024 9:27 am

As per the changelog of v7.15, Radius accounting for IPv6 is now implemented in PPP accounting packet but if you want to enable it then use Terminal or CLI.
 
DarkNate
Forum Guru
Forum Guru
Posts: 1065
Joined: Fri Jun 26, 2020 4:37 pm

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Tue May 14, 2024 5:41 pm

We've completely removed PPPoE from our infrastructure due to persistent MTU issues. We moved to DHCP v4/v6 dual-stack queues on MikroTik and have no problems using any RADIUS software vendor to assign /56 lifetime static PD to each residential customer. Also works nicely with the dual-stack queues for FQ_Codel to reduce bufferbloat.

Not sure why folks are still wasting their time on a legacy protocol.
 
User avatar
nithinkumar2000
Member Candidate
Member Candidate
Topic Author
Posts: 164
Joined: Wed Sep 11, 2019 7:42 am
Location: Coimbatore
Contact:

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Thu May 16, 2024 3:16 pm

Hello DarkNate,

Can you please share us how did you implement DHCP instead of PPPoE.

My Question is:

1. how did you manage to authenticate the users only with DHCP?
2. If someone connects another LAN of their router then how to prevent rogue DHCP Server?
 
DarkNate
Forum Guru
Forum Guru
Posts: 1065
Joined: Fri Jun 26, 2020 4:37 pm

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Fri May 17, 2024 4:07 am

Hello DarkNate,

Can you please share us how did you implement DHCP instead of PPPoE.

My Question is:

1. how did you manage to authenticate the users only with DHCP?
2. If someone connects another LAN of their router then how to prevent rogue DHCP Server?
BNG<>P<>PE<>L2 switch<>OLT or wireless AP

OLT/AP VLANs are transported to BNG using MPLS/VPLS over native IPv6, we did not use legacy IPv4 in the MPLS core.

On L2 switch side, we enabled DHCP Snooping and configured uplink port as trusted port. This solves rogue DHCP server issue if you configured DHCP Snooping correctly for a given network topology.
On OLT or AP side, we enabled PON isolation or client isolation.
On BNG side, the layer 3 sub-interface VLAN of each AP or OLT is on top of the VPLS circuit and finally we used local-proxy-arp on the sub-iface VLAN for additional security.
On DHCP server on the BNG, we enabled add-arp-to-leases. Static IP is impossible for a customer to spoof.
Authentication is done via MAC address of CPE. Customers may update their MAC address via their user login dashboard (talk to your AAA vendor to offer this feature).

QinQ is not required as we're using local-proxy-arp + MPLS Transport + PON/Client isolation.
 
User avatar
nithinkumar2000
Member Candidate
Member Candidate
Topic Author
Posts: 164
Joined: Wed Sep 11, 2019 7:42 am
Location: Coimbatore
Contact:

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Fri May 17, 2024 7:18 am

HI DarkNate,

Thank you for sharing this. got some idea about how to implement the same but now some more doubts

can we use BNG<>L2 SWITCH<>OLT ?

is MPLS VPLS must?
 
DarkNate
Forum Guru
Forum Guru
Posts: 1065
Joined: Fri Jun 26, 2020 4:37 pm

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Fri May 17, 2024 5:35 pm

HI DarkNate,

Thank you for sharing this. got some idea about how to implement the same but now some more doubts

can we use BNG<>L2 SWITCH<>OLT ?

is MPLS VPLS must?
I would advise to never do layer 2 spanning as you described in a production network. Please use MPLS everywhere in ISP production networks.

One more advice, if your enterprise customer is directly connected via PtP fibre to an L2 switch or PE router, then you should ensure to enable port isolation (also known as private VLAN) for additional security on the physical port that your customer is connected to:
viewtopic.php?p=1075835#p1075704
 
stevenyobrauly
just joined
Posts: 4
Joined: Fri Dec 13, 2019 10:52 pm

Re: IPv6 Radius Accounting Not Working for PPPOE Clients (Delegated Prefix)

Tue Jun 11, 2024 12:57 am

Hello DarkNate, Which AAA vendor do you use or recommend?

Hello DarkNate,

Can you please share us how did you implement DHCP instead of PPPoE.

My Question is:

1. how did you manage to authenticate the users only with DHCP?
2. If someone connects another LAN of their router then how to prevent rogue DHCP Server?
BNG<>P<>PE<>L2 switch<>OLT or wireless AP

OLT/AP VLANs are transported to BNG using MPLS/VPLS over native IPv6, we did not use legacy IPv4 in the MPLS core.

On L2 switch side, we enabled DHCP Snooping and configured uplink port as trusted port. This solves rogue DHCP server issue if you configured DHCP Snooping correctly for a given network topology.
On OLT or AP side, we enabled PON isolation or client isolation.
On BNG side, the layer 3 sub-interface VLAN of each AP or OLT is on top of the VPLS circuit and finally we used local-proxy-arp on the sub-iface VLAN for additional security.
On DHCP server on the BNG, we enabled add-arp-to-leases. Static IP is impossible for a customer to spoof.
Authentication is done via MAC address of CPE. Customers may update their MAC address via their user login dashboard (talk to your AAA vendor to offer this feature).

QinQ is not required as we're using local-proxy-arp + MPLS Transport + PON/Client isolation.

Who is online

Users browsing this forum: No registered users and 6 guests