Community discussions

MikroTik App
 
sten
Forum Veteran
Forum Veteran
Topic Author
Posts: 923
Joined: Tue Jun 01, 2004 12:10 pm

[bug?] tc-cake supports negative overhead, but RouterOS does not.

Wed Jul 10, 2024 6:29 pm

Kernel queue tc-cake(8) supports negative overhead but RouterOS does not.
Use case;
/interface bridge settings set allow-fast-path=no use-ip-firewall=no
/interface bridge add fast-forward=no name=bridge protocol-mode=none
/interface bridge filter add action=mark-packet chain=forward disabled=yes mac-protocol=ip new-packet-mark=queue-it out-interface=ether6
/interface bridge filter add action=mark-packet chain=forward disabled=yes mac-protocol=ipv6 new-packet-mark=queue-it out-interface=ether6
/interface bridge port add bridge=bridge hw=no interface=ether6 comment=upstream
/interface bridge port add bridge=bridge hw=no interface=ether7 comment=downstream
/queue type add name="cake-upload" kind=cake cake-overhead=0 cake-overhead-scheme=raw cake-rtt=100ms cake-rtt-scheme=internet cake-diffserv=diffserv4 cake-flowmode=triple-isolate cake-nat=no cake-wash=no cake-ack-filter=aggressive
/queue tree add name=myupload packet-mark=queue-it max-limit=5M parent=ether6 queue=cake-upload-face

Shaping upload to 5 Mbit (assymmetric connection) with aggressive ack filtering and better fairness. Now ETHERNET packets are marked, which would have the ethernet header included in the packet size calculation.

If overhead could be negative, it would be possible to dial in the correct shaping characteristic.

src: https://man.archlinux.org/man/tc-cake.8 ... cification
 
Apachez
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Mon Jul 01, 2024 11:45 pm

Re: [bug?] tc-cake supports negative overhead, but RouterOS does not.

Wed Jul 10, 2024 9:16 pm

Whats the purpose of a negative overhead?

Like if your linux kernel have some vlan tagging offloading for the nic so the kernel doesnt handle the vlan at all but the nic will?
 
sten
Forum Veteran
Forum Veteran
Topic Author
Posts: 923
Joined: Tue Jun 01, 2004 12:10 pm

Re: [bug?] tc-cake supports negative overhead, but RouterOS does not.

Thu Jul 11, 2024 1:45 am

Whats the purpose of a negative overhead?

Like if your linux kernel have some vlan tagging offloading for the nic so the kernel doesnt handle the vlan at all but the nic will?
You think the sch_cake devs made a mistake by including negative overheads?
Considering cake takes overhead (and minimum packet sizes) into consideration when queuing, it matters for the accuracy result.

Who is online

Users browsing this forum: Gigon, Google [Bot] and 83 guests