As per the title, WinBox v4 is dangerous and can crash a router. So far, I've been able to reproduce it with one specific router model, the RB5009UPr+S+.
WinBox version: 4.0beta3
RouterOS version: 7.15
Router config:
Code: Select all
# 2024-09-02 19:40:20 by RouterOS 7.15
# software id = KE3V-5H2I
#
# model = RB5009UPr+S+
# serial number = HFA09BQZDM7
/interface bridge
add admin-mac=78:9A:18:A2:F0:8D auto-mac=no comment=defconf name=bridgeLocal port-cost-mode=short \
vlan-filtering=yes
/interface bridge port
add bridge=bridgeLocal frame-types=admit-only-untagged-and-priority-tagged \
interface=ether1 internal-path-cost=10 path-cost=10 pvid=20
add bridge=bridgeLocal frame-types=admit-only-untagged-and-priority-tagged \
interface=ether2 internal-path-cost=10 path-cost=10 pvid=20
add bridge=bridgeLocal frame-types=admit-only-untagged-and-priority-tagged \
interface=ether3 internal-path-cost=10 path-cost=10 pvid=20
add bridge=bridgeLocal frame-types=admit-only-untagged-and-priority-tagged \
interface=ether4 internal-path-cost=10 path-cost=10 pvid=20
add bridge=bridgeLocal frame-types=admit-only-untagged-and-priority-tagged \
interface=ether5 internal-path-cost=10 path-cost=10 pvid=20
add bridge=bridgeLocal frame-types=admit-only-untagged-and-priority-tagged \
interface=ether6 internal-path-cost=10 path-cost=10 pvid=20
add bridge=bridgeLocal frame-types=admit-only-untagged-and-priority-tagged \
interface=ether7 internal-path-cost=10 path-cost=10 pvid=20
add bridge=bridgeLocal frame-types=admit-only-untagged-and-priority-tagged \
interface=ether8 internal-path-cost=10 path-cost=10 pvid=20
add bridge=bridgeLocal interface=sfp-sfpplus1 internal-path-cost=10 path-cost=10
/ip firewall connection tracking
set udp-timeout=10s
/ip settings
set ip-forward=no
/ipv6 settings
set disable-ipv6=yes
/interface bridge vlan
add bridge=bridgeLocal tagged=bridgeLocal,sfp-sfpplus1 vlan-ids=20
/ip dhcp-client
add comment=defconf interface=bridgeLocal
/ip firewall service-port
set ftp disabled=yes
set tftp disabled=yes
set h323 disabled=yes
set sip disabled=yes
set pptp disabled=yes
/ip service
set telnet disabled=yes
set ftp disabled=yes
set api disabled=yes
set api-ssl disabled=yes
/ip smb shares
set [ find default=yes ] directory=/pub
/ip ssh
set strong-crypto=yes
/system identity
set name="RB5009UPr"
/system note
set show-at-login=no
/system ntp client
set enabled=yes
/system routerboard settings
set auto-upgrade=yes
/tool romon
set enabled=yes
The computer running WinBox 4 is connected to the router's SFP+ port. The SFP module is a Mikrotik S-RJ01.
Steps to reproduce:
1. Create a new workspace
2. Connect to a CRS112-8P-4S switch
3. Open the following windows: Interfaces, Bridge, Switch→FDBs, Switch→VLAN
4. Connect to the RB5009UPr+S+
5. Change to the new workspace
6. Observe how in addition to the Interfaces and Bridge windows, empty Switch FDBs and Switch VLAN windows open
7. At this point, connection to the router is lost (WinBox might take some time to realize)
8. Try to ping or reconnect to the router, it won't work
Have to unplug the router's power cable to fix it.
If you try the same with WinBox v3 sessions and you open a session where the Switch windows were open, they do not open when connecting to the RB5009UPr and nothing happens. So this bug is unique to WinBox v4. Now I'm afraid to use WinBox v4.