/system logging rulesCan someone point me to instructions for enabling wireless debug logging?
/system logging rulesCan someone point me to instructions for enabling wireless debug logging?
Add Topics :debug & wireless, Actions: memory.
That's it.
Can you share the wireless part of the config? Just to check current settings.
/interface wifi
set [ find default-name=wifi1 ] channel.frequency=2401-5835 \
.skip-dfs-channels=all configuration.country="United States" .mode=ap \
.ssid=MikroTik disabled=no security.authentication-types=\
wpa2-psk,wpa3-psk .connect-priority=0/1 .encryption=\
ccmp,gcmp,ccmp-256,gcmp-256 .ft=yes .ft-over-ds=yes .group-key-update=1d \
.wps=disable
set [ find default-name=wifi2 ] channel.frequency=2401-5835 \
.skip-dfs-channels=all configuration.country="United States" .mode=ap \
.ssid=MikroTik disabled=no security.authentication-types=\
wpa2-psk,wpa3-psk .connect-priority=0/1 .encryption=\
ccmp,gcmp,ccmp-256,gcmp-256 .ft=yes .ft-over-ds=yes .group-key-update=1d \
.wps=disable
set [ find default-name=wifi3 ] channel.frequency=2401-5835 \
.skip-dfs-channels=all configuration.country="United States" .hide-ssid=\
yes .mode=ap .ssid=MikroTik-Mesh disabled=no \
security.authentication-types=wpa3-psk .connect-priority=0/1 .encryption=\
ccmp,gcmp,ccmp-256,gcmp-256 .ft=yes .ft-over-ds=yes .group-key-update=1d \
.wps=disable
Normally I'd agree, but the spouse took the phone to other locations with public Wi-Fi and it allegedly worked fine. Bring it back home to the MikroTik network and no luck.@k2dI5umrD9VO: It’s not related to ROS. This is a known issue with iOS 18 (and also in the previews) but no one has figured out the root cause or how to fix it: https://www.google.com/search?q=%22iOS+ ... reddit.com
Yes, same result.Did you try forget network and then reconnect?
Or... try wifi configuration using defaults (only country is required) - just to see if work with iOS 18. Specifically trying ft=no, since that seems an area that could be broken. Or, perhaps try the 7.16rc "testing" with your current configuration to see if some random fix in RouterOS fixes this - there are always some wifi tweaks in each release. Both might be good step before giving up to downgrade.or if all else fails, roll back to iOS 17.
What do you mean with mixed languages?I remember some Apple devices (at least in the past) could have issues with mixed languages on APs within the same SSID domain.
The same company which added a deliberate slowing down of older HW and it still surprises you ?OT: it really bugs me that Apple require an A17 chip to enable ChatGPT integration in iOS 18. It’s so very typical of Apple always finding new ways to push people to upgrade their hardware.
@erlinden: Sorry, I meant to say regional settings.What do you mean by mixed languages?
@holvoetn: Yeah, no surprise there! But it still bugs the hell out of me every time it pops up..The same company that added deliberate slowdowns to older hardware and it still surprises you? What do you think MS is doing with their Co-Pilot story? Same purpose—push hardware sales (MS license will come with it). They all use these tricks...
@dude2k: check out the WiFi logs and help others by analyze the root cause. Btw, what build are you using? Fwiw, I’m still running macOS 15 RC on an M2 MBA with no issues (so far anyway!) using AX with FT.Hi, I have the same problem and I think it's worth finding a solution.
You're not alone.Only as a side note, ...(I simply cannot bear videos, but that's just me) ...
Hi, I'm using 7.15.3 on all Mikrotik APs and Routers. Before iOS18 I had no problem, also roaming was working fine.[@dude2k: check out the WiFi logs and help others by analyze the root cause. Btw, what build are you using? Fwiw, I’m still running macOS 15 RC on an M2 MBA with no issues (so far anyway!) using AX with FT.
add country=Germany datapath=datapath2-vlan30-gast disabled=no mode=ap name=cfg3-gast security=sec3-gast security.authentication-types=wpa2-psk,wpa3-psk .connect-priority=0/1 .encryption=ccmp,gcmp,ccmp-256,gcmp-256 ssid=gast
add authentication-types=wpa2-psk,wpa3-psk connect-priority=0/1 disabled=no encryption=ccmp,gcmp,ccmp-256,gcmp-256 ft=yes ft-over-ds=yes ft-preserve-vlanid=no name=sec3-gast wps=disable
Look for the section “Wi-Fi for iOS/iPadOS” in iOS Profiles and Logs
Does it connect when you disable FT and reboot ?I Have AC and AX APs and use FT and "FT over DS". WPA2-PSK and WPA3-PSK (But also tested only WPA2-PSK, but didn't work)
Tried a few minutes ago, no changes, does not workDoes it connect when you disable FT and reboot ?
Then it might be helpfull to share your (wireless) configSame iPhone, upgraded to iOS 18; nothing changed with WiFi on ax^3.
/interface wifi export
Link to Driver Log TXT-File from Macbook:As already written: ROS logs are not helpful. You all need to capture your client logs.
Then it might be helpfull to share your (wireless) configSame iPhone, upgraded to iOS 18; nothing changed with WiFi on ax^3.
Remove serial and any other private info.Code: Select all/interface wifi export
2024-09-19 12:54:01 by RouterOS 7.15.3
# software id = EBTN-KIA3
#
# model = C53UiG+5HPaxD2HPaxD
# serial number = xxx
/interface wifi channel
add disabled=no frequency=2412,2432,2472 name=ch-2ghz \
reselect-interval=1d skip-dfs-channels=disabled width=20mhz
add disabled=no frequency=5490-5730 name=ch-5ghz skip-dfs-channels=\
disabled width=20/40/80mhz
/interface wifi security
add authentication-types=wpa2-psk connect-priority=0/1 disabled=no \
encryption=ccmp ft=yes ft-over-ds=yes management-protection=\
allowed name=wifi-security wps=disable
add authentication-types=wpa2-psk connect-priority=0/1 disabled=no \
encryption=ccmp ft=yes ft-over-ds=yes management-protection=\
allowed name=wifi-security-iot wps=disable
/interface wifi configuration
add channel=ch-2ghz country=Poland disabled=no dtim-period=3 name=\
wifi-config security=wifi-security ssid=xxx
add channel=ch-2ghz country=Poland disabled=no dtim-period=3 \
hide-ssid=yes name=wifi-iot security=wifi-security-iot \
security.ft=yes .ft-over-ds=yes ssid=xxx
/interface wifi
set [ find default-name=wifi2 ] channel=ch-2ghz channel.frequency=\
2412,2432,2472 configuration=wifi-config configuration.mode=ap \
disabled=no name=wifi-2ghz security=wifi-security
add channel.frequency=2412,2432,2472 configuration=wifi-iot \
configuration.mode=ap disabled=no mac-address=xx:xx:xx:xx:xx:xx \
master-interface=wifi-2ghz mtu=1500 name=wifi-2ghz-iot security=\
wifi-security-iot
set [ find default-name=wifi1 ] channel=ch-5ghz channel.frequency=\
5490-5730 configuration=wifi-config configuration.mode=ap \
disabled=no name=wifi-5ghz security=wifi-security
Is d4:01:c3:d2:48:d9 your APs bssid?Link to Driver Log TXT-File from Macbook:As already written: ROS logs are not helpful. You all need to capture your client logs.
https://1drv.ms/t/s!AsOJquxuP-h5hewWtvJ ... Q?e=yTxxJA
Link to Driver Log TXT-File from Macbook: https://1drv.ms/t/s!AsOJquxuP-h5hewWtvJ ... Q?e=yTxxJA
Link to Driver Log TXT-File from Macbook: https://1drv.ms/t/s!AsOJquxuP-h5hewWtvJ ... Q?e=yTxxJA
Just a suggestion; when sharing a log this big, try giving a hint about when the issue happened so people know where to start looking. Also, this log is primarily meant for the Apple Developer forums or Apple Support but if you’re lucky someone here might have time to help you out.
Interesting- so the beta releases, Wi-Fi worked fine, but now that's it final, it doesn't?I'm also using Beta of iOS 18 since the beginning. Was working fine. Right now I've 18.1 beta 3 installed. Also without a Problem.
Only iOS 18, iPad OS 18 and MacOS 15y is making problems.
WatchOS 11 is also working fine.
Could you please post your wifi config for testing?
[admin@MikroTik] > /interface wireless export
# 2024-09-19 18:49:15 by RouterOS 7.15.3
# software id = KT6A-4P99
#
# model = RB4011iGS+5HacQ2HnD
# serial number = xxxxx
/interface wireless security-profiles
set [ find default=yes ] eap-methods="" supplicant-identity=MikroTik
add authentication-types=wpa2-psk disable-pmkid=yes eap-methods="" mode=dynamic-keys name=public-sp supplicant-identity=""
add authentication-types=wpa2-psk disable-pmkid=yes eap-methods="" mode=dynamic-keys name=2&5GHz-ap supplicant-identity=""
add authentication-types=wpa2-psk disable-pmkid=yes eap-methods="" mode=dynamic-keys name=iot-sp supplicant-identity=""
/interface wireless
set [ find default-name=wlan1 ] band=5ghz-onlyac channel-width=20/40/80mhz-XXXX comment=5GHz country=netherlands default-authentication=no default-forwarding=no disabled=no distance=indoors frequency=5500 installation=indoor mode=ap-bridge \
security-profile=2&5GHz-ap ssid=xxxx station-roaming=enabled vlan-id=84 wireless-protocol=802.11 wps-mode=disabled
set [ find default-name=wlan2 ] ampdu-priorities=0,1,2,3,4,5 band=2ghz-g/n channel-width=20/40mhz-XX comment=2GHz country=netherlands default-authentication=no default-forwarding=no disabled=no distance=indoors frequency=auto installation=indoor \
mode=ap-bridge security-profile=iot-sp ssid=xxxx station-roaming=enabled wireless-protocol=802.11 wps-mode=disabled
add default-authentication=no default-forwarding=no disabled=no mac-address=76:4D:xx:xx:xx:xx master-interface=wlan2 name=wlan2.1 security-profile=2&5GHz-ap ssid=xxxx wps-mode=disabled
add default-authentication=no default-forwarding=no disabled=no mac-address=76:4D:xx:xx:xx:xx master-interface=wlan2 name=wlan2.2 security-profile=public-sp ssid=xxxx station-roaming=enabled wps-mode=disabled
The engineer also said CrowdStrike sent out a “Tech Alert” to customers, adding that “there’s quite a lot going on with the changes in the network stack.”
Are you using "wireless" or the "wifi-qcom" packages? That looks like the original wireless package.As fa as I know, I don't use EAP
[cesar@RB5009] > /interface/wifi/security/print detail
Flags: X - disabled
0 name="Example WPA3" authentication-types=wpa2-psk,wpa3-psk encryption=ccmp,gcmp,ccmp-256,gcmp-256 passphrase="xxxxxxxx" disable-pmkid=yes management-protection=required wps=disable dh-groups=19,20,21 ft=yes ft-over-ds=yes
[cesar@RB5009] > /interface/wifi/security/unset numbers=0 value-name=encryption
[cesar@RB5009] > /interface/wifi/security/print detail
Flags: X - disabled
0 name="Example WPA3" authentication-types=wpa2-psk,wpa3-psk passphrase="xxxxxxxx" disable-pmkid=yes management-protection=required wps=disable dh-groups=19,20,21 ft=yes ft-over-ds=yes
[cesar@RB5009] >
After some more testing, it seems to work fine with encryption=ccmp,gcmp as well.
Latest v7 release. I've already swapped out the MikroTik Audience APs for a competing Wi-Fi AP product from another vendor and "like magic", everything works fine, even iOS 18 devices. I've switched on/off from MikroTik's Wi-Fi gear so many times over the years, I don't even see the point in continuing to use their Wi-Fi gear. There would need to be significant and compelling reasons for me to switch back at this point. The competition in the Wi-Fi space is so far ahead of MikroTik it's actually kind of sad. I'll continue to use the routers and switches but ugh, the wireless gear is like being in the stone age at this point. That doesn't even brush upon the shortcomings of the management solution for them (CAPsMAN) which is a wholly separate problem in itself.Did OP ever tell us which ROS version his/her problem occurs on?? Or which Mikrotik AP? I would guess Audience but who knows.
That was a simple question about the ROS version number; the answer to that is not "latest". We don't know what you think "latest" is.Latest v7 release.
Yet, you come to the forum, create a topic, and want to place all the blame on ROS. That's a rather strange approach. The device you've updated has a problem after update. Is there a correlation?My spouse recently updated her iPhone SE to iOS 18. Since then, she can't connect to the Wi-Fi network. Whenever I try to connect, it prompts for the Wi-Fi password, I enter it correctly, but then it immediately says unable to connect. Nothing at the router or Wi-Fi AP level has changed.
Some remarks:Code: Select all/interface wifi set [ find default-name=wifi1 ] channel.frequency=2401-5835 \ .skip-dfs-channels=all configuration.country="United States" .mode=ap \ .ssid=MikroTik disabled=no security.authentication-types=\ wpa2-psk,wpa3-psk .connect-priority=0/1 .encryption=\ ccmp,gcmp,ccmp-256,gcmp-256 .ft=yes .ft-over-ds=yes .group-key-update=1d \ .wps=disable set [ find default-name=wifi2 ] channel.frequency=2401-5835 \ .skip-dfs-channels=all configuration.country="United States" .mode=ap \ .ssid=MikroTik disabled=no security.authentication-types=\ wpa2-psk,wpa3-psk .connect-priority=0/1 .encryption=\ ccmp,gcmp,ccmp-256,gcmp-256 .ft=yes .ft-over-ds=yes .group-key-update=1d \ .wps=disable set [ find default-name=wifi3 ] channel.frequency=2401-5835 \ .skip-dfs-channels=all configuration.country="United States" .hide-ssid=\ yes .mode=ap .ssid=MikroTik-Mesh disabled=no \ security.authentication-types=wpa3-psk .connect-priority=0/1 .encryption=\ ccmp,gcmp,ccmp-256,gcmp-256 .ft=yes .ft-over-ds=yes .group-key-update=1d \ .wps=disable
I found that @normis gave this as advice:- .encryption=ccmp,gcmp,ccmp-256,gcmp-256. Is this something WinBox sets? Or is this on purpose?
viewtopic.php?p=1090178&hilit=tkip#p10901782) in "configuration" tab add one config template, that is all you need. don't enter anything else except SSID name and wireless password (select WPA2 and all cyphers except TKIP)