Why would it do that?
The thing is that if you make an L2 port a
gateway of a route, the router sends an ARP request down that port, asking for the MAC address of the actual destination IP address. Some routers (like Cisco by default) respond to such an ARP request with their own MAC address if they have a route to the destination IP address. Mikrotik can do that too if you set the
arp property of the corresponding interface to
proxy-arp, so if your LTE router in passthrough mode is a Mikrotik one, this could be a way (but I have actually never tried to configure
arp=proxy-arp on an interface used for LTE passthrough, so it may be just wishful thinking). If it is another brand, this is not the way.
An approach that will always work is to use the
script item of the DHCP server to update the
gateway item of all the routes you need to use the LTE path, something like (not tested!)
:if ($bound=1) do={
:local lteFlagRoute [/ip route find where comment~"LTE flag route"]
:if ([/ip route get $lteFlagRoute gateway] != $"gateway-address") do={
:foreach lteRoute in=[/ip route find where comment~"LTE"] do={
/ip route set $lteRooute gateway=$"gateway-address"
}
}
}
You have to choose just one of the routes to be used to track changes and set its comment to contain "LTE flag route" as a substring, and set the comment of eventual other routes you want to update to contain "LTE" as a substring, like "My
LTE flag route for failover" and "
LTE route for 3CX" to make it work. The DHCP client spawns the script whenever the DHCP lease changes, and if that change includes a change of the gateway address (which it typically will when the LTE router uses passthrough mode), it will update all tehe routes.