I’m trying to set up a wireless network with CAPsMAN, and I need the clients to receive IP addresses from a DHCP server on VLAN 202. Here’s my current setup:
I created VLAN 202 on the CAPsMAN router.
I added a bridge named Bridge-CAPsMAN-202 with vlan-filtering=yes.
DHCP server is configured to serve addresses.
I have set the WiFi configuration in CAPsMAN to use Bridge-CAPsMAN-202 but left the VLAN ID blank in the Datapath to avoid tagged VLAN traffic to clients.
However, clients are still not receiving an IP address from the DHCP server. I’ve also tried:
Testing the DHCP server directly on VLAN 202 with other devices (wired).
Here’s CapsMan configuration:
Code: Select all
/interface bridge
add name=Bridge-CAPsMAN-202 pvid=202 vlan-filtering=yes
/interface vlan
add interface=ether2-SW name=VoIP-WLAN vlan-id=202
/interface wifi datapath
add bridge=Bridge-CAPsMAN-202 disabled=no name=DP-VoIP-WLAN
/interface wifi security
add authentication-types=wpa-psk,wpa2-psk disabled=no name=Akey-VoIP wps=\
disable
/interface wifi configuration
add datapath=DP-VoIP-WLAN disabled=no name=5G-VWLAN security=Akey-VoIP ssid=\
Heqom
add datapath=DP-VoIP-WLAN disabled=no name=2G-VWLAN security=Akey-VoIP ssid=\
Heqom
/ip pool
add name=dhcp_pool3 ranges=172.30.202.12-172.30.202.30
/ip dhcp-server
add address-pool=dhcp_pool3 interface=VoIP-WLAN lease-time=5h name=VoIP-WLAN
/interface wifi capsman
set ca-certificate=auto enabled=yes interfaces=ether2-SW package-path="" \
require-peer-certificate=no upgrade-policy=none
/interface wifi provisioning
name-format=%I radio-mac=X:X:X:X:X slave-configurations=5G-VWLAN
name-format=%I radio-mac=X:X:X:X:X slave-configurations=2G-VWLAN
/ip address
add address=172.30.202.1/24 interface=VoIP-WLAN network=172.30.202.0
/ip dhcp-server network
add address=172.30.202.0/24 dns-server=172.30.202.1 gateway=172.30.202.1
/ip dns
set servers=8.8.8.8,4.2.2.4
Code: Select all
/interface vlan
add interface=E02-SW name=V-WLAN vlan-id=202
/interface wifi
# managed by CAPsMAN
# mode: AP, SSID: Heqom, channel: 2412/ax/Ce
set [ find default-name=wifi2 ] channel.band=2ghz-ax .frequency=2437 .width=\
20mhz configuration.manager=capsman-or-local .mode=ap .ssid=Heqom \
disabled=no name=WLAN-2.4GHz security=Akey
# managed by CAPsMAN
# mode: AP, SSID: Heqom, channel: 5500/ax/Ceee
set [ find default-name=wifi1 ] channel.skip-dfs-channels=all \
configuration.manager=capsman-or-local .mode=ap .ssid=Heqom disabled=\
no name=WLAN-5GHz security=Akey
/interface wifi cap
set discovery-interfaces=E02-SW enabled=yes
/ip address
add address=172.30.202.252/24 interface=V-WLAN network=172.30.202.0