I would like to start by introducing myself as an enthusiast, although not a professional, who enjoys researching network technologies. I am reaching out for your assistance, as despite my efforts, I haven’t been able to find a solution to a particular issue.
Let me begin by describing my setup. I have a 1000 Mbps Download / 50 Mbps Upload internet package at home, delivered via FTTH (Fiber to the Home). My internet provider uses a Huawei ONT to terminate the fiber connection and then provides a modem to access the internet. As someone passionate about networking, I initially replaced the provided modem with a MikroTik CRS326-24G-2S+RM, where the LAN cable from the ONT was connected to the MikroTik router, and with VLAN ID 35 configured, I was able to access the internet without any issues.
After further research, I decided to go one step further and remove the ONT device. After some investigation, I acquired a Huawei MA5671A and installed OpenWrt on it. Successfully configuring this setup, I was able to access the internet without any problems using a Keenetic Giga KN-1010. The results were flawless.
Speed Results:
However, when I tried to replicate this setup with my MikroTik device, I noticed that the speed results were inconsistent and much lower than expected, despite the fact that I believe the MikroTik device is more powerful than the initial test device. I’m fairly certain this issue is related to configuration.
I would like to share my speed results and configuration with you in the hope that you can provide guidance or help me identify the problem. If I manage to resolve this issue, I would be happy to create a comprehensive FTTH MikroTik guide.
Speed Results from MikroTik:
Configuration:
Code: Select all
/interface ethernet set [find default-name=sfp-sfpplus1] name=WAN
/interface ethernet switch set [find] l3-hw-offloading=yes
/interface ethernet switch set [find] qos-hw-offloading=yes
/interface bridge add name=LAN vlan-filtering=yes igmp-snooping=yes
/interface bridge port add bridge=LAN interface=ether1 hw=yes
/interface bridge port add bridge=LAN interface=ether2 hw=yes
/interface bridge port add bridge=LAN interface=ether3 hw=yes
/interface bridge port add bridge=LAN interface=ether4 hw=yes
/interface bridge port add bridge=LAN interface=ether5 hw=yes
/interface bridge port add bridge=LAN interface=ether6 hw=yes
/interface bridge port add bridge=LAN interface=ether7 hw=yes
/interface bridge port add bridge=LAN interface=ether8 hw=yes
/interface bridge port add bridge=LAN interface=ether9 hw=yes
/interface bridge port add bridge=LAN interface=ether10 hw=yes
/interface bridge port add bridge=LAN interface=ether11 hw=yes
/interface bridge port add bridge=LAN interface=ether12 hw=yes
/interface bridge port add bridge=LAN interface=ether13 hw=yes
/interface bridge port add bridge=LAN interface=ether14 hw=yes
/interface bridge port add bridge=LAN interface=ether15 hw=yes
/interface bridge port add bridge=LAN interface=ether16 hw=yes
/interface bridge port add bridge=LAN interface=ether17 hw=yes
/interface bridge port add bridge=LAN interface=ether18 hw=yes
/interface bridge port add bridge=LAN interface=ether19 hw=yes
/interface bridge port add bridge=LAN interface=ether20 hw=yes
/interface bridge port add bridge=LAN interface=ether21 hw=yes
/interface bridge port add bridge=LAN interface=ether22 hw=yes
/interface bridge port add bridge=LAN interface=ether23 hw=yes
/interface bridge port add bridge=LAN interface=ether24 hw=yes
/interface bridge port add bridge=LAN interface=sfp-sfpplus2 hw=yes
/interface ethernet set [find] mtu=1500
/ip address add address=10.0.0.1/24 interface=LAN
/ip dns set servers=1.1.1.1,1.0.0.1 allow-remote-requests=no
/ppp secret add name="xxxx@ttnet" password="xxxx" profile=default
/interface pppoe-client add name=TT-FTTH interface=WAN user="xxxx@ttnet" password="xxxx" service-name="" add-default-route=yes
/interface pppoe-client enable TT-FTTH
/ip pool add name=DHCPPool ranges=10.0.0.2-10.0.0.254
/ip dhcp-server network add address=10.0.0.0/24 dns-server=1.1.1.1,1.0.0.1 gateway=10.0.0.1
/ip dhcp-server add name=DHCPServer interface=LAN address-pool=DHCPPool
/ip dhcp-server enable DHCPServer
/ip firewall nat add chain=srcnat src-address=10.0.0.0/24 action=masquerade
/ip firewall filter remove [find where chain=forward and action=accept]
/ip firewall filter add chain=forward action=fasttrack-connection connection-state=established,related
/ip firewall filter add chain=forward action=accept connection-state=established,related
Note: No additional changes were made other than running these configurations and testing them.
I look forward to your feedback and assistance in resolving this issue. Thank you in advance for your time and help!