Hi,
my configs for far:
/interface wifi configuration
add channel=24 country=Austria datapath=UNG disabled=no mode=ap name=UNG-24 security=UNG ssid=UNG
add channel=50 datapath=UNG disabled=no mode=ap name=UNG-50 security=UNG ssid=UNG
add channel=24 datapath=UNGiot disabled=no mode=ap name=UNGiot-24 security=UNGiot ssid=UNGiot steering=steering
add channel=50 country=Austria datapath=UNGiot disabled=no mode=ap name=UNGiot-50 security=UNGiot ssid=UNGiot
add channel=24 country=Austria datapath=UNGbb disabled=no mode=ap name=UNGbb-24 security=UNGbb ssid=UNGbb
add datapath=UNGstream disabled=no mode=ap name=UNGstream-24 security=UNGstream ssid=UNGstream
add channel=50 country=Austria datapath=UNGstream disabled=no mode=ap name=UNGstream-50 security=UNGstream ssid=UNGstream
add channel=24 country=Australia datapath=UNGsecurity disabled=no mode=ap name=UNGsecurity-24 security=UNGsecurity ssid=UNGsecurity
add channel=50 country=Austria datapath=UNGsecurity disabled=no mode=ap name=UNGsecurtiy-50 security=UNGsecurity ssid=UNGsecurtiy
add channel=24 country=Austria datapath=UNG disabled=no hide-ssid=yes mode=ap name=UNG24-24 security=UNG ssid=UNG24
add channel=50 country=Austria datapath=UNG disabled=no hide-ssid=yes mode=ap name=UNG50-50 security=UNG ssid=UNG50
add datapath=UNGbb disabled=no mode=ap name=UNGbb-50 security=UNGbb ssid=UNGbb
/interface wifi datapath
add disabled=no interface-list=UNG name=UNG
add bridge=UNGiot-bridge disabled=no name=UNGiot
add bridge=UNGstream-bridge disabled=no name=UNGstream
add bridge=UNGsecurity-bridge disabled=no name=UNGsecurity
add bridge=UNGbb-bridge disabled=no name=UNGbb
add bridge=UNGinterconnect-bridge disabled=no name=UNGinterconnect
/interface wifi channel
add band=2ghz-ax disabled=no name=24 skip-dfs-channels=10min-cac width=20/40mhz
add band=5ghz-ax disabled=no name=50 skip-dfs-channels=10min-cac width=20/40/80mhz
/interface wifi security
add authentication-types=wpa2-psk disabled=no ft=yes ft-over-ds=yes name=UNG wps=disable
add authentication-types=wpa2-psk,wpa3-psk disabled=no ft=yes ft-over-ds=yes name=UNGbb wps=disable
add authentication-types=wpa2-psk,wpa3-psk disabled=no ft=yes ft-over-ds=yes name=UNGiot wps=disable
add authentication-types=wpa2-psk,wpa3-psk disabled=no ft=yes ft-over-ds=yes name=UNGstream wps=disable
add authentication-types=wpa2-psk,wpa3-psk disabled=no ft=yes ft-over-ds=yes name=UNGsecurity wps=disable
add action=create-enabled disabled=no master-configuration=UNG-50 slave-configurations=UNGstream-50,UNGiot-50,UNGbb-50,UNGsecurtiy-50 supported-bands=5ghz-ax
add action=create-enabled disabled=no master-configuration=UNG-24 slave-configurations=UNGstream-24,UNGiot-24,UNGbb-24,UNGsecurity-24 supported-bands=2ghz-ax
So far what worked:
- I created vlans for every WIFI on every device (CAPSman and HAP)
- I created bridges for every VLAN and joined in the VLAN
- I enabled the option:
/interface/wifi/cap/set slaves-static=yes
- I recreated the datapath on every hap
- I changed the datapath setting manually on every hap (so that they correct wifi will be in the correct bridge)
Seems to work okayish - but this seem NOT to be the way the manuals suggested me how this should work.
Configuration on the hap:
VLANs:
add interface=ether1 name=UNG-vlan vlan-id=10
add interface=ether1 name=UNGbb-vlan vlan-id=1
add interface=ether1 name=UNGiot-vlan vlan-id=20
add interface=ether1 name=UNGsecurity-vlan vlan-id=30
add interface=ether1 name=UNGstream-vlan vlan-id=40
Bridge:
/interface bridge
add name=UNG-bridge port-cost-mode=short
add name=UNGbb-bridge port-cost-mode=short
add name=UNGiot-bridge port-cost-mode=short
add name=UNGsecurity-bridge port-cost-mode=short
add name=UNGstream-bridge port-cost-mode=short
/interface bridge port
add bridge=UNG-bridge interface=UNG-vlan internal-path-cost=10 path-cost=10
add bridge=UNGbb-bridge interface=UNGbb-vlan internal-path-cost=10 path-cost=10
add bridge=UNGiot-bridge interface=UNGiot-vlan internal-path-cost=10 path-cost=10
add bridge=UNGsecurity-bridge interface=UNGsecurity-vlan internal-path-cost=10 path-cost=10
add bridge=UNGstream-bridge interface=UNGstream-vlan internal-path-cost=10 path-cost=10
add bridge=UNG-bridge interface=ether4 internal-path-cost=10 path-cost=10
Datapath:
/interface wifi datapath
add bridge=*6 comment=defconf disabled=no name=capdp
add bridge=UNG-bridge disabled=no name=UNG
add bridge=UNGiot-bridge disabled=no name=UNGiot
add bridge=UNGstream-bridge disabled=no name=UNGstream
add bridge=UNGbb-bridge disabled=no name=UNGbb
add bridge=UNGsecurity-bridge disabled=no name=UNGsecurity
# managed by CAPsMAN 192.168.89.1, traffic processing on CAP
# mode: AP, SSID: UNG, channel: 2442/ax/eC
set [ find default-name=wifi1 ] configuration.manager=capsman .mode=ap datapath=UNG disabled=no security.connect-priority=0
# managed by CAPsMAN 192.168.89.1, traffic processing on CAP
# mode: AP, SSID: UNGstream
add configuration.mode=ap datapath=UNGstream disabled=no mac-address=4A:A9:8A:06:58:C3 master-interface=wifi1 name=wifi2 security.connect-priority=0
# managed by CAPsMAN 192.168.89.1, traffic processing on CAP
# mode: AP, SSID: UNGiot
add configuration.mode=ap datapath=UNGiot disabled=no mac-address=4A:A9:8A:06:58:C4 master-interface=wifi1 name=wifi3 security.connect-priority=0
# managed by CAPsMAN 192.168.89.1, traffic processing on CAP
# mode: AP, SSID: UNGbb
add configuration.mode=ap datapath=UNGbb disabled=no mac-address=4A:A9:8A:06:58:C5 master-interface=wifi1 name=wifi4
# managed by CAPsMAN 192.168.89.1, traffic processing on CAP
# mode: AP, SSID: UNGsecurity
add configuration.mode=ap datapath=UNGsecurity disabled=no mac-address=4A:A9:8A:06:58:C6 master-interface=wifi1 name=wifi5
And best of all - I did a ping test for 500 pings - seems that I have a 5% packet loss - which leads to "connectivity to capsman interrupted" - so all WIFIs are getting recreated around all 2 minutes...
Any help warmely welcome in case further configs needed - please let me know.
Björn