I managed to get the VLANs working, kind of the Internet keeps not showing up.
But doing /tools/ping 8.8.8.8 interface=ppp-out I get the wanted reply.
Besides no Internet I haven't yet looked into on how to isolate my VLANs against each other.
Also L2TP with IPsec is working.
But looking at the example configurations router.rsc and switch.rsc I cannot figure out whats actualy wrong with my configuration.
Here is my current config:
# 2025-02-23 03:35:42 by RouterOS 7.17.2
/interface bridge
add admin-mac=D4:01:C3:E5:2A:A4 auto-mac=no comment=defconf name=bridgeLocal \
protocol-mode=none vlan-filtering=yes
/interface pppoe-client
add add-default-route=yes interface=ether1 name=pppoe-out1 use-peer-dns=yes \
user=ppp_srabbiosi1
/interface vlan
add interface=bridgeLocal name=vlan10 vlan-id=10
add interface=bridgeLocal name=vlan20 vlan-id=20
add interface=bridgeLocal name=vlan178 vlan-id=178
add interface=bridgeLocal name=vlan1000 vlan-id=1000
/caps-man datapath
add bridge=bridgeLocal client-to-client-forwarding=yes name=Office20 vlan-id=\
20 vlan-mode=use-tag
/caps-man security
add authentication-types=wpa2-psk encryption=aes-ccm name=der-space
add authentication-types=wpa2-psk encryption=aes-ccm name=GreenMountain
/caps-man configuration
add country=germany datapath=Office20 installation=any mode=ap name=Office \
rx-chains=0,1,2,3 security=GreenMountain ssid=test tx-chains=0,1,2,3
add country=germany datapath=Office20 installation=any mode=ap name=cfg1 \
rx-chains=0,1,2,3 security=der-space ssid=der-space tx-chains=0,1,2,3
/caps-man interface
add configuration=Office disabled=no l2mtu=1600 mac-address=48:8F:5A:57:E3:85 \
master-interface=none name=Keller-1 radio-mac=48:8F:5A:57:E3:85 \
radio-name=488F5A57E385
add configuration=Office disabled=no l2mtu=1600 mac-address=48:8F:5A:57:E3:84 \
master-interface=none name=Keller-2 radio-mac=48:8F:5A:57:E3:84 \
radio-name=488F5A57E384
/interface list
add name=WAN
add name=LAN
add name=VLAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip ipsec proposal
set [ find default=yes ] auth-algorithms=sha256,sha1 enc-algorithms="aes-256-c\
bc,aes-256-ctr,aes-256-gcm,aes-192-cbc,aes-192-ctr,aes-192-gcm,aes-128-cbc\
,aes-128-ctr,aes-128-gcm,3des" lifetime=0s
/ip pool
add name=dhcp20 ranges=192.168.20.100-192.168.20.254
add name=dhcp10 ranges=192.168.10.100-192.168.10.254
add name=dhcp178 ranges=192.168.178.100-192.168.178.254
add name=dhcp1000 ranges=192.168.0.100-192.168.0.254
add name=ovpn ranges=192.168.178.92-192.168.178.99
/ip dhcp-server
add address-pool=dhcp20 comment="Office Wifi" interface=vlan20 name=dhcp20
add address-pool=dhcp10 comment="Guest Wifi" interface=vlan10 name=dhcp10
add address-pool=dhcp178 comment=Server interface=vlan178 name=dhcp178
add address-pool=dhcp1000 comment=filip interface=vlan1000 name=dhcp1000
/ppp profile
set *0 use-upnp=yes
add bridge=bridgeLocal change-tcp-mss=yes dns-server=\
192.168.178.251,192.168.178.252 local-address=192.168.178.91 name=ovpn \
remote-address=ovpn use-encryption=required use-ipv6=no
set *FFFFFFFE use-ipv6=no
/caps-man access-list
add action=accept allow-signal-out-of-range=10s disabled=no mac-address=\
4C:75:25:30:E9:ED ssid-regexp="^der-space\$"
add action=accept allow-signal-out-of-range=10s disabled=no mac-address=\
DC:97:BA:D3:1E:F9 ssid-regexp="^der-space\$"
add action=accept allow-signal-out-of-range=10s disabled=no mac-address=\
B4:CE:40:A4:68:7E signal-range=-120..120 ssid-regexp="^der-space\$" time=\
0s-1d,sun,mon,tue,wed,thu,fri,sat
add action=accept allow-signal-out-of-range=10s disabled=no mac-address=\
34:60:F9:0F:9E:15 mac-address-mask=00:00:00:00:00:00 signal-range=\
-120..120 ssid-regexp="^der-space\$" time=\
0s-1d,sun,mon,tue,wed,thu,fri,sat
add action=reject allow-signal-out-of-range=10s disabled=no ssid-regexp=\
"^der-space\$"
/caps-man manager
set ca-certificate=auto certificate=auto enabled=yes upgrade-policy=\
suggest-same-version
/caps-man provisioning
add action=create-enabled master-configuration=Office name-format=identity
/interface bridge port
add bridge=bridgeLocal comment=defconf disabled=yes ingress-filtering=no \
interface=ether1 internal-path-cost=10 path-cost=10
add bridge=bridgeLocal comment=defconf interface=ether2
add bridge=bridgeLocal comment=defconf interface=ether3
add bridge=bridgeLocal comment=defconf interface=ether4
add bridge=bridgeLocal comment=defconf interface=ether5 pvid=20
add bridge=bridgeLocal comment=defconf interface=ether6 pvid=20
add bridge=bridgeLocal comment=defconf interface=ether7 pvid=20
add bridge=bridgeLocal comment=defconf frame-types=\
admit-only-untagged-and-priority-tagged interface=ether8 pvid=20
add bridge=bridgeLocal comment=defconf interface=sfp-sfpplus1
/interface bridge vlan
add bridge=bridgeLocal tagged=sfp-sfpplus1,ether4 vlan-ids=10
add bridge=bridgeLocal tagged=sfp-sfpplus1,ether4 vlan-ids=20
add bridge=bridgeLocal tagged=sfp-sfpplus1,ether4 vlan-ids=178
add bridge=bridgeLocal tagged=sfp-sfpplus1,ether4 vlan-ids=1000
/interface l2tp-server server
set allow-fast-path=yes authentication=mschap2 default-profile=ovpn enabled=\
yes one-session-per-host=yes use-ipsec=required
/interface list member
add interface=ether1 list=WAN
add interface=bridgeLocal list=LAN
add interface=vlan20 list=VLAN
add interface=vlan10 list=VLAN
add interface=vlan178 list=VLAN
add interface=vlan1000 list=VLAN
/interface ovpn-server server
add mac-address=FE:A3:93:79:5D:2D name=ovpn-server1
/ip address
add address=192.168.20.1/24 interface=vlan20 network=192.168.20.0
add address=192.168.10.1/24 interface=vlan10 network=192.168.10.0
add address=192.168.178.1/24 interface=vlan178 network=192.168.178.0
add address=192.168.0.1/24 interface=vlan1000 network=192.168.0.0
/ip dhcp-client
add disabled=yes interface=ether1
/ip dhcp-server lease
add address=192.168.178.179 client-id=1:74:ac:b9:41:23:bc mac-address=\
74:AC:B9:41:23:BC server=dhcp178
add address=192.168.178.178 client-id=1:48:8f:5a:39:cf:e4 mac-address=\
48:8F:5A:39:CF:E4 server=dhcp178
add address=192.168.178.177 client-id=1:48:8f:5a:3a:4f:f1 mac-address=\
48:8F:5A:3A:4F:F1 server=dhcp178
add address=192.168.178.169 client-id=1:48:8f:5a:57:d7:a7 mac-address=\
48:8F:5A:57:D7:A7 server=dhcp178
add address=192.168.178.168 client-id=1:3c:ec:ef:71:1d:df comment=\
"IPMI - node1.der-space.prod" mac-address=3C:EC:EF:71:1D:DF server=\
dhcp178
add address=192.168.178.167 client-id=1:48:8f:5a:57:e3:83 mac-address=\
48:8F:5A:57:E3:83 server=dhcp178
/ip dhcp-server network
add address=0.0.0.0/24 dns-server=0.0.0.0 gateway=0.0.0.0 netmask=24
add address=192.168.20.0/24 dns-server=192.168.20.1 gateway=192.168.20.1 \
netmask=24
/ip dns
set servers=192.168.178.251,192.168.178.252
/ip firewall filter
add action=accept chain=input comment=\
"defconf: accept established,related,untracked" connection-state=\
established,related,untracked
add action=accept chain=input comment="allow IPsec NAT" dst-port=4500 \
protocol=udp
add action=accept chain=input comment="allow IKE" dst-port=500 protocol=udp
add action=accept chain=input comment="allow l2tp" dst-port=1701 protocol=udp
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
invalid
add action=accept chain=input protocol=ipsec-esp
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
"defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from VLAN" \
in-interface-list=!VLAN
add action=accept chain=forward comment="VLAN Internet Access only" \
connection-state=new in-interface-list=VLAN out-interface-list=WAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
connection-state=established,related hw-offload=yes
add action=accept chain=forward comment=\
"defconf: accept established,related, untracked" connection-state=\
established,related,untracked
add action=drop chain=forward comment=\
"defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
connection-state=new in-interface-list=WAN
add action=accept chain=input comment="Allow VLAN" in-interface-list=VLAN
add action=drop chain=input comment=Drop
add action=drop chain=forward comment=Drop
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
ipsec-policy=out,none out-interface-list=WAN
add action=masquerade chain=srcnat comment="masq. vpn traffic" src-address=\
192.168.178.0/24
/ip ipsec profile
set [ find default=yes ] dpd-interval=2m dpd-maximum-failures=5 \
enc-algorithm=aes-256,aes-192,aes-128
/ip service
set www-ssl certificate=webfig disabled=no
/ppp secret
add name=antrobotics profile=ovpn
/system clock
set time-zone-name=Europe/Berlin
/system identity
set name=RB5009UPr
/system note
set show-at-login=no
/system ntp client
set enabled=yes
/system ntp server
set broadcast=yes enabled=yes manycast=yes multicast=yes use-local-clock=yes
/system ntp client servers
add address=192.53.103.108 comment=ptbtime1.ptb.de
add address=192.53.103.104 comment=ptbtime2.ptb.de