I have a L009UiGS and use RouterOS 7.16.2. I want to add a new isolated network for my smart-home gadgets. One reason is because I have an inverter and an EV-wallbox in garage connected to the router via ethernet port (ether2) and I don't want anyone can access private stuff (e.g. NAS) by simply plug-off one of the devices and plugin a computer.
I was able to successfully set this up, but within the new network local DNS is not resonding (pointing to default gateway). Just getting timeouts on "nslookup whatever.com". Routing, NAT, etc. works fine. When using my provider's name-servers instead everything is fine and I can access any internet service (e.g. websites, etc.). I initially setup the router using the standard configuration and in this network, to which all my computers and also NAS is connected, local DNS works fine. I would prefer to use local DNS, because it is updated whenever the public IP lease expires and maybe new name-servers are provided.
This is my setup for the new network:
Code: Select all
/interface/veth/add name=veth2 address=172.18.0.2/24 gateway=172.18.0.1 comment=smarthome
/interface/bridge/add name=smarthome
/ip/address/add address=172.18.0.1/24 interface=smarthome
/interface/bridge/port add bridge=smarthome interface=veth2
/interface/bridge/port/set [find interface=ether2] bridge=smarthome comment=smarthome
# dhcp server
/ip/pool/add name=dhcp-smarthome ranges=172.18.0.2-172.18.0.250
/ip/dhcp-server/network/add address=172.18.0.0/24 gateway=172.18.0.1 dns-server=172.18.0.1 comment=smarthome
/ip/dns/static/add comment=smarthome name=smarthome.lan type=A ttl=1d address=172.18.0.1
/ip/dhcp-server/add name=smarthome interface=smarthome address-pool=dhcp-smarthome comment=smarthome
/ip/firewall/nat/add comment=smarthome:masquerade chain=srcnat out-interface-list=WAN ipsec-policy=out,none action=masquerade
It seems like local DNS is not available on 172.18.0.1 or traffic is dropped. I didn't find any configuration on the default network, searching "export compact", which makes DNS explicitly available to the network created by the default configuration.
Has anyone an idea how to fix this?
Thank you,
Stephan