Hi
I'm using my Hex S router to access the internet via PPoE and I also want it to connect to a remote site using Ubuntu Server with Wireguard.
The Wire guard client works, as from the RouterOS Terminal I can ping the remote hosts using Wireguard. (e.g 10.128.1.1)
However, from my PC (192.168.1.202) I can access the Internet as expected but cannot connect to the remote systems (10.128.1.1) using Wireguard.
Is anyone able to offer advice please?
Thanks
Here is my current config
# 2025-03-24 11:16:13 by RouterOS 7.18.2
# software id = LHJH-UTR9
#
# model = RB760iGS
/interface bridge
add admin-mac=F4:1E:57:AB:9A:AA auto-mac=no ingress-filtering=no name=bridge \
port-cost-mode=short vlan-filtering=yes
/interface ethernet
set [ find default-name=sfp1 ] advertise="10M-baseT-half,10M-baseT-full,100M-b\
aseT-half,100M-baseT-full,1G-baseT-half,1G-baseT-full"
/interface wireguard
add listen-port=1719 mtu=1420 name=WG_Interface
/interface vlan
add interface=bridge name=Guest_080 vlan-id=80
add interface=bridge name=IoT_020 vlan-id=20
add interface=bridge name=VOIP_050 vlan-id=50
/interface pppoe-client
add add-default-route=yes disabled=no interface=ether5 name=zen use-peer-dns=\
yes user=zen*****@zen
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface lte apn
set [ find default=yes ] ip-type=ipv4 use-network-apn=no
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp_pool2 ranges=192.168.1.50-192.168.1.69
add name=dhcp_pool3 ranges=192.168.20.2-192.168.20.254
add name=dhcp_pool4 ranges=10.1.80.2-10.1.80.254
add name=dhcp_pool5 ranges=172.16.0.2-172.16.0.14
/ip dhcp-server
add address-pool=dhcp_pool2 interface=bridge lease-time=10m name=dhcp2
add address-pool=dhcp_pool3 interface=IoT_020 lease-time=10m name=dhcp3
add address-pool=dhcp_pool4 interface=Guest_080 lease-time=10m name=dhcp4
add address-pool=dhcp_pool5 interface=VOIP_050 lease-time=10m name=dhcp1
/ip smb users
set [ find default=yes ] disabled=yes
/port
set 0 name=serial0
/ppp profile
add name=Draytek use-compression=yes
/routing bgp template
set default disabled=no output.network=bgp-networks
/routing ospf instance
add disabled=no name=default-v2
/routing ospf area
add disabled=yes instance=default-v2 name=backbone-v2
/interface bridge port
add bridge=bridge ingress-filtering=no interface=ether2 internal-path-cost=10 \
path-cost=10
add bridge=bridge ingress-filtering=no interface=ether3 internal-path-cost=10 \
path-cost=10
add bridge=bridge ingress-filtering=no interface=ether4 internal-path-cost=10 \
path-cost=10
add bridge=bridge ingress-filtering=no interface=sfp1 internal-path-cost=10 \
path-cost=10
add bridge=bridge ingress-filtering=no interface=ether1 internal-path-cost=10 \
path-cost=10
/ip firewall connection tracking
set udp-timeout=10s
/ip neighbor discovery-settings
set discover-interface-list=LAN
/ipv6 settings
set disable-ipv6=yes max-neighbor-entries=8192
/interface bridge vlan
add bridge=bridge tagged=ether1,bridge vlan-ids=20
add bridge=bridge tagged=ether1,bridge vlan-ids=50
add bridge=bridge tagged=ether1,bridge vlan-ids=80
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether5 list=WAN
add interface=zen list=WAN
add interface=WG_Interface list=LAN
/interface ovpn-server server
add auth=sha1,md5 mac-address=FE:5C:B1:FF:90:7F name=ovpn-server1
/interface wireguard peers
add allowed-address=0.0.0.0/0 endpoint-address=ZZ.ZZ.ZZ.ZZ endpoint-port=\
51820 interface=WG_Interface name=peer4 persistent-keepalive=30s \
public-key="ZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZ"
/ip address
add address=192.168.1.1/24 interface=bridge network=192.168.1.0
add address=192.168.20.1/24 interface=IoT_020 network=192.168.20.0
add address=10.1.80.1/24 interface=Guest_080 network=10.1.80.0
add address=172.16.0.1/28 interface=VOIP_050 network=172.16.0.0
add address=10.8.0.4/24 interface=WG_Interface network=10.8.0.0
/ip dhcp-server network
add address=10.1.80.0/24 gateway=10.1.80.1
add address=172.16.0.0/28 gateway=172.16.0.1
add address=192.168.1.0/24 dns-server=192.168.1.1 gateway=192.168.1.1
add address=192.168.20.0/24 gateway=192.168.20.1
add address=192.168.88.0/24 gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8
/ip dns static
add address=192.168.88.1 comment=defconf name=router.lan type=A
/ip firewall address-list
add address=10.1.80.0/24 list=Local-Networks
add address=176.16.0.0/28 list=Local-Networks
add address=192.168.1.0/24 list=Local-Networks
add address=192.168.20.0/24 list=Local-Networks
/ip firewall filter
add action=accept chain=input comment=\
"defconf: accept established,related,untracked" connection-state=\
established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
"defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
connection-state=established,related hw-offload=yes
add action=accept chain=forward comment=\
"defconf: accept established,related, untracked" connection-state=\
established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
connection-state=invalid
add action=drop chain=forward comment=\
"defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
connection-state=new in-interface-list=WAN
add action=drop chain=forward comment="Drop VLAN Routing" dst-address-list=\
Local-Networks src-address-list=Local-Networks
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
ipsec-policy=out,none out-interface-list=WAN
add action=masquerade chain=srcnat comment=Wireguard disabled=yes \
src-address=10.8.0.0/24
/ip ipsec profile
set [ find default=yes ] dh-group=modp1024 dpd-interval=2m \
dpd-maximum-failures=5 enc-algorithm=aes-256,aes-128,3des
/ip route
add disabled=no distance=1 dst-address=10.128.1.0/24 gateway=WG_Interface \
routing-table=main scope=30 suppress-hw-offload=no target-scope=10
/ip smb shares
set [ find default=yes ] directory=/flash/pub
/routing bfd configuration
add disabled=no interfaces=all min-rx=200ms min-tx=200ms multiplier=5
/system clock
set time-zone-name=Europe/London
/system logging
add topics=ipsec
add topics=pptp
/system note
set show-at-login=no
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN