Community discussions

MikroTik App
 
azhar
just joined
Topic Author
Posts: 19
Joined: Sat Jul 08, 2023 8:12 pm
Location: Lahore-PAkistan

Script for email backup file

Sat Mar 29, 2025 4:31 pm

I've wrote a scrpit in my mikrotik router to send me a backup file through email. It was working fine since upgrade router OS to 7.18.2. After upgrade it is saying

input does not match any value of file (/tool/e-mail/send (file); line 9)

:local EMAIL "it@tlpk.com"
:local PASSWORD "xxxxx"
:local TIME ([/system clock get time])
:local DATE ([/system clock get date])
:local FILENAME "Backup $[/system identity get name]-$[/system clock get date]"
:local MESSAGE "Please see attached file..."
/system backup save name=$FILENAME password=$PASSWORD
/delay 10
/tool e-mail send file=$FILENAME to=$EMAIL subject="Your MikroTik backup file as of $DATE $TIME" body=$MESSAGE
 
eltikpad
Frequent Visitor
Frequent Visitor
Posts: 95
Joined: Sun Jan 12, 2025 10:54 pm

Re: Script for email backup file

Sun Mar 30, 2025 6:35 pm

There seem to have been changes recently to the way the cli completes commands.

Make sure your $FILENAME variable exactly matches the full filename of the backup with any extension. It will no longer be matched without the extension.

Note:
I think it was this change from 7.18
*) console - do not autocomplete arguments when match is both exact and ambiguous;
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 12945
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: Script for email backup file

Mon Mar 31, 2025 12:47 pm

work only on v7.10 and later code

:local EMAIL    "it@tlpk.com"
:local PASSWORD "xxxx"
/system clock
:local DATE [get date]
:local TIME [get time]
/system identity
:local FILENAME "Backup $[get name]-$DATE.backup"
:local MESSAGE  "Please see attached file..."
/system backup save name=$FILENAME password=$PASSWORD
/delay 10s
/tool e-mail send file=$FILENAME to=$EMAIL subject="Your MikroTik backup file as of $DATE $TIME" body=$MESSAGE