I am observing the following situation on multiple routers (various platforms - powerpc, x86, so far haven't seen it on mipsle/mipsbe; also different ROS versions are affected, I have observed this on ROS 3.20 and 3.22):
I am trying to set up an IPv6 OSPFv3 routing on ROS. The boxes have both routing-test and mpls-test packages installed (those are required for OSPFv3 to work).
The configuration of one box follows:
Code: Select all
[admin@xxx] /routing ospf-v3> export
# mar/30/2009 11:46:50 by RouterOS 3.22
# software id = K1GZ-RVT
#
/routing ospf-v3 instance
set default comment="" disabled=no distribute-default=never metric-bgp=20 \
metric-connected=20 metric-default=1 metric-other-ospf=20 metric-rip=20 \
metric-static=20 name=default redistribute-bgp=as-type-2 \
redistribute-connected=as-type-1 redistribute-other-ospf=as-type-1 \
redistribute-rip=as-type-2 redistribute-static=as-type-1 router-id=\
10.152.0.1
/routing ospf-v3 area
set backbone area-id=0.0.0.0 disabled=no instance=default name=backbone type=\
default
/routing ospf-v3 interface
add area=backbone cost=10 dead-interval=40s disabled=no hello-interval=10s \
instance-id=0 interface=all network-type=default passive=no priority=1 \
retransmit-interval=5s transmit-delay=1s
Code: Select all
[admin@yyy] /routing ospf-v3> export
# mar/30/2009 11:47:39 by RouterOS 3.22
# software id = 9ZF1-PTT
#
/routing ospf-v3 instance
set default comment="" disabled=no distribute-default=never metric-bgp=20 metric-connected=20 metric-default=1 \
metric-other-ospf=20 metric-rip=20 metric-static=20 name=default redistribute-bgp=no redistribute-connected=\
as-type-1 redistribute-other-ospf=no redistribute-rip=no redistribute-static=as-type-1 router-id=10.128.9.1
/routing ospf-v3 area
set backbone area-id=0.0.0.0 disabled=no instance=default name=backbone type=default
/routing ospf-v3 area range
add advertise=yes area=backbone cost=calculated disabled=no range=::/0
/routing ospf-v3 interface
add area=backbone cost=10 dead-interval=40s disabled=no hello-interval=10s instance-id=0 interface=bridge1 \
network-type=broadcast passive=no priority=1 retransmit-interval=5s transmit-delay=1s
add area=backbone cost=10 dead-interval=40s disabled=no hello-interval=10s instance-id=0 interface=wlan1 \
network-type=broadcast passive=no priority=1 retransmit-interval=5s transmit-delay=1s
Code: Select all
/routing ospf-v3 neighbor print
Code: Select all
[admin@yyy] /routing ospf-v3> neighbor print
[admin@yyy] /routing ospf-v3>
Thanks,
Radek