Community discussions

 
jasejames
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 63
Joined: Fri Jun 26, 2009 11:04 am

Metarouter OpenWRT custom compile not working on latest

Sun Aug 02, 2009 5:07 am

I'm trying to compile the latest OpenWRT trunk to run on Metarouter but it is failing at various points with the patch apparently the culprit.

Does anyone know if the patch should be working currently and if not, is there an update?
 
PepeOnAchair
just joined
Posts: 8
Joined: Sat Nov 22, 2008 10:28 pm

Re: Metarouter OpenWRT custom compile not working on latest

Sun Aug 02, 2009 10:38 pm

Hi,
this weekend I`ve tried to compile OpenWRT as well. First error I got with the path was solved by adding break/enter behind last line in "openwrt-metarouter-1.1.patch". But during compilation I got these errors which I don`t know, how to solve:

.
.
.
Applying /home/pepe/trunk/target/linux/generic-2.6/patches-2.6.27/208-rtl8110sb_fix.patch using plaintext:
patching file drivers/net/r8169.c
Hunk #1 succeeded at 1507 (offset -19 lines).
Hunk #2 succeeded at 1516 (offset -19 lines).
Hunk #3 succeeded at 1525 (offset -19 lines).
Hunk #4 FAILED at 2853.
1 out of 4 hunks FAILED -- saving rejects to file drivers/net/r8169.c.rej
Patch failed! Please fix /home/pepe/trunk/target/linux/generic-2.6/patches-2.6.27/208-rtl8110sb_fix.patch!
make[3]: *** [/home/pepe/trunk/build_dir/toolchain-mips_gcc-4.1.2_uClibc-0.9.30.1/linux-2.6.27.21/.prepared86a4dd3aaceaeaeca884aabd65ed581e] Error 1
make[3]: Leaving directory `/home/pepe/trunk/toolchain/kernel-headers'
make[2]: *** [toolchain/kernel-headers/prepare] Error 2
make[2]: Leaving directory `/home/pepe/trunk'
make[1]: *** [/home/pepe/trunk/staging_dir/toolchain-mips_gcc-4.1.2_uClibc-0.9.30.1/stamp/.toolchain_install] Error 2
make[1]: Leaving directory `/home/pepe/trunk'
make: *** [world] Error 2



... this is the end, my only friend - the end :)



Does anyone know what is wrong? Just in case it is usefull, this is inside the "r8169.c.rej" file:

--- a/drivers/net/r8169.c
+++ b/drivers/net/r8169.c
@@ -1526,7 +1526,7 @@ static const struct rtl_cfg_info {
.hw_start = rtl_hw_start_8169,
.region = 1,
.align = 0,
- .intr_event = SYSErr | LinkChg | RxOverflow |
+ .intr_event = LinkChg | RxOverflow |
RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
.napi_event = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
.features = RTL_FEATURE_GMII
@@ -1535,7 +1535,7 @@ static const struct rtl_cfg_info {
.hw_start = rtl_hw_start_8168,
.region = 2,
.align = 8,
- .intr_event = SYSErr | LinkChg | RxOverflow |
+ .intr_event = LinkChg | RxOverflow |
TxErr | TxOK | RxOK | RxErr,
.napi_event = TxErr | TxOK | RxOK | RxOverflow,
.features = RTL_FEATURE_GMII | RTL_FEATURE_MSI
@@ -1544,7 +1544,7 @@ static const struct rtl_cfg_info {
.hw_start = rtl_hw_start_8101,
.region = 2,
.align = 8,
- .intr_event = SYSErr | LinkChg | RxOverflow | PCSTimeout |
+ .intr_event = LinkChg | RxOverflow | PCSTimeout |
RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
.napi_event = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
.features = RTL_FEATURE_MSI
@@ -2872,12 +2872,12 @@ static irqreturn_t rtl8169_interrupt(int
rtl8169_tx_timeout(dev);
break;
}
-
+#if 0
if (unlikely(status & SYSErr)) {
rtl8169_pcierr_interrupt(dev);
break;
}
-
+#endif
if (status & LinkChg)
rtl8169_check_link_status(dev, tp, ioaddr);


Good luck or thank you for help :)
Pep.
 
jasejames
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 63
Joined: Fri Jun 26, 2009 11:04 am

Re: Metarouter OpenWRT custom compile not working on latest

Sun Aug 02, 2009 11:06 pm

Yup, same issue here.

If you alter the 208 patch file to remove that last section that is failing, then the kernel-updates section also fails with a bunch of patch errors.

The kernel-updates section also fails once the trunk is patched, even if you leave the config at the defaults.

Suspect that a new patch file is required.
 
Gerard
Trainer
Trainer
Posts: 336
Joined: Wed Apr 26, 2006 4:21 am
Location: Kentucky, USA
Contact:

Re: Metarouter OpenWRT custom compile not working on latest

Tue Sep 08, 2009 6:55 pm

Any updates on this?

Gerard

edit: I just deleted target/linux/generic-2.6/patches-2.6.27/208-rtl8110sb_fix.patch and build r17542 compiles and seems to work fine.
 
nik247
Frequent Visitor
Frequent Visitor
Posts: 61
Joined: Fri Jan 16, 2009 1:00 pm
Location: Ukraine, Kyiv

Re: Metarouter OpenWRT custom compile not working on latest

Wed Sep 09, 2009 10:58 am

Latest trunk image build success with this patch (208-rtl8110sb_fix.patch) without errors.
 
amarburg
just joined
Posts: 7
Joined: Tue Oct 06, 2009 3:10 am

Re: Metarouter OpenWRT custom compile not working on latest

Wed Oct 07, 2009 10:59 am

With a bit of re-editing I got the the patch to work (attached, rename as .patch rather than .txt). Minor line number and formatting changes.

I'll admit haven't tested it yet .. it's still building.

This is with openwrt trunk from git.
You do not have the required permissions to view the files attached to this post.

Who is online

Users browsing this forum: No registered users and 5 guests