Community discussions

MikroTik App
 
meconiotronic
newbie
Topic Author
Posts: 30
Joined: Wed Mar 14, 2012 9:50 am

Help with ospf - mpls wisp public ip

Mon May 04, 2015 11:55 pm

Hi.

I have a small wisp network.

Ospf is running on every bst, they have loopback redoundancy for failover etc...Everything work fine

The scenario is:

pppoe servers<-->CCR<-->ApBST<-->StationBST... etc... ->Ap for clients <--> Clients
There is an eoip tunnel on every "Ap for clients" that is bridged to CCR.
pppoe <__EOIP__> Ap for clients <--> Clients

My question is: If i want add pppoe server on every "AP for clients" how i can bring up to them the public ip address without an eoip tunnel?

i have heard something about /32 network for this, someone can explain me how?

Now in some bst i have activated mpls and vpls is working, it could help?

what would be the best solution?

Thanks.
 
009hnoor
just joined
Posts: 2
Joined: Wed May 13, 2015 12:06 pm

Re: Help with ospf - mpls wisp public ip

Wed May 13, 2015 12:37 pm

i have heard something about /32 network for this, someone can explain me how?
 
User avatar
ZeroByte
Forum Guru
Forum Guru
Posts: 4047
Joined: Wed May 11, 2011 6:08 pm

Re: Help with ospf - mpls wisp public ip

Fri May 15, 2015 12:59 am

Now in some bst i have activated mpls and vpls is working, it could help?

what would be the best solution?

Thanks.
vpls is "super bridging" - think automatic EoIP.... or it is when using BGP-signaled vpls.

Anyway you can assign a static /32 per customer by putting the IP address in your RADIUS profile, or as the remote IP on the secret. (leave this blank in the profile)
In the profile, set local IP = loopback IP of AP

Make sure there is a network statement in the customer AP which includes the range where user IPs are selected from.
(if you have a /23 of public IP, you could just specify that entire range if you're using a flat area 0)

Whenever a customer attaches and receives a /32 from the AP, it's going to be added to the AP's routing table as an Active, Dynamic, Connected /32 route on interface pppoe-USERID, and since that /32 is a part of OSPF due to the network you added, it will be advertised to the rest of your network.


I built a quick proof-of-concept Mikrotik in GNS3 and connected a PPPoE client (r1) and a Cisco router as an OSPF neighbor (because it's faster for me to set up a Cisco router than a Mikrotik)

R1 --pppoe--> R2 ----- R3(cisco)

R2 has loopback IP 10.10.10.2/32 and R3 has 10.10.10.3/32
The link from R2 to R3 is 10.0.0.0/24 with R2 = 10.0.0.2 and R3 = 10.0.0.3
The PPPoE service assigns clients from pool1 (192.168.99.x)

Whenever R1 is active with R2, here's what R3 sees:
R3#show ip route ospf
     192.168.99.0/32 is subnetted, 1 subnets
O       192.168.99.254 [110/11] via 10.0.0.2, 00:01:29, FastEthernet0/0
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O       10.10.10.2/32 [110/11] via 10.0.0.2, 00:02:20, FastEthernet0/0
Here's the routing table on R2:
Flags: X - disabled, A - active, D - dynamic, 
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, 
B - blackhole, U - unreachable, P - prohibit 
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADo  0.0.0.0/0                          10.0.0.3                110
 1 ADC  10.0.0.0/24        10.0.0.2        ether3                    0
 2 ADC  10.1.1.0/24        10.1.1.2        ether1                    0
 3 ADC  10.10.10.2/32      10.10.10.2      bridge1                   0
 4 ADo  10.10.10.3/32                      10.0.0.3                110
 5 ADC  192.168.99.254/32  10.0.0.2        <pppoe-r1>                0
Here's the configuration of the PPPoE server:
# may/14/2015 21:43:15 by RouterOS 6.28
# software id = TWIQ-YM3K
#
/interface bridge
add name=bridge1
/ip pool
add name=pool1 ranges=192.168.99.1-192.168.99.254
/ppp profile
set 0 local-address=10.0.0.2 remote-address=pool1 use-ipv6=no use-mpls=no
/routing ospf instance
set [ find default=yes ] router-id=10.10.10.2
/interface pppoe-server server
add disabled=no interface=ether2 max-mru=1480 max-mtu=1480 mrru=1600 \
    service-name=service1
/ip address
add address=10.0.0.2/24 interface=ether3 network=10.0.0.0
add address=10.10.10.2/32 interface=bridge1 network=10.10.10.2
/ppp secret
add name=r1 password=r1 service=pppoe
/routing ospf interface
add interface=ether3 network-type=broadcast
add network-type=broadcast passive=yes
#note - see below about passive interfaces! <----- NOTE
/routing ospf network
add area=backbone network=10.0.0.0/24
add area=backbone network=10.10.10.0/24
add area=backbone network=192.168.0.0/16
The passive interface configuration keeps your router from sending hello packets on the PPPoE connections, which both prevents users from being able to join your OSPF and doing harm, and it cuts down on chatty packets that don't help anybody. When you set the default interface as passive, you must now go in and explicitly define your active ospf interfaces where you want adjacencies to form. In this case, I added ether3 because that's the interface that leads to my Cisco router.

This is very basic, and if you've gotten vpls working, certainly you should be able to figure out what the moving parts are in my example and apply them to your own network.

Good luck!

Who is online

Users browsing this forum: No registered users and 8 guests