It is possible in RouterOS and CRS switches.
So called hybrid VLAN port configuration is described in CRS Port Based VLAN example #2
http://wiki.mikrotik.com/wiki/Manual:CR ... Based_VLAN
Here is hybrid port example using RouterOS bridges and VLAN interfaces.
The setup is similar to CRS Port Based VLAN example #2:
//ether1 is Trunk port
//ether2 is Hybrid port with vlan200 untagged
//ether3 is Hybrid port with vlan300 untagged
//ether4 is Hybrid port with vlan400 untagged
/interface vlan
add name=ether1-vlan200 interface=ether1 vlan-id=200
add name=ether1-vlan300 interface=ether1 vlan-id=300
add name=ether1-vlan400 interface=ether1 vlan-id=400
add name=ether2-vlan300 interface=ether2 vlan-id=300
add name=ether2-vlan400 interface=ether2 vlan-id=400
add name=ether3-vlan200 interface=ether3 vlan-id=200
add name=ether3-vlan400 interface=ether3 vlan-id=400
add name=ether4-vlan200 interface=ether4 vlan-id=200
add name=ether4-vlan300 interface=ether4 vlan-id=300
/interface bridge
add name=bridge-vlan200
add name=bridge-vlan300
add name=bridge-vlan400
/interface bridge port
add bridge=bridge-vlan200 interface=ether1-vlan200
add bridge=bridge-vlan200 interface=ether2
add bridge=bridge-vlan200 interface=ether3-vlan200
add bridge=bridge-vlan200 interface=ether4-vlan200
add bridge=bridge-vlan300 interface=ether1-vlan300
add bridge=bridge-vlan300 interface=ether2-vlan300
add bridge=bridge-vlan300 interface=ether3
add bridge=bridge-vlan300 interface=ether4-vlan300
add bridge=bridge-vlan400 interface=ether1-vlan400
add bridge=bridge-vlan400 interface=ether2-vlan400
add bridge=bridge-vlan400 interface=ether3-vlan400
add bridge=bridge-vlan400 interface=ether4