Community discussions

 
User avatar
IanD
just joined
Topic Author
Posts: 5
Joined: Tue Jun 28, 2016 4:36 am

Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Tue Jun 28, 2016 6:22 am

Hi All,
 
I have been able to get my hands on a Sierra MC7430 4g LTE-A mini-PCI-e Modem and make it detectable in a RB953GS.
It seems LTE is not supported at this time, so PPP it is. (bring on ROS V7)
 
Issue:
When the PPP connection is configured and enabled, it successfully connects and receives an IP from the Telco.
5 seconds after the successful connection with the telco, the PPP interface disconnects for approximately 1 second then reconnects – a connect/disconnect process then repeats.

Note: While the PPP interface is connected I can ping sites such as Google DNS (8.8.8.8) and resolve DNS.
 
Could somebody please help shed some light on what could be causing the PPP interface to disconnect?
Or, is it a modem config I am missing?

The modem appears to be successfully connected, routes are created and the PPP 'looks' fine to me... (not a PPP negotiation expert here)
 
Log
Note: IP addressed below are dynamic address from the telco (Telstra)
---------- start ----------
Jan/02/1970 01:34:12 async,ppp,info ppp-out1: initializing...
Jan/02/1970 01:34:12 async,ppp,info ppp-out1: reseting link...
Jan/02/1970 01:34:13 async,debug usb2:2: sent ATH
Jan/02/1970 01:34:13 async,debug usb2:2: rcvd OK
Jan/02/1970 01:34:13 async,ppp,info ppp-out1: initializing modem...
Jan/02/1970 01:34:14 async,ppp,info ppp-out1: dialing out...
Jan/02/1970 01:34:14 async,debug usb2:2: sent AT+CGDCONT=1,"IP","telstra.internet"
Jan/02/1970 01:34:14 async,debug usb2:2: rcvd OK
Jan/02/1970 01:34:14 async,debug usb2:2: sent ATDT*99***1#
Jan/02/1970 01:34:14 async,debug usb2:2: rcvd CONNECT 150000000
Jan/02/1970 01:34:14 async,ppp,debug ppp-out1: LCP lowerup
Jan/02/1970 01:34:14 async,ppp,debug,packet  ppp-out1: sent LCP ConfReq id=0x2
Jan/02/1970 01:34:14 async,ppp,debug,packet    <magic 0x29df159b>
Jan/02/1970 01:34:14 async,ppp,debug,packet    <pcomp>
Jan/02/1970 01:34:14 async,ppp,debug,packet    <accomp>
Jan/02/1970 01:34:14 async,ppp,debug ppp-out1: LCP open
Jan/02/1970 01:34:14 async,ppp,debug,packet  ppp-out1: rcvd LCP ConfReq id=0xbb
Jan/02/1970 01:34:14 async,ppp,debug,packet    <asyncmap 0x0>
Jan/02/1970 01:34:14 async,ppp,debug,packet    <magic 0x229a052>
Jan/02/1970 01:34:14 async,ppp,debug,packet    <pcomp>
Jan/02/1970 01:34:14 async,ppp,debug,packet    <accomp>
Jan/02/1970 01:34:14 async,ppp,debug,packet    <auth  chap>
Jan/02/1970 01:34:14 async,ppp,debug,packet  ppp-out1: sent LCP ConfAck id=0xbb
Jan/02/1970 01:34:14 async,ppp,debug,packet    <asyncmap 0x0>
Jan/02/1970 01:34:14 async,ppp,debug,packet    <magic 0x229a052>
Jan/02/1970 01:34:14 async,ppp,debug,packet    <pcomp>
Jan/02/1970 01:34:14 async,ppp,debug,packet    <accomp>
Jan/02/1970 01:34:14 async,ppp,debug,packet    <auth  chap>
Jan/02/1970 01:34:14 async,ppp,debug,packet  ppp-out1: rcvd LCP ConfAck id=0x2
Jan/02/1970 01:34:14 async,ppp,debug,packet    <magic 0x29df159b>
Jan/02/1970 01:34:14 async,ppp,debug,packet    <pcomp>
Jan/02/1970 01:34:14 async,ppp,debug,packet    <accomp>
Jan/02/1970 01:34:14 async,ppp,debug ppp-out1: LCP opened
Jan/02/1970 01:34:14 async,ppp,debug,packet  ppp-out1: rcvd LCP DiscReq id=0xbc
Jan/02/1970 01:34:14 async,ppp,debug,packet     <magic 0x229a052>
Jan/02/1970 01:34:14 async,ppp,debug,packet  ppp-out1: rcvd CHAP Challenge id=0x1
Jan/02/1970 01:34:14 async,ppp,debug,packet     <challenge len=16>
Jan/02/1970 01:34:14 async,ppp,debug,packet     <name UMTS_CHAP_SRVR>
Jan/02/1970 01:34:14 async,ppp,debug,packet  ppp-out1: sent CHAP Response id=0x1
Jan/02/1970 01:34:14 async,ppp,debug,packet     <response len=16>
Jan/02/1970 01:34:14 async,ppp,debug,packet  ppp-out1: rcvd CHAP Success id=0x1
Jan/02/1970 01:34:14 async,ppp,info ppp-out1: authenticated
Jan/02/1970 01:34:14 async,ppp,debug ppp-out1: IPCP lowerup
Jan/02/1970 01:34:14 async,ppp,debug,packet  ppp-out1: sent IPCP ConfReq id=0x3
Jan/02/1970 01:34:14 async,ppp,debug,packet     <addr 0.0.0.0>
Jan/02/1970 01:34:14 async,ppp,debug,packet     <ms-dns 0.0.0.0>
Jan/02/1970 01:34:14 async,ppp,debug,packet     <ms-dns 0.0.0.0>
Jan/02/1970 01:34:14 async,ppp,debug ppp-out1: IPCP open
Jan/02/1970 01:34:14 async,ppp,debug ppp-out1: IPV6CP open
Jan/02/1970 01:34:14 async,ppp,debug ppp-out1: MPLSCP lowerup
Jan/02/1970 01:34:14 async,ppp,debug,packet  ppp-out1: sent MPLSCP ConfReq id=0x2
Jan/02/1970 01:34:14 async,ppp,debug ppp-out1: MPLSCP open
Jan/02/1970 01:34:14 async,ppp,debug ppp-out1: BCP open
Jan/02/1970 01:34:14 async,ppp,debug ppp-out1: CCP lowerup
Jan/02/1970 01:34:14 async,ppp,debug ppp-out1: CCP open
Jan/02/1970 01:34:14 async,ppp,debug,packet  ppp-out1: rcvd LCP ProtRej id=0xbd
Jan/02/1970 01:34:14 async,ppp,debug,packet      82 81 01 02 00 04
Jan/02/1970 01:34:14 async,ppp,debug,packet  ppp-out1: rcvd IPCP ConfReq id=0x8
Jan/02/1970 01:34:14 async,ppp,debug,packet  ppp-out1: sent IPCP ConfNak id=0x8
Jan/02/1970 01:34:14 async,ppp,debug,packet     <addr 0.0.0.0>
Jan/02/1970 01:34:14 async,ppp,debug,packet  ppp-out1: rcvd IPCP ConfNak id=0x3
Jan/02/1970 01:34:14 async,ppp,debug,packet     <addr 22.230.114.53>
Jan/02/1970 01:34:14 async,ppp,debug,packet     <ms-dns 10.4.27.70>
Jan/02/1970 01:34:14 async,ppp,debug,packet     <ms-dns 10.4.58.204>
Jan/02/1970 01:34:14 async,ppp,debug,packet  ppp-out1: sent IPCP ConfReq id=0x4
Jan/02/1970 01:34:14 async,ppp,debug,packet     <addr 22.230.114.53>
Jan/02/1970 01:34:14 async,ppp,debug,packet     <ms-dns 10.4.27.70>
Jan/02/1970 01:34:14 async,ppp,debug,packet     <ms-dns 10.4.58.204>
Jan/02/1970 01:34:14 async,ppp,debug,packet  ppp-out1: rcvd IPCP ConfReq id=0x9
Jan/02/1970 01:34:14 async,ppp,debug,packet  ppp-out1: sent IPCP ConfAck id=0x9
Jan/02/1970 01:34:14 async,ppp,debug,packet  ppp-out1: rcvd IPCP ConfAck id=0x4
Jan/02/1970 01:34:14 async,ppp,debug,packet     <addr 22.230.114.53>
Jan/02/1970 01:34:14 async,ppp,debug,packet     <ms-dns 10.4.27.70>
Jan/02/1970 01:34:14 async,ppp,debug,packet     <ms-dns 10.4.58.204>
Jan/02/1970 01:34:14 async,ppp,debug ppp-out1: IPCP opened
Jan/02/1970 01:34:14 async,ppp,info ppp-out1: could not determine remote address, using 10.112.112.144
Jan/02/1970 01:34:14 async,ppp,info ppp-out1: connected
Jan/02/1970 01:34:14 system,info item added
Jan/02/1970 01:34:14 system,info item added
Jan/02/1970 01:34:14 route,debug,event Interface change
Jan/02/1970 01:34:14 route,debug,event     interface=ppp-out1
Jan/02/1970 01:34:14 route,debug,event     status=UP,RUNNING
Jan/02/1970 01:34:14 route,debug,event     mtu=1500
Jan/02/1970 01:34:14 route,debug,event Interface change
Jan/02/1970 01:34:14 route,debug,event     interface=ppp-out1
Jan/02/1970 01:34:14 route,debug,event     status=UP,RUNNING
Jan/02/1970 01:34:14 route,debug,event     mtu=1500
Jan/02/1970 01:34:14 route,debug,calc Begin calculation
Jan/02/1970 01:34:14 route,debug,event Link up
Jan/02/1970 01:34:14 route,debug,event     interface=ppp-out1
Jan/02/1970 01:34:14 route,debug,event Update
Jan/02/1970 01:34:14 route,debug,event     interface=ppp-out1
Jan/02/1970 01:34:14 route,debug,event Added candidate route
Jan/02/1970 01:34:14 route,debug,event     dst-prefix=0.0.0.0/0
Jan/02/1970 01:34:14 route,debug,event     attributes
Jan/02/1970 01:34:14 route,debug,event         protocol=DYNAMIC
Jan/02/1970 01:34:14 route,debug,event         distance=0
Jan/02/1970 01:34:14 route,debug,event         scope=30
Jan/02/1970 01:34:14 route,debug,event         target-scope=10
Jan/02/1970 01:34:14 route,debug,event         next-hop= address=10.112.112.144
Jan/02/1970 01:34:14 route,debug,event         origin-type=DYNAMIC
Jan/02/1970 01:34:14 route,debug,calc End calculation
Jan/02/1970 01:34:14 route,debug Begin redistribution
Jan/02/1970 01:34:14 route,debug Accept  0.0.0.0/0
Jan/02/1970 01:34:14 route,debug Commit prefix 0.0.0.0/0
Jan/02/1970 01:34:14 route,debug End redistribution
Jan/02/1970 01:34:14 route,debug,calc Begin calculation
Jan/02/1970 01:34:14 route,debug,event Address added or changed
Jan/02/1970 01:34:14 route,debug,event     local=22.230.114.53
Jan/02/1970 01:34:14 route,debug,event     network=10.112.112.144/32
Jan/02/1970 01:34:14 route,debug,event     interface=ppp-out1
Jan/02/1970 01:34:14 route,debug,event Added candidate route
Jan/02/1970 01:34:14 route,debug,event     dst-prefix=10.112.112.144/32
Jan/02/1970 01:34:14 route,debug,event     attributes
Jan/02/1970 01:34:14 route,debug,event         protocol=CONNECT
Jan/02/1970 01:34:14 route,debug,event         distance=0
Jan/02/1970 01:34:14 route,debug,event         scope=10
Jan/02/1970 01:34:14 route,debug,event         target-scope=0
Jan/02/1970 01:34:14 route,debug,event         connected-net= address=22.230.114.53/32 interface=ppp-out1
Jan/02/1970 01:34:14 route,debug,event         routing-mark=main
Jan/02/1970 01:34:14 route,debug,event         table=main
Jan/02/1970 01:34:14 route,debug,event         origin-type=CONNECTED
Jan/02/1970 01:34:14 route,debug,calc Tag next hop for recalculation
Jan/02/1970 01:34:14 route,debug,calc     address=10.112.112.144
Jan/02/1970 01:34:14 route,debug,calc Select route
Jan/02/1970 01:34:14 route,debug,calc     dst-address=10.112.112.144/32
Jan/02/1970 01:34:14 route,debug,calc     attributes
Jan/02/1970 01:34:14 route,debug,calc         protocol=CONNECT
Jan/02/1970 01:34:14 route,debug,calc         distance=0
Jan/02/1970 01:34:14 route,debug,calc         scope=10
Jan/02/1970 01:34:14 route,debug,calc         target-scope=0
Jan/02/1970 01:34:14 route,debug,calc         connected-net= address=22.230.114.53/32 interface=ppp-out1
Jan/02/1970 01:34:14 route,debug,calc         routing-mark=main
Jan/02/1970 01:34:14 route,debug,calc         table=main
Jan/02/1970 01:34:14 route,debug,calc         origin-type=CONNECTED
Jan/02/1970 01:34:14 route,debug,calc Next hop resolved
Jan/02/1970 01:34:14 route,debug,calc     address=10.112.112.144
Jan/02/1970 01:34:14 route,debug,calc     route=10.112.112.144/32
Jan/02/1970 01:34:14 route,debug,calc     immediate-address=10.112.112.144
Jan/02/1970 01:34:14 route,debug,calc     interface=ppp-out1
Jan/02/1970 01:34:14 route,debug,calc Select route
Jan/02/1970 01:34:14 route,debug,calc     dst-address=0.0.0.0/0
Jan/02/1970 01:34:14 route,debug,calc     attributes
Jan/02/1970 01:34:14 route,debug,calc         protocol=DYNAMIC
Jan/02/1970 01:34:14 route,debug,calc         distance=0
Jan/02/1970 01:34:14 route,debug,calc         scope=30
Jan/02/1970 01:34:14 route,debug,calc         target-scope=10
Jan/02/1970 01:34:14 route,debug,calc         next-hop= address=10.112.112.144
Jan/02/1970 01:34:14 route,debug,calc         origin-type=DYNAMIC
Jan/02/1970 01:34:14 route,debug,calc End calculation
Jan/02/1970 01:34:14 route,debug Begin redistribution
Jan/02/1970 01:34:14 route,debug Accept add 10.112.112.144/32
Jan/02/1970 01:34:14 route,debug Accept add 0.0.0.0/0
Jan/02/1970 01:34:14 route,debug Commit prefix 0.0.0.0/0
Jan/02/1970 01:34:14 route,debug Commit prefix 10.112.112.144/32
Jan/02/1970 01:34:14 route,debug End redistribution
Jan/02/1970 01:34:19 async,ppp,debug ppp-out1: LCP lowerdown
Jan/02/1970 01:34:19 async,ppp,debug ppp-out1: LCP closed
Jan/02/1970 01:34:19 async,ppp,debug ppp-out1: CCP lowerdown
Jan/02/1970 01:34:19 async,ppp,debug ppp-out1: BCP lowerdown
Jan/02/1970 01:34:19 async,ppp,debug ppp-out1: BCP down event in starting state
Jan/02/1970 01:34:19 async,ppp,debug ppp-out1: IPCP lowerdown
Jan/02/1970 01:34:19 async,ppp,debug ppp-out1: IPCP closed
Jan/02/1970 01:34:19 async,ppp,debug ppp-out1: IPV6CP lowerdown
Jan/02/1970 01:34:19 async,ppp,debug ppp-out1: IPV6CP down event in starting state
Jan/02/1970 01:34:19 async,ppp,debug ppp-out1: MPLSCP lowerdown
Jan/02/1970 01:34:19 async,ppp,info ppp-out1: terminating... - hungup
Jan/02/1970 01:34:19 route,debug,event Interface change
Jan/02/1970 01:34:19 route,debug,event     interface=ppp-out1
Jan/02/1970 01:34:19 route,debug,event     status=DOWN
Jan/02/1970 01:34:19 route,debug,event     mtu=1500
Jan/02/1970 01:34:19 route,debug,event Interface change
Jan/02/1970 01:34:19 route,debug,event     interface=ppp-out1
Jan/02/1970 01:34:19 route,debug,event     status=DOWN
Jan/02/1970 01:34:19 route,debug,event     mtu=1500
Jan/02/1970 01:34:19 async,ppp,debug ppp-out1: LCP lowerdown
Jan/02/1970 01:34:19 async,ppp,debug ppp-out1: LCP down event in starting state
Jan/02/1970 01:34:19 async,ppp,info ppp-out1: disconnected
Jan/02/1970 01:34:19 async,ppp,info ppp-out1: initializing...
Jan/02/1970 01:34:19 async,ppp,info ppp-out1: reseting link...
Jan/02/1970 01:34:19 route,debug,event Remove interface ppp-out1
Jan/02/1970 01:34:19 system,info item removed
Jan/02/1970 01:34:19 system,info item removed
Jan/02/1970 01:34:19 route,debug,calc Begin calculation
Jan/02/1970 01:34:19 route,debug,event Removed route
Jan/02/1970 01:34:19 route,debug,event     state=ACTIVE
Jan/02/1970 01:34:19 route,debug,event     dst-prefix=10.112.112.144/32
Jan/02/1970 01:34:19 route,debug,event     attributes
Jan/02/1970 01:34:19 route,debug,event         protocol=CONNECT
Jan/02/1970 01:34:19 route,debug,event         distance=0
Jan/02/1970 01:34:19 route,debug,event         scope=10
Jan/02/1970 01:34:19 route,debug,event         target-scope=0
Jan/02/1970 01:34:19 route,debug,event         connected-net= address=22.230.114.53/32 interface=ppp-out1
Jan/02/1970 01:34:19 route,debug,event         routing-mark=main
Jan/02/1970 01:34:19 route,debug,event         table=main
Jan/02/1970 01:34:19 route,debug,event         origin-type=CONNECTED
Jan/02/1970 01:34:19 route,debug,calc Tag next hop for recalculation
Jan/02/1970 01:34:19 route,debug,calc     address=10.112.112.144
Jan/02/1970 01:34:19 route,debug,event Removed route
Jan/02/1970 01:34:19 route,debug,event     state=ACTIVE
Jan/02/1970 01:34:19 route,debug,event     dst-prefix=0.0.0.0/0
Jan/02/1970 01:34:19 route,debug,event     attributes
Jan/02/1970 01:34:19 route,debug,event         protocol=DYNAMIC
Jan/02/1970 01:34:19 route,debug,event         distance=0
Jan/02/1970 01:34:19 route,debug,event         scope=30
Jan/02/1970 01:34:19 route,debug,event         target-scope=10
Jan/02/1970 01:34:19 route,debug,event         next-hop= address=10.112.112.144
Jan/02/1970 01:34:19 route,debug,event         origin-type=DYNAMIC
Jan/02/1970 01:34:19 route,debug,calc Tag next hop for recalculation
Jan/02/1970 01:34:19 route,debug,calc     address=10.112.112.144
Jan/02/1970 01:34:19 route,debug,calc Tag next hop for recalculation
Jan/02/1970 01:34:19 route,debug,calc     address=10.112.112.144
Jan/02/1970 01:34:19 route,debug,calc End calculation
Jan/02/1970 01:34:19 route,debug Begin redistribution
Jan/02/1970 01:34:19 route,debug Accept withdraw 0.0.0.0/0
Jan/02/1970 01:34:19 route,debug Accept withdraw 10.112.112.144/32
Jan/02/1970 01:34:19 route,debug Commit prefix 0.0.0.0/0
Jan/02/1970 01:34:19 route,debug Commit prefix 10.112.112.144/32
Jan/02/1970 01:34:19 route,debug End redistribution
Jan/02/1970 01:34:19 route,debug,calc Begin calculation
Jan/02/1970 01:34:19 route,debug,event Address removed
Jan/02/1970 01:34:19 route,debug,event     network=10.112.112.144/32
Jan/02/1970 01:34:19 route,debug,calc End calculation
---------- repeat ----------
Jan/02/1970 01:34:20 async,debug usb2:2: sent ATH
Jan/02/1970 01:34:20 async,debug usb2:2: rcvd OK
Jan/02/1970 01:34:20 async,ppp,info ppp-out1: initializing modem...
Jan/02/1970 01:34:21 async,ppp,info ppp-out1: dialing out...
Jan/02/1970 01:34:21 async,debug usb2:2: sent AT+CGDCONT=1,"IP","telstra.internet"

Hardware:
Routerboard:     953GS 5HPnT - ROS 6.35.4 current (Note: ROS < 6.35 fails to create/see the USB port)
4G Modem:        Sierra MC7430 - Firmware: SWI9X30C_02.14.03.00     PRI: 002.013_000, Telstra carrier provisioning file
                              Pins 23, 25, 31 and 33 covered by tape (to stop USB3 <> PCIe interface negotiation confusion..?) Not recommended for production environments
SIM card:             Activated Telstra SIM (tested working in 320U)
 
Configuration:
All configuration has been done on a freshly reset RB953.
Current configuration is essentially the same as our Sierra 320 USB modems, except for the Data Channel and the USB port mode.
* Would be nice to be able to change one of the channels to enable scripts to pull modem stats from the info channel, while PPP connected

Modem
There are no specific settings configured - all default

Router
[admin@MikroTik] > export                           
# jan/02/1970 03:57:32 by RouterOS 6.35.4
# software id = WJ6C-EF5H
#

/port
set 1 name=usb2
/interface ppp-client
add apn=telstra.internet data-channel=2 dial-on-demand=no info-channel=2 name=ppp-out1 port=usb2
/ip address
add address=192.168.88.1/24 interface=ether1 network=192.168.88.0
/ip firewall nat
add action=masquerade chain=srcnat log=yes log-prefix="MASQ - " out-interface=ppp-out1
/system leds
set 0 interface=wlan1
add interface=wlan2 leds=wlan2_signal1-led,wlan2_signal2-led,wlan2_signal3-led,wlan2_signal4-led,wlan2_signal5-led type=wireless-signal-strength
add interface=wlan2 leds=wlan2_tx-led type=interface-transmit
add interface=wlan2 leds=wlan2_rx-led type=interface-receive
/system logging
add action=disk topics=!ups
/system routerboard settings
set cpu-frequency=720MHz protected-routerboot=disabled
[admin@MikroTik] 
         
USB
/system routerboard usb print 
  type: mini-PCIe


Port
This setting does not seem to matter whether it is on or off - same connect/disconnect issue
[admin@MikroTik] /port firmware print 
              directory: firmware
  ignore-directip-modem: yes
[admin@MikroTik] 
PPP Info
/interface ppp-client info ppp-out1 
       modem-status: call in progress
         pin-status: no password required
      functionality: full
       manufacturer: Sierra Wireless, Incorporated
              model: MC7430
           revision: SWI9X30C_02.14.03.00 r6134 CARMD-EV-FRMWR2 2016/03/28 14:34:14
      serial-number: 359074060086602
   current-operator: Telstra Mobile Telstra (cellid 7f68a02)
  access-technology: Evolved 3G (LTE)
     signal-strengh: -53 dBm
   frame-error-rate: n/a
I hope I haven't missed anything... Let me know and I will add it asap

If we can nut this out, I will post a "Sierra MC7430 4g LTE-A mini-PCI-e Modem Configuration" topic for anybody interested.

Thanks
Ian D
 
kristaps
Member Candidate
Member Candidate
Posts: 272
Joined: Mon Jan 27, 2014 1:37 pm

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Tue Jun 28, 2016 2:10 pm

Hi could you please provide with supout.rif and send it to support@mikrotik.com?
 
User avatar
IanD
just joined
Topic Author
Posts: 5
Joined: Tue Jun 28, 2016 4:36 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Tue Jun 28, 2016 4:30 pm

Hi kristaps,

Sure, I have sent a SUPOUT.rif to support - Ticket#201606286600057

supout.rif attached

Thanks
Ian D
 
wenasong
just joined
Posts: 20
Joined: Thu Jul 10, 2014 6:54 pm

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Wed Jul 13, 2016 9:22 am

Same problem happened to me. Just gotten MC7430 too, thinking to replace the old MC7710 in our boards.

With RB912 and RB953, can get DNS and IP but disconnects after a few seconds.
With RB922, not connecting at all, PPP DEBUG, says nothing informative, just initializing...
 
User avatar
IanD
just joined
Topic Author
Posts: 5
Joined: Tue Jun 28, 2016 4:36 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Thu Jul 14, 2016 4:04 am

 Hi wenasong,

Thanks for the input. The MC7430 is a great Modem, on paper.
I woke up this morning vowing to update this thread, thanks for the reminder... Other elements of this project have been consuming most of my time.

wenasong: Did you have to cover the USB3 pins to get the MC7430 working in the RB912 (or RB953)?

I have been working on this issue with kristaps from MikroTik support. He has asked me to see if I can replicate the issue in Linux and send him some more logs.

Setup:
HP EliteBook 8440p
Ubuntu 16.04 LTS (all updates installed)
wvdial (PPP dialer)
USB to Mini PCIe adapter (http://www.m2mconnectivity.com.au/brand ... press-card)
Sierra AirPrime  MC7430

Result:
I am able to replicate the connection issue however the time between the last ping and reconnect can be between 90-120 seconds.

1) Start Connection - successful
2) 4-5 pings & dns resolution -  As you can see not much time to do any thorough testing
3) No connection for 90-120 seconds
And repeat

Logs sent to Mikrotik

MikroTik support:
Last update from MikroTik support : "It Looks There  is FW issue in sierra card"

MikroTik have not yet responded to my query on if they are going to, or want me to, log a bug with Sierra.
I may have to do this through the Australian Supplier (M2M connectivity).

Conclusion:
I am going to assume that MikroTik will not spend to much more time on this issue. When you think about it, that is probably fair. The issue doesn't seem to be with RouterOS and I assume there is no config under the hood of RouterOS that they can tweak to get a stable connection. Further testing under linux may prove this wrong..

I feel there may be another Sierra firmware issue that is stopping the MC7430 from falling back to USB2 when it fails to negotiate a connection on its USB3 port - I will mention this too.
I have read posts on the internet that say the HOST device is responsible for negotiating the comms to the PCI-e device, not the PCI-e device itself (this sounds reasonable to me..). If this is the case, MikroTik may have a PCIe driver / hardware incompatibility negotiating the comms on pins 23, 25, 31 and 33 for USB3 WLAN devices...?

I will place a request on the Sierra Dev forums to see if anybody has replicated this issue in Linux. Somebody smarter than I may know what the issue is or have a fix that I can pass on to MikroTik to try.

Thanks
IanD

Disclaimer: I do not work for M2M connectivity, they are my supplier.
 
helipos
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Sat Jun 25, 2016 11:32 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Mon Dec 05, 2016 3:42 am

Hi IanD and Wenasong, Just wondering if either of you managed to get the MC7430's working?
 
wenasong
just joined
Posts: 20
Joined: Thu Jul 10, 2014 6:54 pm

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Mon Dec 05, 2016 4:40 am

Hi IanD and Wenasong, Just wondering if either of you managed to get the MC7430's working?
Nope, sticking with MC7710, most stable after all.
 
helipos
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Sat Jun 25, 2016 11:32 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Mon Dec 05, 2016 11:09 am

Nope, sticking with MC7710, most stable after all.
True but I need band 28. Anyway I've bought one so I'll see how I go.
If I make any real progress I'll keep updating here.
 
wenasong
just joined
Posts: 20
Joined: Thu Jul 10, 2014 6:54 pm

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Thu Dec 08, 2016 8:58 am

Nope, sticking with MC7710, most stable after all.
True but I need band 28. Anyway I've bought one so I'll see how I go.
If I make any real progress I'll keep updating here.
Actually all Sierra Wireless board without DIP Firmware, (DirectIP) won't be able to work properly. I suggest you go for Huawei Modem 909 something.
 
helipos
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Sat Jun 25, 2016 11:32 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Thu Dec 22, 2016 11:10 am

Well I got the little bastard to work.

Correction I think there are at least two things.
First if the modem get an IP and then says is cant resolve remote address or some BS like that then flash the Telstra firmware on it from the Sierra website.
I think mine needed that since it was an ebay special.

If it simply disconnects like IanD described It might need the USB3.0 pins taped over ( I'm still testing)
Untitled.png
This is on a USB expansion board with USB3.0 pins taped as described http://forum.mikrotik.com/viewtopic.php?t=110367 Post #11
You do not have the required permissions to view the files attached to this post.
 
helipos
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Sat Jun 25, 2016 11:32 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Fri Dec 23, 2016 9:04 am

I did a bit more testing today which told me this much.

It's pretty flakey, ie when the modem wants to fart around it does. When it wants to work it works well.
The only real difference between Ian D's setup and mine would be a more recent firmware for the modem "Telstra SWI9X30C_02.20.03.01 002.019_001"
I've got my USB3.0 pins taped and without that I cannot get it working at all.

I have currently got it working in the USB carrier board (can't think of a better name) on a RB952 since I bricked my 953.
I have not been able to get just the MC7430 to detect in the Mini-PCI-e ports thus the USB carrier board.

I think the more useful things to know would be how/if you can change the USB port for the info channel.
I also suspect the band numbers have been rearranged in the Telstra firmware.
Last edited by helipos on Fri Dec 23, 2016 10:48 am, edited 1 time in total.
 
helipos
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Sat Jun 25, 2016 11:32 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Fri Dec 23, 2016 9:33 am

15:32:41 async,ppp,info ppp-out2: terminating... - hungup 
15:32:41 async,ppp,info ppp-out2: disconnected 
15:32:41 async,ppp,info ppp-out2: initializing... 
15:32:41 async,ppp,info ppp-out2: reseting link... 
15:32:41 system,info item removed 
15:32:41 system,info item removed 
15:32:42 async,ppp,info ppp-out2: initializing modem... 
15:32:43 async,ppp,info ppp-out2: dialing out... 
15:32:43 async,ppp,info ppp-out2: authenticated 
15:32:43 async,ppp,info ppp-out2: could not determine remote address, using 10.112.112.233 
15:32:43 async,ppp,info ppp-out2: connected 
15:32:43 system,info item added 
15:32:43 system,info item added 
15:32:48 async,ppp,info ppp-out2: terminating... - hungup 
15:32:48 async,ppp,info ppp-out2: disconnected 
15:32:48 async,ppp,info ppp-out2: initializing... 
15:32:48 async,ppp,info ppp-out2: reseting link... 
15:32:48 system,info item removed 
15:32:48 system,info item removed 
15:32:49 async,ppp,info ppp-out2: initializing modem... 
15:32:50 async,ppp,info ppp-out2: dialing out... 
15:32:50 async,ppp,info ppp-out2: authenticated 
15:32:50 async,ppp,info ppp-out2: could not determine remote address, using 10.112.112.234 
15:32:50 async,ppp,info ppp-out2: connected 
15:32:50 system,info item added 
15:32:50 system,info item added 
When getting this rubbish I've found I can reliably get it to connect if I remove the modem from the USB carrier board, wait 5 and plug it back in.
 
helipos
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Sat Jun 25, 2016 11:32 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Thu Jan 26, 2017 9:37 am

Ok so I've done a fair bit of testing and have concluded the following.
I need someone who really understands PPP :D

Here are some logs from a "failing" connection which fails about every 5 seconds repeatedly.
Fresh reboot, interface enabled.

14:41:56 system,info,account user admin logged in from 10.0.0.200 via telnet 
14:42:25 async,ppp,info ppp-out1: initializing... 
14:42:25 async,ppp,info ppp-out1: reseting link... 
14:42:25 system,info device changed by admin 
14:42:26 async,ppp,info ppp-out1: initializing modem... 
14:42:27 async,ppp,info ppp-out1: dialing out... 
14:42:27 async,ppp,debug ppp-out1: LCP lowerup 
14:42:27 async,ppp,debug ppp-out1: LCP open 
14:42:27 async,ppp,debug,packet  ppp-out1: sent LCP ConfReq id=0x1 
14:42:27 async,ppp,debug,packet    <magic 0x62a10c2c> 
14:42:27 async,ppp,debug,packet    <pcomp> 
14:42:27 async,ppp,debug,packet    <accomp> 
14:42:27 async,ppp,debug,packet  ppp-out1: rcvd LCP ConfReq id=0x9 
14:42:27 async,ppp,debug,packet    <asyncmap 0x0> 
14:42:27 async,ppp,debug,packet    <magic 0x4c052c01> 
14:42:27 async,ppp,debug,packet    <pcomp> 
14:42:27 async,ppp,debug,packet    <accomp> 
14:42:27 async,ppp,debug,packet    <auth  chap> 
14:42:27 async,ppp,debug,packet  ppp-out1: sent LCP ConfAck id=0x9 
14:42:27 async,ppp,debug,packet    <asyncmap 0x0> 
14:42:27 async,ppp,debug,packet    <magic 0x4c052c01> 
14:42:27 async,ppp,debug,packet    <pcomp> 
14:42:27 async,ppp,debug,packet    <accomp> 
14:42:27 async,ppp,debug,packet    <auth  chap> 
14:42:27 async,ppp,debug,packet  ppp-out1: rcvd LCP ConfAck id=0x1 
14:42:27 async,ppp,debug,packet    <magic 0x62a10c2c> 
14:42:27 async,ppp,debug,packet    <pcomp> 
14:42:27 async,ppp,debug,packet    <accomp> 
14:42:27 async,ppp,debug ppp-out1: LCP opened 
14:42:27 async,ppp,debug,packet  ppp-out1: rcvd LCP DiscReq id=0xa 
14:42:27 async,ppp,debug,packet     <magic 0x4c052c01> 
14:42:27 async,ppp,debug,packet  ppp-out1: rcvd CHAP Challenge id=0x1 
14:42:27 async,ppp,debug,packet     <challenge len=16> 
14:42:27 async,ppp,debug,packet     <name UMTS_CHAP_SRVR> 
14:42:27 async,ppp,debug,packet  ppp-out1: sent CHAP Response id=0x1 
14:42:27 async,ppp,debug,packet     <response len=16> 
14:42:27 async,ppp,debug,packet  ppp-out1: rcvd CHAP Success id=0x1 
14:42:27 async,ppp,info ppp-out1: authenticated 
14:42:27 async,ppp,debug ppp-out1: IPCP lowerup 
14:42:27 async,ppp,debug ppp-out1: IPCP open 
14:42:27 async,ppp,debug,packet  ppp-out1: sent IPCP ConfReq id=0x1 
14:42:27 async,ppp,debug,packet     <addr 0.0.0.0> 
14:42:27 async,ppp,debug,packet     <ms-dns 0.0.0.0> 
14:42:27 async,ppp,debug,packet     <ms-dns 0.0.0.0> 
14:42:27 async,ppp,debug ppp-out1: IPV6CP open 
14:42:27 async,ppp,debug ppp-out1: MPLSCP lowerup 
14:42:27 async,ppp,debug ppp-out1: MPLSCP open 
14:42:27 async,ppp,debug,packet  ppp-out1: sent MPLSCP ConfReq id=0x1 
14:42:27 async,ppp,debug ppp-out1: BCP open 
14:42:27 async,ppp,debug ppp-out1: CCP lowerup 
14:42:27 async,ppp,debug ppp-out1: CCP open 
14:42:27 async,ppp,debug,packet  ppp-out1: rcvd LCP ProtRej id=0xb 
14:42:27 async,ppp,debug,packet      82 81 01 01 00 04 
14:42:27 async,ppp,debug,packet  ppp-out1: rcvd IPCP ConfReq id=0x6 
14:42:27 async,ppp,debug,packet  ppp-out1: sent IPCP ConfNak id=0x6 
14:42:27 async,ppp,debug,packet     <addr 0.0.0.0> 
14:42:27 async,ppp,debug,packet  ppp-out1: rcvd IPCP ConfNak id=0x1 
14:42:27 async,ppp,debug,packet     <addr 10.106.8.75> 
14:42:27 async,ppp,debug,packet     <ms-dns 10.5.80.241> 
14:42:27 async,ppp,debug,packet     <ms-dns 10.5.68.232> 
14:42:27 async,ppp,debug,packet  ppp-out1: sent IPCP ConfReq id=0x2 
14:42:27 async,ppp,debug,packet     <addr 10.106.8.75> 
14:42:27 async,ppp,debug,packet     <ms-dns 10.5.80.241> 
14:42:27 async,ppp,debug,packet     <ms-dns 10.5.68.232> 
14:42:27 async,ppp,debug,packet  ppp-out1: rcvd IPCP ConfReq id=0x7 
14:42:27 async,ppp,debug,packet  ppp-out1: sent IPCP ConfAck id=0x7 
14:42:27 async,ppp,debug,packet  ppp-out1: rcvd IPCP ConfAck id=0x2 
14:42:27 async,ppp,debug,packet     <addr 10.106.8.75> 
14:42:27 async,ppp,debug,packet     <ms-dns 10.5.80.241> 
14:42:27 async,ppp,debug,packet     <ms-dns 10.5.68.232> 
14:42:27 async,ppp,debug ppp-out1: IPCP opened 
14:42:27 async,ppp,info ppp-out1: could not determine remote address, using 10.112.112.124 
14:42:27 async,ppp,info ppp-out1: connected 
14:42:27 system,info item added 
14:42:27 system,info item added 
14:42:32 async,ppp,debug ppp-out1: LCP lowerdown 
14:42:32 async,ppp,debug ppp-out1: LCP closed 
14:42:32 async,ppp,debug ppp-out1: CCP lowerdown 
14:42:32 async,ppp,debug ppp-out1: BCP lowerdown 
14:42:32 async,ppp,debug ppp-out1: BCP down event in starting state 
14:42:32 async,ppp,debug ppp-out1: IPCP lowerdown 
14:42:32 async,ppp,debug ppp-out1: IPCP closed 
14:42:32 async,ppp,debug ppp-out1: IPV6CP lowerdown 
14:42:32 async,ppp,debug ppp-out1: IPV6CP down event in starting state 
14:42:32 async,ppp,debug ppp-out1: MPLSCP lowerdown 
14:42:32 async,ppp,info ppp-out1: terminating... - hungup 
14:42:32 async,ppp,debug ppp-out1: LCP lowerdown 
14:42:32 async,ppp,debug ppp-out1: LCP down event in starting state 
14:42:32 async,ppp,info ppp-out1: disconnected 
14:42:32 async,ppp,info ppp-out1: initializing... 
14:42:32 async,ppp,info ppp-out1: reseting link... 
14:42:32 system,info item removed 
14:42:32 system,info item removed 
14:42:33 async,ppp,info ppp-out1: initializing modem... 
14:42:34 async,ppp,info ppp-out1: dialing out... 
14:42:34 async,ppp,debug ppp-out1: LCP lowerup 
14:42:34 async,ppp,debug,packet  ppp-out1: sent LCP ConfReq id=0x2 
14:42:34 async,ppp,debug,packet    <magic 0x4757c8ef> 
14:42:34 async,ppp,debug,packet    <pcomp> 
14:42:34 async,ppp,debug,packet    <accomp> 
14:42:34 async,ppp,debug ppp-out1: LCP open 
14:42:34 async,ppp,debug,packet  ppp-out1: rcvd LCP ConfReq id=0xc 
14:42:34 async,ppp,debug,packet    <asyncmap 0x0> 
14:42:34 async,ppp,debug,packet    <magic 0x4c054896> 
14:42:34 async,ppp,debug,packet    <pcomp> 
14:42:34 async,ppp,debug,packet    <accomp> 
14:42:34 async,ppp,debug,packet    <auth  chap> 
14:42:34 async,ppp,debug,packet  ppp-out1: sent LCP ConfAck id=0xc 
14:42:34 async,ppp,debug,packet    <asyncmap 0x0> 
14:42:34 async,ppp,debug,packet    <magic 0x4c054896> 
14:42:34 async,ppp,debug,packet    <pcomp> 
14:42:34 async,ppp,debug,packet    <accomp> 
14:42:34 async,ppp,debug,packet    <auth  chap> 
14:42:34 async,ppp,debug,packet  ppp-out1: rcvd LCP ConfAck id=0x2 
14:42:34 async,ppp,debug,packet    <magic 0x4757c8ef> 
14:42:34 async,ppp,debug,packet    <pcomp> 
14:42:34 async,ppp,debug,packet    <accomp> 
14:42:34 async,ppp,debug ppp-out1: LCP opened 
14:42:34 async,ppp,debug,packet  ppp-out1: rcvd LCP DiscReq id=0xd 
14:42:34 async,ppp,debug,packet     <magic 0x4c054896> 
14:42:34 async,ppp,debug,packet  ppp-out1: rcvd CHAP Challenge id=0x1 
14:42:34 async,ppp,debug,packet     <challenge len=16> 
14:42:34 async,ppp,debug,packet     <name UMTS_CHAP_SRVR> 
14:42:34 async,ppp,debug,packet  ppp-out1: sent CHAP Response id=0x1 
14:42:34 async,ppp,debug,packet     <response len=16> 
14:42:34 async,ppp,debug,packet  ppp-out1: rcvd CHAP Success id=0x1 
14:42:34 async,ppp,info ppp-out1: authenticated 
14:42:34 async,ppp,debug ppp-out1: IPCP lowerup 
14:42:34 async,ppp,debug,packet  ppp-out1: sent IPCP ConfReq id=0x3 
14:42:34 async,ppp,debug,packet     <addr 0.0.0.0> 
14:42:34 async,ppp,debug,packet     <ms-dns 0.0.0.0> 
14:42:34 async,ppp,debug,packet     <ms-dns 0.0.0.0> 
14:42:34 async,ppp,debug ppp-out1: IPCP open 
14:42:34 async,ppp,debug ppp-out1: IPV6CP open 
14:42:34 async,ppp,debug ppp-out1: MPLSCP lowerup 
14:42:34 async,ppp,debug,packet  ppp-out1: sent MPLSCP ConfReq id=0x2 
14:42:34 async,ppp,debug ppp-out1: MPLSCP open 
14:42:34 async,ppp,debug ppp-out1: BCP open 
14:42:34 async,ppp,debug ppp-out1: CCP lowerup 
14:42:34 async,ppp,debug ppp-out1: CCP open 
14:42:34 async,ppp,debug,packet  ppp-out1: rcvd LCP ProtRej id=0xe 
14:42:34 async,ppp,debug,packet      82 81 01 02 00 04 
14:42:34 async,ppp,debug,packet  ppp-out1: rcvd IPCP ConfReq id=0x8 
14:42:34 async,ppp,debug,packet  ppp-out1: sent IPCP ConfNak id=0x8 
14:42:34 async,ppp,debug,packet     <addr 0.0.0.0> 
14:42:34 async,ppp,debug,packet  ppp-out1: rcvd IPCP ConfNak id=0x3 
14:42:34 async,ppp,debug,packet     <addr 10.106.11.96> 
14:42:34 async,ppp,debug,packet     <ms-dns 10.5.80.241> 
14:42:34 async,ppp,debug,packet     <ms-dns 10.5.68.232> 
14:42:34 async,ppp,debug,packet  ppp-out1: sent IPCP ConfReq id=0x4 
14:42:34 async,ppp,debug,packet     <addr 10.106.11.96> 
14:42:34 async,ppp,debug,packet     <ms-dns 10.5.80.241> 
14:42:34 async,ppp,debug,packet     <ms-dns 10.5.68.232> 
14:42:34 async,ppp,debug,packet  ppp-out1: rcvd IPCP ConfReq id=0x9 
14:42:34 async,ppp,debug,packet  ppp-out1: sent IPCP ConfAck id=0x9 
14:42:34 async,ppp,debug,packet  ppp-out1: rcvd IPCP ConfAck id=0x4 
14:42:34 async,ppp,debug,packet     <addr 10.106.11.96> 
14:42:34 async,ppp,debug,packet     <ms-dns 10.5.80.241> 
14:42:34 async,ppp,debug,packet     <ms-dns 10.5.68.232> 
14:42:34 async,ppp,debug ppp-out1: IPCP opened 
14:42:34 async,ppp,info ppp-out1: could not determine remote address, using 10.112.112.125 
14:42:34 async,ppp,info ppp-out1: connected 
14:42:34 system,info item added 
14:42:34 system,info item added 
14:42:35 async,ppp,debug ppp-out1: LCP close 
14:42:35 async,ppp,debug ppp-out1: LCP closed 
14:42:35 async,ppp,debug ppp-out1: CCP lowerdown 
14:42:35 async,ppp,debug ppp-out1: BCP lowerdown 
14:42:35 async,ppp,debug ppp-out1: BCP down event in starting state 
14:42:35 async,ppp,debug ppp-out1: IPCP lowerdown 
14:42:35 async,ppp,debug ppp-out1: IPCP closed 
14:42:35 async,ppp,debug ppp-out1: IPV6CP lowerdown 
14:42:35 async,ppp,debug ppp-out1: IPV6CP down event in starting state 
14:42:35 async,ppp,debug ppp-out1: MPLSCP lowerdown 
14:42:35 async,ppp,debug,packet  ppp-out1: sent LCP TermReq id=0x3 
14:42:35 async,ppp,debug,packet     administrator request 
14:42:35 async,ppp,debug,packet  ppp-out1: rcvd LCP TermAck id=0x3 
14:42:35 async,ppp,debug ppp-out1: LCP lowerdown 
14:42:35 async,ppp,info ppp-out1: terminating... - administrator request 
14:42:35 system,info item removed 
14:42:35 system,info item removed 
14:42:35 system,info device changed by admin 
14:42:35 async,ppp,debug ppp-out1: LCP lowerdown 
14:42:35 async,ppp,debug ppp-out1: LCP down event in initial state 
14:42:35 async,ppp,info ppp-out1: disabled
Here is the same logging configuration, just removed the MC7430 for about 5 seconds, and then plugged it back in. Wait about another 30 seconds until a LED illuminates on the USB carrier board and then enable the interface. Once it comes up, it will stay up pretty much indefinitely.
MC7430 removed from USB caddy for 5 seconds and returned, Interface then enabled again.

14:47:51 system,info device changed by admin 
14:47:51 async,ppp,info ppp-out1: initializing... 
14:47:51 async,ppp,info ppp-out1: reseting link... 
14:47:52 async,ppp,info ppp-out1: initializing modem... 
14:47:53 async,ppp,info ppp-out1: dialing out... 
14:47:53 async,ppp,debug ppp-out1: LCP lowerup 
14:47:53 async,ppp,debug ppp-out1: LCP open 
14:47:53 async,ppp,debug,packet  ppp-out1: sent LCP ConfReq id=0x1 
14:47:53 async,ppp,debug,packet    <magic 0x3e3678e6> 
14:47:53 async,ppp,debug,packet    <pcomp> 
14:47:53 async,ppp,debug,packet    <accomp> 
14:47:53 async,ppp,debug,packet  ppp-out1: rcvd LCP ConfReq id=0x0 
14:47:53 async,ppp,debug,packet    <asyncmap 0x0> 
14:47:53 async,ppp,debug,packet    <magic 0x4c0a25df> 
14:47:53 async,ppp,debug,packet    <pcomp> 
14:47:53 async,ppp,debug,packet    <accomp> 
14:47:53 async,ppp,debug,packet    <auth  chap> 
14:47:53 async,ppp,debug,packet  ppp-out1: sent LCP ConfAck id=0x0 
14:47:53 async,ppp,debug,packet    <asyncmap 0x0> 
14:47:53 async,ppp,debug,packet    <magic 0x4c0a25df> 
14:47:53 async,ppp,debug,packet    <pcomp> 
14:47:53 async,ppp,debug,packet    <accomp> 
14:47:53 async,ppp,debug,packet    <auth  chap> 
14:47:53 async,ppp,debug,packet  ppp-out1: rcvd LCP ConfAck id=0x1 
14:47:53 async,ppp,debug,packet    <magic 0x3e3678e6> 
14:47:53 async,ppp,debug,packet    <pcomp> 
14:47:53 async,ppp,debug,packet    <accomp> 
14:47:53 async,ppp,debug ppp-out1: LCP opened 
14:47:53 async,ppp,debug,packet  ppp-out1: rcvd LCP DiscReq id=0x1 
14:47:53 async,ppp,debug,packet     <magic 0x4c0a25df> 
14:47:53 async,ppp,debug,packet  ppp-out1: rcvd CHAP Challenge id=0x1 
14:47:53 async,ppp,debug,packet     <challenge len=16> 
14:47:53 async,ppp,debug,packet     <name UMTS_CHAP_SRVR> 
14:47:53 async,ppp,debug,packet  ppp-out1: sent CHAP Response id=0x1 
14:47:53 async,ppp,debug,packet     <response len=16> 
14:47:53 async,ppp,debug,packet  ppp-out1: rcvd CHAP Success id=0x1 
14:47:53 async,ppp,info ppp-out1: authenticated 
14:47:53 async,ppp,debug ppp-out1: IPCP lowerup 
14:47:53 async,ppp,debug ppp-out1: IPCP open 
14:47:53 async,ppp,debug,packet  ppp-out1: sent IPCP ConfReq id=0x1 
14:47:53 async,ppp,debug,packet     <addr 0.0.0.0> 
14:47:53 async,ppp,debug,packet     <ms-dns 0.0.0.0> 
14:47:53 async,ppp,debug,packet     <ms-dns 0.0.0.0> 
14:47:53 async,ppp,debug ppp-out1: IPV6CP open 
14:47:53 async,ppp,debug ppp-out1: MPLSCP lowerup 
14:47:53 async,ppp,debug ppp-out1: MPLSCP open 
14:47:53 async,ppp,debug,packet  ppp-out1: sent MPLSCP ConfReq id=0x1 
14:47:53 async,ppp,debug ppp-out1: BCP open 
14:47:53 async,ppp,debug ppp-out1: CCP lowerup 
14:47:53 async,ppp,debug ppp-out1: CCP open 
14:47:53 async,ppp,debug,packet  ppp-out1: rcvd LCP ProtRej id=0x2 
14:47:53 async,ppp,debug,packet      82 81 01 01 00 04 
14:47:54 async,ppp,debug,packet  ppp-out1: rcvd IPCP ConfNak id=0x1 
14:47:54 async,ppp,debug,packet     <ms-dns 10.11.12.13> 
14:47:54 async,ppp,debug,packet     <ms-dns 10.11.12.14> 
14:47:54 async,ppp,debug,packet     <ms-wins 10.11.12.13> 
14:47:54 async,ppp,debug,packet     <ms-wins 10.11.12.14> 
14:47:54 async,ppp,debug,packet  ppp-out1: sent IPCP ConfReq id=0x2 
14:47:54 async,ppp,debug,packet     <addr 0.0.0.0> 
14:47:54 async,ppp,debug,packet     <ms-dns 10.11.12.13> 
14:47:54 async,ppp,debug,packet     <ms-dns 10.11.12.14> 
14:47:54 async,ppp,debug,packet     <ms-wins 10.11.12.13> 
14:47:54 async,ppp,debug,packet     <ms-wins 10.11.12.14> 
14:47:55 async,ppp,debug,packet  ppp-out1: rcvd IPCP ConfNak id=0x2 
14:47:55 async,ppp,debug,packet     <ms-dns 10.11.12.13> 
14:47:55 async,ppp,debug,packet     <ms-dns 10.11.12.14> 
14:47:55 async,ppp,debug,packet     <ms-wins 10.11.12.13> 
14:47:55 async,ppp,debug,packet     <ms-wins 10.11.12.14> 
14:47:55 async,ppp,debug,packet  ppp-out1: sent IPCP ConfReq id=0x3 
14:47:55 async,ppp,debug,packet     <addr 0.0.0.0> 
14:47:55 async,ppp,debug,packet     <ms-dns 10.11.12.13> 
14:47:55 async,ppp,debug,packet     <ms-dns 10.11.12.14> 
14:47:55 async,ppp,debug,packet     <ms-wins 10.11.12.13> 
14:47:55 async,ppp,debug,packet     <ms-wins 10.11.12.14> 
14:47:56 async,ppp,debug,packet  ppp-out1: rcvd IPCP ConfReq id=0x0 
14:47:56 async,ppp,debug,packet  ppp-out1: sent IPCP ConfNak id=0x0 
14:47:56 async,ppp,debug,packet     <addr 0.0.0.0> 
14:47:56 async,ppp,debug,packet  ppp-out1: rcvd IPCP ConfRej id=0x3 
14:47:56 async,ppp,debug,packet     <ms-wins 10.11.12.13> 
14:47:56 async,ppp,debug,packet     <ms-wins 10.11.12.14> 
14:47:56 async,ppp,debug,packet  ppp-out1: sent IPCP ConfReq id=0x4 
14:47:56 async,ppp,debug,packet     <addr 0.0.0.0> 
14:47:56 async,ppp,debug,packet     <ms-dns 10.11.12.13> 
14:47:56 async,ppp,debug,packet     <ms-dns 10.11.12.14> 
14:47:56 async,ppp,debug,packet  ppp-out1: rcvd IPCP ConfReq id=0x1 
14:47:56 async,ppp,debug,packet  ppp-out1: sent IPCP ConfAck id=0x1 
14:47:56 async,ppp,debug,packet  ppp-out1: rcvd IPCP ConfNak id=0x4 
14:47:56 async,ppp,debug,packet     <addr 10.107.124.217> 
14:47:56 async,ppp,debug,packet     <ms-dns 10.5.68.232> 
14:47:56 async,ppp,debug,packet     <ms-dns 10.5.80.241> 
14:47:56 async,ppp,debug,packet  ppp-out1: sent IPCP ConfReq id=0x5 
14:47:56 async,ppp,debug,packet     <addr 10.107.124.217> 
14:47:56 async,ppp,debug,packet     <ms-dns 10.5.68.232> 
14:47:56 async,ppp,debug,packet     <ms-dns 10.5.80.241> 
14:47:56 async,ppp,debug,packet  ppp-out1: rcvd IPCP ConfAck id=0x5 
14:47:56 async,ppp,debug,packet     <addr 10.107.124.217> 
14:47:56 async,ppp,debug,packet     <ms-dns 10.5.68.232> 
14:47:56 async,ppp,debug,packet     <ms-dns 10.5.80.241> 
14:47:56 async,ppp,debug ppp-out1: IPCP opened 
14:47:56 async,ppp,info ppp-out1: could not determine remote address, using 10.112.112.126 
14:47:56 async,ppp,info ppp-out1: connected 
14:47:56 system,info item added 
14:47:56 system,info item added
When testing through the mPCI-e ports its the same story.
If anyone has any ideas from the logs feel free to pipe up.
 
helipos
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Sat Jun 25, 2016 11:32 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Thu Feb 16, 2017 1:29 am

Well I've tested it in Linux (Kali 2016.2) and using Network Manager to connect it works flawlessly. I can disconnect, reconnect, reboot, ect and it connects and stays connected every time,
It also cranks the speed 100Mbs down and 35Mbs up still using USB2.
I've raised a support ticket to see try get some help from Mikrotik.
 
Wyz4k
Member Candidate
Member Candidate
Posts: 182
Joined: Fri Jul 10, 2009 10:23 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Wed Mar 01, 2017 8:45 am

Hey guys,

Any update on this?
 
helipos
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Sat Jun 25, 2016 11:32 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Fri Mar 03, 2017 10:41 am

Yeah, Mikrotik as usual gave some really embarrassingly simple things to try that seem to work.

Once you configure it correctly enough to get the interface dropping every 5 seconds. Issue a 5 second reboot of the USB power bus, the modem will boot, connect and stay connected. I just tested it and it has stayed up for 3 days straight. So will do some more cycling, resets,disable interface etc so see how reliable the 5 second power cycle is.
 
helipos
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Sat Jun 25, 2016 11:32 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Fri Mar 03, 2017 12:05 pm

Did What___________________________Modem connects______________5 second USB power cycle_________Additional notes
_________________________________and stays connected____________results in stable connection
_______________________________without user intervention

Unplugged the RB953____________________ No____________________________ Yes__________________Unknown length of power off
Unplugged the RB953 (second try)__________ Yes____________________________Didnt test_____________Was given a good 5 seconds off
Unplugged the RB953 (Third try)____________Yes____________________________Yes__________________Was given about 1 second off
Unplugged the RB953 (Fourth try)___________Yes____________________________Yes__________________Was given about 1 second off
Unplugged the RB953 (Fifth try)_____________Yes____________________________Didn't test_____________Was given about 3 seconds off

Disabled the PPP interface_________________Yes____________________________Yes__________________Disabled for about 1 second
Disabled the PPP interface_________________No_____________________________Yes__________________Disabled for about 6-8 seconds
Disabled the PPP interface_________________No_____________________________Yes__________________Disabled for about 10 seconds
Disabled the PPP interface_________________Yes____________________________Didn't test_____________Disabled for about 1 second
Disabled the PPP interface_________________Yes____________________________Didn't test_____________Disabled for about 2 seconds
Disabled the PPP interface_________________Yes____________________________Didn't test_____________Disabled for about 3 seconds
Disabled the PPP interface_________________No_____________________________Yes__________________Disabled for about 4 seconds

Rebooted the RB953______________________No_____________________________Yes
Rebooted the RB953______________________No_____________________________Yes

**screw what ever took all the spaces out**

In summary.
Doing power cycles on the RB953, the MC7430 was reasonably reliable at connecting back up.
Disabling the PPP interface for more than about 4 seconds would result in the PPP interface cycling. A 5 second USB power reset cured it's ills everytime.
Rebooting the RB953 caused the PPP to start cycling everytime once the MC7430 had booted. A 5 second USB power reset cured it's ills everytime.


I'll write a guide after I've done some more testing.
 
David1234
Forum Guru
Forum Guru
Posts: 1186
Joined: Sun Sep 18, 2011 7:00 pm

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Wed Mar 29, 2017 10:10 am

Hello ,
I have the same problem
I have try to do what you told
when the ppp is connected I'm sending a usb reset duration=5
but after it return , it still disconnected every 6-7 sec
using verstion 6.36

also I'm using RB411 and x86
there is no option there to do "usb reset" - so what can I do?

Thanks ,
 
helipos
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Sat Jun 25, 2016 11:32 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Thu Mar 30, 2017 5:47 am

First thing is to upgrade the ROS version.
I'm not the familiar with the cli prompts so will talk in terms of Winbox.

If you go to the following menu in Winbox you should find the "usb power reset"
System > Routerboard > USB power reset
once your in that screen it's pretty self explanatory.

What do you mean by
also I'm using RB411 and x86
RB411 AFAIK is not an x86 instruction set.
 
helipos
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Sat Jun 25, 2016 11:32 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Tue Apr 11, 2017 12:50 pm

Ok here is a pair of scripts and a schedule, bit rough around the edges, actually probably rough all the way through. But it does work.
It will power reset the USB device if there are three lots of "link down " count increases in 10 seconds.
If it needs to power cycle the USB a couple of times it will reboot the router as a precaution.
ROS 6.38 and RouterBOARD 952Ui-5ac2nD

I will develop and post another for the RB953 since thats what I want to use in the end.
I might even improve the script as I already know some poor code in there.
add name=Startup on-event="system script run 1\
    \n\
    \n" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-time=startup
add interval=20s name="20 seconds" on-event="system script run 0\
    \n" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-date=apr/09/2017 start-time=08:08:46
/system script
add name=PPP-link-down-check owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source="log info PPP_script_start\r\
    \nglobal A1 [interface get ppp-out1 link-downs ]\r\
    \ndelay delay-time=10\r\
    \nglobal A2 [interface get ppp-out1 link-downs ]\r\
    \nglobal A3\r\
    \nglobal A4\r\
    \n\r\
    \nif (\$A2 > \$A1) do={:set \$A3 (\$A3+1)} else={:set \$A3 value=(\$A3+0)}\r\
    \nif (\$A3 >=3) do={system routerboard usb power-reset duration= 5; global A3 0; :set \$A4 (\$A4+1)}\r\
    \nif (\$A4 >=3) do={system reboot}\r\
    \nlog info PPP_script_end"
add name=variable-initialise owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source="global A1 0\r\
    \nglobal A2 0\r\
    \nglobal A3 0\r\
    \nglobal A4 0"

 
helipos
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Sat Jun 25, 2016 11:32 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Thu Apr 27, 2017 11:09 am

/system scheduler
add name=Startup on-event="system script run variable-initialise" policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-time=startup
add interval=20s name="20 seconds" on-event="system script run PPP-link-down-check" policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-date=apr/09/2017 start-time=08:08:46
add interval=1h name="1 hour" on-event="system script run Variable-A4-subtraction" policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-date=apr/18/2017 start-time=09:14:23
add interval=15m name="15 minutes" on-event="system script run Variable-A3-subtraction" policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-date=apr/18/2017 start-time=09:14:23
add interval=10s name="10 seconds" on-event="system script run Google-ping-check" policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-date=apr/18/2017 start-time=09:55:35


/system script
add name=PPP-link-down-check owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source="global A1 [interface get ppp-out link-downs ]\r\
    \ndelay delay-time=10\r\
    \nglobal A2 [interface get ppp-out1 link-downs ]\r\
    \nglobal A3\r\
    \nglobal A4\r\
    \n\r\
    \nif (\$A2 > \$A1) do={:set \$A3 (\$A3+1)} else={:set \$A3 value=(\$A3+0)}\r\
    \nif (\$A3 >=3) do={log info Modem_reboot ;system routerboard usb power-reset duration= 5 bus=1; global A3 0; :set \$A4 (\$A4+1)}\r\
    \nif (\$A4 >=3) do={system reboot}"
add name=variable-initialise owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source=\
    "global A1 0\r\
    \nglobal A2 0\r\
    \nglobal A3 0\r\
    \nglobal A4 0\r\
    \nglobal A5 30"
add name=Variable-A4-subtraction owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source=\
    "global A4\r\
    \nif (\$A4 > 0) do={:set \$A4 (\$A4-1); log info A4-1}"
add name=Variable-A3-subtraction owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source=\
    "global A3\r\
    \nif (\$A3 > 0) do={:set \$A3 (\$A3-1); log info A3-1}"
add name=Google-ping-check owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source="global A5\r\
    \n\r\
    \nif ([ping 8.8.8.8 count=1]=1) do={:if (\$A5 >= 30) do={delay delay-time=0} else={:set \$A5 (\$A5+1)}} else={:set \$A5 (\$A5-1)}\r\
    \nif (\$A5 <= 0) do={system routerboard usb power-reset duration= 5 bus=1 ;delay delay-time=5 ;system reboot}\r\
    \n\r\
    \n\r\
    \n"
Right an improved script set here.
One set will look for incrementing PPP link down counts and reboots the modem if it continues long enough.
Second set will reboot the router if the modem reboots don't seem to be fixing the issue.
Third one will reboot the router if it cant ping 8.8.8.8 (google's dns servers)
There are a couple of others that will slowly decrement the counters used in the other scripts.

Edit: neglected to add the scheduler section of config.
Fixed some typos in the link down script
Modified the Google ping check script to only reboot the router not the bus as it sometimes conflicted with the ppp link down script.
Last edited by helipos on Sat Sep 08, 2018 11:49 am, edited 4 times in total.
 
Wyz4k
Member Candidate
Member Candidate
Posts: 182
Joined: Fri Jul 10, 2009 10:23 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Tue May 16, 2017 6:24 am

I've just decided to give a MC7430 a try, and I can't even get it to be picked up in the USB tab. I've made sure that it's not in direct-ip mode, and I've rebooted several times. I've power-resetted the USB several times. Nothing. I downgraded to 6.35.4 and my device got stuck in a endless boot reset, boot, reset loop. I had to netinstall to break this loop. Netinstalled with 6.35.4 and it still would not pick up the MC7430.
 
helipos
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Sat Jun 25, 2016 11:32 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Fri May 19, 2017 12:38 pm

What RouterBoard hardware are you using?
 
Wyz4k
Member Candidate
Member Candidate
Posts: 182
Joined: Fri Jul 10, 2009 10:23 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Fri May 19, 2017 3:52 pm

RB922
 
helipos
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Sat Jun 25, 2016 11:32 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Sun May 21, 2017 8:57 am

I'm guessing but try this.

System > Routerboard > USB
and set the USB port to Mini-PCIe

On the RB953 you can only run either the type A port or the mini-PCIe ports.


Hopefully it will then show up in the
System > resources > USB
System > ports list

Also don't forget to tape the USB 3.0 pins on the MC7430
 
Wyz4k
Member Candidate
Member Candidate
Posts: 182
Joined: Fri Jul 10, 2009 10:23 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Mon May 22, 2017 4:22 am

I'm guessing but try this.

System > Routerboard > USB
and set the USB port to Mini-PCIe

On the RB953 you can only run either the type A port or the mini-PCIe ports.


Hopefully it will then show up in the
System > resources > USB
System > ports list

Also don't forget to tape the USB 3.0 pins on the MC7430
I've done the USB port type and rebooted to no avail. But what is this about taping USB 3.0 pins?

Edit: Right, I see. I missed that. Will try taping the pins and revert :) Thanks for that!
 
helipos
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Sat Jun 25, 2016 11:32 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Thu May 25, 2017 1:05 am

Have any luck Wyz4k?
 
gmstack
just joined
Posts: 4
Joined: Wed Aug 16, 2017 12:01 pm

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Wed Aug 16, 2017 12:14 pm

I'm running one of these (MC7430) in a RB2011 with a USB OTG cable and a MiniPCIe to USB adaptor. Was seeing the modem connect for 5 seconds then disconnect.

USB power reset wasn't working - the modem would go away until I rebooted the RB2011 (I've read there are some issues regarding the 2011 and USB...)

I've found another solution: put
at+cgatt=0
in the PPP init script. From reading this thread, the cause might be the modem auto connecting to the LTE network before the connection from the router is established. That command forces a disconnect from the mobile network meaning our connection might occur first - which might have been why power-resetting the modem then immediately connecting worked.

Seems to have stayed up for 16 minutes now - which is certainly more than the 6 seconds I got before.

Edit: It would appear that the modem might be staying in 3G mode with that set. I've got it to reconnect the packet session in the dial script with
AT+cgatt=1;D*99#
and the connection appears to perform better - unfortunately the data and info serial channels appear to be the same so I can't send further AT commands while connected to determine what state the modem's in.
 
helipos
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Sat Jun 25, 2016 11:32 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Sun Aug 20, 2017 7:21 am

unfortunately the data and info serial channels appear to be the same so I can't send further AT commands while connected to determine what state the modem's in.
Its pretty shite for that, however good find on the info I'll give it a try this week.
 
David1234
Forum Guru
Forum Guru
Posts: 1186
Joined: Sun Sep 18, 2011 7:00 pm

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Sun Aug 20, 2017 9:55 am

gmstack - Thanks ,
in my router is working and connecting to LTE and 3G
I didn't check to see if he change from 3G to LTE but he is connecting to both of them .

Thanks for the tip
 
helipos
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Sat Jun 25, 2016 11:32 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Tue Aug 22, 2017 8:14 am

I've found another solution: put
at+cgatt=0
in the PPP init script.

Edit: It would appear that the modem might be staying in 3G mode with that set. I've got it to reconnect the packet session in the dial script with
AT+cgatt=1;D*99#
and the connection appears to perform better.
Hi GM could you elaborate a little more on where you have put both of those commands. Is it part of the "dial command" inside the PPP tab of the PPP interface? Or is it part of some script you have built?
 
gmstack
just joined
Posts: 4
Joined: Wed Aug 16, 2017 12:01 pm

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Thu Aug 31, 2017 3:18 pm

I've found another solution: put
at+cgatt=0
in the PPP init script.

Edit: It would appear that the modem might be staying in 3G mode with that set. I've got it to reconnect the packet session in the dial script with
AT+cgatt=1;D*99#
and the connection appears to perform better.
Hi GM could you elaborate a little more on where you have put both of those commands. Is it part of the "dial command" inside the PPP tab of the PPP interface? Or is it part of some script you have built?
The first one (I said "init script") goes into "Modem Init" in the PPP interface (you'll need to turn on Advanced Mode to see it). The second one (I said "dial script") is the "dial command" in the same page. Sorry, wasn't clear on the exact field names because I wasn't in front of the router config at the time.
 
helipos
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Sat Jun 25, 2016 11:32 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Fri Sep 01, 2017 1:44 am

Sorry, wasn't clear on the exact field names
Not a problem, thanks for the reply
 
helipos
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Sat Jun 25, 2016 11:32 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Mon Sep 04, 2017 12:48 pm

gmstack or David1234

While I find it's working pretty well picking up connectivity without needing intervention. If I reboot the router via winbox (and probably ssh) it wont connect and does the usual reset after 6 seconds BS. A simple disable and re-enable of the ppp interface works to get it connected again.

Are you still running any other scripts to help with this?
Or is it just me..

Cheers
Helipos
 
David1234
Forum Guru
Forum Guru
Posts: 1186
Joined: Sun Sep 18, 2011 7:00 pm

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Sun Nov 12, 2017 1:04 pm

I have notice the same problem here also
When I force the modem to connect to LTE
at!selrat=06
 
it disconnect after 5-6 seconds ,when I add the modem-int
interface ppp-client
add allow=pap,chap apn=internet data-channel=2 dial-on-demand=no disabled=no \
info-channel=2 modem-init="at+cgatt=0" mrru=1600 name=ppp-out1 phone=*99# port=\
usb1
it say
int string failed : at+cgatt=0


how could it be?
I have reset the modem some times - nothing

Any thought?

Thanks ,
 
helipos
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Sat Jun 25, 2016 11:32 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Mon Mar 19, 2018 3:40 am

I see there is some new Telstra firmware for the MC7430.
SWI9X30C_02.24.05.06 might give it a whirl in a few weeks, let you know how it goes.
 
Wyz4k
Member Candidate
Member Candidate
Posts: 182
Joined: Fri Jul 10, 2009 10:23 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Mon Mar 19, 2018 4:11 am

I haven't done any more testing on the MC7430, but I have asked Mikrotik to look into the firmware stability now that the MC7304 has been made end of life.

Personally we've moved to a different radio that's cheaper and offers better functionality.
 
MurkyVision
just joined
Posts: 1
Joined: Tue Jun 03, 2014 3:48 pm

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Mon Mar 19, 2018 5:13 am

WOW guys, there has been some updates to this thread.... I haven't been checking because i never got a "Topic reply notification" till today..

Well an update my end, I gave up.. No help from Sierra and no help from MikroTik.. However MikroTik did say it should be supported natively in the new kernel (ROS V7) ROFL

I am now deploying Cat 16 Telstra Nighthawk M1's (Netgear MR1100) to access B28 and they are working great! where the Sierra Aircard 320U had extremely poor signal.
Note: i am also have been using "Panorama 700-2700MHz MiMo Ultra Wideband Panel Antenna" on both devices which has helpded a little.
You should be able to pick the Nighhawk (MR1100) up for around $330 from Telstra in any quantity.

The MR1100 is powered from the USB port (battery left in for stability) and I am passing through the external(ish) IP address to a DHCP Client on the Mikrotik via Ethernet

The only issue i have is the Ethernet port on the MR1100 can go to sleep should there be no detected connection e.g. the MikroTik is turned off overnight.. This is to save battery power as the Ethernet port apparently consumes a lot. Not something you need enabled in a typically battery powered Wi-Fi hotspot. And, yes it even sleeps when when connected to power, fully charged. The simple fix is to tap the Power button on the MR1100 to reactivate a scan of the Ethernet port. This has currently not been an issue if the router is left on at all times.
Oh, and don't forget to update the firmware through the WEB interface on the device as there have been some stability and functionality improvements.

It is a pain in the butt having a 2nd loose devices floating around with cables everywhere, but I am currently making a 3D printed "backpack" to house the MR1100 for the CA/433U case for a little protection and cable management. I may also make one for the RB2011UAS-2HnD-IN... I will post the STLs on thingiverse and link it to here when completed.

IanD
 
mc0e
just joined
Posts: 2
Joined: Thu Sep 28, 2017 8:15 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Mon Mar 19, 2018 5:58 am

I haven't done any more testing on the MC7430, but I have asked Mikrotik to look into the firmware stability now that the MC7304 has been made end of life.

Personally we've moved to a different radio that's cheaper and offers better functionality.
What did you pick, out of interest?

Sorry if that's off topic.
 
Wyz4k
Member Candidate
Member Candidate
Posts: 182
Joined: Fri Jul 10, 2009 10:23 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Mon Mar 19, 2018 5:53 pm

SIMCOM SIM7100E
 
User avatar
IanD
just joined
Topic Author
Posts: 5
Joined: Tue Jun 28, 2016 4:36 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Mon Mar 19, 2018 11:54 pm

WOW guys, there has been some updates to this thread.... I haven't been checking because I never got a "Topic reply notification" till yesterday..

Well an update my end, I gave up.. No help from Sierra and no help from MikroTik.. However MikroTik did say it should be supported natively in the new kernel (ROS V7) ROFL. It was just taking too long to work a solution that I was confident that would be stable.

I am now deploying “Cat 16” Telstra Nighthawk M1's (Netgear MR1100) to access B28 and they are working great! Especially where the Sierra Aircard 320U had extremely poor signal.
Note: I am also using "Panorama 700-2700MHz MiMo Ultra Wideband Panel Antenna" on both devices which has helped a little.
You should be able to pick the Nighthawk (MR1100) up for around $330 from Telstra in any quantity.

The MR1100 is powered from the USB port on the router (battery left in for stability) and I am passing through the external(ish) IP address to a DHCP Client on the MikroTik via Ethernet

The only issue I have is the Ethernet port on the MR1100 can go to sleep should there be no detected Ethernet connection e.g. the MikroTik is turned off overnight.. This is to save battery power as the Ethernet port apparently consumes a lot. Not something you need enabled in a typically battery powered Wi-Fi hotspot. Yes it even sleeps when connected to power, fully charged. The simple fix is to tap the Power button on the MR1100 to reactivate a scan of the Ethernet port. This has currently not been an issue if the router is left on at all times.
Oh, and don't forget to update the firmware through the WEB interface on the device as there have been some stability and functionality improvements. The latest firmware has a setting that will keep the Ethernet port alive for 2 Minutes before going to sleep

It is a pain in the butt having a 2nd loose devices floating around with cables everywhere, but I am currently making a 3D printed "backpack" to house the MR1100 for the CA/433U case for a little protection and cable management. I may also make one for the RB2011UAS-2HnD-IN... I will post the STLs on thingiverse and link it to here when completed.

IanD
 
vacool
just joined
Posts: 9
Joined: Sat Sep 24, 2016 5:35 pm

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Sun May 06, 2018 8:22 pm

Has someone tried to use this card with RBM33G (Do USB 3.0 pins have to be taped also with this board)?
 
helipos
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Sat Jun 25, 2016 11:32 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Mon May 21, 2018 3:56 am

I am now deploying “Cat 16” Telstra Nighthawk M1's (Netgear MR1100) to access B28 and they are working great!
What speeds are you getting out of the MR1100?
I was never able to get a decent speed out of the Mikrotik when it had the MC7430 plugged directly in to it's ports.
So I've kinda splashed out bought a mini PC to host the modem, which now looking at the MR1100, kinda looks stupid and expensive.
 
Jamesits
just joined
Posts: 21
Joined: Thu Jul 13, 2017 10:15 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Tue May 22, 2018 12:58 pm

I've been using EM7430/EM7455 (the M.2 version of MC7430/MC7455) for a while steadily on RB3011.

To disable DirectIP modem mode: plug the card into your computer (any adapter will be OK; you might need to download driver on Sierra Wireless website if you are using Windows, Linux is fine). Find the correct COM port (There will be 3 or 4 COM ports from that card; type "ATI" into every one, hit enter and check the reply if it matches below) and type the following commands (you only need to type the line after #input, others are returned by the card itself)

Code: Select all

# view card info
# input:
ATI

Manufacturer: Sierra Wireless, Incorporated
Model: EM7430
Revision: SWI9X30C_02.14.03.00 r6134 CARMD-EV-FRMWR2 2016/03/28 14:34:14
MEID:
IMEI:
IMEI SV:
FSN:
+GCAP: +CGSM


OK

# set a password (you need to do this to get some command working, don't know why)
# input:
AT!ENTERCND="A710"

OK

# query USB mode
# input:
AT!USBCOMP?

Config Index: 1
Config Type: 1 (Generic)
Interface bitmask: 0000100D (diag,nmea,modem,mbim)

OK

# disable DirectIP modem mode
# input:
AT!USBCOMP=1,1,D

OK

# query again
# input:
AT!USBCOMP?

Config Index: 1
Config Type: 1 (Generic)
Interface bitmask: 0000000D (diag,nmea,modem)

OK
now pull out the card and put it to RouterOS.

My RouterOS config:

Code: Select all

/port
set 1 baud-rate=auto name=em7455
/interface ppp-client
add data-channel=2 dial-command="AT+CGATT=1;D*99#" info-channel=2 modem-init="AT+CGATT=0" name=ppp-out-em7455 port=em7455
/system gps
set channel=1 enabled=yes init-string="\$GPS_STOP,\$GPS_START" port=em7455 set-system-time=yes
 
User avatar
IanD
just joined
Topic Author
Posts: 5
Joined: Tue Jun 28, 2016 4:36 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Thu May 24, 2018 5:37 am

Hey Helipos,
What speeds are you getting out of the MR1100?
Ran a test from one of our sites in deep inside Melbourne Airport and was getting 30-35Mbps down and 25Mbps up. These speeds are a lot faster and signal is much more stable than the Sierra 320U's we were using.
Speeds can be much much faster outside or in smaller buildings, especially where there is less contention on the tower.

Note: I am using the Ethernet port with IP pass-through (DHCP client) so the USB port is just for charging/power. (No need for ignore-directip-modem and PPTP client, which limits speed to begin with)

As for looks and price, i say "ehh". Looks do not matter to us, its all about functionality and reliability. You also have to put a price on man hours for time and effort messing around with devices (mc7430) that may or may not work to a service level you require. At $330 for a device that will be in service for 4+ years.. Tis OK in my books

If i can get some more speed test results I will update this message

Regards
IanD
 
helipos
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Sat Jun 25, 2016 11:32 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Sun Jul 08, 2018 4:07 am

Well I've built the first working version of the speed box. It looks like this.
MC7430-- Jetway NF591--Mikrotik RB953

The NF591 is just a low powered PC running Kali which is a offshoot of Debian Linux.
It sets up the MC7430, does the NAT and then pumps it out on one of it's interfaces.

The RB953 pick it up from there and runs the DNS and DHCP servers for the subnet.
It also has the wireless cards.

Here is the Kali config, quite a bit of the network config is GUI based. I also expect you to complete the network config as you require for your setup I;ve just put the bits I need to remember to do.
systemctl enable ssh
rm /etc/ssh/sshd_config
nano /etc/ssh/sshd_config
PermitRootLogin = yes

#################################################################

nano /etc/ssh/sshd_config

X11Forwarding yes
AllowAgentForwarding yes
PermitRootLogin yes

#################################################################

iptables -A INPUT -p tcp ! -s 192.168.6.2 -j DROP

#################################################################


#################################################################


#################################################################

Setup networks manually
eth0 192.168.6.1
IPv4 method "share to other computers"

Mobile broadband 
"automatically connect"


#################################################################
reboot
#################################################################

touch /etc/apt/sources.list
chmod 644 /etc/apt/sources.list
echo "deb http://http.kali.org/kali kali-rolling main contrib non-free" > /etc/apt/sources.list
apt-key adv --keyserver hkp://keys.gnupg.net --recv-keys 7D8D0BF6


#################################################################

apt-get update
apt-get dist-upgrade
Here is the Mikrotik.
[admin@Porta_Hub] > export hide-sensitive 
# jul/08/2018 08:56:48 by RouterOS 6.42.5
# software id = 0NE8-0RN3
#
# model = 953GS-5HnT
# serial number = 49C50414682D
/interface bridge
add fast-forward=no name=bridge1
/interface wireless
set [ find default-name=wlan1 ] band=5ghz-a/n channel-width=20/40mhz-Ce country=australia disabled=no frequency-mode=regulatory-domain mode=ap-bridge ssid="MikroTik 5.0" wireless-protocol=802.11
set [ find default-name=wlan2 ] band=2ghz-b/g/n channel-width=20/40mhz-eC disabled=no frequency=auto mode=ap-bridge ssid="Mikrotik 2.0"
/interface ethernet
set [ find default-name=sfp1 ] auto-negotiation=no speed=100Mbps
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" mode=dynamic-keys supplicant-identity=MikroTik
add authentication-types=wpa2-psk eap-methods="" name=Free supplicant-identity=MikroTik
/ip ipsec proposal
set [ find default=yes ] enc-algorithms=aes-256-cbc,aes-192-cbc,aes-128-cbc,3des
/ip pool
add name=pool1 ranges=192.168.6.100-192.168.6.200
/ip dhcp-server
add address-pool=pool1 authoritative=after-2sec-delay disabled=no interface=bridge1 name=server1
/port
set 1 baud-rate=9600 data-bits=8 flow-control=none name=usb2 parity=none stop-bits=1
set 2 baud-rate=9600 data-bits=8 flow-control=none name=usb3 parity=none stop-bits=1
/interface ppp-client
add apn=telstra.datapack data-channel=2 dial-on-demand=no info-channel=2 name=ppp-out1 port=usb3
/interface l2tp-client
add connect-to=180.181.XXX.XXX disabled=no keepalive-timeout=30 name=l2tp-out1 profile=default use-ipsec=yes user=Porta_Hub_remote
/routing ospf instance
set [ find default=yes ] name=OSPF router-id=0.0.0.2
/snmp community
set [ find default=yes ] addresses=0.0.0.0/0
/interface bridge port
add bridge=bridge1 hw=no interface=ether2
add bridge=bridge1 hw=no interface=ether3
add bridge=bridge1 interface=wlan1
add bridge=bridge1 interface=wlan2
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=sfp1
add bridge=bridge1 interface=sfp2
/ip address
add address=192.168.6.2/24 interface=bridge1 network=192.168.6.0
/ip dhcp-server network
add address=192.168.6.0/24 dns-server=192.168.6.2 gateway=192.168.6.1
/ip dns
set allow-remote-requests=yes servers=61.9.242.33,61.9.194.49
/ip firewall filter
# bridge2 not ready
add action=drop chain=forward dst-port=53 in-interface=*14 protocol=tcp
# bridge2 not ready
add action=drop chain=forward dst-port=53 in-interface=*14 protocol=udp
/ip firewall nat
add action=masquerade chain=srcnat disabled=yes out-interface=ppp-out1
add action=masquerade chain=srcnat disabled=yes out-interface=*14
/ip route
add distance=1 gateway=192.168.6.1
/ip service
set telnet disabled=yes
set www port=8080
set ssh port=50000
set www-ssl disabled=no
set api disabled=yes
set api-ssl disabled=yes
/routing ospf network
add area=backbone network=172.16.1.4/30
add area=backbone network=192.168.6.0/24
/system clock
set time-zone-autodetect=no time-zone-name=Australia/Perth
/system identity
set name=Porta_Hub
/system leds
add interface=wlan2 leds=wlan2_signal1-led,wlan2_signal2-led,wlan2_signal3-led,wlan2_signal4-led,wlan2_signal5-led type=wireless-signal-strength
add interface=wlan2 leds=wlan2_tx-led type=interface-transmit
add interface=wlan2 leds=wlan2_rx-led type=interface-receive
/system routerboard settings
set silent-boot=no
/system scheduler
add interval=1w name="Sunday Midnight" on-event="system script run Autoupdater" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-date=dec/03/2017 start-time=00:00:00
/system script
add name=Autoupdater owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source="policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source=\"system package update or-updates :global FWstatus [/system packag\
    e update get status]; if (\\\$FWstatus = \\\"New version is available\\\") do={system package update download; delay delay-time=3600; system reboot} else={}"
[admin@Porta_Hub] > 
The speed is quite an interesting topic.
I was building it at work yesterday and had some double NAT going on until I figured I could get rid of that.
With the double NAT a laptop running windows OS really struggled to get anything +40MB/s.
The same laptop on the same connection running Kali it flew, +100Mb/s down and around 35 up

I bought the porta hub home to try it off my desktop, got rid of the double NAT and it flies as well. I've just run at it 0900 local time, 80Mb/s down 37.5Mb/s up.
I will go back to work to try it out again on the laptop.
I should also mention I've got access to all three Telstra Bands 700, 1800, 2600 so it will crossband to get that sort of speed.

PS the latest Telstra Firmware 02.24.05.06 seems to work no problems.
 
helipos
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Sat Jun 25, 2016 11:32 am

Re: Sierra MC7430 4g LTE-A mini-PCI-e Modem PPP issues

Mon Oct 01, 2018 1:14 am

I'll second the Nighthawk M1.

A little bit fiddly, doesn't always behave how you think, but once its setup it does go quite well.
USB tethering works a treat, can get 80+ Mb/s over USB.
Do have to use double NAT, unless you get a proper public IP from your provider, but that is no different to the MC7430 I suppose.

Who is online

Users browsing this forum: pcunite and 18 guests