Community discussions

MUM Europe 2020
 
rpra
newbie
Topic Author
Posts: 36
Joined: Tue Jan 24, 2012 8:43 pm

High CPU load when PPPoE sessions disconnects

Tue Feb 07, 2017 7:27 pm

I think this problem appeared in some recent versions of ROS.
It definitely exists on 6.35.4 and 6.38.1.

When we have network outages, some PPPoE sessions are disconnecting with 'peer not responding' errors.
In this moments CCR CPUs are 100% utilised, so than router almost stop passing any traffic.

This can continue for some minutes. Router looses OSPF neighbors, and it's all becomes a catastrophe!
It number of disconnecting sessions is over 200-300 it collapses 100%.

Seeing this on several different CCRs.
 
yovetal
just joined
Posts: 1
Joined: Sun Jul 02, 2017 2:55 pm

Re: High CPU load when PPPoE sessions disconnects

Sun Jul 02, 2017 3:06 pm

Hello!

We have the same problem on our CCR-1036. Now we use RouterOS v.6.39.2. And the problem is still exist.

I created a TriubleTicket in Mikrotik Support half a year ago, but they still have not fond the solution.
 
supaul77
just joined
Posts: 1
Joined: Mon Jul 17, 2017 10:24 am

Re: High CPU load when PPPoE sessions disconnects

Mon Jul 17, 2017 10:25 am

I am facing same Problem. Any solution ?
 
p3rad0x
Long time Member
Long time Member
Posts: 603
Joined: Fri Sep 18, 2015 5:42 pm
Location: South Africa
Contact:

Re: High CPU load when PPPoE sessions disconnects

Wed Jul 19, 2017 12:18 am

Hi,

Are you using masquerade?
There you go then you touched something ;-) : it only takes a change in wind direction to screw with your nat :-)
 
stergulc
just joined
Posts: 1
Joined: Thu Apr 13, 2017 11:06 am

Re: High CPU load when PPPoE sessions disconnects

Tue Aug 22, 2017 10:39 pm

Any workaround?
We have same issue...
 
ntmanxp
just joined
Posts: 21
Joined: Fri Feb 15, 2008 9:04 pm

Re: High CPU load when PPPoE sessions disconnects

Tue Sep 26, 2017 10:48 pm

+1 for me
 
User avatar
tomaskir
Trainer
Trainer
Posts: 1122
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: High CPU load when PPPoE sessions disconnects

Thu Sep 28, 2017 4:49 pm

If you are using Masquarade on the router, that is the problem.
When using Masquarade, RouterOS has to do full connection tracking recalculation on EACH interface connect/disconnect.

So if you have lots of PPPoE session connecting/disconnecting, connection tracking will constantly be recalculated which will can high CPU usage.

Solution:
Stop using Masquarade on routers that have a lot of dynamic interfaces.
Either use srcnat, or fix your architecture (use routing).
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
ntmanxp
just joined
Posts: 21
Joined: Fri Feb 15, 2008 9:04 pm

Re: High CPU load when PPPoE sessions disconnects

Fri Sep 29, 2017 4:10 pm

In my case, I do not use masquerading, just src-nat.
And even selecting sessions ( i.e. 20/30 of them ) that uses Public IP address from the pool, the CPU raises, and tooks a while to go down.
Months ago, I did use Interim Update. Was a disaster.Lot's of load to the CCR.
Adding 1+1, 'maybe' it's related to the accounting. Or the packets count that the sessions sent to the Radius ( the count process itself )
Let's think that the support/development staff can dig deeper and shows us a fix.
 
User avatar
aacable
Member
Member
Posts: 425
Joined: Wed Sep 17, 2008 11:58 am
Location: ISLAMIC Republic of PAKISTAN
Contact:

Re: High CPU load when PPPoE sessions disconnects

Mon Oct 02, 2017 10:05 am

Facing same issue here as well. using following RB's (with 6.40.3)
RB3011xxx
CCR1016
CCR1036
_____________
Regard's

Syed Jahanzaib
Web: http://aacable.wordpress.com
Email: aacable [at] hotmail.com
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8320
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: High CPU load when PPPoE sessions disconnects

Mon Oct 02, 2017 11:29 am

Facing same issue here as well
same as what? do you use 'action=masquerade'?
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
aacable
Member
Member
Posts: 425
Joined: Wed Sep 17, 2008 11:58 am
Location: ISLAMIC Republic of PAKISTAN
Contact:

Re: High CPU load when PPPoE sessions disconnects

Mon Oct 02, 2017 1:39 pm

Yes Masquerade and Routing both in one box.
Scenario is something like below ...
4 wan dsl links configured with PCC using SRC-ADDRESS approach. for specific group of users.
1 wan link for public ip users routing. for users with public ips.
_____________
Regard's

Syed Jahanzaib
Web: http://aacable.wordpress.com
Email: aacable [at] hotmail.com
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8320
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: High CPU load when PPPoE sessions disconnects

Mon Oct 02, 2017 1:56 pm

So if you have the same issue, then the solution should also be the same: viewtopic.php?p=620765#p620765
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
aacable
Member
Member
Posts: 425
Joined: Wed Sep 17, 2008 11:58 am
Location: ISLAMIC Republic of PAKISTAN
Contact:

Re: High CPU load when PPPoE sessions disconnects

Mon Oct 02, 2017 2:30 pm

So if you have the same issue, then the solution should also be the same: viewtopic.php?p=620765#p620765
Noted. I saw that later. Will test it.
_____________
Regard's

Syed Jahanzaib
Web: http://aacable.wordpress.com
Email: aacable [at] hotmail.com
 
rsvieira
just joined
Posts: 1
Joined: Tue Oct 03, 2017 4:29 pm

Re: High CPU load when PPPoE sessions disconnects

Tue Oct 03, 2017 4:34 pm

Hello, we have the same problem, using SRC and not MASQUERADE. Already we see our architecture and we are not finding problem. In a box with 1000 session when falls between 100 or 200 session, falls all the routing and tunnels, CPU rises to 90 / 95%.
 
User avatar
ViREnG
Member Candidate
Member Candidate
Posts: 217
Joined: Tue Aug 11, 2009 4:01 pm
Location: Yekaterinburg

Re: High CPU load when PPPoE sessions disconnects

Sat Oct 07, 2017 1:33 pm

I have the same problem , and don't using any masquerade .

My pppoe clients are connected via VPLS and each vpls handle about 100~200 client and if one of them disconnect because of network fault , CPU will increase to 100% usage and freeze router .

ROS : 6.38.7
Devices : 3x CCR1036
Each Device handle about 1K PPPoE Client

* If I disable the connection tracking , problem will solve but then I can't use src-nat .

cpu_usage_pppoe_disconnect.png
anybody know what's the problem ?
You do not have the required permissions to view the files attached to this post.
 
User avatar
ViREnG
Member Candidate
Member Candidate
Posts: 217
Joined: Tue Aug 11, 2009 4:01 pm
Location: Yekaterinburg

Re: High CPU load when PPPoE sessions disconnects

Sat Oct 07, 2017 4:59 pm

..
..
..
..
..
..
..
Hi, guys, take a look :)
Image
 
mducharme
Trainer
Trainer
Posts: 878
Joined: Tue Jul 19, 2016 6:45 pm

Re: High CPU load when PPPoE sessions disconnects

Sat Oct 07, 2017 11:55 pm

anybody know what's the problem ?
Are your clients using public IPs or private?

If your clients are on public IPs for the most part, you can have connection tracking turned off for some things and on for other things, controlling that with the Raw table.

If your clients are on private IPs, a good workaround might be to do the NAT on a separate router rather than the same device.
 
User avatar
ViREnG
Member Candidate
Member Candidate
Posts: 217
Joined: Tue Aug 11, 2009 4:01 pm
Location: Yekaterinburg

Re: High CPU load when PPPoE sessions disconnects

Sun Oct 08, 2017 7:40 am

anybody know what's the problem ?
If your clients are on public IPs for the most part, you can have connection tracking turned off for some things and on for other things, controlling that with the Raw table.
.
:D Yes , Yes :)
I must using action notrack ?
is it enough ?
/ip firewall raw
add action=notrack chain=prerouting src-address-list=public_pools
 
mducharme
Trainer
Trainer
Posts: 878
Joined: Tue Jul 19, 2016 6:45 pm

Re: High CPU load when PPPoE sessions disconnects

Sun Oct 08, 2017 7:51 am

anybody know what's the problem ?
If your clients are on public IPs for the most part, you can have connection tracking turned off for some things and on for other things, controlling that with the Raw table.
.
:D Yes , Yes :)
I must using action notrack ?
is it enough ?
/ip firewall raw
add action=notrack chain=prerouting src-address-list=public_pools
Yes, also note that if you want some contents of your public_pools to still be processed by connection tracking, you can "accept" that traffic above the notrack rule, accepted traffic is still processed by the main firewall as well, so accept doesn't mean "I trust this", it means "I want to track this"
 
User avatar
ViREnG
Member Candidate
Member Candidate
Posts: 217
Joined: Tue Aug 11, 2009 4:01 pm
Location: Yekaterinburg

Re: High CPU load when PPPoE sessions disconnects

Sun Oct 08, 2017 8:09 am

Still have some connection with destination address of my public pools .
Do I need to turn of to dst-address of my public pools too ?
 
mducharme
Trainer
Trainer
Posts: 878
Joined: Tue Jul 19, 2016 6:45 pm

Re: High CPU load when PPPoE sessions disconnects

Sun Oct 08, 2017 8:12 am

Still have some connection with destination address of my public pools .
Do I need to turn of to dst-address of my public pools too ?
Yes probably.
 
User avatar
ViREnG
Member Candidate
Member Candidate
Posts: 217
Joined: Tue Aug 11, 2009 4:01 pm
Location: Yekaterinburg

Re: High CPU load when PPPoE sessions disconnects

Sun Oct 08, 2017 8:56 am

@mducharme Thanks , Problem Solved.
 
ntmanxp
just joined
Posts: 21
Joined: Fri Feb 15, 2008 9:04 pm

Re: High CPU load when PPPoE sessions disconnects

Sat Dec 30, 2017 3:56 pm

Hi There

I was facing same problem.
I did 'no track' rule for both src address and dst address with the public ip pools.
No OSPF, no other routing protocols than the ones involved in PPP concentrator. Radius is authenticating users.
No using masquerading, just src-nat in case of the public IP pools get full, and yielding to private ones.
In case of private pools, the NAT is doing it with src-nat.

But anyway, If a do select for example 25 sessions, all public ip pool for example, and hit the disconnect, the CPU raises close to 90/95%, and the profile shows that firewall is taking most of it.
It tooks about 10/15 seconds to decrease to normal state.

In case of power blackout, then got massive disconnects. This cause a long time high cpu usage.
Then, the LCP echo of the PPP server got many timeouts of actual and running sessions ( the lucky ones with energy at home ), which leads to more disconnects for 'peer is not responding', which raise CPU usage, and this cause more 'peer is not responding'...and you can imagine the movie, right? Snowball!!!

If someone got an idea, I'll be glad to hear it.

Regards

Andres.-
 
User avatar
tomaskir
Trainer
Trainer
Posts: 1122
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: High CPU load when PPPoE sessions disconnects

Sat Dec 30, 2017 4:01 pm

Just DO NOT use NAT on any routers that have high number of connecting/disconnecting interfaces.

Use basic networking principle of 'separation of concerns'.
Each device in your network should be responsible for one function - don't mix too many things into one device.

Place an additional router "in front" of the PPPoE concentrator, and do NAT there.
Problem solved.
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
ntmanxp
just joined
Posts: 21
Joined: Fri Feb 15, 2008 9:04 pm

Re: High CPU load when PPPoE sessions disconnects

Sat Dec 30, 2017 5:31 pm

Hi Tomaskir
I do not have option to have more public IPs to give.
More users than available public IPs.
So must give them private IPs and NAT'em to navigate.

Besides, if you read the post, even with PUBLIC IP POOLs disconnects ( 25 at once for example), the CPU raises to the top.
NO matter if public pool, private pool, the CPU hit 100% on 20+ disconnects.
Although i'll like, no way to control the electricity of the town. So no way to control massive disconnects. :(

By this point of view, if the public IP disconnection raise CPU to 90/100%, no sense to add a point of failure natting between the router and the ppp concentrator.
First, the CPU raise must be close to zero, then I can think to solve nat.

Regards

Andres-.
 
User avatar
tomaskir
Trainer
Trainer
Posts: 1122
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: High CPU load when PPPoE sessions disconnects

Sat Dec 30, 2017 6:46 pm

It doesn't matter if the user has public or private IP, it's about interfaces.

When interfaces connect/disconnect, with combination with NAT, it gives you high CPU usage.
So simply eliminate NAT from that router.

Have a separate router "in front" of the PPPoE concentrator, that NATs the traffic from the private IPs.
Setup routing (even static routes) between the PPPoE concentrator and the new router.
Terminate public and private IPs on the PPPoE concentrator.

That way, you will not have CPU usage issues.
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
n21roadie
Forum Guru
Forum Guru
Posts: 1896
Joined: Fri Aug 07, 2009 10:36 pm
Location: Limerick,Ireland

Re: High CPU load when PPPoE sessions disconnects

Sat Dec 30, 2017 7:21 pm

If you are using Masquarade on the router, that is the problem.
When using Masquarade, RouterOS has to do full connection tracking recalculation on EACH interface connect/disconnect.

So if you have lots of PPPoE session connecting/disconnecting, connection tracking will constantly be recalculated which will can high CPU usage.

Solution:
Stop using Masquarade on routers that have a lot of dynamic interfaces.
Either use srcnat, or fix your architecture (use routing).
Just curious - if static interfaces were also disconnecting/reconnecting would this also result in high CPU usage by connection tracking ?
Also if dynamic interfaces use more resources than static, is it possible to set PPPoE client interfaces as static?
 
User avatar
tomaskir
Trainer
Trainer
Posts: 1122
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: High CPU load when PPPoE sessions disconnects

Sun Dec 31, 2017 12:12 am

Any interface connecting/disconnecting - does not matter if dynamic or static.
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
User avatar
sebastia
Forum Guru
Forum Guru
Posts: 1796
Joined: Tue Oct 12, 2010 3:23 am
Location: Antwerp, BE

Re: High CPU load when PPPoE sessions disconnects

Sun Dec 31, 2017 2:30 am

 
deansouwit1996
just joined
Posts: 1
Joined: Thu Jan 04, 2018 12:01 pm

Re: High CPU load when PPPoE sessions disconnects

Thu Jan 04, 2018 12:06 pm

Hi all..

My clients make use of a basic Mikrotik to PoE to Radio setup , however when viewing the logs on our NAS\High-Site, we notice that an error keeps appearing, it connects, then terminates and says "Peer not responding"
any idea as to what would cause this issue ?
 
ntmanxp
just joined
Posts: 21
Joined: Fri Feb 15, 2008 9:04 pm

Re: High CPU load when PPPoE sessions disconnects

Thu Jan 04, 2018 8:06 pm

Hi Tomaskir

Well, I did setup an CCR as NAT Server, doing all the stuff instead of doing it on PPPoE Concentrator.
Besides some turnarounds I did to solve misconfigured/hijacked DNS natting, and issues like that ( finally solved with mangle and routing mark ), finally disabled every ip-Firewall-NAT rule, and the disconnection ( tested with 900 sessions, public and private IPs ) worked like a charm.
CPU even notice the hit.
Radius ate 900 requests, and soon reconnected more than 600 sessions ( other absorbed by other PPP Concentrators ).

So, thanks all

Regards

Andres.-
 
jimi
just joined
Posts: 1
Joined: Sat Jan 06, 2018 2:15 am

Re: High CPU load when PPPoE sessions disconnects

Sat Jan 06, 2018 2:22 am

Hi ntmanxp ,
I have the same problem with PPPoE disconnects , can you show me how did you configured CCR as NAT Server and other CCR as PPPoE Concentrator ?
thnx
 
ntmanxp
just joined
Posts: 21
Joined: Fri Feb 15, 2008 9:04 pm

Re: High CPU load when PPPoE sessions disconnects

Tue Jan 09, 2018 9:45 pm

HI there!

In the NAT server just added the IP address to be on the WAN side, and the IP address to be on the LAN side, paying attention of the mask to cover the network to be natted.
Then, adding the src-nat rules to do the thing.

/ip address
add address=181.xxx.yyy.235/24 comment="--- PPP1 ---" interface=WAN10 network=181.xxx.yyy.0
add address=172.221.1.1/16 comment="--- PPP1 Privada ---" interface=WAN10 network=172.221.0.0
#
/ip firewall nat
add action=src-nat chain=srcnat comment="--- Nateo PPP1 Privadas ---" src-address=172.21.0.0/20 to-addresses=181.xxx.yyy.235

Then on each PPP Server, uncomment every NAT rule. Then:

/ip firewall mangle
add action=mark-routing chain=prerouting comment="--- Envío IPs-PRIVADAS al SVR-NAT ---" new-routing-mark=SVR-NAT passthrough=no src-address-list=IPs_Privadas

/ip route
add distance=1 gateway=181.xxx.yyy.235 routing-mark=SVR-NAT

This way, marking the routing to be natted, points to the NAT Server.
Wich do the NAT to the PPP Concentrator.
Both NAT an PPP on same WAN segment.

Regards
 
cicserver
Member
Member
Posts: 300
Joined: Sun Jul 24, 2011 12:04 pm

Re: High CPU load when PPPoE sessions disconnects

Thu Jan 11, 2018 6:12 am

Following is my current scenario. only 1 CCR which is configured as PPPoE Server. it have public ip interface and few dsl links too.
So all is running in one box. I am using mark routing to distinguish users , like if user have private ip he will nat via dsl, and if he has public ip, he will go via default route of public. now when pppoe users disconnects the CPU touches to 90-100, I understand its dueto interface status change, how can I introduce 2nd Mikrotik so that all natting should go there?
ccr.png
You do not have the required permissions to view the files attached to this post.
 
User avatar
aacable
Member
Member
Posts: 425
Joined: Wed Sep 17, 2008 11:58 am
Location: ISLAMIC Republic of PAKISTAN
Contact:

Re: High CPU load when PPPoE sessions disconnects

Sat Jan 13, 2018 3:20 pm

@cicserver

I would suggest to mark private ip series and then make a route so they should ROUTE to 2nd router, where NAT will happen. you may need to create reverse route on 2nd router as well so communications between subnet works fine,
_____________
Regard's

Syed Jahanzaib
Web: http://aacable.wordpress.com
Email: aacable [at] hotmail.com
 
rocknight13
newbie
Posts: 45
Joined: Sun Dec 25, 2011 8:08 pm
Location: Iraq
Contact:

Re: High CPU load when PPPoE sessions disconnects

Sun Feb 11, 2018 1:59 pm

If you are using Masquarade on the router, that is the problem.
When using Masquarade, RouterOS has to do full connection tracking recalculation on EACH interface connect/disconnect.

So if you have lots of PPPoE session connecting/disconnecting, connection tracking will constantly be recalculated which will can high CPU usage.

Solution:
Stop using Masquarade on routers that have a lot of dynamic interfaces.
Either use srcnat, or fix your architecture (use routing).
can you please give us how we can do that I am facing same problem
assume this
ISP--->Switch----->Real IP:Radius Server
------>Real IP:CCR1036(PPPOEserver---->NAT---->)EndUser
Where I have to add NAT server and how to configer it to work with PPPOE Server

Real IP:for Radius and CCR1036 with 212.XX.YY.ZZ/26
EndUserIP:172.18.255.0/16
Thanks in advance
regards
 
abaidwellnet
just joined
Posts: 3
Joined: Wed Jul 29, 2015 7:31 pm

Re: High CPU load when PPPoE sessions disconnects

Thu Mar 15, 2018 9:29 am

It doesn't matter if the user has public or private IP, it's about interfaces.

When interfaces connect/disconnect, with combination with NAT, it gives you high CPU usage.
So simply eliminate NAT from that router.

Have a separate router "in front" of the PPPoE concentrator, that NATs the traffic from the private IPs.
Setup routing (even static routes) between the PPPoE concentrator and the new router.
Terminate public and private IPs on the PPPoE concentrator.

That way, you will not have CPU usage issues.

Can Some One Explain Whole Situation with Configuration Guide... Because we also right now facing same problem...
 
abaidwellnet
just joined
Posts: 3
Joined: Wed Jul 29, 2015 7:31 pm

Re: High CPU load when PPPoE sessions disconnects

Thu Mar 15, 2018 9:35 am

We Setup Last month 1 CCR 1036 12G-4S
With load balancing or Natting in same Router...
Problem just Connecting or disconnecting PPPoE clients cause Cpu usages High 100%...

Now Yesterday we Purchase another CCR 1036 12G-4s...
We do not understanding how we do natting or load balancing in 2nd router...Or PPPOE users in 1st Router...


Can some Give Us Configurations with any Ip Series So we can adjust them with our Network...
Thanks...
 
sindy
Forum Guru
Forum Guru
Posts: 4197
Joined: Mon Dec 04, 2017 9:19 pm

Re: High CPU load when PPPoE sessions disconnects

Fri Mar 16, 2018 11:56 pm

We Setup Last month 1 CCR 1036 12G-4S
With load balancing or Natting in same Router...
Problem just Connecting or disconnecting PPPoE clients cause Cpu usages High 100%...

Now Yesterday we Purchase another CCR 1036 12G-4s...
We do not understanding how we do natting or load balancing in 2nd router...Or PPPOE users in 1st Router...


Can some Give Us Configurations with any Ip Series So we can adjust them with our Network...
Thanks...
Have you read the previous posts of this topic above? Especially, have you noticed that most likely the use of masquerade to do src-nat is the reason of the problem? Are the addresses you get via PPPoE static or do they change over time?
Instead of writing novels, post /export hide-sensitive. Use find&replace in your favourite text editor to systematically replace all occurrences of each public IP address potentially identifying you by a distinctive pattern such as my.public.ip.1.
 
Kusaybia001
just joined
Posts: 2
Joined: Fri Apr 13, 2018 11:45 am

Re: High CPU load when PPPoE sessions disconnects

Fri Apr 13, 2018 12:04 pm

Also I face this problem terminating disconnecting peer is not responding

not in all routers
can any one help me?
 
rini
Frequent Visitor
Frequent Visitor
Posts: 76
Joined: Wed Sep 22, 2010 1:28 am

Re: High CPU load when PPPoE sessions disconnects

Mon Aug 27, 2018 2:00 pm

Hi

I was getting the same problem and I do NAT in different CCR and pppoe server in another CCR. All is fine but i have some problems to ping mikrotik devices behind pppoe server


I have a CCR1036-8G-2S+ configured it as pppoe server. Pppoe Clients are ok with ip range 10.10.0.0/24
On the interface that is pppoe server i have some CRS, Access point Mikrotik, AP UBIQUITI. (all those are in ip range 10.20.22.0/24)

example MIKROTIK AP 10.20.22.55 or 10.20.22.56 , UBIQUITI AP 10.20.22.65 or 10.20.22.66

I have a route where I route all this to nat server. I dont do mangle here or nat or filter. in nat section i have nothing

In route section is:

dst-address=0.0.0.0/0 gateway=NAT IP

On this pppoe server i can ping all my devivces mikrotik ap or ubiquiti. I can manage from here with telnet and ssh

Problem.

A client connected here to this pppoe server is getting ip 10.10.0.2. All is ok.

I Do traceroute www.google.com and it is shown

hop1: 192.168.2.1 internal ip of client router
hop2: 10.10.0.1
hop3: NAT IP
hop4: Gateway of my ISP Provider
......
......
.........GOOGLE IP

Internet is all ok on all ppppoe clients

But if i want to manage an Access point in my network i can only manage Ubiquity.
When i ping from client side i can ping ubiquiti but cant ping mikrotik devices.

I do traceroute from client and I get
for ubiquiti
Hop 1: 10.10.0.1
Hop 2: 10.20.22.65

for Mikrotik
Hop 1: 10.10.0.1
Hop 2: Timeout

But from this client i can ping all the other clients that have mikrotik cpe or other devices

Problem 2:

On the NAT side. I have only a firewall (masquerade). I dont have any filters or mangle. Nothing only masquerade.

In the route section i have the default gateway of my isp and static routes to see pppoe clients directly and static route for my ap

static route are

dst-address=0.0.0.0/0 gateway=ISP Gateway
dst-address=10.10.0.0/24 gateway=PPPOE SERVER IP
dst-address=10.20.22.0/24 gateway=PPPOE SERVER IP

I can ping all clients. when i want to ping my Access Points that are behind pppoe server I can ping and manage only ubiquity. I cant ping and manage mikrotik devices..



What i am missing ?

Best Regards
 
mkx
Forum Guru
Forum Guru
Posts: 3357
Joined: Thu Mar 03, 2016 10:23 pm

Re: High CPU load when PPPoE sessions disconnects

Mon Aug 27, 2018 2:11 pm

I'd say check FW rules on those Mikrotik devices.
BR,
Metod
 
rini
Frequent Visitor
Frequent Visitor
Posts: 76
Joined: Wed Sep 22, 2010 1:28 am

Re: High CPU load when PPPoE sessions disconnects

Mon Aug 27, 2018 9:56 pm

I'd say check FW rules on those Mikrotik devices.
Those are all configured in bridge mode.
I have created a bridge and put all ports to that bridge. There are no firewall at all

Do i have to create forward rules for icmp ??
 
sindy
Forum Guru
Forum Guru
Posts: 4197
Joined: Mon Dec 04, 2017 9:19 pm

Re: High CPU load when PPPoE sessions disconnects

Mon Aug 27, 2018 11:01 pm

Do these Mikrotik devices have any route configured on them? I.e. do they know where to send the icmp response?
Instead of writing novels, post /export hide-sensitive. Use find&replace in your favourite text editor to systematically replace all occurrences of each public IP address potentially identifying you by a distinctive pattern such as my.public.ip.1.
 
rini
Frequent Visitor
Frequent Visitor
Posts: 76
Joined: Wed Sep 22, 2010 1:28 am

Re: High CPU load when PPPoE sessions disconnects

Mon Aug 27, 2018 11:13 pm

Do these Mikrotik devices have any route configured on them? I.e. do they know where to send the icmp response?
No. they dont have any firewall. Is only a bridge on ap

/interface bridge
add mtu=1500 name=bridge1 protocol-mode=none
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=wlan1

/ip address
add address=192.168.200.2/30 interface=bridge1 network=192.168.200.0
 
sindy
Forum Guru
Forum Guru
Posts: 4197
Joined: Mon Dec 04, 2017 9:19 pm

Re: High CPU load when PPPoE sessions disconnects

Mon Aug 27, 2018 11:18 pm

If they have no route, you can only access/ping them from their own subnet. They will bridge any traffic on L2, but if they have to send a packet anywhere outside 192.168.200.0/30, they need a route.
Instead of writing novels, post /export hide-sensitive. Use find&replace in your favourite text editor to systematically replace all occurrences of each public IP address potentially identifying you by a distinctive pattern such as my.public.ip.1.
 
rini
Frequent Visitor
Frequent Visitor
Posts: 76
Joined: Wed Sep 22, 2010 1:28 am

Re: High CPU load when PPPoE sessions disconnects

Mon Aug 27, 2018 11:23 pm

If they have no route, you can only access/ping them from their own subnet. They will bridge any traffic on L2, but if they have to send a packet anywhere outside 192.168.200.0/30, they need a route.
Thanks for fast response.

can you write me an example how to add route there ?
 
rini
Frequent Visitor
Frequent Visitor
Posts: 76
Joined: Wed Sep 22, 2010 1:28 am

Re: High CPU load when PPPoE sessions disconnects

Mon Aug 27, 2018 11:29 pm

If they have no route, you can only access/ping them from their own subnet. They will bridge any traffic on L2, but if they have to send a packet anywhere outside 192.168.200.0/30, they need a route.
thank you.

problem solved
like you said.

they needed a route.

Now i can access them.
 
sindy
Forum Guru
Forum Guru
Posts: 4197
Joined: Mon Dec 04, 2017 9:19 pm

Re: High CPU load when PPPoE sessions disconnects

Mon Aug 27, 2018 11:31 pm

/ip route add dst-address=0.0.0.0/0 gateway=192.168.200.1 (the other IP address in the only connected subnet which hopefully is a device closer to the machine from which you ping).
Instead of writing novels, post /export hide-sensitive. Use find&replace in your favourite text editor to systematically replace all occurrences of each public IP address potentially identifying you by a distinctive pattern such as my.public.ip.1.
 
okoun
Frequent Visitor
Frequent Visitor
Posts: 98
Joined: Fri Feb 18, 2011 3:11 pm

Re: High CPU load when PPPoE sessions disconnects

Thu Dec 13, 2018 2:14 pm

It doesn't matter if the user has public or private IP, it's about interfaces.

When interfaces connect/disconnect, with combination with NAT, it gives you high CPU usage.
So simply eliminate NAT from that router.

Have a separate router "in front" of the PPPoE concentrator, that NATs the traffic from the private IPs.
Setup routing (even static routes) between the PPPoE concentrator and the new router.
Terminate public and private IPs on the PPPoE concentrator.

That way, you will not have CPU usage issues.
Masquerade is not a problem.
Generally, NAT is a problem.
Is there any rule exactly what makes the problem?
Should not Mikrotik exclude the dynamic interface to any exception, so that adding / removing does not affect the connection table in the firewall?

Separate pppoe and NAT solutions are nice but need to buy HW hard drives unnecessarily.
 
josueflat
just joined
Posts: 1
Joined: Fri Feb 01, 2013 1:07 am
Contact:

Re: High CPU load when PPPoE sessions disconnects

Mon Jan 14, 2019 6:48 pm

I think this problem appeared in some recent versions of ROS.
It definitely exists on 6.35.4 and 6.38.1.

When we have network outages, some PPPoE sessions are disconnecting with 'peer not responding' errors.
In this moments CCR CPUs are 100% utilised, so than router almost stop passing any traffic.

This can continue for some minutes. Router looses OSPF neighbors, and it's all becomes a catastrophe!
It number of disconnecting sessions is over 200-300 it collapses 100%.

Seeing this on several different CCRs.
I have de same Problem In CCR1072 V6.43.8
 
AVA
just joined
Posts: 21
Joined: Mon Jun 18, 2018 6:19 pm

Re: High CPU load when PPPoE sessions disconnects

Wed Jan 16, 2019 4:02 pm

We have also the same problem. I changed all masquerade rules to src nat rules but the CCR1036 (pppoe server with ~1000 sessions) went down again, when the router lost ~200 sessions due to a failing link... I decided to build up a ospf system with redundant pppoe server (2 routers without connection tracking) + 2 routers for bgp with connection tracking.
 
User avatar
vipnet
newbie
Posts: 26
Joined: Sat Jul 20, 2013 9:27 pm
Location: Brazil

Re: High CPU load when PPPoE sessions disconnects

Sun Oct 06, 2019 4:15 am

The problem is queue use 100% cpu please fix
Alex Endres.
VIPNET TELECOM LTDA - MONTENEGRO-RS/BRASIL

https://bmspanel.bmsoftware.org/parceir ... 95dd/0/N/N

Who is online

Users browsing this forum: No registered users and 119 guests