Community discussions

MikroTik App
 
User avatar
Antixx
Member Candidate
Member Candidate
Topic Author
Posts: 100
Joined: Mon Jun 26, 2006 9:46 am

Limit Bandwidth for 64 user> IMPORTANT

Wed Feb 21, 2007 8:54 pm

if i have all 2048 kbps and i have 64 user in my network. How to set users with CIR=32kbps MIR=64kbps Burst=512kbps, it is not the way create 64 simple queues and 1 parent, isnt it?

by the way PCQ is not working good because when user want to download then he/she can not login to yahoo messenger , etc... and has no burst...

PLEASE IF ANYBODY KNOW LET ME KNOW?
 
Diganet
Member
Member
Posts: 349
Joined: Sun Oct 30, 2005 9:30 pm
Location: Denmark
Contact:

Re: Limit Bandwidth for 64 user> IMPORTANT

Thu Feb 22, 2007 1:44 am

if i have all 2048 kbps and i have 64 user in my network. How to set users with CIR=32kbps MIR=64kbps Burst=512kbps, it is not the way create 64 simple queues and 1 parent, isnt it?

by the way PCQ is not working good because when user want to download then he/she can not login to yahoo messenger , etc... and has no burst...

PLEASE IF ANYBODY KNOW LET ME KNOW?
PCQ works fine if you set up priorisation on the global in/out as parent and mangle your apps and then make queues with different priorities

/Henrik
 
ashisheitl
Member Candidate
Member Candidate
Posts: 119
Joined: Fri Dec 01, 2006 10:33 am

Thu Feb 22, 2007 5:22 am

Henrik is Right,

PCQ should work fine in your case.

Try it.

ASHISH.
 
User avatar
Antixx
Member Candidate
Member Candidate
Topic Author
Posts: 100
Joined: Mon Jun 26, 2006 9:46 am

Re: Limit Bandwidth for 64 user> IMPORTANT

Thu Feb 22, 2007 3:55 pm

if i have all 2048 kbps and i have 64 user in my network. How to set users with CIR=32kbps MIR=64kbps Burst=512kbps, it is not the way create 64 simple queues and 1 parent, isnt it?

by the way PCQ is not working good because when user want to download then he/she can not login to yahoo messenger , etc... and has no burst...

PLEASE IF ANYBODY KNOW LET ME KNOW?
PCQ works fine if you set up priorisation on the global in/out as parent and mangle your apps and then make queues with different priorities

/Henrik

As u can see in my old message:
by the way PCQ is not working good because when user want to download then he/she can not login to yahoo messenger , etc... and has no burst...

what do u mean? could you please explain more about your recommended solution?
 
Diganet
Member
Member
Posts: 349
Joined: Sun Oct 30, 2005 9:30 pm
Location: Denmark
Contact:

Re: Limit Bandwidth for 64 user> IMPORTANT

Fri Feb 23, 2007 11:41 am

if i have all 2048 kbps and i have 64 user in my network. How to set users with CIR=32kbps MIR=64kbps Burst=512kbps, it is not the way create 64 simple queues and 1 parent, isnt it?

by the way PCQ is not working good because when user want to download then he/she can not login to yahoo messenger , etc... and has no burst...

PLEASE IF ANYBODY KNOW LET ME KNOW?
PCQ works fine if you set up priorisation on the global in/out as parent and mangle your apps and then make queues with different priorities

/Henrik

As u can see in my old message:
by the way PCQ is not working good because when user want to download then he/she can not login to yahoo messenger , etc... and has no burst...

what do u mean? could you please explain more about your recommended solution?
If you imagine a PCQ queue that equally shares bandwith. In that queue you can set up different priorities for different kind of traffic, so that for example VOIP and MSN always takes precedence over other kinds of traffic and therefore always gets through. In your situation it would make Yahoo messenger work even if the users are filling up the lines with big downloads..

/Henrik
 
User avatar
Antixx
Member Candidate
Member Candidate
Topic Author
Posts: 100
Joined: Mon Jun 26, 2006 9:46 am

I think u didnt get my target.

Fri Feb 23, 2007 6:14 pm

thanks for your attention, I think u didnt get my target.

group of users with:
======
CIR=8kbps
MIR=128kbps
Burst= 256kbps
======
in a group with 256kbps Bandwidth,
when users is more than 8 for example 256 users,
any way to set rule above without create simple queue for each user? PCQ is not good i am not satisfied, SFQ is better i think, it work fine in situation create a simple queue for each user,
Please let me know how can i create fast tree.
 
User avatar
chvdr
Member
Member
Posts: 403
Joined: Thu Sep 22, 2005 8:53 pm

Fri Feb 23, 2007 10:58 pm

Hi,
you can use an equal limitation for all users, but the better way is to use hotspot with bandwidth limitations for all users. Then users can have different profiles and so on...
It's easy and it works fine.
Regards,
C. G.
 
User avatar
marksx
Member Candidate
Member Candidate
Posts: 109
Joined: Sat Jun 26, 2004 9:56 pm
Location: POLAND

Sat Feb 24, 2007 2:40 am

the best method is to use queue trees for example (orginally from my atricle http://www.cyberbajt.com.pl/cyber.php?get=raport,65,4 - sorry but only in polish now...) :

interfaces Lan & Internet are bridged

Packet mark for upload:
you'll need to copy these to system scripts and run them to generate rules
:for x from 2 to 254 do={ /ip firewall mangle add chain=prerouting
src-address=(192.168.0. . $x ) action=mark-packet
new-packet-mark=( $x . upload ) passthrough=no }
Packet mark for download:
:for x from 2 to 254 do={ /ip firewall mangle add chain=postrouting 
dst-address=(192.168.0. . $x ) action=mark-packet 
new-packet-mark=( $x . download ) passthrough=no }
New queue type
/queue type add name="sfq" kind=sfq sfq-perturb=5 sfq-allot=1514

Main parent queue 4 download (assuming that your LAN interface is named Lan):
/queue tree add name="Download" parent=Lan queue=sfq max-limit=1730k
... and for upload...
(assuming that your WAN interface is named Internet ):
/queue tree add name="Upload" parent=Internet queue=sfq max-limit=1730k
script for download queues
:for z from 2 to 254 do={ /queue tree add parent=Download
packet-mark=( $z . download ) limit-at=32000 queue=sfq 
priority=7 max-limit=256000 }

script for upload queues
:for b from 2 to 254 do={ /queue tree add parent=Upload 
packet-mark=( $b . upload ) limit-at=32000 queue=sfq 
priority=7 max-limit=220000 }

And if you will copy&paste (removing non requied addional spaces) all you should have worinkg BM for 192.168.0.2 to 192.168.254 addresses

with 256Kbits MIR (maximum), 32Kbits CIR (guaranteed)


of course that the veeeeery simple BM, if you're interested with some more adv. configuration please email me m.burzynski @ cyberbajt.pl

Or write here ew can think something out
Mikrotik Certifird Teacher - High Performance Wireless Networks Administrator
Contact: marek (at) prowireless.pl
 
User avatar
Antixx
Member Candidate
Member Candidate
Topic Author
Posts: 100
Joined: Mon Jun 26, 2006 9:46 am

My Config

Sun Feb 25, 2007 7:11 am

Please see my Config n tell me your idea, by seeing my config i think u will found what i want to do.
short explaination of waht i want,
group every 8 or 16 users,
for example 256kbps bandwidth for 32 users with 8kbps CIR and 64kbps MIR, that mean if every 32 users want to use bandwidth every one have own 8kbps if not user can have up to 64kbps and burst to 256k,
and head group (group64 with their 8 simple queue) even have 256 CIR and 512kbps MIR that mean if any bandwith is empty, group use BW up to 512kbps,
I hope u can clearly understand my target, and i am sure every administrator of network want to do this, for qos

#
/ queue simple
add name="dialup1" target-addresses=216.16.12.0/24 dst-address=0.0.0.0/0 interface=Dialup \
parent=Root direction=both priority=1 queue=wireless-default/wireless-default \
limit-at=704000/704000 max-limit=1472000/1472000 total-queue=default-small disabled=no
add name="Dialup2" target-addresses=216.16.13.0/24 dst-address=0.0.0.0/0 interface=Dialup \
parent=Root direction=both priority=7 queue=default-small/default-small \
limit-at=64000/128000 max-limit=256000/256000 burst-limit=512000/512000 \
burst-threshold=256000/256000 burst-time=8s/8s total-queue=default-small disabled=no
add name="Dialup3" target-addresses=216.16.14.0/24 dst-address=0.0.0.0/0 interface=Dialup \
parent=Root direction=both priority=8 queue=wireless-default/wireless-default \
limit-at=64000/64000 max-limit=192000/256000 burst-limit=512000/1408000 \
burst-threshold=256000/256000 burst-time=10s/10s total-queue=default-small disabled=no
add name="Kamran" target-addresses=217.219.177.219/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=IPBased direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=128000/256000 \
burst-limit=128000/256000 burst-threshold=64000/64000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="IPBased" target-addresses=217.219.177.216/29 dst-address=0.0.0.0/0 \
interface=BroadBand parent=Root direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=64000/64000 max-limit=128000/256000 \
burst-limit=192000/512000 burst-threshold=96000/64000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue1" target-addresses=192.168.10.1/32 dst-address=0.0.0.0/0 interface=BroadBand \
parent=64k direction=both priority=8 queue=wireless-default/wireless-default \
limit-at=8000/8000 max-limit=64000/64000 burst-limit=128000/256000 \
burst-threshold=64000/64000 burst-time=8s/8s total-queue=default-small disabled=no
add name="queue2" target-addresses=192.168.10.2/32 dst-address=0.0.0.0/0 interface=BroadBand \
parent=64k direction=both priority=8 queue=wireless-default/wireless-default \
limit-at=8000/8000 max-limit=64000/64000 burst-limit=128000/256000 \
burst-threshold=64000/64000 burst-time=8s/8s total-queue=default-small disabled=no
add name="queue3" target-addresses=192.168.10.3/32 dst-address=0.0.0.0/0 interface=BroadBand \
parent=64k direction=both priority=8 queue=wireless-default/wireless-default \
limit-at=8000/8000 max-limit=64000/64000 burst-limit=128000/256000 \
burst-threshold=64000/64000 burst-time=8s/8s total-queue=default-small disabled=no
add name="queue4" target-addresses=192.168.10.4/32 dst-address=0.0.0.0/0 interface=BroadBand \
parent=64k direction=both priority=8 queue=wireless-default/wireless-default \
limit-at=8000/8000 max-limit=64000/64000 burst-limit=128000/256000 \
burst-threshold=64000/64000 burst-time=8s/8s total-queue=default-small disabled=no
add name="queue5" target-addresses=192.168.10.5/32 dst-address=0.0.0.0/0 interface=BroadBand \
parent=64k direction=both priority=8 queue=wireless-default/wireless-default \
limit-at=8000/8000 max-limit=64000/64000 burst-limit=128000/256000 \
burst-threshold=64000/64000 burst-time=8s/8s total-queue=default-small disabled=no
add name="queue6" target-addresses=192.168.10.6/32 dst-address=0.0.0.0/0 interface=BroadBand \
parent=64k direction=both priority=8 queue=wireless-default/wireless-default \
limit-at=8000/8000 max-limit=64000/64000 burst-limit=128000/256000 \
burst-threshold=64000/64000 burst-time=8s/8s total-queue=default-small disabled=no
add name="queue7" target-addresses=192.168.10.7/32 dst-address=0.0.0.0/0 interface=BroadBand \
parent=64k direction=both priority=8 queue=wireless-default/wireless-default \
limit-at=8000/8000 max-limit=64000/64000 burst-limit=128000/256000 \
burst-threshold=64000/64000 burst-time=8s/8s total-queue=default-small disabled=no
add name="queue8" target-addresses=192.168.10.8/32 dst-address=0.0.0.0/0 interface=BroadBand \
parent=64k direction=both priority=8 queue=wireless-default/wireless-default \
limit-at=8000/8000 max-limit=64000/64000 burst-limit=128000/256000 \
burst-threshold=64000/64000 burst-time=8s/8s total-queue=default-small disabled=no
add name="queue9" target-addresses=192.168.10.9/32 dst-address=0.0.0.0/0 interface=BroadBand \
parent=64k direction=both priority=8 queue=wireless-default/wireless-default \
limit-at=8000/8000 max-limit=64000/64000 burst-limit=128000/256000 \
burst-threshold=64000/64000 burst-time=8s/8s total-queue=default-small disabled=no
add name="queue10" target-addresses=192.168.10.10/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=64k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/64000 \
burst-limit=128000/256000 burst-threshold=64000/64000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue11" target-addresses=192.168.10.11/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=64k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/64000 \
burst-limit=128000/256000 burst-threshold=64000/64000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue12" target-addresses=192.168.10.12/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=64k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/64000 \
burst-limit=128000/256000 burst-threshold=64000/64000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue13" target-addresses=192.168.10.13/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=64k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/64000 \
burst-limit=128000/256000 burst-threshold=64000/64000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue14" target-addresses=192.168.10.14/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=64k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/64000 \
burst-limit=128000/256000 burst-threshold=64000/64000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue15" target-addresses=192.168.10.15/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=64k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/64000 \
burst-limit=128000/256000 burst-threshold=64000/64000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue16" target-addresses=192.168.10.16/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=64k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/64000 \
burst-limit=128000/256000 burst-threshold=64000/64000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue17" target-addresses=192.168.10.17/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=64k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/64000 \
burst-limit=128000/256000 burst-threshold=64000/64000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue18" target-addresses=192.168.10.18/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=64k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/64000 \
burst-limit=128000/256000 burst-threshold=64000/64000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue19" target-addresses=192.168.10.19/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=64k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/64000 \
burst-limit=128000/256000 burst-threshold=64000/64000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue20" target-addresses=192.168.10.20/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=64k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/64000 \
burst-limit=128000/256000 burst-threshold=64000/64000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue21" target-addresses=192.168.10.21/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=64k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/64000 \
burst-limit=128000/256000 burst-threshold=64000/64000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue22" target-addresses=192.168.10.22/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=64k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/64000 \
burst-limit=128000/256000 burst-threshold=64000/64000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue23" target-addresses=192.168.10.23/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=64k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/64000 \
burst-limit=128000/256000 burst-threshold=64000/64000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue24" target-addresses=192.168.10.24/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=64k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/64000 \
burst-limit=128000/256000 burst-threshold=64000/64000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue25" target-addresses=192.168.10.25/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=64k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/64000 \
burst-limit=128000/256000 burst-threshold=64000/64000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue26" target-addresses=192.168.10.26/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=64k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/64000 \
burst-limit=128000/256000 burst-threshold=64000/64000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue27" target-addresses=192.168.10.27/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=64k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/64000 \
burst-limit=128000/256000 burst-threshold=64000/64000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue28" target-addresses=192.168.10.28/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=64k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/64000 \
burst-limit=128000/256000 burst-threshold=64000/64000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue29" target-addresses=192.168.10.29/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=64k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/64000 \
burst-limit=128000/256000 burst-threshold=64000/64000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue30" target-addresses=192.168.10.30/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=64k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/64000 \
burst-limit=128000/256000 burst-threshold=64000/64000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue31" target-addresses=192.168.10.31/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=64k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/64000 \
burst-limit=128000/256000 burst-threshold=64000/64000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue32" target-addresses=192.168.10.32/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=64k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/64000 \
burst-limit=128000/256000 burst-threshold=64000/64000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="64k" target-addresses=192.168.10.0/27 dst-address=0.0.0.0/0 interface=BroadBand \
parent=DSL direction=both priority=5 queue=wireless-default/wireless-default \
limit-at=128000/256000 max-limit=256000/512000 burst-limit=512000/1048000 \
burst-threshold=256000/256000 burst-time=8s/8s total-queue=default-small disabled=no
add name="queue33" target-addresses=192.168.10.128/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=128k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/128000 \
burst-limit=128000/256000 burst-threshold=64000/128000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue34" target-addresses=192.168.10.129/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=128k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/128000 \
burst-limit=128000/256000 burst-threshold=64000/128000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue35" target-addresses=192.168.10.130/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=128k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/128000 \
burst-limit=128000/256000 burst-threshold=64000/128000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue36" target-addresses=192.168.10.131/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=128k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/128000 \
burst-limit=128000/256000 burst-threshold=64000/128000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue37" target-addresses=192.168.10.132/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=128k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/128000 \
burst-limit=128000/256000 burst-threshold=64000/128000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue38" target-addresses=192.168.10.133/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=128k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/128000 \
burst-limit=128000/256000 burst-threshold=64000/128000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue39" target-addresses=192.168.10.134/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=128k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/128000 \
burst-limit=128000/256000 burst-threshold=64000/128000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue40" target-addresses=192.168.10.135/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=128k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/128000 \
burst-limit=128000/256000 burst-threshold=64000/128000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="128k" target-addresses=192.168.10.128/29 dst-address=0.0.0.0/0 interface=BroadBand \
parent=DSL direction=both priority=6 queue=wireless-default/wireless-default \
limit-at=64000/128000 max-limit=192000/512000 burst-limit=1048000/1048000 \
burst-threshold=128000/256000 burst-time=5s/5s total-queue=default-small disabled=no
add name="queue41" target-addresses=192.168.10.160/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=256k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/256000 \
burst-limit=128000/512000 burst-threshold=48000/128000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue42" target-addresses=192.168.10.161/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=256k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/128000 \
burst-limit=128000/512000 burst-threshold=64000/96000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue43" target-addresses=192.168.10.162/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=256k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/256000 \
burst-limit=128000/512000 burst-threshold=64000/256000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue44" target-addresses=192.168.10.163/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=256k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/256000 \
burst-limit=128000/512000 burst-threshold=64000/256000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue45" target-addresses=192.168.10.164/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=256k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/256000 \
burst-limit=128000/512000 burst-threshold=64000/256000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue46" target-addresses=192.168.10.165/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=256k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/256000 \
burst-limit=128000/512000 burst-threshold=64000/256000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue47" target-addresses=192.168.10.166/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=256k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/256000 \
burst-limit=128000/512000 burst-threshold=64000/256000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue48" target-addresses=192.168.10.167/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=256k direction=both priority=8 \
queue=wireless-default/wireless-default limit-at=8000/8000 max-limit=64000/256000 \
burst-limit=128000/512000 burst-threshold=64000/256000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="256k" target-addresses=192.168.10.160/29 dst-address=0.0.0.0/0 interface=BroadBand \
parent=DSL direction=both priority=7 queue=wireless-default/wireless-default \
limit-at=64000/128000 max-limit=192000/512000 burst-limit=512000/1408000 \
burst-threshold=256000/256000 burst-time=8s/8s total-queue=default-small disabled=no
add name="queue49" target-addresses=192.168.10.192/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=384k direction=both priority=8 \
queue=default-small/default-small limit-at=8000/8000 max-limit=64000/384000 \
burst-limit=128000/512000 burst-threshold=96000/384000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue50" target-addresses=192.168.10.193/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=384k direction=both priority=8 \
queue=default-small/default-small limit-at=8000/8000 max-limit=64000/384000 \
burst-limit=128000/512000 burst-threshold=96000/384000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue51" target-addresses=192.168.10.194/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=384k direction=both priority=8 \
queue=default-small/default-small limit-at=8000/8000 max-limit=64000/384000 \
burst-limit=128000/512000 burst-threshold=96000/384000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue52" target-addresses=192.168.10.195/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=384k direction=both priority=8 \
queue=default-small/default-small limit-at=8000/8000 max-limit=64000/384000 \
burst-limit=128000/512000 burst-threshold=96000/384000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue53" target-addresses=192.168.10.196/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=384k direction=both priority=8 \
queue=default-small/default-small limit-at=8000/8000 max-limit=64000/384000 \
burst-limit=128000/512000 burst-threshold=96000/384000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue54" target-addresses=192.168.10.197/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=384k direction=both priority=8 \
queue=default-small/default-small limit-at=8000/8000 max-limit=64000/384000 \
burst-limit=128000/512000 burst-threshold=96000/384000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue55" target-addresses=192.168.10.198/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=384k direction=both priority=8 \
queue=default-small/default-small limit-at=8000/8000 max-limit=64000/384000 \
burst-limit=128000/512000 burst-threshold=96000/384000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="queue56" target-addresses=192.168.10.199/32 dst-address=0.0.0.0/0 \
interface=BroadBand parent=384k direction=both priority=8 \
queue=default-small/default-small limit-at=8000/8000 max-limit=64000/384000 \
burst-limit=128000/512000 burst-threshold=96000/384000 burst-time=8s/8s \
total-queue=default-small disabled=no
add name="384k" target-addresses=192.168.10.192/29 dst-address=0.0.0.0/0 interface=BroadBand \
parent=DSL direction=both priority=8 queue=wireless-default/wireless-default \
limit-at=64000/64000 max-limit=128000/384000 burst-limit=196000/512000 \
burst-threshold=128000/384000 burst-time=8s/8s total-queue=default-small disabled=no
add name="DSL" target-addresses=192.168.10.0/24 dst-address=0.0.0.0/0 interface=BroadBand \
parent=Root direction=both priority=8 queue=wireless-default/wireless-default \
limit-at=256000/512000 max-limit=512000/512000 burst-limit=1408000/1408000 \
burst-threshold=512000/512000 burst-time=8s/8s total-queue=default-small disabled=no
add name="Root" dst-address=0.0.0.0/0 interface=all parent=none direction=both \
priority=8 queue=wireless-default/wireless-default limit-at=1408000/1408000 \
max-limit=1470000/1470000 total-queue=default-small disabled=no
add name="Blocked" dst-address=0.0.0.0/0 interface=all parent=none direction=both \
priority=8 queue=default-small/default-small limit-at=0/0 max-limit=4000/4000 \
total-queue=default-small disabled=no
 
User avatar
marksx
Member Candidate
Member Candidate
Posts: 109
Joined: Sat Jun 26, 2004 9:56 pm
Location: POLAND

Sun Feb 25, 2007 8:15 pm

I understand (not everything, because of big mess with these rules) but this situation should be closest to yours:

Image

We have 10Mbits backbone, some business client(s) with guaranteed bandwidth (6Mbits) , plus we have individual coustomers with guaranteed traffic 4Mbits.

But highest load for business ones is between 8 to 16, and on individual beetween 18 to 23, so we can share almost all 10Mbits to business on day and on night - to home users.

All we need to do is to prepare queue tree with parent for all our backbone, then we can setup children queues (business & home) to share 10Mbits among them and add another childrens (with parent to home) to share bandwidth among amount allowed for home ones.


in MT this should look like this:

Image

In this case i've limited individual clients to only 3 of them and only in one direction, but you should catch main idea
 
User avatar
Antixx
Member Candidate
Member Candidate
Topic Author
Posts: 100
Joined: Mon Jun 26, 2006 9:46 am

queue type

Tue Feb 27, 2007 7:20 pm

I understand (not everything, because of big mess with these rules) but this situation should be closest to yours:

Image

We have 10Mbits backbone, some business client(s) with guaranteed bandwidth (6Mbits) , plus we have individual coustomers with guaranteed traffic 4Mbits.

But highest load for business ones is between 8 to 16, and on individual beetween 18 to 23, so we can share almost all 10Mbits to business on day and on night - to home users.

All we need to do is to prepare queue tree with parent for all our backbone, then we can setup children queues (business & home) to share 10Mbits among them and add another childrens (with parent to home) to share bandwidth among amount allowed for home ones.


in MT this should look like this:

Image

In this case i've limited individual clients to only 3 of them and only in one direction, but you should catch main idea
----
Thanks for your idea, it's very good to use little rules for this situation becasue i dont like to use 512 one mangle in my mangle table but it is better to add 100 simple queue which i think has lower load, by the way you didnt talked about what your queue type in your second topology and how you group your customer, ip based or with mangle again ,
nowaday i use hotspot then users logged in to server they get a new range of ip and then we work on IPs and do our bandwidth shaping on IPs to give special quality.
 
Pascal32
just joined
Posts: 1
Joined: Thu Dec 02, 2010 9:47 pm

Re: Limit Bandwidth for 64 user> IMPORTANT

Thu Dec 02, 2010 11:08 pm

I use 10 Mb on Ether an I have 10 clients on Wlan. Please , haw I make good Queues tree ? I have only the Queue simple,
 
User avatar
chvdr
Member
Member
Posts: 403
Joined: Thu Sep 22, 2005 8:53 pm

Re: Limit Bandwidth for 64 user> IMPORTANT

Mon Dec 06, 2010 8:59 am

Hi there! my last post was... 2007. But I saw that there is an interest. I can only say that there are too many things made by MT for a good client management and traffic limitations.

But if you make limit your customer's speed to a fixed speed, you'll lose these customers.

Modern time give us many tools for making not only traffic management, we can make our customers happy that they are our customers.

The only question is "how?". You have to make two things: traffic prioritization and bandwidth limitation. Clients have to share a good amount of traffic, not to be limited to 256k. Id est they have to can use 4-5Mbps, dynamically shared by a queue tree. If you (as a customer) are the only active customer, you have to can use all these 4-5Mbps. If smb else click to open a webpage, his web loading have to start in a moment. And if you download e.g. with uTorrent with your maximum traffic speed, loading of a webpage have to be with high priority and start in a small moment after the click.

The question is still "How?"? This cannot be answered in one word. Read in MT forums, MUM materials. See what a good lessons made Megis for example.

At last, read, read, read! This is the kernel of the business.
--
Best regards,
C. G.

If nothing to say, do not say anything...
All thoughts that have huge effect actually are simple...

Who is online

Users browsing this forum: accesspointkft, alber, arm920t, gergelyaki, jebz and 141 guests