Community discussions

MikroTik App
User avatar
just joined
Topic Author
Posts: 5
Joined: Thu Dec 20, 2018 4:11 pm
Location: Málaga, Spain

Unable to connect to 2.4Ghz

Thu Feb 14, 2019 5:27 pm


I have an office setup with a RB4011iGS+ doing generic office routing as well as CAPsMAN for two cAP ac to cover a fairly small office.

My problem is that I am unable to use 2.4 Ghz wifi. Everything works fine for 5 Ghz clients. For debugging purposes I have set up two SSIDs, one called "company.5g" and one called "company.2g". Any attempt to connect to "company.2g" fails, and "company.5g" works. I have tried from several clients. Currently I get nothing in the log, but I have seen "4-way handshake" errors. Both the mentioned networks use the same security config, though.

See relevant config below (edited for confidentiality):
# feb/14/2019 16:08:55 by RouterOS 6.43.12
# software id = 5XDT-UT6X
# model = RB4011iGS+
# serial number = 
/caps-man channel
add band=5ghz-onlyac name=5g-channel-auto reselect-interval=12h \
add band=2ghz-b/g/n name=2g-channel-auto reselect-interval=12h
/interface bridge
add fast-forward=no name=bridge-clientvpn
add admin-mac=BX::::X8 auto-mac=no name=bridge-internal
add fast-forward=no name=bridge-wifi-internal
add fast-forward=no name=bridge-wifi-public
/interface ethernet
set [ find default-name=ether1 ] name=ether1-wan
set [ find default-name=ether3 ] disabled=yes
set [ find default-name=ether4 ] disabled=yes
set [ find default-name=ether5 ] disabled=yes
set [ find default-name=ether6 ] disabled=yes
set [ find default-name=ether7 ] disabled=yes
set [ find default-name=ether8 ] disabled=yes
set [ find default-name=ether9 ] name=ether9-ap-conference
set [ find default-name=ether10 ] name=ether10-ap-entrance poe-out=off
set [ find default-name=sfp-sfpplus1 ] disabled=yes
/interface pppoe-client
add add-default-route=yes disabled=no interface=ether1-wan name=\
    wan-xx-fiber user=xx@xx
/caps-man datapath
add bridge=bridge-internal client-to-client-forwarding=yes name=\
add bridge=bridge-wifi-public client-to-client-forwarding=no name=\
/caps-man security
add authentication-types=wpa2-psk name=companyinternal-security
add authentication-types=wpa2-psk name=companypublic-security
add authentication-types=wpa2-eap eap-methods=passthrough \
    eap-radius-accounting=yes encryption=aes-ccm group-encryption=aes-ccm \
/caps-man configuration
add channel=2g-channel-auto country=spain datapath=internal-datapath mode=ap \
    name=cap-internal-2g security=companyinternal-security ssid=company.local
add channel=5g-channel-auto country=spain datapath=internal-datapath \
    distance=indoors name=cap-internal-5g security=companyinternal-security \
add datapath=public-datapath name=cap-public security=companypublic-security \
add datapath=internal-datapath name=cap-corporate security=\
    companycorporate-security ssid=company.corporate
add datapath=public-datapath name=cap-public-2g security=\
    companypublic-security ssid=company.2g
add datapath=public-datapath name=cap-public-5g security=\
    companypublic-security ssid=company.5g
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcppool-wifi-internal ranges=
add name=dhcppool-internal ranges=
add name=dhcppool-vpn ranges=
add name=dhcppool-wifi-public ranges=
/ip dhcp-server
add address-pool=dhcppool-wifi-internal disabled=no interface=\
    bridge-wifi-internal lease-time=1d name=dhcp-wifi-internal
add address-pool=dhcppool-internal disabled=no interface=bridge-internal \
    lease-time=1d name=dhcp-internal
add address-pool=dhcppool-wifi-public disabled=no interface=\
    bridge-wifi-public lease-time=1d name=dhcp-wifi-public
/system logging action
add bsd-syslog=yes name=diskstation remote= target=remote
/caps-man manager
set enabled=yes
/caps-man provisioning
add action=create-dynamic-enabled hw-supported-modes=ac master-configuration=\
    cap-internal-5g name-format=prefix name-prefix=cap-5g \
add action=create-dynamic-enabled hw-supported-modes=gn master-configuration=\
    cap-internal-2g name-format=prefix name-prefix=cap-2g \
/interface bridge port
add bridge=bridge-internal interface=ether10-ap-entrance
add bridge=bridge-internal interface=ether2
add bridge=bridge-internal interface=ether9-ap-conference
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface list member
add comment=defconf disabled=yes interface=ether1-wan list=WAN
add interface=ether2 list=LAN
add interface=ether10-ap-entrance list=LAN
add interface=bridge-internal list=LAN
add interface=wan-xx-fiber list=WAN
add interface=bridge-clientvpn list=LAN
add interface=bridge-wifi-internal list=LAN
add interface=ether9-ap-conference list=LAN
/ip address
add address= interface=bridge-wifi-internal network=
add address= interface=bridge-internal network=
add address= interface=bridge-clientvpn network=
add address= interface=bridge-wifi-public network=
/ip dhcp-client
add dhcp-options=hostname,clientid interface=ether1-wan
/ip dhcp-server lease
add address= mac-address=BX::::X3 server=dhcp-internal
add address= mac-address=BX::::X4 server=dhcp-internal
/ip dhcp-server network
add address= dns-server=, gateway=
add address= dns-server=,, \
    gateway= netmask=24
add address= dns-server=,, \
    gateway= netmask=24
/ip dns
set servers=,,
/ip dns static
add address= name=router.lan
/ip service
set telnet disabled=yes
set ftp disabled=yes
set api disabled=yes
set api-ssl disabled=yes
/system logging
add action=diskstation topics=critical
add action=diskstation topics=error
add action=diskstation topics=info,!caps
add action=diskstation topics=warning
add topics=caps
add topics=wireless,debug
add topics=caps,debug
I have tried factory resetting both the cAPs. All devices are on latest stable firmware.

I am operating basically the same infrastructure in two other locations, and there it seems to work.

Update: It seems this is because I am using slave configurations. This works for 5 Ghz, not for 2.4 Ghz. No idea why.

Any ideas?
Last edited by magnusak on Fri Mar 08, 2019 2:16 pm, edited 1 time in total.
just joined
Posts: 2
Joined: Fri Feb 20, 2015 1:03 am

Re: Unable to connect to 2.4Ghz

Wed Feb 27, 2019 10:17 pm

We have this exact same problem.

Bump anyone have any ideas?
User avatar
just joined
Topic Author
Posts: 5
Joined: Thu Dec 20, 2018 4:11 pm
Location: Málaga, Spain

Re: Unable to connect to 2.4Ghz

Fri Mar 08, 2019 11:37 am

I have just upgraded my routers and access points to v 6.44 and it did not help.

I still have this problem where I cannot use 2.4 Ghz. Any ideas? Should I contact support?
Forum Guru
Forum Guru
Posts: 2106
Joined: Wed Jun 12, 2013 1:59 pm
Location: Netherlands

Re: Unable to connect to 2.4Ghz

Fri Mar 08, 2019 12:02 pm

I would start by selecting channels manually. For 2G radio use either 1, 6 or 11 and make sure bandwidth is set to 20MHz.
User avatar
just joined
Topic Author
Posts: 5
Joined: Thu Dec 20, 2018 4:11 pm
Location: Málaga, Spain

Re: Unable to connect to 2.4Ghz

Fri Mar 08, 2019 12:53 pm

I am getting closer to a solution. Auto vs manual frequency does not seem to matter, but when not using slave configurations I do manage to connect (I use master and slave configurations for different SSIDs). I will do some more experiments and see if I get to a conclusion.
User avatar
just joined
Topic Author
Posts: 5
Joined: Thu Dec 20, 2018 4:11 pm
Location: Málaga, Spain

Re: Unable to connect to 2.4Ghz

Fri Mar 08, 2019 2:14 pm

I have now done a lot of experiments and come to the conclusion that 2.4 Ghz wifi does not work on my setup when using slave configurations. I.e. neither the master nor the slave configuration works, if I have any slave configuration activated on the 2.4 Ghz radio. If anyone wants to suggest any config, please let me know.
just joined
Posts: 1
Joined: Fri May 17, 2019 3:05 pm

Re: Unable to connect to 2.4Ghz

Fri May 17, 2019 3:11 pm

I am having the same issue. 2.4GHz interface shows in: "not running and Slave" mode. Hence the AP for 2.4GHz doesn't show up in the scan in any of the devices.

Did this get resolved?
just joined
Posts: 23
Joined: Wed Jun 20, 2018 9:49 am

Re: Unable to connect to 2.4Ghz

Thu Jan 02, 2020 9:33 am

Any solution to this problem?
Get exactly the same issue, 5Ghz works, 2.4Ghz "cannot connect".
CAP AC in Dual AP Home mode.

Who is online

Users browsing this forum: GoogleOther [Bot], sinisa and 10 guests