Community discussions

MikroTik App
 
User avatar
krafg
Forum Guru
Forum Guru
Topic Author
Posts: 1020
Joined: Sun Jun 28, 2015 7:36 pm

Tips: LtAP (Not mini)

Wed Jul 08, 2020 8:41 pm

This post is for if you have some troubles with this device.

Enable GPS:

System -> Ports -> Serial1 -> Baud Rate = 115200

/system serial-terminal port=serial1 channel=0

MiniPCI-e or USB modem: (Default: USB-type-A)

/system routerboard usb set type=mini-PCIe
/system routerboard usb set type=USB-type-A

Select SIM: (Default: Slot 2)

/system routerboard modem set sim-slot=2
/system routerboard modem set sim-slot=3

Update firmware:

/interface lte firmware-upgrade lte1
/interface lte firmware-upgrade lte1 upgrade=yes
/interface lte firmware-upgrade lte2
/interface lte firmware-upgrade lte2 upgrade=yes

MTU:

Both interfaces set on 1480

Fix LTE: (Until ROS v6.47, starting with v6.48 beta and 6.47.1 is fixed) (This also affects to RBM33G).

If you use R11e-LTE and R11e-LTE-US at same time, probably you will have troubles to get both interfaces with running state. Both interfaces connects to cell towers but not runs. This can help you if you have ROS 6.47 or lower.

/system scheduler
add name=FixLTE on-event="log info \"LTE fix script started\"\r\
\ndelay 60s;\r\
\n:global runloop true\r\
\n:while (\$runloop=true) do={\r\
\n if ([interface get lte2 actual-mtu] = 1499 ) do={\r\
\n log info \"lte2 re-enable\"\r\
\n system routerboard usb power-reset\r\
\n delay 5s;\r\
\n log info \"lte1 re-enable\"\r\
\n interface lte disable lte1;\r\
\n interface lte enable lte1;\r\
\n }\r\
\n if ([interface get lte2 actual-mtu] != 1499 ) do={\r\
\n system script environment remove runloop\r\
\n log info \"LTE fix script completed\"\r\
\n }\r\
\n} " policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-time=startup

Now reboot and when both interfaces connects to respective cell towers, check if both are running.

More details here.

Interfaces running but no Internet access:

- Remember to activate your SIM card with a smartphone and check if you can browse on Internet with it first.

Block Diagram:

Image

R11e-LTE6 + R11e-LTE-US or 2x R11e-LTE-US not work together

- Both interfaces are recognized on Resources, but only 1x R11e-LTE-US is on the interface list. Unfortunately they can not work together by hardware limitations (This also affects to RBM33G).

Image

The hardware limitation is caused by USB EndPoints (EPs). LtAP and RBM33G have 32 EPs available.

xHCI Host Controller: 1 EPs (These devices have 2 host controllers, so, 30 EPs are available for miniPCIe cards).

R11e-LTE: 11 EPs
R11e-4G: 12 EPs
R11e-LTE6: 13 EPs
R11e-LTE-US: 18 EPs

Regards.
Last edited by krafg on Mon Jan 25, 2021 4:53 pm, edited 4 times in total.
 
AlexRodac
just joined
Posts: 23
Joined: Tue Jun 30, 2020 6:37 pm

Re: Tips: LtAP (Not mini)

Tue Aug 25, 2020 8:53 pm

Hello how are you?
I have a small problem, I already installed the modem for slot 1, it recognizes it and everything fine, but now I want to know how to make the device change sim automatically with some script, in addition to knowing how to activate the sms, to achieve that when receiving An SMS with the secret followed by some command, I resent the information with the sender's number, but you can help me with this, thank you.


This is the script that I had found in https://wiki.mikrotik.com/wiki/Dual_SIM_Application but I do not understand very well, I created the script and a task in netwach but it does not make the change, it remains marking error.



{
# Setup and read current values, "up" SIM slot will be used for roaming, "down" for home network
: global simSlot [/ system routerboard sim get sim-slot]
: global timeoutLTE 60
: global timeoutConnect 60

# Wait for LTE to initialize for maximum "timeoutLTE" seconds
: local i 0
: local isLTEinit false
: while ($ i <$ timeoutLTE) do = {
: foreach n in = [/ interface lte find] do = {: set $ isLTEinit true}
: if ($ isLTEinit = true) do = {
: set $ i $ timeoutLTE
}
: set $ i ($ i + 1)
: delay 1s
}

# Check if LTE is initialized, or try power-reset the modem
: if ($ isLTEinit = true) do = {
# Wait for LTE interface to connect to mobile network for maximum "timeoutConnet" seconds
: local isConnected false
: set $ i 0
: while ($ i <$ timeoutConnect) do = {
: if ([/ interface lte get [find name = "lte1"] running] = true) do = {
: set $ isConnected true
: set $ i $ timeoutConnect
}
: set $ i ($ i + 1)
: delay 1s
}
# Check if LTE is connected
if ($ isConnected = true) do = {
: local Info [/ interface lte info [find name = "lte1"] once as-value]
: local isRoaming ($ Info -> "roaming")
# Check which SIM slot is used
: if ($ simSlot = "down") do = {
# If "down" (home) slot, check roaming status
: if ($ isRoaming = true) do = {
: log info message = "Roaming detected, switching to SIM UP (Roaming)"
/ system routerboard sim set sim-slot = up
}
} else = {
# Else "up" (roaming) slot, check roaming status
: if (! $ isRoaming = true) do = {
: log info message = "Not roaming, switching to SIM DOWN (Home)"
/ system routerboard sim set sim-slot = down
}
}
} else = {
: log info message = "LTE interface did not connect to network, wait for next scheduler"
}
} else = {
: log info message = "LTE modem did not appear, trying power-reset"
/ system routerboard usb power-reset duration = 5s
}
}
 
User avatar
krafg
Forum Guru
Forum Guru
Topic Author
Posts: 1020
Joined: Sun Jun 28, 2015 7:36 pm

Re: Tips: LtAP (Not mini)

Thu Jan 21, 2021 5:15 pm

Added hardware limitation tip.

Regards.

Who is online

Users browsing this forum: No registered users and 6 guests