Community discussions

MikroTik App
 
nixmd
just joined
Topic Author
Posts: 23
Joined: Mon Dec 21, 2020 7:56 pm

Slow wlan and high CPU usage on hAP lite

Mon Feb 01, 2021 4:46 pm

I just bought hAP lite and configured it to work with my LHG 5 which works as internet router.
Before buying this new router, I was using my old VDSL router to connect wireless devices to LHG 5 and it was working as expected. But this new hAP lite tc sometimes is really slow when using wireless and if I open winbox or webfig, it takes a lot of time to load pages. Other times that it's not slow, All I can achieve though wlan is about 20Mbps (hardly, most of the time is less than this) which is half of the available bandwidth but if I connect to it using ethernet2/3/4 I can achieve all the bandwidth available, but still opening winbox or webfig takes a lot of time and sometimes throws me out.
If I download a large file using wlan I can see that download speed is constantly going up and down, also UDP packet such as VoIP are lost regularly on wlan.
I've to mention that upload speed is great though and I can achieve 48Mbps for upload speed.
Here's my config:
# feb/01/2021 17:59:26 by RouterOS 6.48
# software id = M9YH-83UW
#
# model = RB941-2nD
/interface bridge
add name=bridge1
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa2-psk eap-methods="" mode=dynamic-keys name=ParallelWorld supplicant-identity=""
add authentication-types=wpa-psk,wpa2-psk eap-methods="" group-ciphers=tkip,aes-ccm mode=dynamic-keys name=Skynet supplicant-identity="" unicast-ciphers=\
    tkip,aes-ccm
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n country=etsi disabled=no frequency=2442 mode=ap-bridge security-profile=ParallelWorld ssid=ParallelWorld wireless-protocol
add keepalive-frames=disabled mac-address= master-interface=wlan1 mode=station multicast-buffering=disabled name=wlan2-skynet security-prof
    Skynet ssid=Skynet wds-cost-range=0 wds-default-cost=0 wps-mode=disabled
/ip pool
add name=dhcp_pool0 ranges=192.168.0.20-192.168.0.254
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=bridge1 lease-time=2d10m name=dhcp1
/interface bridge port
add bridge=bridge1 interface=wlan1
add bridge=bridge1 interface=ether2 multicast-router=disabled
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
/ip address
add address=192.168.0.1/24 interface=bridge1 network=192.168.0.0
/ip dhcp-client
add disabled=no interface=ether1
add disabled=no interface=wlan2-skynet
/ip dhcp-server network
add address=192.168.0.0/24 dns-server=192.168.1.1 gateway=192.168.0.1
/ip dns
set servers=192.168.1.1
/ip firewall filter
add action=fasttrack-connection chain=forward connection-state=established,related
add action=accept chain=forward connection-state=established,related
/ip firewall nat
add action=masquerade chain=srcnat src-address=192.168.0.0/24
/ip service
set telnet disabled=yes
set ftp disabled=yes
set api disabled=yes
set api-ssl disabled=yes
/system ntp client
set enabled=yes
 
nixmd
just joined
Topic Author
Posts: 23
Joined: Mon Dec 21, 2020 7:56 pm

Re: Slow wlan and high CPU usage on hAP lite

Mon Feb 01, 2021 9:52 pm

Ok, solved the problem with high CPU usage by downgrading firmware and ROS to latest LTS version which is 6.46.8. But the problem with wlan still exists. Down speed goes up and down, seems like it's buffering incoming data and when it reaches a defined threshold, it transmits them all. I just changed channel width to 20/40 Ce and it helped to gain a little more bandwidth but still does not provide a stable download speed.

I don't know if these help or not but here's the output of iw station dump on my laptop during downloading
        inactive time:  8 ms
        rx bytes:       341695912
        rx packets:     139943
        tx bytes:       6740048
        tx packets:     66705
        tx retries:     2862
        tx failed:      0
        beacon loss:    2
        beacon rx:      6117
        rx drop misc:   477
        signal:         -50 [-50] dBm
        signal avg:     -51 [-51] dBm
        beacon signal avg:      -49 dBm
        tx bitrate:     270.0 MBit/s MCS 15 40MHz
        tx duration:    0 us
        rx bitrate:     43.3 MBit/s MCS 4 short GI
        rx duration:    0 us
        authorized:     yes
        authenticated:  yes
        associated:     yes
        preamble:       long
        WMM/WME:        yes
        MFP:            no
        TDLS peer:      no
        DTIM period:    1
        beacon interval:100
        short preamble: yes
        short slot time:yes
        connected time: 628 seconds
        associated at [boottime]:       1025.671s
        associated at:  1612208267755 ms
        current time:   1612208895406 ms
This is when winbox is open and is constantly sending data

        inactive time:  172 ms
        rx bytes:       285249707
        rx packets:     118086
        tx bytes:       5706584
        tx packets:     56495
        tx retries:     2518
        tx failed:      0
        beacon loss:    2
        beacon rx:      5075
        rx drop misc:   420
        signal:         -52 [-52] dBm
        signal avg:     -52 [-52] dBm
        beacon signal avg:      -51 dBm
        tx bitrate:     300.0 MBit/s MCS 15 40MHz short GI
        tx duration:    0 us
        rx bitrate:     135.0 MBit/s MCS 6 40MHz short GI
        rx duration:    0 us
        authorized:     yes
        authenticated:  yes
        associated:     yes
        preamble:       long
        WMM/WME:        yes
        MFP:            no
        TDLS peer:      no
        DTIM period:    1
        beacon interval:100
        short preamble: yes
        short slot time:yes
        connected time: 521 seconds
        associated at [boottime]:       1025.671s
        associated at:  1612208267755 ms
        current time:   1612208788472 ms
and this is idle time
        inactive time:  4668 ms
        rx bytes:       285991097
        rx packets:     118702
        tx bytes:       5781639
        tx packets:     57054
        tx retries:     2611
        tx failed:      0
        beacon loss:    2
        beacon rx:      5720
        rx drop misc:   425
        signal:         -52 [-52] dBm
        signal avg:     -52 [-52] dBm
        beacon signal avg:      -52 dBm
        tx bitrate:     300.0 MBit/s MCS 15 40MHz short GI
        tx duration:    0 us
        rx bitrate:     150.0 MBit/s MCS 7 40MHz short GI
        rx duration:    0 us
        authorized:     yes
        authenticated:  yes
        associated:     yes
        preamble:       long
        WMM/WME:        yes
        MFP:            no
        TDLS peer:      no
        DTIM period:    1
        beacon interval:100
        short preamble: yes
        short slot time:yes
        connected time: 587 seconds
        associated at [boottime]:       1025.671s
        associated at:  1612208267755 ms
        current time:   1612208854537 ms
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 2999
Joined: Mon Apr 08, 2019 1:16 am

Re: Slow wlan and high CPU usage on hAP lite

Tue Feb 02, 2021 12:18 am

Ok for not using 6.48.

Lets go back to the wifi problem. (there is better information in the hAP Lite , in the wireless table, under registration. You might need to make some columns wider (RX rate, TX rate) and add some columns : TX/RX signal strength, TX/RX CCQ,

With the laptop information (most counters are cumulative) it is clear that "rx bitrate: 43.3 MBit/s MCS 4 short GI" is a problem indicator.
MCS 4 is a very low density encoding , and single channel. It points to massive interference or distortion at the PC receiver.

Looking for the root cause is what is needed. Your config is one point of information, but rises some questions and triggers some hints.
add authentication-types=wpa2-psk eap-methods="" mode=dynamic-keys name=ParallelWorld supplicant-identity=""
add authentication-types=wpa-psk,wpa2-psk eap-methods="" group-ciphers=tkip,aes-ccm mode=dynamic-keys name=Skynet supplicant-identity="" unicast-ciphers=\
tkip,aes-ccm
You use ParallelWorld to connect (no security ? OK you removed it)
What is Skynet doing? Hint: avoid TKIP if you can.
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n country=etsi disabled=no frequency=2442 mode=ap-bridge security-profile=ParallelWorld ssid=ParallelWorld wireless-protocol
add keepalive-frames=disabled mac-address= master-interface=wlan1 mode=station multicast-buffering=disabled name=wlan2-skynet security-prof
Skynet ssid=Skynet wds-cost-range=0 wds-default-cost=0 wps-mode=disabled
Hint: avoid the 802.11b if you can (only very old devices require it)
frequency=2442 is channel 7. I hope you checked the RF signals around with "Freq Usage" and "Snooper", and you have a reason to deviate from the 1-6-11 usual picklist.
(Etsi can use 1-5-9-13 but it is not very common). Using 7 could create adjacent channel interference with any-one on channel 5-6-8-9.
What is Skynet station doing here? Are you wifi or ethernet connected to the LHG 5 ? At least both WLAN definitions will share the radio, and as such the available airtime.
(And the slowest will take most airtime, and reduce the throughput for both.)

Please look for interference (co-channel wait, and adjacent channel distortion)

PS: The throughput for a slow and fast device together is not the average of their throughput ! Slow speed x , and fast speed y, then this will give
speed =(x*y) / (x+y)
for both. (and Yes, this is slower than x !)
 
nixmd
just joined
Topic Author
Posts: 23
Joined: Mon Dec 21, 2020 7:56 pm

Re: Slow wlan and high CPU usage on hAP lite

Tue Feb 02, 2021 1:00 am

Thanks for devoting your precious time to me.
Lets go back to the wifi problem. (there is better information in the hAP Lite , in the wireless table, under registration. You might need to make some columns wider (RX rate, TX rate) and add some columns : TX/RX signal strength, TX/RX CCQ,
Here's the output of registration table when winbox when idle
interface=wlan1 mac-address= ap=no wds=no bridge=no rx-rate="1Mbps" 
   tx-rate="30Mbps-40MHz/2S/SGI" packets=49,78 bytes=6022,12196 frames=47,80 frame-bytes=6172,11964 
   hw-frames=176,88 hw-frame-bytes=24820,15324 tx-frames-timed-out=0 uptime=58s last-activity=15s500ms 
   signal-strength=-53dBm@1Mbps signal-to-noise=61dB signal-strength-ch0=-60dBm signal-strength-ch1=-53dBm 
   strength-at-rates=-53dBm@1Mbps 26s680ms,-47dBm@2Mbps 15s500ms,-46dBm@5.5Mbps 57s450ms,-52dBm@11Mbps 57s350ms,-
                  46dBm@6Mbps 47s670ms,-48dBm@12Mbps 56s890ms,-47dBm@18Mbps 56s530ms,-47dBm@24Mbps 55s860ms,-
                  48dBm@36Mbps 55s640ms,-48dBm@48Mbps 47s980ms,-46dBm@54Mbps 42s780ms 
   tx-ccq=56% p-throughput=5423 distance=4 last-ip=192.168.0.254 802.1x-port-enabled=yes 
   authentication-type=wpa2-psk encryption=aes-ccm group-encryption=aes-ccm management-protection=no 
   wmm-enabled=yes tx-rate-set="CCK:1-11 OFDM:6-54 BW:1x-2x SGI:1x-2x HT:0-15"
And it is during download
interface=wlan1 mac-address= ap=no wds=no bridge=no rx-rate="300Mbps-40MHz/2S/SGI" 
   tx-rate="135Mbps-40MHz/1S/SGI" packets=16031,5489 bytes=23064098,481445 frames=10555,5492 
   frame-bytes=23214962,448854 hw-frames=13294,5634 hw-frame-bytes=29586993,672482 tx-frames-timed-out=0 
   uptime=7m7s last-activity=0ms signal-strength=-49dBm@6Mbps signal-to-noise=65dB signal-strength-ch0=-57dBm 
   signal-strength-ch1=-49dBm strength-at-rates=-55dBm@1Mbps 23s290ms,-48dBm@2Mbps 21s910ms,-46dBm@5.5Mbps 
                  22s250ms,-49dBm@11Mbps 21s840ms,-49dBm@6Mbps 30ms,-48dBm@12Mbps 20s850ms,-48dBm@18Mbps 
                  20s830ms,-48dBm@24Mbps 20s30ms,-48dBm@36Mbps 19s840ms,-48dBm@48Mbps 18s850ms,-48dBm@54Mbps 
                  18s690ms,-52dBm@HT40-1 18s160ms,-52dBm@HT40-2 18s20ms,-52dBm@HT40-3 17s950ms,-52dBm@HT40-4 
                  840ms,-52dBm@HT40-5 280ms,-53dBm@HT40-6 110ms,-53dBm@HT40-7 10ms 
   tx-ccq=56% p-throughput=105619 distance=4 last-ip=192.168.0.254 802.1x-port-enabled=yes 
   authentication-type=wpa2-psk encryption=aes-ccm group-encryption=aes-ccm management-protection=no 
   wmm-enabled=yes tx-rate-set="CCK:1-11 OFDM:6-54 BW:1x-2x SGI:1x-2x HT:0-15"

With the laptop information (most counters are cumulative) it is clear that "rx bitrate: 43.3 MBit/s MCS 4 short GI" is a problem indicator.
MCS 4 is a very low density encoding , and single channel. It points to massive interference or distortion at the PC receiver.
Rx bitrate was variable, sometimes up, sometimes down. This is while Tx was always at 300 or 150 and of course upload speed was at maximum.

Looking for the root cause is what is needed. Your config is one point of information, but rises some questions and triggers some hints.

You use ParallelWorld to connect (no security ? OK you removed it)
What is Skynet doing? Hint: avoid TKIP if you can.
ParallelWorld is in ap-bridge mode and utilizes WPA2 aes and yes passphrase is removed from the exported configs.
Skynet is another access point which I am planning to use it as an range extender but for now, this virtual AP is disabled to diagnose main problem, and yes, TKIP has been removed but I didn't update virtual AP information as I was struggling with ap-bridge.

frequency=2442 is channel 7. I hope you checked the RF signals around with "Freq Usage" and "Snooper", and you have a reason to deviate from the 1-6-11 usual picklist.
(Etsi can use 1-5-9-13 but it is not very common). Using 7 could create adjacent channel interference with any-one on channel 5-6-8-9.
Yes, I had checked frequency usage and almost every channel was used by neighbors so I decided to use 7 which had lesser traffic on it. Then I read about overlapping channels and then switched to channel 6, but still had the main problem.

What is Skynet station doing here? Are you wifi or ethernet connected to the LHG 5 ? At least both WLAN definitions will share the radio, and as such the available airtime.
(And the slowest will take most airtime, and reduce the throughput for both.)
LHG 5 ether output is connected to hAP lite ether1 and wlan1 (part of bridge1) is acting as WLAN. Skynet is laying around looking for a chance to send terminators to the Earth, but it's switched off (for now) and does not cause interference.

Please look for interference (co-channel wait, and adjacent channel distortion)
I don't know about possible interference but before using this new hAP lite, Skynet (old vdsl router) was acting as WLAN for LHG 5 and I didn't see such problem.
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 2999
Joined: Mon Apr 08, 2019 1:16 am

Re: Slow wlan and high CPU usage on hAP lite

Tue Feb 02, 2021 1:41 am

Thanks for the information.

It will not be an easy task to tune this setup. It is the wifi radio spectrum that is giving bad throughput.

The idle numbers are for a very short association time (58s) and without sufficient traffic interface rates get low (there are more slow beacons than fast data frames).

So let's concentrate on the "during download".
Signal strength is OK. Signal-noise is OK.
135Mbps could be better. Losing the second stream (1S instead of 2S) is slowing things down. Still there is a reasonable p-throughput (105619 Kbps).
There is 30 % retransmission (frames=10555 need hw-frames=13294). This lowers the interface rate (or even reduces the streams) every time when retransmission is needed.
(With the standard config with hw-retries=7 as set in advanced) 7 retransmissions count only as 1 hw-transmission)
Using b/g/n (and not g/n) makes the beacons and multicasts to be transmitted at 1 Mbps.... tx-rate-set="CCK:1-11 OFDM:6-54 BW:1x-2x SGI:1x-2x HT:0-15"
Avoid the b, and the CCK 1-11 , with the 1 Mbps speed, will disappear. (This removes the "Basic Rates" for the b-rates )

But the most difficult part is finding the interference ! (microwave oven, VOIP phones, camera, other devices on 2.4 GHz (there are many that are not using wifi, but use the 2.4 GHz spectrum), reflection on metal sheets, or walls or furniture). Moving the hAP Lite TC could have an impact. But as you have times with reasonable speed and some really slow speed, I suspect some active device that is causing the trouble around your laptop.

The hAp Lite TC can do a spectral scan.
Was your VDSL router 2.4GHz only, or 2.4 and 5 GHz?
 
nixmd
just joined
Topic Author
Posts: 23
Joined: Mon Dec 21, 2020 7:56 pm

Re: Slow wlan and high CPU usage on hAP lite

Tue Feb 02, 2021 10:13 am

Was your VDSL router 2.4GHz only, or 2.4 and 5 GHz?
2.4 only

Here's another test with Netgear WN111v2 usb wireless card while connected to winbox
interface=wlan1 mac-address=00:24:B2:57:35:41 ap=no wds=no bridge=no rx-rate="135Mbps-40MHz/1S/SGI" tx-rate="6.5Mbps-20MHz/1S" packets=751,732 bytes=489965,106753 frames=751,734 frame-bytes=491469,102597 hw-frames=3763,845 
   hw-frame-bytes=2920323,138936 tx-frames-timed-out=0 uptime=1m22s last-activity=30ms signal-strength=-46dBm@HT20-6 signal-to-noise=68dB signal-strength-ch0=-57dBm signal-strength-ch1=-46dBm 
   strength-at-rates=-75dBm@1Mbps 6s300ms,-52dBm@6Mbps 4s960ms,-46dBm@HT20-0 1m21s140ms,-46dBm@HT20-3 14s90ms,-49dBm@HT20-4 29s900ms,-50dBm@HT20-5 54s60ms,-46dBm@HT20-6 30ms,-54dBm@HT20-7 24s120ms,-45dBm@HT40-1 22s290ms,-50dBm@HT40-2 8s670ms,-
                  49dBm@HT40-3 1s190ms,-51dBm@HT40-4 23s610ms,-51dBm@HT40-5 36s420ms,-60dBm@HT40-6 30ms,-61dBm@HT40-7 34s 
   tx-ccq=30% p-throughput=695 distance=3 last-ip=192.168.0.246 802.1x-port-enabled=yes authentication-type=wpa2-psk encryption=aes-ccm group-encryption=aes-ccm management-protection=no wmm-enabled=yes tx-rate-set="OFDM:6-54 BW:1x-2x SGI:2x HT:0-15"
and this is when I was downloading
interface=wlan1 mac-address=00:24:B2:57:35:41 ap=no wds=no bridge=no rx-rate="135Mbps-40MHz/1S" tx-rate="45Mbps-40MHz/1S/SGI" packets=15000,7200 bytes=21106248,623404 frames=15000,7204 frame-bytes=21136246,580676 hw-frames=30707,7723 
   hw-frame-bytes=40405770,910206 tx-frames-timed-out=0 uptime=1m57s last-activity=10ms signal-strength=-47dBm@6Mbps signal-to-noise=68dB signal-strength-ch0=-57dBm signal-strength-ch1=-48dBm 
   strength-at-rates=-67dBm@1Mbps 1s340ms,-47dBm@6Mbps 60ms,-48dBm@HT20-0 1m56s140ms,-50dBm@HT20-1 24s360ms,-49dBm@HT20-2 50s180ms,-44dBm@HT20-3 9s650ms,-41dBm@HT20-4 18s140ms,-52dBm@HT20-5 4s980ms,-48dBm@HT20-6 7s620ms,-48dBm@HT20-7 6s70ms,-
                  54dBm@HT40-1 20s190ms,-57dBm@HT40-2 7s300ms,-51dBm@HT40-3 3s870ms,-51dBm@HT40-4 3s680ms,-58dBm@HT40-5 290ms,-59dBm@HT40-6 800ms,-59dBm@HT40-7 60ms 
   tx-ccq=36% p-throughput=1484 distance=3 last-ip=192.168.0.246 802.1x-port-enabled=yes authentication-type=wpa2-psk encryption=aes-ccm group-encryption=aes-ccm management-protection=no wmm-enabled=yes 
   tx-rate-set="OFDM:6-54 BW:1x-2x SGI:2x HT:0-15" 
Output of iw station dump during download
Station 48:8f:5a:6e:bc:e9 (on wlx0024b2573541)
        inactive time:  1120 ms
        rx bytes:       202604460
        rx packets:     138195
        tx bytes:       5621572
        tx packets:     60129
        tx retries:     9091
        tx failed:      683
        beacon loss:    1
        beacon rx:      1665
        rx drop misc:   354
        signal:         -53 dBm
        signal avg:     -52 dBm
        beacon signal avg:      -52 dBm
        tx bitrate:     150.0 MBit/s MCS 7 40MHz short GI
        tx duration:    0 us
        rx bitrate:     13.5 MBit/s MCS 0 40MHz
        rx duration:    0 us
        expected throughput:    42.388Mbps
        authorized:     yes
        authenticated:  yes
        associated:     yes
        preamble:       long
        WMM/WME:        yes
        MFP:            no
        TDLS peer:      no
        DTIM period:    1
        beacon interval:100
        short preamble: yes
        short slot time:yes
        connected time: 253 seconds
        associated at [boottime]:       44940.094s
        associated at:  1612252182178 ms
        current time:   1612252434283 ms


Wireless link during downloading was so unstable that it would stop downloading after a short while.
I'd used this wireless card for connecting to APs out of access for built-in wireless card of my laptop.
 
nixmd
just joined
Topic Author
Posts: 23
Joined: Mon Dec 21, 2020 7:56 pm

Re: Slow wlan and high CPU usage on hAP lite

Tue Feb 02, 2021 10:27 am

Here's the output of spectral history
Image

and it's the output of spectral-scan with show-interference=yes
# software id = M9YH-83UW
#
FREQ INTERFERENCE            DBM GRAPH                                         
2381 none                    -98 ::.                                           
2383 none                    -95 :::.                                          
2385 none                   -100 :..                                           
2387 none                    -98 :.                                            
2389 none                    -95 :::.                                          
2391 none                    -92 ::::::.                                       
2393 none                    -94 ::::.                                         
2396 none                    -92 ::::::.                                       
2398 none                    -93 ::::::.                                       
2400 none                    -91 :::::::......................                 
2402 none                    -92 :::::::...........                            
2404 none                    -91 :::::::....                                   
2406 none                    -93 ::::::..................                      
2408 none                    -93 ::::::.......................                 
2411 none                    -97 :::.......                                    
2413 none                    -96 ::::..                                        
2415 none                    -96 ::::..                                        
2417 none                    -95 ::::.                                         
2419 none                    -99 :............                                 
2421 none                   -101 :.............................                
2423 none                   -100 :..................                           
2426 none                   -100 :...........                                  
2428 none                    -87 ::::::::::..                                  
2430 none                    -95 ::::......                                    
2432 none                    -92 :::::::........                               
2434 none                    -95 ::::............                              
2436 none                    -97 :::.............                              
2438 none                    -96 ::::............                              
2441 none                    -93 ::::::.......                                 
2443 none                    -91 :::::::.....                                  
2445 none                    -92 :::::::...                                    
2447 none                    -91 ::::::.                                       
2449 none                    -91 ::::::.                                       
2452 none                    -90 ::::::::..                                    
2454 none                    -87 ::::::::::..............                      
2456 none                    -85 :::::::::::.                                  
2458 none                    -76 ::::::::::::::::::.                           
2460 none                    -72 :::::::::::::::::::::.                        
2462 none                    -92 ::::::.                                       
2464 none                    -91 ::::::.                                       
2467 none                    -91 ::::::.                                       
2469 none                    -85 ::::::::::::.                                 
2471 none                    -60 ::::::::::::::::::::::::::::::.               
2473 none                    -69 ::::::::::::::::::::::::.......               
2475 none                    -82 ::::::::::::::......                          
2477 none                    -87 ::::::::::..                                  
2479 none                    -90 ::::::::...                                   
2482 none                    -93 ::::::....                                    
2484 none                    -95 ::::.....                                     
2486 none                    -94 :::::..                                       
2488 none                    -90 :::::::.                                      
2490 none                    -95 ::::.                                         
2492 none                   -104 .                                             
2494 none                   -105 .                                             
2497 none                   -103 .                                             
2499 none                   -103 .                                             
2501 none                   -106 .                                             
2503 none                   -103 .                                             
2505 none                   -105 .                                             
2507 none                   -104 .                                             
2509 none                   -106 .                                             
2512 none                   -105 .                                             
2514 none                   -104 .                                             
2516 none                   -107 .                                             
2518 none                   -106 .      

# software id = M9YH-83UW
#
FREQ INTERFERENCE            DBM GRAPH                                         
2381 none                    -97 :::.                                          
2383 none                    -94 ::::.                                         
2385 none                    -96 ::::.                                         
2387 none                    -96 :::.                                          
2389 none                    -96 ::::.                                         
2391 none                    -93 ::::::.                                       
2393 none                    -93 ::::::.                                       
2396 none                    -93 ::::::.                                       
2398 none                    -91 :::::::.                                      
2400 none                    -93 ::::::...                                     
2402 none                    -93 ::::::..                                      
2404 none                    -92 :::::::...                                    
2406 none                    -92 :::::::.................                      
2408 none                    -89 :::::::::....................                 
2411 none                    -65 ::::::::::::::::::::::::::.                   
2413 none                    -71 ::::::::::::::::::::::.                       
2415 none                    -89 ::::::::.                                     
2417 none                    -92 ::::::.                                       
2419 none                    -97 :::............                               
2421 none                    -97 :::...........................                
2423 none                    -99 :..................                           
2426 none                    -94 :::::.......                                  
2428 none                    -80 :::::::::::::::.                              
2430 none                    -90 ::::::::....                                  
2432 none                    -97 :::............                               
2434 none                    -95 ::::.......................                   
2436 none                    -83 ::::::::::::::..                              
2438 none                    -69 :::::::::::::::::::::::.                      
2441 none                    -83 :::::::::::::.                                
2443 none                    -86 :::::::::::.                                  
2445 none                    -70 :::::::::::::::::::::::.                      
2447 none                    -87 :::::::::.                                    
2449 none                    -90 :::::::.                                      
2452 none                    -99 :.......                                      
2454 none                   -100 :.........                                    
2456 none                    -99 :...........                                  
2458 none                   -100 :..................                           
2460 none                   -100 :.....................                        
2462 none                   -100 :.............                                
2464 none                    -95 ::::...........................               
2467 none                    -96 ::::..........................                
2469 none                    -89 :::::::::.....                                
2471 none                    -96 ::::...........................               
2473 none                   -100 :.......................                      
2475 none                    -99 :.............                                
2477 none                   -100 :.........                                    
2479 none                   -102 :.......                                      
2482 none                    -99 :.....                                        
2484 none                    -99 :...                                          
2486 none                   -101 :....                                         
2488 none                    -99 :.......                                      
2490 none                   -102 :...                                          
2492 none                   -106 .                                             
2494 none                   -106 .                                             
2497 none                   -107 .                                             
2499 none                   -105 .                                             
2501 none                   -104 .                                             
2503 none                   -104 .                                             
2505 none                   -104 .                                             
2507 none                   -105 .                                             
2509 none                   -106 .                                             
2512 none                   -106 .                                             
2514 none                   -105 .                                             
2516 none                   -105 .                                             
2518 none                   -105 .                                             

# software id = M9YH-83UW
#
FREQ INTERFERENCE            DBM GRAPH                                         
2381 none                    -96 :::.                                          
2383 none                    -93 :::::.                                        
2385 none                    -96 ::::.                                         
2387 none                    -97 :::.                                          
2389 none                    -95 ::::.                                         
2391 none                    -93 :::::.                                        
2393 none                    -92 ::::::.                                       
2396 none                    -92 ::::::.                                       
2398 none                    -87 :::::::::.                                    
2400 none                    -62 :::::::::::::::::::::::::::::.                
2402 none                    -64 :::::::::::::::::::::::::::.                  
2404 none                    -62 :::::::::::::::::::::::::::::.                
2406 none                    -83 :::::::::::::.                                
2408 none                    -87 :::::::::.                                    
2411 none                    -90 ::::::::...................                   
2413 none                    -91 :::::::................                       
2415 none                    -91 :::::::..                                     
2417 none                    -91 ::::::.                                       
2419 none                    -93 ::::::.........                               
2421 none                    -94 :::::.......                                  
2423 none                    -96 ::::.......                                   
2426 none                    -95 ::::.....                                     
2428 none                    -79 ::::::::::::::::.                             
2430 none                    -87 ::::::::::..                                  
2432 none                    -96 ::::.......                                   
2434 none                    -97 :::........................                   
2436 none                    -96 ::::..........                                
2438 none                    -94 :::::...................                      
2441 none                   -100 :.............                                
2443 none                    -99 :..........                                   
2445 none                    -97 :::.....................                      
2447 none                   -101 :.........                                    
2449 none                   -101 :.......                                      
2452 none                   -103 :....                                         
2454 none                   -103 :.......                                      
2456 none                   -103 :........                                     
2458 none                   -103 :..........                                   
2460 none                    -92 :::::::......                                 
2462 none                    -83 :::::::::::::.                                
2464 none                    -84 :::::::::::::..................               
2467 none                    -89 :::::::::.....................                
2469 none                    -84 :::::::::::::.                                
2471 none                    -84 ::::::::::::.                                 
2473 none                    -82 :::::::::::::.                                
2475 none                    -60 ::::::::::::::::::::::::::::::.               
2477 none                    -60 ::::::::::::::::::::::::::::::.               
2479 none                    -81 ::::::::::::::.                               
2482 none                   -105 .                                             
2484 none                   -105 .                                             
2486 none                   -106 .                                             
2488 none                   -107 .                                             
2490 none                   -107 .                                             
2492 none                   -105 .                                             
2494 none                   -106 .                                             
2497 none                   -104 .                                             
2499 none                   -105 .                                             
2501 none                   -105 .                                             
2503 none                   -103 .                                             
2505 none                   -105 .                                             
2507 none                   -104 .                                             
2509 none                   -106 .                                             
2512 none                   -107 .                                             
2514 none                   -105 .                                             
2516 none                   -105 .                                             
2518 none                   -105 .                                             

# software id = M9YH-83UW
#
FREQ INTERFERENCE            DBM GRAPH                                         
2381 none                    -98 ::...                                         
2383 none                    -96 ::::...                                       
2385 none                    -96 ::::..                                        
2387 none                    -98 ::...                                         
2389 none                    -96 ::::...                                       
2391 none                    -93 ::::::.                                       
2393 none                    -93 ::::::.                                       
2396 none                    -94 :::::....                                     
2398 none                    -93 ::::::...                                     
2400 none                    -87 :::::::::.                                    
2402 none                    -87 :::::::::.                                    
2404 none                    -82 ::::::::::::::.                               
2406 none                    -78 :::::::::::::::::............                 
2408 none                    -78 :::::::::::::::::.                            
2411 none                    -69 :::::::::::::::::::::::.                      
2413 none                    -77 :::::::::::::::::.                            
2415 none                    -78 ::::::::::::::::.                             
2417 none                    -79 ::::::::::::::::.                             
2419 none                    -83 :::::::::::::.                                
2421 none                    -81 ::::::::::::::.                               
2423 none                    -90 :::::::.                                      
2426 none                    -87 :::::::::.                                    
2428 none                    -86 :::::::::::.....                              
2430 none                    -87 :::::::::.                                    
2432 none                   -100 :......                                       
2434 none                    -98 ::...........                                 
2436 none                    -99 :.........................                    
2438 none                    -98 ::............                                
2441 none                    -98 ::...................                         
2443 none                    -98 ::...                                         
2445 none                    -95 :::.                                          
2447 none                    -92 ::::::.                                       
2449 none                    -75 :::::::::::::::::::.                          
2452 none                    -90 :::::::.                                      
2454 none                    -81 ::::::::::::::.                               
2456 none                    -67 :::::::::::::::::::::::::.                    
2458 none                    -89 ::::::::.                                     
2460 none                    -92 ::::::.                                       
2462 none                    -94 :::::.....                                    
2464 none                    -94 :::::........                                 
2467 none                    -98 ::...............                             
2469 none                   -100 :.............................                
2471 none                    -98 ::...............                             
2473 none                    -87 ::::::::::......                              
2475 none                    -87 ::::::::::...                                 
2477 none                   -101 :......                                       
2479 none                   -100 :......................                       
2482 none                   -101 :..................                           
2484 none                   -101 :..............                               
2486 none                   -101 :.............                                
2488 none                   -102 :..........                                   
2490 none                   -103 :............                                 
2492 none                   -105 :..........                                   
2494 none                   -106 :...........                                  
2497 none                   -105 :...........                                  
2499 none                   -107 :..........                                   
2501 none                   -105 .                                             
2503 none                   -105 .                                             
2505 none                   -104 .                                             
2507 none                   -106 .                                             
2509 none                   -105 .                                             
2512 none                   -105 .                                             
2514 none                   -106 .                                             
2516 none                   -107 .                                             
2518 none                   -107 .                                             

# software id = M9YH-83UW
#
FREQ INTERFERENCE            DBM GRAPH                                         
2381 none                    -97 ::.                                           
2383 none                    -94 ::::.                                         
2385 none                    -98 ::..                                          
2387 none                    -98 :.                                            
2389 none                    -95 :::.                                          
2391 none                    -93 :::::.                                        
2393 none                    -94 :::::.                                        
2396 none                    -92 ::::::.                                       
2398 none                    -92 ::::::.                                       
2400 none                    -90 ::::::::..                                    
2402 none                    -90 ::::::::..                                    
2404 none                    -90 ::::::::......                                
2406 none                    -90 ::::::::.........                             
2408 none                    -91 :::::::..........                             
2411 none                    -90 ::::::::................                      
2413 none                    -64 :::::::::::::::::::::::::::.                  
2415 none                    -66 ::::::::::::::::::::::::::.                   
2417 none                    -87 ::::::::::.......                             
2419 none                    -91 :::::::.......                                
2421 none                    -94 :::::..........                               
2423 none                   -100 :.......                                      
2426 none                    -89 :::::::::.                                    
2428 none                    -81 ::::::::::::::.                               
2430 none                    -70 ::::::::::::::::::::::::...                   
2432 none                    -77 ::::::::::::::::::..........                  
2434 none                    -80 :::::::::::::::.                              
2436 none                    -81 ::::::::::::::.                               
2438 none                    -82 :::::::::::::.                                
2441 none                    -84 ::::::::::::.                                 
2443 none                    -83 :::::::::::::.                                
2445 none                    -82 :::::::::::::.                                
2447 none                    -81 ::::::::::::::.                               
2449 none                    -77 ::::::::::::::::::..                          
2452 none                    -87 :::::::::.                                    
2454 none                    -87 ::::::::::.....                               
2456 none                    -86 :::::::::::...............                    
2458 none                    -81 ::::::::::::::.                               
2460 none                    -81 ::::::::::::::.                               
2462 none                   -103 :....                                         
2464 none                   -103 :....                                         
2467 none                   -101 :.                                            
2469 none                   -100 :............................                 
2471 none                    -93 ::::::.......................                 
2473 none                    -86 :::::::::::...                                
2475 none                    -78 ::::::::::::::::.                             
2477 none                    -62 :::::::::::::::::::::::::::::.                
2479 none                    -86 ::::::::::.                                   
2482 none                    -91 ::::::.                                       
2484 none                    -91 ::::::.                                       
2486 none                    -93 :::::.                                        
2488 none                    -94 ::::.                                         
2490 none                   -100 .                                             
2492 none                   -107 .                                             
2494 none                   -106 .                                             
2497 none                   -105 .                                             
2499 none                   -107 .                                             
2501 none                   -105 .                                             
2503 none                   -104 .                                             
2505 none                   -106 .                                             
2507 none                   -103 .                                             
2509 none                   -107 .                                             
2512 none                   -107 .                                             
2514 none                   -106 .                                             
2516 none                   -107 .                                             
2518 none                   -105 .                                             

 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 2999
Joined: Mon Apr 08, 2019 1:16 am

Re: Slow wlan and high CPU usage on hAP lite

Tue Feb 02, 2021 11:25 am

Thanks.

OK lots of information.

With the hw-frames TX count much higher than the frames counter, and (based on that) a TX-CCQ of 36%, no wonder you drop to the lowest speed possible (MCS 0) , 13Mbps interface rate, giving 13 / 2 * 0.36 = 2.34 Mbps data rate if you are the only user. And the next lower step after MCS 0 ... is disconnect.

It is clearly interference at the laptop receiver. Signal is good and very strong in both directions. Noise is low.

The spectrum shows a very burst pattern above channel 6. Many scans and "auto" frequency settings would miss the busy signals, and chose something above channel 6.

What is the source of those red spots and yellow fields. (Clean area should be black with some blue)? That's the question. And how much, or what more, of that will be picked up by the laptop?
Does it disappear if some devices are switched off ???

So I propose that you change the AP to channel 1 (2412 MHz) , and only 20 MHz wide (uses 2402 till 2422)
If that gives a good CCQ and MCS, then the channel 1 Ce 40 Mhz can be tried (this uses 2402 till 2442). But 40 MHz wide is seldom clean in 2.4 GHz band.
 
nixmd
just joined
Topic Author
Posts: 23
Joined: Mon Dec 21, 2020 7:56 pm

Re: Slow wlan and high CPU usage on hAP lite

Tue Feb 02, 2021 4:48 pm

Thanks.
Actually it's me that must thank you.
What is the source of those red spots and yellow fields. (Clean area should be black with some blue)? That's the question. And how much, or what more, of that will be picked up by the laptop?
Does it disappear if some devices are switched off ???
Take a look at these. These are on top of wireless snoop scan most of the time:
Image
Image
Image

How can some of these don't provide any MAC address?
What are these in your opinion?
 
nixmd
just joined
Topic Author
Posts: 23
Joined: Mon Dec 21, 2020 7:56 pm

Re: Slow wlan and high CPU usage on hAP lite

Tue Feb 02, 2021 5:06 pm

I powered off every wireless client (cell phones, TV, laptops) and this is the out of spectral history:
Image

I didn't see any red spot, highest was yellow.
But still I can see these unknown sources in wireless snoop:
Image
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 2999
Joined: Mon Apr 08, 2019 1:16 am

Re: Slow wlan and high CPU usage on hAP lite  [SOLVED]

Tue Feb 02, 2021 5:18 pm

Little symbols indicate stations/AP-networks/frequencies. Stations and AP have MAC addresses, frequencies (channels) have not.

How can they be there if no stations or AP are visible?
Either their signal cannot be decoded (too weak to decode, to much distorted, non 802.11 protocol, just noise)
Non 802.11 are things like bluetooth, remote controls, wireless keyboard & mouse, DECT telephone, some camera systems, sensors, home automation, ...

If you enable "Receive Errors" in the Settings of Snooper, you might even see more.
Instead of "all", you can filter the type as "frequencies, networks and stations" in Snooper.
In the last column, snooper counted many "stations", but could not give a 802.11 MAC address.

Channel 13 was very busy.

Your last scan is rather clean. OK channel 6 is busy, but will be no problem. A really clean 2.4 GHz is very rare to non-existing.

You have the tools now to find a clean channel for your AP.
 
nixmd
just joined
Topic Author
Posts: 23
Joined: Mon Dec 21, 2020 7:56 pm

Re: Slow wlan and high CPU usage on hAP lite

Tue Feb 02, 2021 5:33 pm

Non 802.11 are things like bluetooth, remote controls, wireless keyboard & mouse, DECT telephone, some camera systems, sensors, home automation, ...
Image
Your last scan is rather clean. OK channel 6 is busy, but will be no problem. A really clean 2.4 GHz is very rare to non-existing.
You have the tools now to find a clean channel for your AP.
I moved AP a few and could find some clear spots and also some busy ones, I'm going to move it in every possible corner to find the best spot.
I will also try to find a spectral analyzer for my laptop (if there's any) and use that to figure out if there's a problem with placement of laptop (I mean where I put it most of the time)
 
nixmd
just joined
Topic Author
Posts: 23
Joined: Mon Dec 21, 2020 7:56 pm

Re: Slow wlan and high CPU usage on hAP lite

Fri Feb 05, 2021 2:03 am

Thank you
This conversation helped me solve part of the problem and understand why the other part is not solvable.
The part which is solved is reaching the maximum overall bandwidth.
And the part which is not solved was bounces in download speed which is due to shared medium (air) used for communication.

Who is online

Users browsing this forum: Ahrefs [Bot], Bing [Bot] and 20 guests