/ip cloud set ddns-enabled=yes
I have seen this across a few units now...I have a new cap ac that was shipped with 6.44 and updated it to 6.47.4 before resetting the config into caps mode. I just ran the following and it worked fine.
Code: Select all/ip cloud set ddns-enabled=yes
[admin@mikrotik] > /tool traceroute cloud2.mikrotik.comWhat can you see if you just traceroute the resolved cloud IPs? This should tell you whether it is a routing issue somewhere between you and the servers or an overload of those servers. I am running ddns update on two units since yesterday and never hit a pause (but I just had a look a few times during that time).
I have set up a firewall rule to log when that packet goes out on 15252. I see it go out. I have EXPLICITY allowed 15252 in and there is nothing coming in on that port.I used the packet sniffer and when you enable ip cloud on a new device it sends one udp packet to one of the addresses resolved by cloud2.mikrotik.com on port 15252. In my case it is sending data to 159.148.172.251 and 159.148.172.201. I tried on two different cap ac devices.
Once the request is made by the client the cloud server sends back a response. Each enable/disable should just be 2 packets.
My CCR is also about that old... but it has been kept current.I have a CCR1009 which is almost 5 years old and it has been updating fine - I keep it current, so at one point was on 6.33 or earlier.
/tool sniffer packet> print brief
# TIME INTERFACE SRC-ADDRESS DST-ADDRESS IP-PROTOCOL SIZE CPU FP
0 3.463 bridge 192.168.69.5:35003 159.148.147.201:15252 udp 96 0 no
1 3.533 bridge 159.148.147.201:15252 192.168.69.5:35003 udp 102 0 no
/ip cloud> print
ddns-enabled: yes
ddns-update-interval: none
update-time: yes
public-address: Y.Y.Y.Y
dns-name: XXXX.sn.mynetname.net
status: updated
warning: Router is behind a NAT. Remote connection might not work.
I understand you're nervous about it, so you may have written something else than what you actually intended to write - did you explicitly allow reception from UDP/15252? The communication looks as follows:I have set up a firewall rule to log when that packet goes out on 15252. I see it go out. I have EXPLICITY allowed 15252 in and there is nothing coming in on that port.
[me@MyTik] > tool sniffer quick ip-address=159.0.0.0/8 interface=ether1
INTERFACE TIME NUM DIR SRC-MAC DST-MAC VLAN SRC-ADDRESS DST-ADDRESS PROTOCOL SIZE CPU FP
ether1 59.844 1 -> B8:69:F4:F9:73:65 5C:F1:DC:EF:8A:7A 192.168.5.105:33036 159.148.172.251:15252 ip:udp 96 0 no
ether1 59.888 2 <- 5C:F1:DC:EF:8A:7A B8:69:F4:F9:73:65 159.148.172.251:15252 192.168.5.105:33036 ip:udp 102 0 no
instead disable/enable - as the first will attempt to re-auth with the server, the second will attempt to send a packet to unsubscribe you from the service (in case you wanted to use the service, but now want to remove trace of it and your IP address)/ip cloud force-update
I do not have any x86 installs.routers and CHRs are eligible for IP Cloud (sorry no x86 installs). If you try to get that - you can check the status of the ordeal.
Fastest way is to useinstead disable/enable - as the first will attempt to re-auth with the server, the second will attempt to send a packet to unsubscribe you from the service (in case you wanted to use the service, but now want to remove trace of it and your IP address)/ip cloud force-update
Nope.Do the devices all share the same ISP?
All of my tests have been on Comcast, from various locations on their network.
I have same problem too.Hello to all,
few hours ago two routerbooards of mine stopped upfating ddns IP ... even Public IP adress does not appear in ip-cloud window ... till then everything worked correctly for years ...
I reset configuration on one , downgraded from 6.48.3 down to 6.47.10 but nothing changed (disabled ip-cloud before downgrade/upgrade) ... one more thing: this one even does not show it's own DNS name ... both public-adress and dns-name fields are blank (?!) ... could accept public-addres not showing up but it's-own-dns-name ?!?!
I kindly ask for help/support ...
Thank you in advance
BR
Tonci
how about right now?still problem?I also have the same issue since few hours. I have 6.48.2 installed on my hex.
No public ip address is being shown in ip cloud. Screenshot is attached.
/ip dns static
add forward-to=159.148.147.201 regexp=".*mynetname\\.net" ttl=10m type=FWD
If you have a local Tik doing DNS for you (or another DNS server you can configure conditional DNS forwarders on), It will force any name resolution attempts for mynetname.net to go straight to Mikrotik's servers, which will correctly resolve the name for you. If your monitoring is down because of name res it will sort that out. (You may need to clear your DNS cache on both your router and your device.)Hi rextended & excession, are you saying this added bit to a config will fix the problem temporarily?
/ip dns static
add forward-to=159.148.147.201 regexp=".*mynetname\\.net" ttl=10m type=FWD
Nice, how access remote device that use cloud... for update the cloud...
Very brillant copy & paste solution...
***********************
The domain mynetname.net expire on 2022-04-29T08:21:38Z
Simply mikrotik forgot to pay the $35 annual fee to publicdomainregistry.com
Stop speculating and writing idiocy and wait for the service to restore.
I did.Make Mikrotik support multiple dynamic DNS providers
:local hostName [/system identity get name];
:local resolvedIP [:resolve $hostName];
:local ipaddress [/ip address get [find interface="lte1"] address];
:local currentIP [:pick $ipaddress 0 [:find $ipaddress "/"]];
:if ($resolvedIP != $currentIP) do={
/log info ("DDNS: " . $hostName . " : " . $resolvedIP . " -> " . $currentIP);
:local result [/tool fetch user=MikroTik password="***" url=("https://your.dyndns.provid.er/nic/update?system=dyndns&hostname=".$hostName."&myip=".$currentIP) as-value output=user];
}
Thanks i have lost VPN client connection, this script work great, hope they fix soonMikroitk's revolvers are still working, you can add a conditional rule to get your resolution working again:
159.148.147.201
159.148.172.251Code: Select all/ip dns static add forward-to=159.148.147.201 regexp=".*mynetname\\.net" ttl=10m type=FWD
# whois mynetname.net | grep -i sus
Name Server: ns1.suspended-domain.com
Name Server: ns2.suspended-domain.com
Agree. Or perhaps some backup host someplace else for geo-redundancy. Not asking 5-nines here.Why on the forum?
They should have a services status on the main website.
Broken here as well.IPCloud working?
Doesn't work anywhere. I've got 238 routers lying around.IPCloud working?
Well, they should have a status page. I'd suggest Dude and function to update the web siteAgree. Or perhaps some backup host someplace else for geo-redundancy. Not asking 5-nines here.Why on the forum?
They should have a services status on the main website.