Community discussions

MikroTik App
 
Denniz01
just joined
Topic Author
Posts: 4
Joined: Thu Jul 29, 2021 8:41 pm

PPOE connection is bridged. How to add VLAN's or some kind of isolation on ether ports?

Wed Sep 29, 2021 2:13 pm

Hello Guys,

maybe this is a very simple question, I'm kind of new and hope to get some answers. Here is what I'm trying to do:
# ether 0 <-- WAN PPOE
# ether1 --> SWITCH ->(multiple connections) invisible to other ether ports
# ether2 --> AP-> (TL-WR841N: For Guest LAN and WLAN) should not see ether1 ip's
As I understand it can be solved with VLAN's. I watched some tutorials but my problem is that the router dials up ppoe and it is bridged. So most of the tutorials create a new bridge, but a bridge is already assigned. Hope it is clear. Here are my settings. Would be great to get some simple solution.


Basically the one thing that I changed from default, is to try to make it more secure and allowed some port forwardings (they only worked with masquerade command.)

# sep/29/2021 13:05:01 by RouterOS 6.47.10
# software id = RKPD-G2FL
#
# model = RB4011iGS+
# serial number = F0380E36CDBF
/interface bridge
add admin-mac=2C:C8:1B:46:39:96 auto-mac=no comment=defconf name=bridge
/interface pppoe-client
add add-default-route=yes disabled=no interface=ether1 name=pppoe-out1 \
    use-peer-dns=yes user=xxxxxxx@xxx.com
/interface ethernet switch port
set 0 default-vlan-id=0
set 1 default-vlan-id=0
set 2 default-vlan-id=0
set 3 default-vlan-id=0
set 4 default-vlan-id=0
set 5 default-vlan-id=0
set 6 default-vlan-id=0
set 7 default-vlan-id=0
set 8 default-vlan-id=0
set 9 default-vlan-id=0
set 10 default-vlan-id=0
set 11 default-vlan-id=0
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge name=defconf
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
add bridge=bridge comment=defconf interface=ether6
add bridge=bridge comment=defconf interface=ether7
add bridge=bridge comment=defconf interface=ether8
add bridge=bridge comment=defconf interface=ether9
add bridge=bridge comment=defconf interface=ether10
add bridge=bridge comment=defconf interface=sfp-sfpplus1
/ip neighbor discovery-settings
set discover-interface-list=none
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
add interface=pppoe-out1 list=WAN
/ip address
add address=192.168.88.1/24 comment=defconf interface=ether2 network=\
    192.168.88.0
/ip arp
add address=192.168.88.103 interface=bridge mac-address=3C:78:0E:59:5C:BA
/ip dhcp-client
add comment=defconf interface=ether1
/ip dhcp-server lease
add address=192.168.88.111 client-id=1:a0:8c:fd:d8:c:1f mac-address=\
    A0:8C:FD:D8:0C:1F server=defconf
add address=dhcp mac-address=2C:41:78:4F:BB:6D server=defconf
/ip dhcp-server network
add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 comment=defconf name=router.lan
/ip firewall filter
add action=accept chain=input comment=\
    "defconf: accept established,related,untracked" connection-state=\
    established,related,untracked
add action=accept chain=input comment="defconf: drop invalid" \
    connection-state=invalid
add action=drop chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
    "defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=accept chain=input comment="defconf: drop all not coming from LAN" \
    in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
    ipsec-policy=in,ipsec
add action=drop chain=forward comment="defconf: accept out ipsec policy" \
    ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related
add action=accept chain=forward comment=\
    "defconf: accept established,related, untracked" connection-state=\
    established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
    connection-state=invalid
add action=drop chain=forward comment=\
    "defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
    connection-state=new in-interface-list=WAN
add action=accept chain=forward dst-address=192.168.88.102 protocol=rdp
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
    ipsec-policy=out,none out-interface-list=WAN
add action=dst-nat chain=dstnat dst-port=774 in-interface=pppoe-out1 \
    protocol=tcp src-port="" to-addresses=192.168.88.102 to-ports=3389
add action=dst-nat chain=dstnat dst-port=776 protocol=tcp to-addresses=\
    192.168.88.102 to-ports=776
add action=dst-nat chain=dstnat dst-port=775 protocol=tcp to-addresses=\
    192.168.88.249 to-ports=5601
add action=masquerade chain=srcnat src-address=192.168.88.102
add action=masquerade chain=srcnat src-address=192.168.88.249
add action=dst-nat chain=dstnat dst-port=774 in-interface=pppoe-out1 \
    protocol=udp to-addresses=192.168.88.102 to-ports=3389
add action=dst-nat chain=dstnat disabled=yes dst-port=443 in-interface=\
    pppoe-out1 protocol=tcp to-addresses=192.168.88.87 to-ports=443
add action=dst-nat chain=dstnat disabled=yes dst-port=443 in-interface=\
    pppoe-out1 protocol=tcp to-addresses=192.168.88.87 to-ports=443
add action=dst-nat chain=dstnat disabled=yes dst-port=443 in-interface=\
    pppoe-out1 protocol=tcp to-addresses=192.168.88.87 to-ports=444
/ip firewall service-port
set ftp disabled=yes
set tftp disabled=yes
set sip disabled=yes
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www address=192.168.88.0/24
set ssh disabled=yes
set api disabled=yes
set winbox address=192.168.88.0/24
set api-ssl disabled=yes
/tool bandwidth-server
set enabled=no
/tool mac-server
set allowed-interface-list=none
/tool mac-server mac-winbox
set allowed-interface-list=LAN

Who is online

Users browsing this forum: Ahrefs [Bot], Baidu [Spider], Bing [Bot], davorjs and 19 guests