Community discussions

MikroTik App
 
Skylin3
just joined
Topic Author
Posts: 8
Joined: Mon Jun 14, 2021 1:52 pm

Mangle + fasttrack + queues

Wed Dec 08, 2021 12:48 pm

HW: hapac2, ROS 7.1.
Task:
1. implement some sort of "fast line" priority for UDP traffic on some ports, but not use queue for it.
2. implement speed restriction and lower priority for other traffic.

Now I have simple queues for every client and set connection-mark 'no-mark' to slow and shape non-priority traffic.
/queue simple
add dst=WAN max-limit=150M/150M name=client1 packet-marks=no-mark queue=\
    ethernet-default/ethernet-default target=192.168.30.10/32 total-queue=\
    ethernet-default
    ...
    etc
    
Bridge is configured to capture traffic to queues:
/interface bridge settings
set allow-fast-path=no use-ip-firewall=yes
Mangle is used to mark connection for fasttrack
add action=mark-connection chain=prerouting comment="prior UDP Ports" \
    new-connection-mark=prior-conn passthrough=yes port=\
    99999 protocol=udp
add action=mark-packet chain=prerouting comment=prior-pk connection-mark=\
    prior-conn new-packet-mark=prior-pk passthrough=no
On top of firewall filter created rule:
/ip firewall filter
add action=fasttrack-connection chain=forward connection-mark=prior-conn \
    hw-offload=no
    ...
    then default firewall rules
In IP/settings I see fasstrack is active, in mangle and firewall see fasttrack counters is working.
But if I enter in mangle or firewall fasttrack rule and check statistic tab, I can see that only half of traffic (not sure, egress or ingress) passing through fasttrack. I know packet rate for all traffic (~128 rx and 128 tx packets per second) but in statistic see only 128 "blue" pps instead 256 pps.
If I remove packet-marks 'no-mark' filter in simple queue - half of traffic passing through queue, and half - passing through fasttrack.
How I can diagnose this issue?

Who is online

Users browsing this forum: Bing [Bot], BioMax, GoogleOther [Bot], hatred, mtkvvv and 49 guests